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Welcome to ER/Studio

ER/Studio is a visual modeling application used for platform-independent logical data architecture analysis and
design, in addition to platform-specific physical database design and construction. Its powerful, multi-level design
environment addresses the everyday needs of database administrators, developers, and data architects who build
and maintain large, complex database applications and strive to consolidate, report, and re-use metadata across the
enterprise.

ER/Studio’s progressive interface and simplicity has been designed to effectively address the ease-of-use issues
which have plagued data modeling and CASE tools for the past decade and more. The application equips you to
create, understand, and manage the life-cycle of mission-critical database designs and business metadata within the
enterprise.

ER/Studio is rich and customizable. ER/Studio offers:
« Strong logical design capabilities
« The ability to spawn many physical designs from a corporate logical design
« Bi-directional model comparison and information synchronization
« Visual-Basic for Applications API for product customization
« Powerful DDL reverse engineering and generation
* Metadata import and export capabilities
« Data lineage documentation

« Sophisticated XML, HTML, and RTF-based documentation and reporting facilities.

About This Document

The ER/Studio User Guide is the primary reference for ER/Studio. It provides an overview of the product and gives
detailed instructions on common and less-common tasks. In HTML Help format it serves as the online help for
ER/Studio. It is also distributed in PDF format for easy downloading and printing.

For licensing and installation information, see the ER/Studio Installation Guide.

For pointers to additional information not included in this document, see Additional Product Resources

Product Benefits by Audience

« Data Modelers and Data Architects: ER/Studio is critical for organizations concerned with eliminating data
redundancy, creating an enterprise view of data assets, and assisting development with making informed
decisions about how best to reuse elements pre-defined by the enterprise. Its powerful logical (hon-database or
technology specific) analysis and design environment helps to normalize and create an enterprise view of the
objects concerning the data managed by an organization. More importantly, it can communicate this quickly
through powerful reporting and metadata exchange mechanisms throughout the enterprise.



Database Administrators and Database Developers: Managing databases can be incredibly difficult without a
blueprint or roadmap to understand important object dependencies. ER/Studio’s round-trip engineering
capabilities including database reverse-engineering provide database administrators (DBAs) or developers with
important ‘physical’ data models in seconds. These models can be used as powerful and efficient change
management platforms, allowing users to update a model with the required changes which need to be
implemented at the database and automatically generate DBMS-specific, syntactically correct, alteration or
database DDL.

Business and IT Managers: ER/Studio’s robust reporting facilities allow critical information about designs to the
enterprise to be delivered in seconds. This heavily leveraged and beneficial capability of ER/Studio allows users
to provide, in literally seconds, clear, easily navigable and safe-to-distribute documentation about a database or
enterprise data model to those who need to review it.

Database Support and Connectivity

Supported Database Platforms

ER/Studio supports the following database platforms:

Hitachi HIRDB

IBM® DB/2® for LUW 5.x, 6.X, 7.X, 8.X, and 9.x

IBM® DB/2® for OS/390 5.x, 6.X, 7.X, 8.X, and 9.x

IBM® DB/2® for AS/400 V4R5 and V5R2

IBM® DB/2® for Common Server

Informix ® OnLine, SE, and 9.x

InterBase™ 4 and 2007

Microsoft® Access 2.0, 95, 97, and 2000

Microsoft® SQL Server 4, 6, 7, 2000, 2005, and 2008
Microsoft® Visual FoxPro 2.x, 3.x, and 5.x

MySQL 3.x, 4.x, and 5.x

NCR Teradata V2R4, V2R5, and V2R6

Oracle 7.x, 8.x, 9i, 10g, and 11g

PostgreSQL 8.x

Sybase® Adaptive Server Anywhere (ASA) 6, 7, 8, 9, and 10
Sybase® Adaptive Server Enterprise (ASE) 11.0, 11.5, 11.9, 12.0, 12.5, and 15
Sybase® Adaptive Server 1Q 12.5

Sybase Watcom™ SQL

Sybase SQL Anywhere 5

Database Connectivity
The table below describes the necessary client software needed to successfully connect to a target database.



When selecting client software, make sure the DBMS version matches the client software version. In cases where the
client libraries are backward compatible, the latest client version is recommended. Please refer to the DBMS vendor
for specific client software and the database versions for which it is supported.

Database Required Client Libraries Vendor

Hitachi HIRDB Hitachi ODBC Hitachi

IBM DB/2 OS/390/ IBM DB2 LUW IBM DB2 Connect IBM

IBM AS/400 IBM Client Access for AS/400 IBM

Informix OnLine and SE Informix-Cli and ODBC Informix Software, Inc. and Intersolv,
Inc.

InterBase ODBC Visigenic Software, Inc.

Microsoft Access Access ODBC Microsoft

Microsoft SQL Server SQL Server Client Tools Microsoft

Microsoft Visual FoxPro FoxPro ODBC Microsoft

MySQL MySQL ODBC MySQL

NCR Teradata Teradata ODBC NCR

Oracle SQL*Net or Net8 with configuration files | Oracle

(hosts, tnsnames.ora)

PostgreSQL PostgreSQL ODBC Postgre

Sybase ASA Sybase ASA ODBC Sybase

Sybase ASE Sybase Open Client Sybase

Sybase Adaptive Server 1Q Sybase ASA ODBC Sybase

Sybase Watcom SQL Anywhere SQL Anywhere ODBC Sybase

Additional Product Resources

The Embarcadero Web site is an excellent source for additional product information, including white papers, articles,
FAQs, discussion groups, and the Embarcadero Knowledge Base.

Go to www.embarcadero.com/support, or click any of the links below, to find:

¢ Documentation
¢ Online Demos

e Technical Papers

¢ Discussion Forums

« Knowledge Base


http://www.embarcadero.com/support/
http://www.embarcadero.com/resources/documentation.html
http://www.embarcadero.com/resources/online_demos.html
http://www.embarcadero.com/resources/technical_papers.html
http://www.embarcadero.com/jive/forumindex.jspa
http://www.embarcadero.com/jive/kbcategory.jspa?categoryID=1

Embarcadero Technologies Technical Support

If you have a valid maintenance contract with Embarcadero Technologies, the Embarcadero Technical Support team
is available to assist you with any problems you have with our applications. Our maintenance contract also entitles
registered users of Embarcadero Technologies’ products to download free software upgrades during the active
contract period.

To save you time, Embarcadero Technologies maintains a Knowledge Base of commonly-encountered issues and
hosts Discussion Forums that allow users to discuss their experiences using our products and any quirks they may
have discovered.

To speak directly with Embarcadero Technical Support, see Contacting Embarcadero Technologies Technical Support
below.

NOTE: Evaluators receive free technical support for the term of their evaluation (14 days).

Contacting Embarcadero Technologies Technical Support

When contacting Embarcadero Technologies Technical Support please provide the following to ensure swift and
accurate service:

Personal Information
* Name
¢ Company name and address
¢ Telephone number
¢ Fax number
* Email address
Product and System Information
« Embarcadero product name and version number. This information is found under Help, About.
« Your client operation system and version humber.
* Your database and version number.
Problem Description

A succinct but complete description of the problem is required. If you are contacting us by telephone, please have the
above information, including any error messages, available so that an Embarcadero Technical Support Engineer can
reproduce the error and clearly understand the problem.

There are three ways to contact Embarcadero’s Technical Support department:
* Viathe Web
* Via Phone

¢ Via Email

Via the Web

Embarcadero Technical Support provides an online form that lets you open a Support case via the Web. To access
this form, go to http://www.embarcadero.com/support/open_case.jsp.

We normally acknowledge the receipt of every case on the same day, depending on the time of submission.

Via Phone
United States


http://www.embarcadero.com/jive/kbcategory.jspa?categoryID=1
http://www.embarcadero.com/jive/forumindex.jspa
http://www.embarcadero.com/support/open_case.jsp

Embarcadero Technologies Technical Support phone number is (415) 834-3131 option 2 and then follow the prompts.
The hours are Monday through Friday, 6:00 A.M. to 6:00 P.M. Pacific time.

For licensing issues, including Product Unlock Codes, call (415) 834-3131 option 2 and then follow the prompts. The
hours are Monday through Friday, 6:00 A.M. to 6:00 P.M. Pacific time.

The Embarcadero Technologies Technical Support fax number is (415) 495-4418.
EMEA

Embarcadero Technologies Technical Support phone number is +44 (0)1628 684 499. The hours are Monday to
Friday, 9 A.M. to 5:30 P.M. U.K. time.

For licensing issues, including Product Unlock Codes, call +44 (0)1628-684 494. The hours are Monday to Friday, 9
A.M. to 5:30 P.M. U.K. time

The Embarcadero Technologies Technical Support fax number is +44 (0)1628 684 401.

Via Email
United States

Depending on your needs, send your email to one of the following:
* support@embarcadero.com - Get technical support for users and evaluators
* upgrade@embarcadero.com - Request upgrade information

key@embarcadero.com - Request a product key

wish@embarcadero.com - Make a suggestion about one of our products

EMEA
Depending on your needs, send your email to one of the following:

« uk.support@embarcadero.com- Get technical support for users and evaluators

¢ uk.upgrade@embarcadero.com - Request upgrade information

« uk.key@embarcadero.com - Request a product key

» uk.wish@embarcadero.com - Make a suggestion about one of our products


mailto:support@embarcadero.com?subject=Technical Support Request
mailto:upgrade@embarcadero.com?subject=Upgrade Information Request
mailto:key@embarcadero.com?subject=Key Request
mailto:wish@embarcadero.com?subject=Product Suggestion
mailto:uk.support@embarcadero.com?subject=Technical Support Request
mailto:uk.upgrade@embarcadero.com?subject=Upgrade Information Request
mailto:uk.key@embarcadero.com?subject=Key Request
mailto:uk.wish@embarcadero.com?subject=Product Suggestion

ER/Studio Overview

ER/Studio is an industry-leading data modeling tool for designing and understanding databases, which helps
companies discover, document, and re-use data assets. With round-trip database support, you can reverse-engineer,
analyze, and optimize existing databases. Productivity gains and enforcement of organizational standards can be
achieved with ER/Studio's strong collaboration capabilities.

ER/Studio offers:

Model-driven design environment
Complete database lifecycle support
Enterprise model management

Data lineage documentation

Enterprise communication capabilities
Data warehouse and integration support

Quality database designs

This overview provides a basic introduction to ER/Studio, the products in the ER/Studio family, and Embarcadero
applications that can further enable data architects.

ER/Studio Family Products

There are several products in the immediate ER/Studio family:

ER/Studio Standard: Provides a complete environment for analyzing, designing, creating, and maintaining
database applications.

ER/Studio Enterprise: In addition to ER/Studio Standard, the Enterprise version includes the server-side
ER/Studio Repository for improved teamwork and enterprise collaboration and Embarcadero's business process
and conceptual modeling tool, EA/Studio.

ER/Studio Repository: Productivity gains and enforcement of organizational standards can be achieved with
strong collaboration capabilities offered by ER/Studio Repository, a version-control application. ER/Studio users
connect to the Repository to get a data model revision, check in changes, compare and merge local copies of the
data model to a version in the Repository, and run various usage reports. ER/Studio Viewer and ER/Studio
Enterprise Portal users have read-only access to the Repository.

ER/Studio Viewer: ER/Studio Viewer provides an interactive environment for accessing ER/Studio data models,
offering the same sophisticated navigational features of ER/Studio to members of the modeling team that want
advanced viewing, navigation and printing functionality but do not require the ability to edit the models.

ER/Studio Enterprise Portal: The Enterprise Portal is a browser-based application that provides easy access to
metadata information stored in ER/Studio models, enabling you to search, browse, and report on the information
contained in the ER/Studio Repository.

Universal Data Models: Standard and Industry data model templates for ER/Studio that reduce the
development time of database-related projects by an average of 60 percent, as well as improve the quality of
existing and new data models.

MetaWizard: Integrates metadata across modeling tools, business intelligence, ETL platforms and
industry-standard exchange formats (XMI, XML and XSD). This tool enables ER/Studio to integrate with more
than seventy other applications by sharing metadata through an import-export capability.



In addition to the products above, Embarcadero also offers the following complementary applications:

License Server: The license server is the conduit through which you manage licenses for your Embarcadero
Technologies distributed applications. You administer licenses from a central location, which is a big advantage if
you have users scattered across a large network. You can see how many licenses are available and if they are in
use. You can also you add or remove specific users and reallocate licenses as needed.

Schema Examiner: Ensures the integrity of database schema by performing a comprehensive set of diagnostic
tests that validates the schema and ensures that the rules of the relational model are enforced. Detailed reporting
and graphical documentation simplify the process of pinpointing and reviewing discrepancies. Schema Examiner
also recommends changes to database schema and can automatically generate scripts to fix problems, providing
an efficient and consistent approach to improving database design.

EA/Studio: A business modeling tool for creating a graphical representation of your business from the core
concepts that describe the business, to the processes that detail how your business operates. EA/Studio allows
you to easily model your business processes and how those processes use data. EA/Studio Conceptual
Modeling provides an intuitive way to outline subject areas and concepts that can then drive the creation of
detailed data models. EA/Studio is now free with ER/Studio Enterprise Edition, which includes the ER/Studio
Repository.

EA/Studio Community Edition: A free, Eclipse-based, professional grade, business modeling tool that allows
business and IT users to share business process models in a standardized way and engage in more productive
modeling. It provides flexible and simple process modeling for flowchart creation, intuitive interface allowing
ease-of-use to business users, and captures metadata definitions via full property editors. The process is further
simplified with an easy import from Microsoft Excel and Visio.

Standard Edition Solution Pack: This core set of award winning database tools simplifies and automates the
design, development and administration of mission-critical databases. Use ER/Studio Standard to visually model
and document your databases, DBArtisan Professional to easily manage database schema, storage,
performance and security, and Rapid SQL Professional to quickly create, edit, version and deploy server-side
objects.

Administration Edition Solution Pack: The productivity dream team for DBAs. Use ER/Studio to visually model
and document your databases; DBArtisan Professional to easily manage database schema, storage,
performance, and security; and Embarcadero Change Manager to address the change management challenges
faced by DBAs.



Application Design

The following diagram shows the functional relationship among ER/Studio Enterprise components and with the
software components of a typical development system.
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Application Interface

The ER/Studio interface is divided into several tabbed windows that let you navigate and customize your workspace.
ER/Studio includes context-sensitive toolbars, menus, intuitive icons, keyboard commands, and other resources to
help you work efficiently. ER/Studio's user interface has a standard Windows look and feel.

For a detailed description of the internal data structure of the ER/Studio application itself and for Repository, you can
look at Metadata models (DM1 files) usually found in the following directories:

« Windows XP: C:\Documents and Settings\All Users\Application Data\
Embarcadero\ERStudio_X.X\Sample Models

« Windows Vista: C:\ProgramData\Embarcadero\ERStudio_X.X\Sample Models



For information on enhanced Ul features, click in the image below:
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1 ER/Studio has an enhanced user interface that is similar to Windows XP with intuitive icons.

2 The name of the active model, with or without the full path to the file, can be displayed on the title bar of the main
application window. This is an option you can set in Tools > Options > Application > Application Defaults.

3 ER/Studio displays the active model in bold type, so that you can easily see which model or submodel you are
working on.

4 The Data Model tab of the Diagram Explorer displays indexes, relationships, and attributes as separate nodes.

5 The Data Model tab of the Diagram Explorer displays schema objects like packages, procedures, functions,
materialized views, auxiliary tables, and triggers as separate nodes.

6 The Overview Window lets you navigate large Data Models.
7 The Zoom Window helps you focus on the details of a specific area of a large, reduced diagram.

8 You can dock toolbars anywhere in the ER/Studio user interface.



The Diagram Explorer is comprised of five tabs that offer easy access to important functionality and also includes an
Explorer tree that lets you efficiently navigate the objects of your data models. The ER/Studio interface to the Data
Model is divided into two main areas. On the left is the Diagram Explorer and on the right is the Data Model Window.
This convention is carried out on other tabs of the user interface, such as the Repository and Data Lineage tabs,
where you'll find an explorer on the left and a graphical representation on the right. The Diagram Window also
provides a complete workspace for creating your physical and logical data models. The Diagram Window also
contains smaller, movable windows to help you navigate large data models.

Diagram Explorer

The Diagram Explorer helps you navigate data models and their objects, reuse design elements, and create new
objects. The Diagram Explorer has five tabs that offer easy access to important functionality, enabling you to efficiently
manage your Data Models.

« Data Model: You can expand and collapse the Diagram Explorer nodes as needed. Double-click a node to start
an Entity Editor, Relationship Editor or Subtype Editor.

« Data Dictionary: Lets you manage data dictionary objects, including attachments, defaults, rules, reference
values, user data types, domains, reusable procedural logic, reusable procedures, and libraries.

« Data Lineage: Data Lineage allows you to start with a source and move through an intermediate schema or target
in as many steps as you need.

« Macros: Lets you manage sample, system, and user macros. From this tab you can create, rename and delete
folders as well as add a macro and refresh the macro list.

« Repository: Lets you manage objects stored in the Repository.

Data Model

The Data Model tab displays logical elements such as entities and relationships and physical schema objects such as
packages, procedures, functions, materialized views, auxiliary tables, and triggers as separate nodes. Shortcut menus
are available on the Data Model tab when you right-click an element. Using the Data Model tab, you can:

¢ Create an object

< Edit an object

« Delete an object

« Rename an object

* Change how the data model tree displays by clicking Tools > Options > Application settings.



The Data Model tab also lets you manage objects that are contained within objects, such as columns, which are
contained within tables.

ER/Studio displays the active model in bold type, so you can easily recognize which model or
submodel on which you are working.
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Data Dictionary

The Data Dictionary tab of the Diagram Explorer lets you manage data dictionary objects, including attachments,
defaults, rules, reference values, user datatypes, domains, reusable procedural logic, reusable procedures, and
libraries. The shortcut menu available when you right-click an object lets you add, edit, or delete these Data Dictionary
objects.



The Reusable Procedural Logic folder lets you organize several procedural logic items such as reusable triggers,
reusable procedures, and libraries.
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Data Lineage

The Data Lineage tab provides a visual, drag-and-drop interface to enable you to document how data moves between
the target and source systems along with why and when the data is moved.

Data lineage documents the Extraction, Transformation, and Load (ETL) of data movement and the relevant
computations required when moving data between disparate systems. You can create data movement rules that can
dictate, for example, when the data should be archived or a specific value range the data must fall within in order to be
moved. You may also need to massage the data to, for example, compute the total sales for a particular product
before moving the data to the target. This is sometimes referred to as “source and target” mapping. For example, your
organization’s data warehouse may have data fed in from multiple sources such as CRM, Payroll, General Ledger,
Accounting, or Product/Inventory system. The data warehouse will likely need on-line data marts receiving data from
one of those systems to produce reports for Sales Executives, HR Executives or marketing teams who produce
performance reports about of various aspects of your business

1 GIMDB_80_testing - Data Flow Model Yiew: Broker * ]

H# Data Lineage
E—% Drata Flows
—L#y Broker
= Transformations

=T =B_ru:uker Mame
Inputs

EHE Outputs

LI_L'I Transformation2
[El-ﬁ Components
e Client Load
FhHD  Clignt Load 2

Data Movement Rules

[—ﬁ
& Data Retention [chive Rule]

& Upzert [Update Fule]

Entitiss (10]
T GIM_Dhw
EH— Tables [4]
A GIM_OLTP
FH— Tables [5)
Wiews [2]

- Other Sources
& Legacy

Tables [24)

— BROKER [GIM_OLTF)
| IMVESTMENT [GIM_OLTF)

— BROKER_DIM [GIM_D'w)

Bloa.. | @roa.. BiDa.. |Ema..

i

Bk

BROKER

IHVESTMENT

B BROKER_ID (PK)

% OFFICE_LOCATION_ID (FK)
3 BROKER_LAST_MNAME

< BROKER_FIRST_MAME

< BROKER_MIDDLE_IMITIAL
B MANAGER_D (FK)

3 YEARS_WITH_FIRM

B INVESTMENT_ID (PK)

B INVESTMENT_TYPE_ID (FK)
3 IMVESTMENT_VEMDOR

3 INVESTMENT_MAME

G INVESTMENT _UMIT

G IMVESTMENT _DURATICN

] .

LT',_.Brl:lker Hame

Inputs:
BROKWER BROWER _LAST_MAKME
BROKWER BROKER_FIRST_MAME
INWESTMWEMT INWESTMWENT _MAME

Outputs:
BROKER_DIM BROKER _MAME

o
' —

& INVESTMENT D (P
< INVESTMENT _WENDOR

< INVESTMENT _MANE
< INVESTMEMT _UNIT

¥ BROKER_ID (FI)
3 BROKER_PMAME
3 YEARE_WITH_FIRM

< INVESTIMENT _DURATION

LmTransfurmatiunZ ]




Macros

The Macro tab of the Diagram Explorer lets you add, edit, rename, delete, and run macros. You can also create
folders in which to store macros for easier reference. ER/Studio installs several sample macros in the Sample Macros
folder. These macros are described in more detail in the Using the SAX Basic Macro Editor section of this
documentation.

[l]-ﬁ Sample Macroz

0 Meta Data Management M ac
0 Model Layout Macros
J Modeling Productivity bacros

d Physical Modeling Macros
g woita
#@n ERSBasicHandlers
ERSDeleteH andlers
ERSUpdateHandlers

Repository
The Repository tab of the Diagram Explorer lets you view and access the objects that are stored in the Repository.

5
Ej Iy Models
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Data Model Window

The Data Model window displays the logical and physical data model. You can access functionality through the
menus, shortcut menus, and tool bar buttons. The Data Model window lets you move diagram objects, copy and paste
them in a new location, resize the diagram objects, and change their colors.

The Diagram Window also displays physical schema objects like Procedures, Functions, Packages, Auxiliary Tables,
Tablespaces, Materialized Views, and Synonyms. This presents a visual representation of object dependencies for
impact analysis.

If you right-click a relationship, ER/Studio opens a shortcut menu that lets you modify the relationship between entities
or tables.



In the Data Model Window, ER/Studio displays useful information about each object in your Data Model in the Pop-up
Windows, Zoom Window, and Overview Window.
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Pop-up Windows

Pop-up windows can display brief definitions or the DDL of each object in your Data Model. When you hover the
mouse pointer over any object briefly, ER/Studio displays a pop-up window. The popup in the example above displays
the object definition, “The Medication Dispension....."

To display the entity definition as in the screenshot above, click View > Cursor Popup Help Options > Schema Object
Help and then select Definition.

You can create optional definitions on the Definition tab of the object editor. ER/Studio adds the definition as a
comment when you generate the SQL code.



Zoom Window

The Zoom window helps you focus on the details of a specific area of a large, reduced diagram. This feature is only
available in the Data Model Window. You can open and close the Zoom Window as needed using the View menu or by
pressing F8. You can also move the window by dragging it by its title bar.
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Overview Window

The Overview window lets you navigate large Data Models. The Overview window provides a thumbnail view of the
entire model. You can open and close the Overview window as needed using the View menu or by pressing F9. When
you zoom in or out, the Overview window places a border around the portion of the model displayed in the Data Model
Window.
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Menus

You can access the entire ER/Studio feature set from the application menus. You can also access selected features
from shortcut menus. ER/Studio application menus are across the top of the user interface and shortcut menus are
available when you right-click an object or diagram. All menus are context-sensitive and change depending on the
content of the Data Model Window.

Functionality available in application menus or shortcut menus is also available on Toolbars.

Application Menus

ER/Studio application menus provide access to all functionality. The menus are context-sensitive and change
depending on the content of the Data Model Window. The application menu differs for logical and physical models.

Accessing Shortcut Menus

ER/Studio shortcut menus offer an easy method of accessing object functionality. Shortcut menus offer the same
functionality you can access from the Toolbars or Menus. To access the shortcut menu, right-click an object or model.

Toolbars

ER/Studio toolbars are context-sensitive and change to reflect the element of the application you are using. Toolbar
buttons offer quick access to common features of ER/Studio. All functionality accessible from toolbar buttons is also
accessible from Menus and Accessing Shortcut Menus. Toolbars change depending on if you are working with logical
or physical models.

ER/Studio lets you move toolbars anywhere on the ER/Studio workspace. You can also dock toolbars anywhere on the
perimeters of the workspace. You can also specify which toolbars you want displayed on the workspace.

Moving Toolbars
You can dock and undock toolbars, moving them to any place with the application window.

Undock a Toolbar

1 On adocked toolbar, click and hold the toolbar handle

2 Drag the toolbar to a new location.

Dock a Toolbar
On an undocked toolbar, double-click the title bar of the toolbar.

Displaying Toolbars
Click View and then click to select or deselect the toolbars you want to display or hide.

Keyboard Commands

Keyboard commands, function keys, and shortcuts offer alternative ways to access ER/Studio functionality without
using the mouse. You can use keyboard commands to navigate diagrams and perform basic functions.

¢« PAGE UP: Scrolls up the Diagram Window.



PAGE DOWN: Scrolls down the Diagram Window.

UP ARROW: Scrolls up one line.

DOWN ARROW: Scrolls down one line.

RIGHT ARROW: Scrolls over one position to the right.
LEFT ARROW: Scrolls over one position to the left.
MINUS SIGN: Decreases zoom level by one step.

SHIFT+F8: Lets you freeze the Zoom window so that you can pan around the diagram and still maintain focus on
a specific diagram object. The same command unfreezes the Zoom window.

Function Keys

The function keys let you access certain features or dialog boxes.

F1: Opens the online Help.
F4: Opens the Find Entity/View dialog.
F5: Redraws the diagram.
F7: Activates or deactivate shadowing.

F8: Opens or closes a zoom window.

Shortcuts

Shortcuts let you access important functionality through key combinations.

Ctrl+A: Selects all entities in the Data Model Window.
Ctrl+Shift+A: Selects all entities and relationships in the Data Model Window.

Ctrl+H: Straightens the selected relationship lines horizontally. The lines will straighten based on the docking
point against the parent entity.

Ctrl+L: Straightens the selected relationship lines vertically. The lines will straighten based on the docking point
against the parent entity.

\Hot Keys
You can use the following hotkeys to navigate through your models in the Diagram Explorer:

Page Up: Scrolls up one screen size

Page Down: Scrolls down one screen size

Ctrl+Home: Scrolls to the upper left hand page of the model
Up Arrow: Scrolls up one line

Down Arrow: Scrolls down one line

Full Undo Redo

The Undo and Redo commands restore your model to the last stage of edits. Find them under the Edit menu or use
the Ctrl+Z and Ctrl+Y hotkeys.



Status Bar

ER/Studio provides statistics pertaining to your logical and physical model in the status bar at the bottom of the
application. The table below describes the statistics available on the Status bar:

Diagram Mode | Statistic Definition
Logical Views Total number of views in the current model or submodel

Entities Total number of entities in the current model or submodel

Attributes Total number of attributes in the current model or submodel

Relationships Total number of relationships established in the current model or submodel
Physical Tables Total number of tables in the current model or submodel

Views Total number of views in the current model or submodel

Columns Total number of columns in the current model or submodel

Foreign Keys Total number of foreign keys in the current model or submodel

Configuring and Customizing ER/Studio

There are many options available to customize how ER/Studio behaves and what it displays in the Diagram Windows.
Some options, such as the Diagram and Object Display Options and Model Options are saved in the .dm1 file and
affect how the model displays or behaves immediately, while the Tools Options and Cursor Popup Help Options affect
how the application and any new models created will display or behave.

¢ Changing Diagram and Object Display Options

« Defining Model Options for the Selected Model

¢ Specifying the Location of Shared Data

« Changing Cursor Popup Help Options

Changing Diagram and Object Display Options

Diagram and Object Display options affect how the diagram objects appear only for the selected model or submodel.
You can choose different display options for each physical and logical model and submodel. The diagram and object
display options you choose are stored in the .dm1 file along with your diagram and apply only to the current diagram.
Regular display options for the diagram include setting page boundaries and snapping to grid. Object-specific display
options include specifying the information displayed about each object on the diagram. You can specify the content
displayed for entities and views. You can also customize display settings for relationships and schema objects.

You can change the entity/table display level to show attributes/columns, primary keys, all keys, tables, definitions, or
notes. You can further set display options for certain objects to display object datatype, domain, null options, alternate
keys, and owner.

With views, you can change the display level to show columns, primary keys, all keys, view, definition, and note. You
can further set display options for certain objects to display object owner and parent name.



By default, ER/Studio automatically fits entities and views to display all content selected. However, you can resize any
entity or view to any size.

You can make global changes to the display of any new diagrams and objects by clicking Tools
> Options > Display and making your choices there. For more information, see Defining Model
Options for the Selected Model.

1 Click the logical or physical model or submodel you want to change.
2 Click View > Diagram and Object Display Options.

3 Complete the tabs of the Diagram and Object Display Options dialog and then click OK to implement the
changes to the current model.

The following describes options that are not self-explanatory:
Diagram tab

* Show Page Boundaries: If selected, displays the page boundaries according to the print options, such as the
printer selected, and page size, scale, and orientation chosen in the Print and Print Setup dialogs.

Entity and Table tab
The display level options selected dictate which options will be available in the Available options area.

« Definition: If selected, displays the entity or table definition as defined on the Definition tab of the Entity Editor or
Table Editor.

« Note: If selected, displays the entity or table note as defined on the Notes tab of the Entity Editor or Table Editor.
« Display Table Names: If selected, displays entity and table names.
« Display Column Names: If selected, displays the attribute and column names.

CAUTION: Ifthe Display Level in the Diagram and Object Display Options editor does not match the Attribute
Order designation in the Model Options, drag and drop and on-screen editing errors can occur. If
the true attribute sequence, as designated in the Model Options and the displayed sequence, as
designated in the Diagram and Object Display Options, are not synchronized, then ER/Studio
cannot make the appropriate changes to the entity.

Relationship tab

¢ Relationship Style: The style chosen here applies to any new relationships created in the model or submodel.
You can override the relationship style by right-clicking the relationship and choosing one of the format options
available.

View tab
« Definition: If selected, displays the view definition as defined on the Definition tab of the View Editor.
« Note: If selected, displays the view note as defined on the Notes tab of the View Editor.

« Name Compartment: If selected, displays the view’s name within the view object; otherwise, the view name
displays just above the object.

« Wrap Name: If selected, wraps the view's name when the view width isn’t large enough to accommodate the
entire name.

Schema Objects tab:

For physical models only, controls the display of schema objects such as packages, procedures, functions,
materialized views, auxiliary tables, and triggers.



Transformation tab
NOTE: Available only if the Data Lineage tab is active when View > Diagram and Object Display Options
is clicked.
The Transformation display options control what information is displayed on the Transformation object of a data

flow on the Data Lineage window.

¢ Input and Output Columns: If selected, displays the names of the input and output columns on the
transformation object.

« Code: If selected, displays the transformation code entered on the Definition tab of the Transformation Editor.

« Definition: If selected, displays the business description entered on the Definition tab of the Transformation
Editor.

Drawing Shapes tab

Verb and inverse verb phrases are defined on the Phrases tab of the Relationship Editor. If you choose to
display these phrases, in the Diagram Window you can click and drag them for optimal positioning.

Security Objects tab

Security objects, such as users and roles are not automatically displayed in data models that have been
reverse-engineered; in this case, you must enable their display here.

Apply To tab

You can selectively apply the object display options set on the other tabs to individual elements of your model.

Defining Model Options for the Selected Model

In the Model Options for the selected model, you can define naming rules, model notation, a default datatype,
datatype mapping, assign a prefix to all rolenames, and the order attributes appear. Using the Model Options you can
also synchronize entity and table names, and attribute and column names along with other display options.

The preferences you set here are maintained in the diagram .dm1 file.
1 Right-click the target model and then click Model Options.
Depending on the target model selected, the Logical Model Options or Physical Model Options dialog displays.
2 Complete your changes on the General Options and Name Handling tabs and then click OK.
NOTE: The options that appear depend on whether the selected model is a logical or a physical model

type.

The following describes options that are not self-explanatory. The options available depend on whether you are
defining the options for a logical or a physical model.

General Options tab
« Max Table Name Length: This field is read-only. Its value is platform dependant.
¢ FK Column Definition/Note Synchronization:

« None: The Note and Definition text from the parent PK columns will be propagated when the relationship is
created or a new column is added to the primary key. If there are any changes to the parent PK columns the
changes will not be synchronized to the child columns.



« Partial: The Note and Definition text from the parent PK column will be propagated when the relationship is
created or a new column is added to the primary key and the text will be kept synchronized with the parent PK
columns as long as the text in the parent equals the text in the child. If the text in the foreign key attributes is
changed aside from the parents, the tie between the two will be broken.

« PK Indexes: Selecting Manual Sequence enables manual changes to the sequence of primary key index
columns using the Index Editor. Otherwise, you cannot manually change the sequencing of the index.

« Attribute Order: Selecting Logical Order positions all primary key columns before non-key columns. Selecting
Physical Order positions the keys to mimic the order in the Physical Model, meaning that primary keys can
appear before or after non-key columns. When Logical Order is selected primary keys cannot be reordered in the
Entity Editor. If Logical Order is selected after previously selecting Physical Order, the primary keys in each entity
are re-sequenced so they appear first in the attributes list. You can set default column sequence for new models
in the Options Editor > Application tab.

CAUTION: Ifthe Display Level in the Diagram and Object Display Options editor does not match the Attribute
Order designation in the Model Options, drag and drop and on-screen editing errors can occur. If
the true attribute sequence, as designated in the Model Options and the displayed sequence, as
designated in the Diagram and Object Display Options, are not synchronized, then ER/Studio
cannot make the appropriate changes to the entity.

« View Parser: This determines which parser is used to validate the SQL produced when creating a View. This
allows you to maintain and parse platform-specific syntax in the logical model. Having the same parser for both
the logical model and the targeted platform means that after generating a physical model you don't have to
rewrite the View SQL for it.

« Auto Rolename Prefix: The specified string will be added to the beginning of all rolenames.

« Datatype Mapping: If you have customized a datatype mapping for the selected database platform, from the
Datatype Mapping list you can choose an alternate mapping or the system mapping, which is the default. Custom
datatype mappings are created using the Datatype Mapping Editor; click Tools > Datatype Mapping Editor.

Name Handling Options tab: Sets the synchronization level between entity and table names.

« Complete Synchronization: Matches table and column names with their associated entity and column names.
Both names are always synchronized.

¢ Partial Synchronization: Automatically synchronizes table and column names with their associated entity and
attribute names unless you edit the table name, which breaks the synchronization so that the names can be
different. If names are the same, editing the entity name will update the table name.

* No Synchronization: Prompts you to manually specify both sets of names. Entity and table names are separate.
Also, the rolenames link is broken so that in a foreign key relationship child and parent attributes can have
different names.

« Enable Logical Name Editing: Enables you to directly edit the corresponding objects from the table or entity
editor.

Customizing Standard Model Features for New Models

Use the Tools Options to customize your work environment. The preferences you choose here will apply to all new
models created, including those that are reverse-engineered, although some options apply immediately to affect the
display of the current model. Most of the tool options can be by selection in the Changing Diagram and Object Display

Options or Defining Model Options for the Selected Model.

Define the Model Options for All New Models
1 Click Tools > Options.

2 Complete your changes and then click OK.



Click a link below for information on options that are not self-explanatory:

Application tab Logical tab Physical tab

Name Handling tab Display tab Directories tab
Tools tab Diagram tab View tab

Schema Objects tab Object Types tab Object Names tab
Automation Options tab Data Dictionary tab ERX File Import tab
Undo tab Repository Options tab

Application tab

« Show Status Bar: Displays the status bar at the bottom of the application. For a selected physical model, the
status bar displays the name of the database platform and the total number of Views, Tables, Columns, and
Foreign Keys. For a logical model, the status bar display the model type (Logical) and the total number of Views,
Entities, Attributes, and Relationships.

< Unification Options: Unification is the act of combining columns with the same name to create one single
column. It normally occurs when you propagate a foreign key into a table that has an existing column of the same
name.

Compare Names Only: Unifies overlapping foreign keys that have the same name, even if they originate from
different entities.

Compare Names and Datatypes: Unifies overlapping foreign keys that have the same name and that also
originated from the same entity.

Compare Originating Parents: Unifies overlapping foreign keys that originate from the same originating
parent entity.

Prompt to Resolve FK Columns: Launches the Duplicate Attribute Editor, where you must choose how to
resolve duplicate foreign keys names by creating a rolename to resolve the name conflict.

« Submodel Drag and Drop: To prevent you from inadvertently moving a submodel onto another submodel, you
can choose to have a warning presented when this is attempted, or disable this type of move altogether.

Logical tab

« Case Shift: Choose whether to retain case as typed into the editors or convert the letters as you type in names to
upper or lower case.

¢ FK Column Definition/Note Synchronization:

None: The Note and Definition text from the parent PK columns will be propagated when the relationship is
created or a new column is added to the primary key. If there are any changes to the parent PK columns the
changes will not be synchronized with the child columns.

Partial: The Note and Definition text from the parent PK column will be propagated when the relationship is
created or a new column is added to the primary key and the text will be kept synchronized with the parent PK
columns as long as the text in the parent equals the text in the child. If the text in the foreign key attributes is
changed aside from the parents, the tie between the two will be broken.

* PK Indexes: Selecting Manual Sequence enables manual changes to the sequence of primary key index
columns using the Index Editor. Otherwise, you cannot manually change the sequencing of the index.

Physical tab

* Max Table Name Length: This field is read-only. Its value conforms to the rules of the selected database
platform.

« Auto PK Options: If you choose Yes, when automatically creating Primary Key indexes, ER/Studio automatically
clusters the indexes, re-ordering the data blocks in the same order as the index. This can increase access speed.



¢ FK Column Definition/Note Synchronization:

« None: The Note and Definition text from the parent PK columns will be propagated when the relationship is
created or a new column is added to the primary key. If there are any changes to the parent PK columns the
changes will not be synchronized to the child columns.

« Partial: The Note and Definition text from the parent PK column will be propagated when the relationship is
created or a new column is added to the primary key and the text will be kept synchronized with the parent PK
columns as long as the text in the parent equals the text in the child. If the text in the foreign key attributes is
changed aside from the parents, the tie between the two will be broken.

Name Handling tab

These settings determine how entity names are synchronized with table names, how column names are
synchronized with attribute names, and the reverse, across Logical and Physical Models. You may want
changes in entity names to reflect in table names, but not want synchronization in the other direction. For
example, you might fine-tune names during the deployment of a Physical Model but not want name changes
automatically reflected back to the Logical Model.

« Allow Unification When Editing Names: When set, allows changing role names of foreign attribute or columns
to the same names as other attributes or columns in the same Entity or Table. You can also do this in the Entity
Editor > Attributes tab on a selective basis. Duplicate names will be unified when your edits are committed. This
option affects names in the Entity Editor and Table Editor, on-screen name editing, and names in the Explorer
tree. For example, assume you edit on-screen the FK in Entity4 below from AnotherPK to MyPK.

Entity1 Entity5
& MyPK # AnotherPK

B MyPK

% AnotherPK

Entity1 Entity5
&+ MyPK ¥ AnotherPK

Here is the unified result:




To avoid object name conflicts, you can enclose all names in brackets or quotations or enclose only names that
conflict with SQL keywords. If the database platform supports object names enclosed in brackets or quotes, the
options to enclose object names are available in the General Options area of the DDL tab Options and the DDL
Generation Wizard. If you select Enclose Names That Conflict with Keywords, then any column names that
contain SQL keywords will be automatically enclosed in brackets.

Display tab

Page Boundaries: Displays the page boundaries, which lets you determine where objects should be placed in
the diagram for printing purposes.

Turn on Grid And Snap: Displays a grid on the model background and places new model objects next to grid
lines. Lets you evenly space the model objects.

Cardinality: Displays the cardinality of the relationships between entities or tables.

Verb Phrases: Displays defined verb phrases next to the relationship lines in the diagram.
Rolename Notation: Displays full IDEF1X rolename notation.

Display Mode: Lets you select a display mode and then select Display Options. The options are:

« Attribute (Model Order): Displays the entities and all their attributes in the default order according to the
model type. For example, in the logical model, the attributes appear as they normally would in a logical model:
primary keys first.

e Attribute (Logical Order): Displays the entities and all their attributes in Logical Order, regardless of whether
you are in the logical or physical model. When the attributes are in Logical Order, ER/Studio sequences the
attributes so that the primary keys are always on top.

e Attribute (Physical Order): Displays the entities and all their attributes in Physical Order, regardless of
whether you are in the logical or physical model. When the attributes are in Physical Order, ER/Studio
sequences the attributes to reflect their order in the physical model, without regard to whether the primary keys
are on top or not.

Image Export Settings: Sets image file options for HTML Reports, such as JPG, BMP and WMF. If not
selected, the diagram is rendered in black and white.

Directories tab

Defines the directories in which to store models, database scripts, reports, reference models, and macros.

Tools tab

ISQL Path: Lets you type a file name and location of the SQL tool which will launch and manage the SQL
ER/Studio outputs. You can replace the default uisql .exe with any ISQL editor. For example, you can use
DBArtisan or SQL Server Enterprise Manager's Query Analyzer. The default path for DBArtisan is
C:\Program Files\Embarcadero\DBAXXX\DBArtXXX.exe

Startup Directory: Lets you enter a file name and location of the default save directory for the SQL application.

Diagram tab

NOTE: Options selected here apply immediately to the open data model.

Entity: Select the entity information to display when you hover over the entity.

Schema Object Display: Select the schema object information to display when you hover over the schema
object.

Loiter Time: The amount of time in seconds the popup displays.



View tab
¢ Duplicate View Column Name Resolution

* Prompt: Prompts you to supply column aliases to differentiate between columns whenever duplicate column
names exist.

« Don’t propagate: ER/Studio eliminates duplicate column names from the SELECT clause of the SQL
statement generated to create the view.

« Attach prefix and/or suffix: Appends the supplied prefix or suffix to the column names to differentiate
between duplicate column names. The entity name combined with an underscore character (EntityName_) is
the designated prefix; a sequential number is the designated suffix (01).

* View Column Propagation

* Propagate non-keys only: Propagates only of non-key columns from base tables to views.
« Propagate all columns: Propagates all columns to the view.

« Don’t propagate any columns: Does not allow the propagation of any columns to a view. You must select the
columns to propagate in the View Editor.

*« When adding new columns to a view...: If you select Yes, columns added to a view are propagated to the
views of the child views.

Display SQL Validation Dialog: If selected, you will be prompted to validate any updates you make to the
SQL code for the view.

¢ Column Sorting: Sets the column sorting hierarchy for the view, which will also order the DDL SELECT
statement accordingly.

Schema Objects tab

* Show triggers: If selected, creates the triggers in the DDL of the parent and child according to the parent and
child actions specified.

For example, in the Microsoft SQL Server 2005 platform, selecting parent actions Update: Cascade and Delete:
Set Null produces DDL in the parent table resembling the following:

REFERENCES dbo.child_name(foreign_key name) ON UPDATE CASCADE ON DELETE SET NULL
Object Types tab

The object types selected here control the options that are by default selected in the Generate Other Object
Types area of the General Options tab on page 3 of the DDL Generation Wizard; the options selected by default
can be deselected within the DDL Generation Wizard. For more information, see Generating a Script File or
Database.

Object Names tab

The object names chosen here control the names of triggers and procedures generated by the Generation
Wizard. You can choose to generate the system triggers and default table stored procedures on the Generate
Other Object Types area of the General Options tab on page 3 of the DDL Generation Wizard. For more

information, see Generating a Script File or Database.
Automation Options tab

Using the Automation Interface you can customize the functions called when select database objects are
created, deleted, or updated. In order to enable these customized functions, you must select them here. For
more information, see Automation Objects Programmer’s Guide.




Data Dictionary tab

« Show data dictionary name when displaying dictionary objects: When selected, displays Data Dictionary

objects using the selected format. For example, with the second option selected, the tid user datatype, in the
Pubs.dml sample model displays as pubsDD. tid in the Datatype column of the Entity Editor for the Royal ty
Schedule entity.

Migrate domain attachment bindings during drag ‘n’ drop: When selected, attachments bound to a domain
are propagated to the attribute or column when populating an entity or table with a domain during a
drag-and-drop operation or by selecting the domain in the Domain Name list when editing an attribute or column
in the Entity Editor or Table Editor.

« Attribute/Column Definition Updating: If Disallow Updating is selected, domain definitions cannot be

modified from the entity/table editor.

ERX File Import tab

« Validate Views: If selected, tables and columns in the view are checked for proper syntax. Views failing the

validation are marked as invalid.

Validate Stored Procedures: If selected, stored procedures are checked for proper syntax. Stored procedures
failing the validation are marked as invalid.

Import Foreign Key Indexes: Imports FK indexes that ERWin automatically generates for all FKs.

Use Logical Index Names when Physical Index Names are not defined: If not selected, and the physical
index name is blank, a unique index name is generated for any unnamed indexes. If selected and the physical
name is blank, the corresponding name from the logical model is used. If, as a result of selecting this option,
duplicate names are generated in the physical model, they can be isolated using the Model Validation Wizard.

Undo tab

For the operations you select here, you will be prompted for confirmation before executing the operation.

Repository Options tab

This tab only displays if you have licensed the ER/Studio Repository.

¢ Active File Directory: Displays the full path to the directory where Repository data models are stored.

CAUTION: Keep the Active File Directory on a local machine. A shared network directory can result in

Repository operation errors.

Specifying the Location of Shared Data

1

2

3

4

Click Help > About ERStudio.
Click the File Path tab.
On the File Path dialog, specify the location of the directory where shared files will be kept.

Click OK and then click OK again to exit the About ERStudio dialog.

Changing Cursor Popup Help Options
Sets the popup information displayed when you hover the cursor over a diagram object such as an entity, table,

schema object, or relationship. Help set for entities and relationships will be applied to both the logical and the
physical model.

Click View > Cursor Popup Help Options and then select an entity display option.



Data Modeling Fundamentals

E/R Studio is an entity-relationship modeling tool. The following sections outline data modeling concepts and
especially entity-relationship modeling, upon which ER/Studio is based. The design process, from creating a logical
model to creating the physical model, is also explained.

« Data Modeling Concepts - This section describes data modeling concepts, the development of the relational
model, entity-relationship modeling, and the IDEF1X methodology.

« Developing a Data Model - This section describes the steps involved in creating the logical design; including
naming objects, documenting the design, and normalizing the model, as well as creating the physical design,
from transforming it from the logical model to denormalizing the design and implementing the database.

Data Modeling Concepts

A data model represents the things of significance to your enterprise and the relationships between them. At its core,
a data model depicts the underlying structure of an enterprise's data and the business rules governing it. A data
model is comprised of two parts: a logical design_and a physical_design.

A logical model is developed before the physical model. It addresses the business and functional requirements of
systems development. The logical design allows you to determine the organization of the data that you need to store
in a database before you create the database; it serves as a blueprint.

The physical design addresses the technical implementation of a data model, and shows how the data is stored in the
database. For example, you can specify the datatype to be used by each column in the table, and determine how
tables will be stored in the database.

To design the most effective data model possible, you should focus on the logical design before developing the
physical design. Both the logical and physical design processes are complex so it is best to separate rather than to
mix the two. A sound logical design should streamline the physical design process by clearly defining data structures
and the relationships between them.

A data model can be extremely useful for other things besides creating databases, though that is generally its primary
purpose. In systems development, the goal is to create an effective database application that can support some or all
of your enterprise. However, a data model of your business can help you define operational aspects of your business
that you might otherwise overlook. Also, a well-defined data model that accurately represents your business can be
helpful in orienting employees to goals and operations. The data model can also serve as an invaluable
communications tool for both internal and external constituents.

The Relational Model

Most early data models were developed to help systems analysts conform business data to a physical database or
machine architecture. Hierarchical and network models often ran most efficiently on particular systems. In the early
1970s E. F. Codd developed the relational data model, based on relational algebra. The relational model stressed data
independence, where data independence is defined as independence of data from the underlying physical structure in
which it is stored. Thus, systems that supported relational data models let users easily migrate data to larger or newer
systems with little regard for physical differences between storage devices.



The power of the relational model lies in its simplicity. In the relational model, data is organized in tables of rows and
columns. Each table represents one type of data. Each row, or tuple, represents one of the data of that type. Each
column, or domain, represents one type of information about the type of data stored in the table.

Columns (Domains, Attributes)

Empha LMame FMName 35N
0o Brown John 002-34-9789
Rows
{Tuples, Instances) ooz White Ann 989-45-2323
003 Black Leslie 451-00-4576

Sample Relational Table

The Entity-Relationship Model

Peter Chen introduced entity-relationship modeling during the late 1970s. Along with a number of other theorists, such
as Hammer and McLeod with their Semantic Data Model, Chen introduced a new way of thinking about data. This
new way of thinking stressed the idea that a data model should represent the reality of your business, without regard
for how that model might be implemented in a manual or automated system. Though it can seem ridiculous today,
these ideas were revolutionary at the time, and were instrumental in freeing individuals from the constraints of a
hierarchical model of business. The ability to model your business “on paper” let business planners test out and debug
ideas before implementing them, thus saving money, other resources and much aggravation.

The basic idea behind entity-relationship modeling is this: everything in business can be generalized into an abstract
or archetypal ideal, which we call an entity. These entities have certain characteristics or attributes. These entities also
are related to one another through actions that each entity performs on one or more of the other entities. We call these
actions relationships.

Employee M Assigned to Project

Simple Chen E-R Diagram

In determining the relationship between each of the entities in your data model, you will determine a number of
business rules. Business rules define your business and how you run it. For instance, you know that to be useful, each
employee ID, project ID, and department ID must be unique. While you could use the social security number as the
employee ID, you might want to keep the ID short and more easily sorted. More complex issues to consider are
guestions such as, “How are we to connect employees, projects, and departments so that we minimize data
redundancy and maximize our reporting capabilities?” The answers to this and other questions form the rules by which
you run your business.

Attribute definitions can be used along with relationships to determine or enforce business rules. You can define a
particular set of valid values for any attribute of any entity. For example, you can define a valid range of salaries for a
subset of employees for an attribute called Salary. This set of values is known as a domain.

The Dimensional Model

Dimensional modeling is said to be the most useful for representing end-user access to data. Where a single ER
diagram for an enterprise represents every possible business process, a DM diagram represents a single business
process in a fact table. ER/Studio can identify individual business process components and create the DM diagram for
you.



You can generate a DM diagram by starting with a logical model, by reverse-engineering, by importing a SQL or ERX
file, or by adding a new physical model.

Developing a Data Model

The following overview outlines the ER/Studio data model development process, which is an iterative process.

Starting With a Basic Data Model
You can start from scratch or re-engineer an existing database.

Creating a Basic Data Model

1
2

3
4
5

Create a new data model. (See Creating and Working With Data Models.)

Add entities. (See Creating and Editing Entities and Attributes.)
Define entity attributes. (See Creating and Editing Attributes and Columns.)
Establish relationships between entities. (See Creating Relationships.)

Assign keys (See Creating and Editing Keys.)

Reverse Engineering a Database

Reverse engineer a database. (See Reverse Engineering an Existing Database.)

Importing a File to Create a New Database

Import data from a variety of sources to create a new database. (See Importing a Model from an ERX File,
Importing a Model from an SQL File, and Importing a Data Model from Describe

Ensuring Data Integrity

1

Ensure object names conform to business standards by creating and applying naming conventions. (See Enforce
Naming Standards Using Naming Standards Templates.)

Ensure data values are within a specified range or that they match a value defined in a list by defining reference
values. (See Defining Valid Attribute Data Using Reference Values.)

Ensure data input in tables or column is valid by add rules. (See Promoting Data Integrity Through Rules.)

Automating Data Model Creation and Maintenance

1

Accelerate entity creation and updates by creating domains. (See Ensuring Consistent Domain Definitions Using
User Datatypes.)

Assist user data entry by assigning default values (See Documenting Data Extraction, Transformation, and
Load.)

Create Macros to perform repetitive tasks. (See Automating ER/Studio.)
Define default values for attributes, domains, and user datatypes. (See Create and Edit Defaults.)

Add reusable procedural logic. (See Reusing Procedural Logic.)




Fine Tuning the Data Model

1
2
3

Validate the Model (See Validating the Model.)

Customize the Datatype Mappings (See Customizing Datatype Mappings.)

Create user-defined datatypes for domains and attributes. (See Ensuring Consistent Domain Definitions Using
User Datatypes.)

Generate a Physical Model (See Generating a Physical Data Model.)
Normalize to reduce data redundancy. (See Normalization.)

Denormalize to improve performance (See Denormalizing the Physical Model)

Securing the Data Model

1

2

Check the data model in to the Repository. (See Saving Changed Items to the Repository (Checking In).)

Prevent the data model from being updated or viewed by unauthorized persons by creating Users and Roles and
apply them to the data model. (See Creating and Managing Users and Creating and Managing Roles.)

Prevent the database from being updated or viewed by unauthorized persons by creating Users and Roles and
apply them to the data model. (See Creating and Editing Database Users and Creating and Editing Database
Roles.)

Specify data security information. (See Enforcing Security Using Data Security Types and Properties.)

Preparing for Review and Implementation

1

2
3
4
5
6

Customize the model display (See Customizing the Data Model.)

Provide additional documentation for data model reviewers by creating attachments. (See Validating the Model.)

Document data lineage. (See Documenting Data Extraction, Transformation, and Load )
Create reports for distribution. (See Generating RTF and HTML Model Reports.)

Make it easy for users to access the data by providing a dimensional mode. (See Changing the Model Notation.)

Generate SQL to implement the database. (See Generating a Script File or Database.)

Maintaining the Data Model

1

Ensure the model is updated from the correct sources by documenting data lineage. (See Documenting Data
Extraction, Transformation, and Load.)

As the physical database is updated, synchronize the physical database model with the physical database. (See
Updating a Model Using the Compare and Merge Utility.)

As the physical database model is updated, synchronize the logical database with the physical database. (See
Synchronizing Physical and Logical Models.)

As updates are required, check out portions of the data model from the Repository. (See Viewing the Checkin
History of a Repository Object.)




Using ER/Studio

This section includes the following topics:

* Creating and Working With Data Models

« Best Practices
¢ Common Tasks

* Developing the Logical Model

* Developing the Physical Model

* Working with the Data Dictionary

« Documenting Data Extraction, Transformation, and Load

e Saving and Using Quick Launch Settings
¢ Generating RTF and HTML Model Reports

* Exporting the Data Model

* Printing the Data Model

« Exporting an Image of the Data Model

Creating and Working With Data Models

ER/Studio’s data modeling features enable you to create automatic and customized data model diagrams. ER/Studio
provides functionality to set automatic layouts, change colors and fonts of your objects, and specify relationship lines.

ER/Studio offers five preset auto layouts. You can use a preset layout to automatically generate your data model into
a specific diagram. These automatic layouts dictate how ER/Studio displays relationships and objects. Although these
layouts create a specific diagram with specific rules that control relationships and object placement, you can still
change certain aspects of the display, overriding the automatic layout.

You can set color and font settings for almost any object in your diagram. You can create changes that affect all
objects in your diagram. If you make a change in color or font to the entire diagram, you can then select individual
objects to customize differently.

ER/Studio gives you control over relationship lines. You can control the color, bending, straightening, verb phrases,
and docking points of relationship lines.

If you are working with large data models, ER/Studio offers features that help you zoom and navigate your models
easily. The Overview Window and Zoom Window display thumbnail views of your entire data model. Utilities
accessible from the Diagram toolbar, let you zoom, navigate relationships, and fit your entire data model into the
Diagram Window.

There a several ways to create a data model. This section describes these methods:

¢ Creating a New, Blank Data Model

« Reverse Engineering an Existing Database

¢ |mporting a Model

« Generating a Physical Data Model



¢ Updating a Model Using the Compare and Merge Utility

Creating a New, Blank Data Model
1 Click File > New.

2 Select Draw a new data model and then click OK.

3 Click File > Save, navigate to the appropriate directory, enter a file name, and then click Save.

Reverse Engineering an Existing Database

Use the Reverse engineering function to create a logical and physical model by extracting information from an existing
Data Source. You can specify a data source to reverse engineer using an ODBC or Native connection. Using the
Reverse Engineer Wizard and the native connection, you can specify exactly what you want to reverse engineer,
selecting from a particular database, tables, views, indexes, defaults, rules, user datatypes, owners, objects, views,
and dependencies. Using the Reverse Engineer and an ODBC connection allows you reverse engineer only tables
and views. The information extracted for tables includes constraints, primary keys, foreign keys, and comments. Using
the Quick Launch feature, you can save a set of reverse-engineering options to a file and retrieve them the next time
you need to perform a similar reverse-engineering operation.

1 Click File > New.

2 Select Reverse-engineer an existing database and then click Login.
3 Enter your database connection and login information.

4 The Reverse Engineer Wizard displays.

Here you can select specific objects and information to include in the reverse engineered model. The Reverse
Engineer Wizard will walk you through the rest of the process.

The following describe fields and options in the wizard that are not self-explanatory.
Page 1
e Connection Type:

« ODBC: Using an ODBC connection, you can only reverse engineer tables and views. To add a new ODBC
Data Source or edit an existing one, click Setup to open the ODBC Data Source Administrator dialog. For
more information, see Configuring ODBC Data Source and Target Connections.

« Native/Direct: Using a Native or Direct connection, you can reverse engineer all supported objects for the
selected platform. For more information, see Using Native or Direct Database Connections.

» Database Type: Using a Native connection, ER/Studio can reverse engineer the following databases:
« IBM DB2 OS/390
« IBM DB2 for UDB
¢ MS SQL Server
* Oracle
* Sybase ASE
« Data Source: This field differs depending on if you selected an ODBC or Native connection.
» For an ODBC connection, select a data source from the list.

« For a Native connection, enter the data source connection string.



¢ Quick Launch: In the last step of the wizard, you can save settings to a file for later reuse. If you have previously
saved such a file, you may load it step by clicking the ... button next to Select Settings File on page 2 of the
Import Model wizard. Then click Go to run the import exactly as before, or click Next to modify the settings. The
Wizard Quick Launch data is saved as an .rvo file. The default location for these files is:

Page 2

Windows XP: C:\Documents and Settings\<user>\Embarcadero\ERStudio\XML
Windows Vista: C:\Users\<user>\AppData\Roaming\Embarcadero\ERStudio\XML

To change the default directory for Quick Launch files, click Tools > Options > Directories.

« Database List: If the database platform supports databases, browse and locate one or more databases to
reverse engineer.

¢ Owner List: If the database platform supports databases, browse and locate one or more owners to reverse
engineer.

¢ Include: Select the objects to include in the data model. The default selection is User Tables.
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« Capacity Planning: Selecting any of these options returns information about the database that can help you plan
for storage requirements.

* Object tabs: Displays a tab for every object type selected in the Include list on the previous page. Click the object
tab, review the available objects, and then use the arrows to move the objects you want to reverse engineer to
the Selected Objects area.
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« Infer Referential Integrity: ER/Studio can infer referential Integrity when none is declared in the database. Click
the options that follow to create relationships between entities in your diagram.

Infer Primary Keys: If selected, ER/Studio infers primary keys from unique indexes on a table. If more than
one unique index exists on a table, ER/Studio chooses the index with the fewest columns.

Infer Foreign Keys from Indexes: If selected, ER/Studio infers foreign keys from indexes. When inferring
foreign keys from indexes, ER/Studio looks for indexes whose columns match the names, datatype properties,
and column sequences of a primary key. If the “child” index is a primary key index, it must contain more
columns than the “parent” primary key. In this case, an identifying relationship is created.

Infer Foreign Keys from Names: If selected and your database contains foreign keys, ER/Studio infers
foreign keys from names. When inferring foreign keys from names, ER/Studio looks for columns matching the
names and datatype properties of a primary key. In this case, a non-identifying relationship is created.
ER/Studio cannot infer relationships where the child column has a role name, instead create a
Non-Identifying Relationship and then designate the correct role-named column using the Edit RoleName
function.

Infer Domains: If selected, ER/Studio infers domains from the columns in the database. ER/Studio creates a
domain for each unique combination of a column name and its associated datatype properties. Duplicate
domains with an underscore and number suffix indicate that columns with the same name but different
datatypes were found in the database. This can alert you of how standardized the columns are in a database.
You can use macros to consolidate domains and preserve the bindings from the inferred domains.

* View Dependencies: ER/Studio can ensure all objects referenced by those selected for reverse engineering are
also included.

Reverse Engineer View Dependencies: If selected, ER/Studio includes referenced view dependencies.

Reverse Engineer Other Dependencies: If selected, ER/Studio includes referenced dependencies such as
procedures and triggers. Dependent objects that are not otherwise selected will be included. For example, a
database contains procl, proc2 and proc3, and proc3 references procl and proc2. During reverse
engineering, if you selected only proc3 and this option, procl and proc2 are also included.



Select the Initial Layout Option: Select an initial layout for the data model:

e Circular Layout and Tree Layout - Provide best performance when reverse engineering large databases.

For more information on layout, see Changing Data Model Layout.

View Parser: Select a platform-specific syntax interpreter.
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Summary of Selected Objects: Select an object type to display in the Summary of Selected Objects grid and
then review the object type, owner, and object name of all the objects you selected for the reverse engineer.

Notes

You can reverse engineer diagrams created with DT/Designer to create ER/Studio models.

Reverse-engineered diagrams do not display users and roles by default. To enable Users and Roles, click View
> Diagram and Object Display Options > Security Object > Display All Security Objects.

To create a logical model only from the database, click Tools > Options > Application > Reverse Engineer >
Logical Model Only.

In order to reverse engineer a database you must have both CONNECT and RESOURCE roles assigned to your
user ID.

Objects in SQL 2005 are owned by schemas. A schema can be equated to a user, but does not have to be. This
is not explicitly represented in the explorer tree, nor is there a CREATE SCHEMA DDL function. In the Reverse
Engineering and Compare/Merge Wizards, the “owner” field in the object editors of ER/Studio represent the
schema name for a SQL Server 2005 physical model. The field will be the schema list.

See Also

Specify Application Options for Reverse Engineering

Specify Application Options for Reverse Engineering

Using the Application tab of the Options Editor, you can specify whether reverse engineering always produces both
logical and physical models or logical models only. You can also specify the column sequence for new models that
you revers engineer. Once applied, this customization will apply to all your reverse-engineering projects.

1

2

Click Tools > Options and then click the Application tab.

Specify your reverse-engineering preferences in the Reverse Engineer and Column Order: Reverse Engineer
areas of the Application tab.

Click OK to apply your changes to future reverse-engineering projects.

Importing a Model

ER/Studio allows you to import models from several other applications. This section describes the following import
methods:

« Importing a Model from External Metadata

Importing a Model from an ERX File

Importing a Model from an SQL File




¢ Importing a Data Model from Describe

NOTE: For the best performance when reverse engineering large databases, select Circular or Tree as
the initial layout of your model.

Importing a Model from External Metadata

MetaWizard, a separate product available from Embarcadero, extends ER/Studio’s functionality by providing an import
bridge that allows you to import metadata from applications such as Microsoft Excel, CA AllFusion Erwin, IBM Rational
Data Architect, Oracle Designer, and Sybase PowerDesigner, and from XML structures.

1 Click File > New.
2 Select Import Model from and then from the list, click External Metadata.
3 Click Import.

4  From the Type list in the Import External Metadata wizard, select the XML type of the file to be imported or the
application that created the file.

5 Click the folder icon and then select the file to be imported.
6 Optionally, set the options. which vary depending on the Type selected.

To change a type-specific option, click its value.

7 To start the import, click Next.
The import log displays.
8 Ifimport was successful, click Finish to create the model.
9 When the Import Status Dialog displays “Finished Import,” click Close.

10 Save the new model.

Notes

« The Import File From External Metadata command generates a data model based on metadata in standard XML
and common proprietary formats. For a current list of supported platforms, valid BridgelDs, and corresponding
bridge names, see:

« Windows XP: C:\Program
Files\Embarcadero\ERStudio_X.X\Metalntegration\MIRModelBridges.xml

e Windows Vista:
C:\ProgramData\Embarcadero\ERStudio_X.X\Metalntegration\MIRModelBridges.xml

The .pdf version of this file is available at http://www.embarcadero.com/products/erstudio/erdocs.html.

The options are self-explanatory and additional details appear in the area beneath the options list.

Importing a Model from an ERX File

ER/Studio lets you create a data model by importing ERX files created with ERwin or Meta Integration’s MIMB.
ER/Studio can import ERX files created with ERwin, versions 2.6 through 3.52.

1 Click File > New.

2 Select Import Model from and then from the list, choose ERX File.


http://www.embarcadero.com/products/erstudio/erdocs.html

Click Import.

Navigate to the appropriate directory, select the .erx file, and then click Open.
The import log displays.

Optional. To save or print the log, click Save to File or Print.

If import was successful, click Finish to create the model.

When the ERX Import Status displays “Finished Import,” click Close.

Save the new model.

Importing a Model from an SQL File

1
2
3

Click File > New.

Select Import Model from and then from the list, choose SQL File.

Click Import.

Complete the Import Database SQL File dialog, click OK.

The import log displays.

Optional. To save or print the log, click Save to File or Print.

If import was successful, click Finish to create the model.

When the Import Status Dialog displays “Finished Import,” click Close.

Save the new model.

The following describe fields and options in the wizard that are not self-explanatory.

Quick Launch: In the last step of the wizard, you can save settings to a file for later reuse. If you have previously
saved such a file, you may load it step by clicking the ... button next to Select Settings File on page 2 of the
Import Model wizard. Then click Go to run the import exactly as before, or click Next to modify the settings. The
Wizard Quick Launch data is saved as an .rvo file. The default location for these files is:

¢« Windows XP: C:\Documents and Settings\<user>\Embarcadero\ERStudio\XML
* Windows Vista: C:\Users\<user>\AppData\Roaming\Embarcadero\ERStudio\XML

To change the default directory for Quick Launch files, click Tools > Options > Directories.

« Select a Database SQL File: Type the database file name or browse to the file location and click Open.

« Select the target database platform: From the list, select the target database platform.



Infer Referential Integrity: ER/Studio can infer referential Integrity when none is declared in the database. Click
the options that follow to create relationships between entities in your diagram.

« Infer Primary Keys: If selected, ER/Studio infers primary keys from unique indexes on a table. If more than
one unique index exists on a table, ER/Studio chooses the index with the fewest columns.

< Infer Foreign Keys from Indexes: If selected, ER/Studio infers foreign keys from indexes. When inferring
foreign keys from indexes, ER/Studio looks for indexes whose columns match the names, datatype properties,
and column sequences of a primary key. If the “child” index is a primary key index, it must contain more
columns than the “parent” primary key. In this case, an identifying relationship is created.

¢ Infer Foreign Keys from Names: If selected and your database contains foreign keys, ER/Studio infers
foreign keys from names. When inferring foreign keys from names, ER/Studio looks for columns matching the
names and datatype properties of a primary key. In this case, a non-identifying relationship is created.
ER/Studio cannot infer relationships where the child column has a role name, instead create a Non-ldentifying
Relationship and then designate the correct role-named column using the Edit RoleName function.

« Infer Domains: If selected, ER/Studio infers domains from the columns in the database. ER/Studio creates a
domain for each unique combination of a column name and its associated datatype properties. Duplicate
domains with an underscore and number suffix indicate that columns with the same name but different
datatypes were found in the database. This can alert you of how standardized the columns are in a database.
You can use macros to consolidate domains and preserve the bindings from the inferred domains.

Select the Initial Layout Option: Select an initial layout for the data model:

« Circular Layout or Tree Layout: If selected, provide best performance when reverse engineering large
databases. For more information, see Changing Data Model Layout.

View Parser: Select a platform-specific syntax interpreter.

Summary of Selected Objects: Select an object type to display in the Summary of Selected Objects grid and
then review the object type, owner, and object name of all the objects you selected for the reverse engineer.

Importing a Data Model from Describe

Describe is a complete UML visual modeling solution from Embarcadero for accelerating software design and
collaborative development. Using ER/Studio’s Describe Collaboration you can create ER/Studio data models directly
from Describe diagrams.

The process of importing a Describe Project into a new ER/Studio diagram follows these basic steps:

1

2

A W

6

Create a new ER/Studio diagram.
Create a logical model.

Process any imported Data Dictionaries.
Loop through the mapping structure.
Convert the relationships.

Mark the Describe project with the newly created ER/Studio diagram.

This sequence is followed during the process of importing Describe classes into an existing ER/Studio diagram:

1
2
3

Get the diagram.
Get the logical model.

Process any imported Data Dictionaries.



4 Loop through the structure:
« If the entity node does not have an associated entity, create one.
« If the entity node’s name is modified, get its associated entity and update the entity.
« If the entity node has new attributes, add attributes to the associated entity.

5 If the entity node has modified attributes, update the associated entity’s attributes.

The ER/Studio - Describe Integration Advanced Setup Editor lets you set various options for importing Describe
projects into ER/Studio diagrams. The ER/Studio - Describe Integration Preferences Editor lets you set general
preferences for importing Describe projects into ER/Studio.

Before you begin importing from Describe, you should review the following topics:

« Supported Describe Diagrams and Classes

« Standard Datatype Lengths in ER/Studio

¢ |mport Database Types

¢ Describe - ER/Studio Mapping

See Also
Importing a Describe Project Using the Wizard

Importing a Data Model from Describe Using the Advanced Method

Setting Describe Collaboration Preferences for Importing from Describe

Supported Describe Diagrams and Classes

Using ER/Studio’s Describe Collaboration you can create an ER/Studio models directly by importing the following
types of Describe UML diagrams:

e Class
* Component
« Deployment
* Robustness
Only cldclasses can be imported from Describe to ER/Studio. The following are the cldclasses that you can import:
« Standard classes
¢ Iconix Boundary classes
* Iconix Control classes
« Iconix Entity classes

NOTE: Template and Utility classes, as well as interfaces, are not exported.



Standard Datatype Lengths in ER/Studio

When converting attributes of Describe diagrams with user-defined types to standard datatypes in ER/Studio,
user-defined datatypes that don not have an array specifier to designate the width of the attribute are assigned the
following default widths. These widths are not always evident when you look at the attributes.

NOTE: When converting ER/Studio standard datatypes having these standard widths to Describe
user-defined types, no array specifier is designated. Only non-standard widths are saved in the
array specifier field for the attribute.

Database Type Width
BIGINT 19
BINARY 18
BIT 1
CHAR 18
COUNTER 10
DATE -1
DATETIME -1
DATETIMN -1
DECIMAL 8
DECIMALN 8

DOUBLE PRECISION |18

FLOAT 8

FLOATN 8

IMAGE/LONG BINARY | 18

INTEGER 10
INTN 10
LONG VARCHAR 18

MLSLABEL/VARCHAR | 18

MONEY 19
MONEYN 19
NCHAR 18
NTEXT/LONG 18
NVARCHAR

NUMERIC 9
NUMERICN 9
NVARCHAR 18
PICTURE 18

REAL/SMALLFLOAT 7

ROWID/VARCHAR 18
SERIAL/INTEGER -1
SMALLDATETIME -1

SMALLINT 5




Database Type Width

SMALLMONEY 7
TEXT 18
TIME/DATETIME -1
TIMESTAMP/DATE -1
TINYINT 3
UNIQUEID 16

VARBINARY/BLOB 18

VARCHAR 18

VARIANT 20

Import Database Types
The following table illustrates the various UML types and the database types to which they map:

UML Type Database Type

long BIGINT

byte BINARY

bool BIT

string CHAR

int COUNTER

string DATE

string DATETIME

string DATETIMN

float DECIMAL

float DECIMALN

double DOUBLE PRECISION

float FLOAT

float FLOATN

byte IMAGE/LONG BINARY

int INTEGER

int INTN

string LONG VARCHAR

string MLSLABEL/VARCHAR

float MONEY

float MONEYN

string NCHAR

string NTEXT/LONG
NVARCHAR

float NUMERIC




UML Type Database Type
float NUMERICN

string NVARCHAR

byte PICTURE

float REAL/SMALLFLOAT
string ROWID/VARCHAR
int SERIAL/INTEGER
string SMALLDATETIME
short SMALLINT

Float SMALLMONEY
string TEXT

string TIME/DATETIME
string TIMESTAMP/DATE
short TINYINT

int UNIQUEID

byte VARBINARY/BLOB
string VARCHAR

char VARIANT

Describe - ER/Studio Mapping

The ER/Studio - Describe integration allows direct mapping of Describe class symbols to ER/Studio logical model
entities. In general terms, this lets you generate an ER/Studio data model from a class model. The purpose of the
integration is to give a database modeler using ER/Studio the ability to create a class diagram from a logical database
model.

The integration process maps Describe classes in a specific format. Before importing a class diagram into ER/Studio
you should understand how ER/Studio maps to Describe. Review the following topics to ensure success:

¢ Mapping Datatypes Between Describe and ER/Studio

* Mapping Relationships Between Describe and ER/Studio

¢ Optional vs. Mandatory Relationship (Existence) Mappin

¢ Cardinality Mapping

Mapping Datatypes Between Describe and ER/Studio

The ER/Studio Describe integration includes default mappings that are displayed in the ER/Studio - Describe
Integration Advanced Setup - Datatypes tab. You can add, change, or delete mappings, import mappings from an
XML file, or import a Data Dictionary and then save the new mappings in another datatype mapping file for later use.
You cannot modify the default datatypes file; it is read-only.

1 Click File > Describe™ Collaboration > Import from Describe > Advanced.
2 Onthe Describe - ER/Studio Integration Advanced Setup dialog, click the Datatypes tab.

3 Click a UML or Database type and then select another type from the list.



4 When finished changing the UML to datatype mappings, click Save Mapping, and save your changes to a new
mapping file.
5 When finished making changes on the other tabs of the dialog, click OK.
A new model is created based on the Describe project specified.
Notes

The following describes options that are not self-explanatory:

Datatypes added as: Database types are mapped to UML types; you can add datatypes as User Datatypes or
as Domains. Select an option.

Import Mapping: Select Import Mapping to import an XML file that contains datatype mappings. The Open
dialog opens, allowing you to select an XML file. Click Open to import the file and return to the ER/Studio -
Describe Integration Advanced Setup Editor.

Import Dictionary: Lets you import an ER/Studio diagram’s Data Dictionary. Clicking Import Dictionary opens a
dialog box, that lets you select a dm1 file whose Data Dictionary you want to use. Click Open to import the Data
Dictionary and return to the ER/Studio - Describe Integration Advanced Setup Editor.

Mapping Relationships Between Describe and ER/Studio
The table below illustrates how Describe relationships map to ER/Studio relationships.

Describe Relationship ER/Studio Relationship

Generalization Link Creates an incomplete subtype cluster:

ER/Studio supertype = Describe Super Class
ER/Studio supertype = Describe Super Class

Realization Link Not supported for export to ER/Studio
Dependency Link Not supported for export to ER/Studio
1:1 association link Creates a non-identifying relationship:

ER/Studio parent = Describe start class
ER/Studio child = Describe end class

1:N association link Creates a non-identifying relationship:

ER/Studio parent = Describe start class
ER/Studio child = Describe end class

N:M association link Creates a non-specific relationship:

ER/Studio parent = Describe start class
ER/Studio child = Describe end class

Aggregation link Creates a non-identifying relationship:

ER/Studio parent = Describe end class
ER/Studio child = Describe start class

Composition link Creates an identifying relationship:

ER/Studio parent = Describe end class
ER/Studio child = Describe start class




Optional vs. Mandatory Relationship (Existence) Mapping

You can specify the Existence property of relationships as either optional or mandatory in ER/Studio. When a
non-specific or identifying relationship occurs in ER/Studio, it must be mandatory. This property is stored on the
association in Describe as a tagged value called Existence.The table below details how the tagged value is mapped to
the Existence option in ER/Studio:

Value of Describe Existence Tagged Value | Existence Option in ER/Studio
Optional Optional

Mandatory Mandatory

No tagged value Optional

Invalid tagged value Optional

Many-to-many relationship with Optional Mandatory

Many-to-many relationship with Mandatory Mandatory

Identifying relationship with Optional Mandatory

Identifying relationship with Mandatory Mandatory

Cardinality Mapping

Relationships in ER/Studio can have different values for cardinality, based on the type of relationship and whether it is
an optional or mandatory relationship. This cardinality is mapped to the Rolel and Role2 upper and lower bounds for
the association in Describe. The table below shows this mapping going from Describe to ER/Studio.

Existence = Mandatory

Rolel Rolel Upper Role2 Lower | Role2 Upper Expected Cardinality in ER/Studio

Lower Bound Bound Bound

Bound

Empty 1 0 * One to Zero or More

Empty 1 1 * One to One or More

Empty 1 0 1 One to Zero or One

Empty 1 Empty N (i.e. 1, 2, 3) One to Exactly N

Empty 1 N Empty One to Exactly N

Empty 1 N N One to Exactly N

0 1 0 * This would not be valid in ER/Studio, uses default
One to Zero or More

0 1 1 * This would not be valid in ER/Studio, uses default
One to Zero or More

0 1 0 1 This would not be valid in ER/Studio, uses default
One to Zero or More

0 1 Empty N This would not be valid in ER/Studio, uses default
One to Zero or More

0 1 N Empty This would not be valid in ER/Studio, uses default
One to Zero or More

0 1 N N This would not be valid in ER/Studio, uses default
One to Zero or More

1 1 0 * One to Zero or More




Rolel Rolel Upper Role2 Lower | Role2 Upper Expected Cardinality in ER/Studio

Lower Bound Bound Bound

Bound

1 1 1 * One to One or More

1 1 0 1 One to Zero or One

1 1 Empty N One to Exactly N

1 1 N Empty One to Exactly N

1 1 N N One to Exactly N

Empty 0 0 * This would not be valid in ER/Studio, uses default
One to Zero or More

Empty 0 1 * This would not be valid in ER/Studio, uses default
One to Zero or More

Empty 0 0 1 This would not be valid in ER/Studio, uses default
One to Zero or More

Empty 0 Empty N This would not be valid in ER/Studio, uses default
One to Zero or More

Empty 0 N Empty This would not be valid in ER/Studio, uses default
One to Zero or More

Empty 0 N N This would not be valid in ER/Studio, uses default
One to Zero or More

0 0 0 * This would not be valid in ER/Studio, uses default
One to Zero or More

0 0 1 * This would not be valid in ER/Studio, uses default
One to Zero or More

0 0 0 1 This would not be valid in ER/Studio, uses default
One to Zero or More

0 0 Empty N This would not be valid in ER/Studio, uses default
One to Zero or More

0 0 N Empty This would not be valid in ER/Studio, uses default
One to Zero or More

0 0 N N This would not be valid in ER/Studio, uses default
One to Zero or More

1 Empty 0 * One to Zero or More

1 Empty 1 * One to One or More

1 Empty 0 1 One to Zero or One

1 Empty Empty N One to Exactly N

1 Empty N Empty One to Exactly N

1 Empty N N One to Exactly N

0 Empty 0 * This would not be valid in ER/Studio, uses default
One to Zero or More

0 Empty 1 * This would not be valid in ER/Studio, uses default
One to Zero or More

0 Empty 0 1 This would not be valid in ER/Studio, uses default

One to Zero or More




Rolel Rolel Upper Role2 Lower | Role2 Upper Expected Cardinality in ER/Studio

Lower Bound Bound Bound

Bound

0 Empty Empty N This would not be valid in ER/Studio, uses default
One to Zero or More

0 Empty N Empty This would not be valid in ER/Studio, uses default
One to Zero or More

0 Empty N N This would not be valid in ER/Studio, uses default
One to Zero or More

Empty Empty 0 * This would not be valid in ER/Studio, uses default
One to Zero or More

Empty Empty 1 * This would not be valid in ER/Studio, uses default
One to Zero or More

Empty Empty 0 1 This would not be valid in ER/Studio, uses default
One to Zero or More

Empty Empty Empty N This would not be valid in ER/Studio, uses default
One to Zero or More

Empty Empty N Empty This would not be valid in ER/Studio, uses default
One to Zero or More

Empty Empty N N This would not be valid in ER/Studio, uses default
One to Zero or More

Empty 1 0 * Zero or One to Zero or More

Empty 1 1 * Zero or One to One or More

Empty 1 0 1 Zero or One to Zero or One

Empty 1 Empty N (i.e. 1, 2, 3) Zero or One to Exactly N

Empty 1 N Empty Zero or One to Exactly N

Empty 1 N N Zero or One to Exactly N

0 1 0 * Zero or One to Zero or More

0 1 1 * Zero or One to One or More

0 1 0 1 Zero or One to Zero or One

0 1 Empty N Zero or One to Exactly N

0 1 N Empty Zero or One to Exactly N

0 1 N N Zero or One to Exactly N

1 1 0 * Zero or One to Zero or More

1 1 1 * Zero or One to One or More

1 1 0 1 Zero or One to Zero or One

1 1 Empty N Zero or One to Exactly N

1 1 N Empty Zero or One to Exactly N

1 1 N N Zero or One to Exactly N

Empty 0 0 * Zero or One to Zero or More

Empty 0 1 * Zero or One to One or More

Empty 0 0 1 Zero or One to Zero or One

Empty 0 Empty N Zero or One to Exactly N




Rolel Rolel Upper Role2 Lower | Role2 Upper Expected Cardinality in ER/Studio

Lower Bound Bound Bound

Bound

Empty 0 N Empty Zero or One to Exactly N

Empty 0 N N Zero or One to Exactly N

0 0 0 * Zero or One to Zero or More

0 0 1 * Zero or One to One or More

0 0 0 1 Zero or One to Zero or One

0 0 Empty N Zero or One to Exactly N

0 0 N Empty Zero or One to Exactly N

0 0 N N Zero or One to Exactly N

1 Empty 0 * Zero or One to Zero or More

1 Empty 1 * Zero or One to One or More

1 Empty 0 1 Zero or One to Zero or One

1 Empty Empty N Zero or One to Exactly N

1 Empty N Empty Zero or One to Exactly N

1 Empty N N Zero or One to Exactly N

0 Empty 0 * Zero or One to Zero or More

0 Empty 1 * Zero or One to One or More

0 Empty 0 1 Zero or One to Zero or One

0 Empty Empty N Zero or One to Exactly N

0 Empty N Empty Zero or One to Exactly N

0 Empty N N Zero or One to Exactly N

Empty Empty 0 * This would not be valid in ER/Studio, uses default
One to Zero or More

Empty Empty 1 * This would not be valid in ER/Studio, uses default
One to Zero or More

Empty Empty 0 1 This would not be valid in ER/Studio, uses default
One to Zero or More

Empty Empty Empty N This would not be valid in ER/Studio, uses default
One to Zero or More

Empty Empty N Empty This would not be valid in ER/Studio, uses default
One to Zero or More

Empty Empty N N This would not be valid in ER/Studio, uses default

One to Zero or More




Importing a Describe Project Using the Wizard
The ER/Studio Describe Import Wizard is a five areal wizard that lets you import Describe class symbols and their
relationships into an ER/Studio diagram.

NOTE: You must have Describe open to invoke this wizard.

1 Click File > Describe Collaboration > Import From Describe > Wizard.
2 Follow the Describe - ER/Studio Integration Wizard prompts as it walks you through the rest of the process.

NOTE: Selections you choose on the Preferences and Datatypes tabs of the Advanced editor or the
Preferences editor are used by the wizard. You can change these preferences by clicking
Advanced on the last page of the wizard.

Importing a Data Model from Describe Using the Advanced Method
1 Click File > Describe Collaboration > Import From Describe > Advanced.

The Describe - ER/Studio Integration Advanced Setup dialog appears.
NOTE: You can also access the Advanced Setup dialog by clicking Advanced on the last page of the

Describe Collaboration Wizard.

NOTE: Selections you choose on the Preferences and Datatypes tabs of the Advanced editor will appear
on the respective tabs of the Preferences editor.

2 Loop through the tabs of the dialog and then click OK.
The following describes options that are not self-explanatory:

« Assume Bi-Directionality: If selected, for any association that is non-navigable at both ends, it is assumed that
it is navigable at both ends.

e Import Mapping: Select Import Mapping to import an XML file that contains datatype mappings. The Open
dialog opens, allowing you to select an XML file. Click Open to import the file and return to the ER/Studio -
Describe Integration Advanced Setup Editor.

¢ Class Actions:

* Insert As New: Lets you insert the selected class and its attributes as a new entity in ER/Studio. The inserted
entity is labeled “New”.

* Insert into Selected: Lets you insert the selected class into the selected entity.

* Select Associated: Lets you discover a class’s or attribute’s associated entity; after selecting this menu item,
the selected class’s or attribute’s entity is highlighted in the ER/Studio Entities list box.

Setting Describe Collaboration Preferences for Importing from Describe

Preferences and Datatype you select in this editor or in the Advanced Setup dialog are retained for later use in the
Describe Collaboration Wizard and the Advanced Setup dialog.

1 Click File > Describe Collaboration > Import From Describe > Preferences.

The Describe - ER/Studio Integration Preferences editor appears. The Preferences and Datatypes tabs of this
editor are identical to the respective tabs of the Describe - ER/Studio Integration Advanced Setup dialog.

NOTE: Selections you choose on the Preferences and Datatypes tabs of the Advanced editor will appear
on the respective tabs of the Preferences editor.



2 Loop through the tabs of the dialog and then click OK.

The following notes describe the options that are not self-explanatory:

Assume Bi-Directionality: If selected, for any association that is non-navigable at both ends, it is assumed that
it is navigable at both ends.

Import Mapping: Select Import Mapping to import an XML file that contains datatype mappings. The Open
dialog opens, allowing you to select an XML file. Click Open to import the file and return to the ER/Studio -
Describe Integration Advanced Setup Editor.

Class Actions:

* Insert As New: Lets you insert the selected class and its attributes as a new entity in ER/Studio. The inserted
entity is labeled “New”.

* Insert into Selected: Lets you insert the selected class into the selected entity.

* Select Associated: Lets you discover a class’s or attribute’s associated entity; after selecting this menu item,
the selected class’s or attribute’s entity is highlighted in the ER/Studio Entities list box.

Generating a Physical Data Model

The Generate Physical Model Wizard automatically creates a relational or dimensional physical model based on a
logical model, freeing you to focus on performance during the physical model design phase. The wizard can assist you
by conforming the basic naming and syntax rules of the target database platform; implementing referential integrity,
such as the enforcement of logical keys through indexes or table constraints; and replacing non-specific
(many-to-many) relationships with alternative schema elements more appropriate to the relational or dimensional
model being generated.

Once you have created a logical data model you can generate a physical data model for many different platforms that
is based on the logical data model selected.

1

In the Diagram Explorer, right-click the Main model or a submodel of the logical data model, and then click
Generate Physical Model.

Complete the Generate Physical Model Wizard and click OK to complete the wizard.
The following describes options that are not self-explanatory:

Indexes: The storage and index parameters vary depending on the target database platform selected on page 1.
PK indexes will be generated for each entity having primary key columns. For platforms that support clustered PK
indexes, a clustered option exists on page 2 of the wizard.

Naming standards are applied on page 3 of the wizard using either an XML file or a Naming Standards
Template in the Data Dictionary. Naming standards can replace or remove spaces, perform uppercase/lowercase
conversion, and replace invalid SQL characters.

Quick Launch Settings and Objects: All fields and settings from pages 1 through 5 of the wizard will be
restored when you click Load File or Use Settings. With the Settings Only option, only those general options that
are likely to be useful with a different model are restored, while Settings Only loads information that is generic
and can be used across models. The Settings and Objects option will, for example, load SQL path data specific
to the model.

Notes

For information on defining storage for tables and indexes, see Defining Table Storage and Defining Index
Storage.




Creating New Physical Model

This tool lets you create a new physical model by reverse-engineering a live database or importing a SQL or ERX file.
1 On the Data Model tab, right-click the logical model icon and then select Add New Physical Model.
2 Complete the Add New Physical Model wizard and then click Finish to complete the wizard.
The following describes options that are not self-explanatory:
Step 2
The options available differ depending on the data source selected in Step 1.

Reverse engineer from a database: The options on this tab and subsequent steps are the same as those for
the Reverse Engineering Wizard. For information on these options, see Reverse Engineering an Existing
Database.

Updating a Model Using the Compare and Merge Utility

The Compare and Merge utility allows you to reconcile differences between models and model and database. For
example, you have designed and created a model and then created a database based on that data mode. A data
modeler alters the model and adds a column Gender to the Employee table and simultaneously a DBA alters the
Department table in the database and adds a column Name to the table. The model and the database are no longer in
synch. Round-trip engineering using the Compare and Merge Utility can now help you reconcile the model with the
database.

This section contains the following topics:

« What Can the Compare/Merge Utility Do?

« Updating a Model Using the Compare and Merge Utility
« Using the Comparison Differences to Update an Offline DBMS

« Resolving and Reporting on Comparison Differences

See Also
Synchronizing Physical and Logical Models

What Can the Compare/Merge Utility Do?

The Compare and Merge Utility compares, merges and synchronizes models from a variety of comparison targets. It
can perform different kinds of comparisons.You can use the information from these comparisons to perform merges or
create detailed reports.

The Compare and Merge Utility compares a source and a target model. The active diagram, the one you're viewing
and editing, will always be the source, and from it you select a valid target with which to do comparisons and
subsequent merges.

You can compare and merge a logical model to:
« A physical model of the same data model
¢ A logical model of another ER/Studio data model

* A physical model of another ER/Studio data model



You can compare and merge a physical model to:
« The logical model of the same data model
¢ Another physical model of the same data model that shares the same DBMS platform (and version)
¢ A logical model of another ER/Studio data model
* A physical model of another ER/Studio data model sharing the same DBMS platform (and version)
* Alive database
¢ An SQL file
NOTE: Targets of logical and physical ER/Studio data models can be Repository-based data models
including Named Releases, which are read-only archived snapshots of diagrams managed within
the Repository.
You can compare and merge a submodel to:
* A submodel of the same data model.
¢ The physical model of the same data model.

¢ An SQL file.

The broad spectrum of valid targets allows for various information merging strategies. For example, information in the
Compare and Merge Utility can be:

* Merged from the current model to a valid target.
* Merged from the valid target to the current model.
« Bi-directionally merged simultaneously between source and valid target.

NOTE: Objects in SQL 2005 are owned by schemas. A schema can be equated to a user, but does not
have to be. A schema is not explicitly represented in the Diagram Explorer, nor is there a CREATE
SCHEMA DDL function. In the Reverse Engineering and Compare/Merge Wizards, the “owner”
field in the object editors of ER/Studio represent the schema name for an SQL Server 2005
physical model. The field will be the schema list.

See Also
Updating a Model Using the Compare and Merge Utility

Updating a Model Using the Compare and Merge Utility

Using the Comparison Differences to Update an Offline DBMS

Resolving and Reporting on Comparison Differences




Updating a Model Using the Compare and Merge Utility

Using the Compare and Merge utility you can compare two models and merge any differences found. This will allow
you to report on the differences and if you wish, to synchronize your source model with another model or update your
source model selectively.

NOTE: When comparing or merging with a physical data model or SQL imported data model that was not
initially creating by reverse-engineering an existing database, you must synchronize constraint
names between the data model and the database in order to generate correct ALTER SQL. The
Compare and Merge Utility may not generate the SQL correctly unless the target model (physical
or SQL import) has the same constraint names as the database.

1 Click File > Open and display the source data model.

You can save time by selecting diagram objects on the data model before opening the utility.
Objects that are pre-selected in this manner will be already in the object tree of the utility.

2 Click Model > Compare and Merge Utility.

NOTE: The number of pages and options in the Compare/Merge utility vary depending on what kind of
compare/merge you perform and the source and target models selected.

3 The Compare and Merge Utility Wizard will walk you through the rest of the process.

If you right-click anywhere on the object tree, you can select or deselect all objects using the
short-cut menu. You can also display or hide object owner names for those objects with owners.

The following describes the options that are not self-explanatory:
Page 1

« Compare against a Repository based DM1 file: Lets you compare data models and Named Releases
managed within the ER/Studio Repository. When you select this option, ER/Studio opens the Repository
Operation Status dialog box and the Get From Repository dialog box. This process connects to the current
Repository Server defined in the Repository settings. The Model Compare and Merge wizard automatically gets
the diagram.

« Compare against an SQL file This option is available when the current model selected is a Physical data model.
The selected SQL file must be of the same database platform as the current model. When you select this option,
ER/Studio imports the SQL file and compares it to the current model.

« Compare against a live database: If you select this option, a page appears where you can select the database
and connection type. The connection type can be either ODBC or Native/Direct Connection. For information
about connecting to databases, including troubleshooting information, see Connecting to Database Sources and

Targets.

¢ Comparison Quick Launch: The Compare Quick Launch data is saved as an *.rvo file. For information on using
the Quick Launch option in the wizard, see Saving and Using Quick Launch Settings.




Page 3 - Comparison Options

Please select the off-line ALTER SQL generation options: This option is available only when comparing a
physical data model to an SQL file or to a live database and you've selected to generate SQL on the first page
of the utility and have changed at least one of the default ignore resolutions. When the target model is a live
database you have the option to generate ALTER SQL or to update the target model when the merge is
executed. If you choose to create the ALTER SQL, an additional page of the Compare and Merge Utility
becomes available where you can choose where to save the script file, along with Rebuild and Pre/Post SQL
Options.

NOTE: If physical models were not reverse-engineered in the first place, you may have to synchronize

constraint names between models and the database in order to generate correct ALTER SQL. It
won't run correctly unless the target model (physical or SQL import) has the same constraint
names as the database.

* General Options

Merge only selected objects: When enabled, only the objects that are selected in the model prior to invoking
the Compare Wizard will be selected in the Object Selection page of the wizard (page 4). It's an easy way to
compare just a section of the model.

Show Base Tables Of Denormalization Mappings: When comparing two physical models, shows the base
tables of denormalization maps in the results page. Base tables are the pre-map state tables that are included
in a denormalization map. These tables can be seen in the model by expanding the Denormalization Mapping
node in the Diagram Explorer. These objects are not actually visible in the Diagram Window, but can be
brought back by undoing the denormalization map.

In the results page of the Compare and Merge Wizard, ignored columns are italicized. By showing the ignored
columns in the results screen, you can preserve changes on the target side as you are merging
denormalization maps from one physical model to another.

Denormalization objects are merged in order; the base objects are merged to the target first, then the
denormalization mapping is done. By setting resolutions to Ignore, you can preserve changes after the
denormalization mapping is created.

Options for new Tables and Columns: Exclude table and column definitions, notes, and attachments. These
options are for comparing all model types against each other. When objects do not exist in the target model
and new objects are created via the merge, the definitions, notes, and attachments will not be included for
those new objects. This option can be useful when separate definitions, notes, and attachments are used
between models.

Compare Primary Key As Unique Index: When comparing against a database, ER/Studio normally treats
PK indexes in the model as PK constraints. When this option is enabled, it treats PK indexes as indexes
instead of constraints. Use this option if the PKs in the database are controlled by unique indexes instead of
constraints.

Page 4 - Select Specific Model Objects

Please select the specific model objects for your comparison: On the Tables tab, you have the option to
Reverse-Engineer parent tables. The default is selected. If you select this option, when you click Next,
ER/Studio reverse-engineers the parent tables before moving to the next areal of the wizard.



Page 5 - Results

e Current and Target Model Display Grid: Between the Source and Target models is a Resolution column.
The default merge decision is Ignore. You can click the Resolution column to enable the decision list. If you
want to change the decision, click the list and then click the new resolution. When you change the default
resolution of an object, the decisions of their dependent properties and objects are automatically updated. You
can also click the category folders, like the Tables Resolution column to change all the decisions for all the
underlying objects in that object category. And, you can use the CTRL key to select multiple items, and then
right click to enable the decision list.

¢ SQL Dlfference: To enable the SQL Difference utility, select any difference that is a long text field, such as a
Definition, Note, or DDL, and then click SQL Difference to view the differences between the SQL of the
models. This utility only allows you to view the differences; difference resolutions are performed on the Results
page of the Compare and Merge Utility.

Using the Comparison Differences to Update an Offline DBMS

As a result of comparing a physical model with either another SQL file or a live database, you can create an ALTER
SQL script that you can run later to update your DBMS.

1
2

In the Diagram Explorer, click a physical model and then click Model > Compare and Merge Utility.

On the first page of the utility, select to compare the physical model with either a SQL file or a live database and
then choose Generate .sql for changes merged to target model.

Proceed through the successive pages of the utility.

To resolve the differences found on the results page, click in the Resolution column next to the object to resolve,
select either Merge into Target or Delete from Current, and then click Next.

NOTE: You chose to merge at least one of the changes found into the target sql or live database to
generate ALTER SQL.

On the last page of the utility, provide a file name for the sql script and then choose the Rebuild Options and

Pre/Post SQL Options you want.

Click Finish.

Run the ALTER SQL at your leisure to update the offline DBMS.

Resolving and Reporting on Comparison Differences
The last page of the Compare and Merge Utility presents the differences found during the model compare.

You can modify the default display using the options at the bottom of the page.

Once you have determined how to resolve the differences between the models, click in the Resolution column
next to the object to resolve, and then select either Merge into Target or Delete from Current.

NOTE: The default resolution is Ignore. Unless you change the resolution, the models being compared
will not be updated when you click Finish.

Create a report of the differences and your proposed resolutions by clicking Filter Report on Results.

On the Merge Report dialog, choose to create an HTML or an RTF report.

Type the Report Title name, and then type the Report Filename path or browse and locate it.

Click Ok to create the report.



6 If you're happy with the resolutions you've designated, click Finish. The current and target models are updated
as requested.

If you don’t want to change the models right now, click Cancel. You can run the Compare and Merge Utility
later and implement the changes at that time.

Changing the Database Platform of a Model

ER/Studio lets you change the database platform of your physical model. When initially designing your database, you
selected a database platform. Your choice of database platform may have a profound effect on development and
administration issues. For example, the supported datatypes can differ drastically between database platforms,
although ER/Studio does convert them. In addition, indexing strategy, data storage and query optimization can differ
greatly between different databases for the exact same physical model.

If you decide later in the design process that you need to change your database platform, you can use the Change
Database Platform command.

NOTE: ER/Studio supports all major database platforms. Also, it facilitates the translation between
different database platforms with its datatype and DDL conversion facilities.

For a list of supported database platforms, see Supported Database Platforms.

NOTE: If you change to a database platform that doesn’t support the schema objects in the selected
model, you will lose those objects. For example, packages are supported in Oracle but not in IBM
DB2 for OS/390, so in this case changing the Oracle model results in the package definitions
being lost.
1 Inthe Diagram Explorer, click the physical model you want to change to a different database platform.

2 Click Database > Change Database Platform.

3 Select the database platform and version and then click OK.

Notes

« ER/Studio supports all major database platforms. Also, it facilitates the translation between different database
platforms with its datatype and DDL conversion facilities.

« For a list of supported database platforms, see Supported Database Platforms.

« If you change to a database platform that doesn’t support the schema objects in the selected model, you will lose
those objects. For example, packages are supported in Oracle but not in IBM DB2 for OS/390, so in this case
changing the Oracle model results in the package definitions being lost.

Best Practices

This section is comprised of the following topics:

« Using Descriptive Object Names

* Adding Comments to All Objects

» Color-Coding Objects

* Using Macros for Repetitive Tasks




Using Descriptive Object Names

Every object in a data model (such as entities, attributes, attachments, naming standards templates, and domains)
has a name, which identifies it in the Diagram Explorer, Diagram Window (data model workspace), logs, and reports.

To make it easier to understand data flows, make these names as descriptive as possible. For example, instead of
accepting a default name such as “Entity1,” you might use “Customer.”

NOTE: Multiple entities in a model can have the same name, however the combination of entity name
and entity owner must be unique. You can edit the Owner property of and entity or table in the
Entity or Table Editor.

When naming objects, you have the choice of using upper, lower or mixed case. Perhaps the easiest format for people
to read and understand is mixed case, capitalizing the first letter of every word (for example, CustomerAddress).

You can enforce naming rules by creating Naming Standards and binding them to tables and
entities, or you can create Domains. For more information, see Enforce Naming Standards Using
Naming Standards Templates.

Adding Comments to All Objects

Every object in a data model has a description or definition that is included in reports. To help document your data
models, enter a description or definition for every object detailing its purpose and any other information that might be
needed for a future modeler to understand the object’s role in the task.

Entity definitions are included as table comments when generating a physical database and in exported SQL code if
the target RDBMS supports table comments.

If a data model is imported from Describe, descriptions in the Describe diagrams are included as tooltips.

You can also enhance your data model by documenting relationships. Relationships can also have verb phrases that
describe the relationship. For example, parent relationship Manager, child relationship Child.

Color-Coding Objects

Use colors to make your diagrams more attractive and organized. For more information, see Setting Default Diagram
Colors and Fonts and Overriding Color and Font Settings for a Specific Object.

Using Macros for Repetitive Tasks

ER/Studio includes many macros written in Sax Basic, that can be used as is or customized as required. The tutorials
in this guide, provide some examples of how macros can save you time. The headers of the sample macros contain
some usage documentation but a quick read through of the macro code should give you some ideas of its usefulness.
We don’t guarantee that the sample macros will all work in your environment but if you have special requirements you
can collaborate with other users through the online user forum or contact Embarcadero Support for assistance.

The Macro Editor uses a Sax Basic Engine that is compatible with Microsoft Visual Basic for Applications. This guide
does not extensively describe the syntax or usage of Sax Basic, but there are lots of Visual Basic books available to
guide a novice user. The tutorials provide some examples of how macros can save you time. adequate for naming
objects properly. However, most databases support maximum table and column name lengths of only 18 or 30
characters. While you can enter longer names, the Validate Logical or Physical Models function will check length
violations before DDL generation.



Common Tasks

This section describes the following tasks:

¢ Using Toolbar Tools

« Creating a Data Model Object

« Moving Objects
* Copying Objects
* Resizing Objects

¢ Changing Model Alignment, Distribution and Layout

¢ Finding an Entity, Table or View

¢ Locating an Object in the Diagram Window

« Editing an Object
« Deleting an Object
* Renaming an Object

» Searching for and Changing Object or Object Attribute Names

* Creating and Editing Data Base Views

Using Toolbar Tools

For many procedures, instead of clicking a menu and selecting an option, you can click a tool on one of the toolbars to
accomplish the same task.

For example, to insert an entity you need to click the Entity tool on the Diagram Window. You can obtain the Entity tool
using either of the following methods:

Click Insert > Entity.
OR

Click the Entity tool t

When you pause the cursor over any tool, the name of the tool displays as follows:




Creating a Data Model Object

The Modeling toolbar provides easy access to tools you can use to drag and drop entities and establish the
relationships between them, and also create views. The tools available on the Modeling toolbar depend on whether
the data model you selected in the Diagram Explorer is logical or physical, relational or dimensional, and the
designated platform for the physical models. Not all the Modeling tools create objects that can be represented in the
Diagram Window; some tools like the User and Role tools launch editors that guide you through the process of
creating an object of that type.

1 From the Modeling toolbar, select an object tool.
BulaHde J@8m - bHhhb e«

The cursor changes to an icon representing the object tool.

1]

2 Inthe Diagram Window, click where you want to place the object.

Some object tools, like the entity or view tools, create an object in the Diagram Window, others, such as the
function or user tools, bring up an editor where you specify the object attributes.

For information on creating specific model objects, see Developing the Logical Model and Developing the
Physical Model.

Moving Objects

ER/Studio lets you move data model objects to and from the Diagram Explorer and Diagram Window. ER/Studio
provides easy visual maintenance of your entity-relationship models, by letting you move, copy and paste, drag and
drop, resize, and align all diagram objects. You can move individual or groups of diagram objects anywhere in your
data model even if your model is in a specific diagram auto layout.

You can also move entire submodels to other models in the Diagram Explorer. ER/Studio also lets you move objects
between logical and physical models.

ER/Studio also lets you resize any diagram object. When you add entities, tables, or views to your diagram, ER/Studio
automatically determines the proper dimensions of the object to fit the text that it displays. You can manually resize
these diagram objects to control the presentation of your data models. If you need to hide attributes in an entity or
view, you can resize the entity or view to be smaller than the width of the longest attribute, therefore hiding text.

This section covers moving objects in the Diagram Window, in the Diagram Explorer, and from the Diagram Explorer
to the Diagram Window. It is comprised of the following topics:

* Moving Objects in the Diagram Window

¢ Moving Data Model Objects in the Diagram Explorer

Moving Objects in the Diagram Window
To make your data model more readable, you can move entities, tables, and the relationship lines that join these
objects.

You can move individual or groups of objects anywhere in your data model even if you've chosen a specific auto
layout for the model.

NOTE: Clicking an Auto-Layout option will reposition the objects according to the rules of the Auto-Layout
organization selected. For more information, see Changing Data Model Layout.




Moving Data Model Objects
1 On the Main toolbar, click the Selection tool.

2 Inthe Diagram Window, select and then drag the object to the desired location.

Select multiple entities or tables by dragging the selection tool across them or pressing and
holding Ctrl while you click each object. Once the objects are selected, the cursor changes to

$ and then you can drag the objects to a new location.

The relationship lines joining the objects automatically adjust as the objects are moved.

Moving Relationship Docking Points
1 On the Main toolbar, click the Selection tool.

2 Inthe Diagram Window, click the relationship line you want to change.

3 Move the cursor over the docking point of the relationship until the cursor icon changes to .
£

4 Click and drag the relationship docking point to the desired location on the same entity or table.

NOTE: You cannot change the relationship between entities or tables by moving the relationship line. To
change entity or table relationships, see Creating Relationships.

Moving Data Model Objects in the Diagram Explorer

Moving Objects to Different Nodes

You can move objects, such as entities and attributes between the main logical model and its submodels within the
Diagram Explorer.

1 Click the Selection tool.
2 Inthe Diagram Explorer, select the objects you want to move.

3 Drag to the objects to a new target node and then release the left mouse button.

If the move is permitted, your cursor will change to %3 .

Moving Submodels

To assist you in analyzing your data model, you can move submodels from one model to another. You can also move
submodels to nest them within other submodels.

1 On the Main toolbar, click the Selection tool.

2 Inthe Diagram Explorer, click the submodel you want to move and then drag it to another model or submodel.

When the submodel selection is over an item it can be moved under, the cursor changes to %,

3 Release the mouse button.



Copying Objects

You can create copies of entities, tables, users, roles, shapes, functions, procedures, and schemas within the data
model or between different data models.To copy and paste between different data models, you must have both
models open in the Diagram Window. To resolve any referential integrity issues that arise from copying and pasting
diagram objects, ER/Studio applies several basic rules when copying:

Relationships: ER/Studio only copies relationships that are within the set of model objects chosen. In other
words, any relationships connected to entities outside of the selected set will not be duplicated. One important
effect of this rule is that copied entities lose inherited foreign keys if you also do not include their parent entities.

Entity Types: Because ER/Studio can drop relationships due to the rule above, ER/Studio determines whether
entities are independent or dependent based on their status within the selected set.

Unique Names: To preserve unique names, ER/Studio compares the names of objects being pasted with the
names of objects already located in the target mode. If there are duplicates, ER/Studio serializes object names
as "ObjectNameN", where N is a sequential number attached to the base name.

This section describes the following ways to copy objects:

Copying an Object in the Diagram Window

Copying an Object from the Diagram Explorer to the Diagram Window
Copying Objects Between Models and Submodels

Copying an Object in the Diagram Window

1

2

On the Main toolbar, click the selection tool.
In either the Diagram Explorer or the Diagram Window, click the object to copy and then press Ctrl+C.

A copy of the object is created with the same attributes as the original. The name of the new object will be the
name of the original object appended by 1, such as Entityl. If you create another copy of the object, the new
object would be named Entity2.

Copying Multiple Objects

1
2

On the Main toolbar, click the selection tool.

To select objects that are close in proximity to each other, in the Diagram Window, drag the mouse to draw a
lasso around the objects. In this way, you can also select the relationships associated with the selected objects.

To select objects that are not close to each other, in either the Diagram Explorer or the Diagram Window,
press and hold Ctrl while clicking each object.

To select all entities or tables in a model or submodel, in the Diagram Explorer, click the model or submodel,
expand the object, and then press Ctrl+A.

A copy of the object is created with the same attributes as the original. The name of the new object will be the
name of the original object appended by 1, such as Entityl. If you create another copy of the object, the new
object would be named Entity2.



Copying an Attribute

1 On the Main toolbar, click the attribute selection tool.
2 Inthe Diagram Window, select the attribute to copy, press Ctrl+C, click the target entity and then press Ctrl+V.

You can select multiple objects by clicking in the Diagram Window and then dragging the mouse
to draw a lasso around the diagram objects. You can also select multiple objects by pressing and
holding Ctrl while selecting each object individually.

A copy of the object is created with the same attributes as the original. The name of the new object will be the
name of the original object appended by 1, such as Entityl. If you create another copy of the object, the new
object would be named Entity2.

Copying an Object from the Diagram Explorer to the Diagram Window
1 On the Main toolbar, click the selection tool.

2 Inthe Diagram Explorer, click the object you want to copy and drag it to the Diagram Window.
You can select multiple objects by pressing and holding Ctrl while selecting each object

individually.

A copy of the object is created with the same attributes as the original. The name of the new object will be the
name of the original object appended by 1, such as Entityl. If you create another copy of the object, the new
object would be named Entity2.

You can select multiple objects by pressing and holding Ctrl while selecting each object
individually.

Copying Objects Between Models and Submodels
The following table describes the possible copy operations within the Diagram Explorer.

Data Model Copy Data Model Object From ... to ...
Objects X X - - - -
Logical to Physical to Main logical or | Main physical
Physical Logical submodel to or submodel
logical to physical
submodel Submodel
Attributes no n/a yes n/a
Columns n/a no n/a yes
Entities yes yes yes n/a
Functions n/a no n/a yes
Procedures n/a no n/a yes
Roles yes no yes no
Schemas n/a no n/a yes
Tables n/a yes yes
Users no no yes yes
Views yes yes no no




You can copy objects such as attributes, columns, entities, views, users, roles, and shapes from a logical model to a
physical model and between models and submodels. You can copy functions, procedures, and schemas from one
physical model to another and from one physical submodel to another physical submodel.

1 On the Main toolbar, click the Select tool.
2 Inthe Diagram Explorer, click the object to copy and drag it to the target node.

You can select multiple objects of the same type by pressing and holding Ctrl while selecting each
object individually.

@ The cursor changes to this symbol when over a valid target for pasting an attribute or column to another
entity or table respectively.

® The cursor changes to this symbol when over an invalid target for pasting an object.

.The cursor changes to this symbol when over a valid target for pasting an entity, table, or view to a

submodel within the same model or to a different model in the Diagram Explorer.

Resizing Objects

When you add entities, tables or views to your data model, ER/Studio automatically determines the optimal
dimensions of the object to fit the text that it displays. However, you can resize data model objects such as entities,
shapes, tables, text blocks, and views to control the presentation of your data models.For example, if you need to hide
attributes in an entity or view, you can resize the entity or view to be smaller than the width of the longest attribute,
therefore hiding text.

NOTE: You cannot resize the Title Block of a data model.

Manually Resize Data Model Objects

You can manually resize entities, shapes, tables, text blocks, and views to control the presentation of your data
models.

1 Inthe Diagram Window, select the object you want to resize.

2 Place the cursor over one of the handles, and then click and drag to resize the object.

Automatically Resize Data Model Objects to Fit Text

ER/Studio can automatically resize entities, tables, and views to display the entire object name and displayed
contents.

1 Inthe Diagram Window, select the object you want to resize.
2 Click Format > Resize Entity/View.
The object is resized to accommodate the full width of the text.
If you want to adjust the object size manually, grab a sizing handle and reposition the object boundaries.

You can also resize the selected object to fit the text by pressing Ctrl+R or by right-clicking the
object and then selecting Resize.



Changing Model Alignment, Distribution and Layout

j— *To align a group of objects in a straight line, select them and then
|m] O
= 08 '='I D—D El DD click one of the alignment buttons.

— *To distribute a group of objects, select them and then click an
E][:] = alignment button.

*To rearrange a data model or task diagram using a different

@ ‘;g” ﬁ"::! @ %, .@? % layout type, display the model, then click one of the auto-layout

buttons on the Layout & Alignment Toolbar.

NOTE: To change the layout defaults, click Layout > Layout Properties. Changes affect the current
project file only. For more information on changing Layout Properties, see Changing Data Model

Layout.

Finding an Entity, Table or View
1 Click Edit > Find Entity/View.

2 Type the first letter or first few letters of the entity or view you want to find.
The first matching entity or view found will be highlighted in the list.

3 If necessary, scroll through the list to find the object you're looking for or type more letters to further limit the
scope of the search.

4 Once you've found the object you're searching for, double-click the entry and ER/Studio highlights the object in
the Diagram Explorer and the Diagram Window.

You can also use the Universal Naming Utility to find strings in various objects, enabling you to
for example find all entities with an attribute named city. For more information, see Searching for
and Changing Object or Object Attribute Names.

Locating an Object in the Diagram Window

You can use this procedure to locate objects such as entities, tables, attributes, columns, indexes, procedures, keys,
views, relationships, foreign keys, functions, procedures, and shapes. Some objects, such as users and roles, are not
represented in the Diagram Window and so can't be found using this method.

Find and click an object in the Diagram Explorer.
ER/Studio highlights the object in the Diagram Window.

NOTE: When searching for a foreign key or relationship, ER/Studio focuses the Diagram Window on the
parent and the relationship or foreign key is highlighted so you can follow the line to the child table.

Editing an Object

On the Diagram Explorer or Diagram Window, double-click the object that you want to edit.
An object-specific editor displays where you can change the properties of the object selected.

Alternatively, you can open the editor by selecting the object and then clicking Edit > Edit object
type.



Deleting an Object

1 Onthe Diagram Explorer or Diagram Window, right-click the object that you want to delete.
2 From the shortcut menu, click Delete.

3 Click Yes.

Notes

« When you right-click a submodel object, there is no Delete option. Instead, there is an option to Remove. When
you remove an object from a submodel, the object remains in the Main model unless you select Delete from
Model from the dialog that appears.

* You can select multiple entities by pressing and holding Ctrl while clicking the entities.

* You can delete an attribute by selecting the attribute in the Diagram Explorer or by double-clicking the parent
entity or table in the Diagram Window to bring up the entity or table editor. In the editor, you can select the
attribute to delete and then click Delete.

« When deleting a relationship, you can either delete the relationship entirely or, by selecting Make Foreign Keys
Native in the dialog that displays, you can choose to convert the foreign key relationship to an attribute of the
child entity or table.

Renaming an Object
1 Onthe Diagram Explorer, right-click the object that you want to rename.

2 From the shortcut menu, click Modify Name.
3 Enter the new name and press Enter.

You can rename an attribute by double-clicking the object or its parent in the Diagram Window to
bring up the entity or table editor. In the editor, you can click the attribute and then click Edit.

Searching for and Changing Object or Object Attribute Names

Using the Universal Naming Utility you can globally search, and replace if desired, names, strings, and attachment
value overrides for bound attachments for both your logical and physical models. You define your search, then narrow
the search to specific objects within your models, or to specific models. You can also narrow the search to include only
specified objects or object properties or to include only certain models. The results can include model objects such as
attachment bindings and table storage parameters.

1 Select Tools > Universal Naming Utility.
2 Complete the String Specifications.

You can limit the scope of the search or search and replace using the Object Scope and Model
Scope tabs.

3 To search for a string, click Search.

To replace a string, click Replace. Examine the Search Results and then click Apply to implement the
changes.



4 To create a report of the search results in RTF or HTML format, click Report.
To create a submodel of selected results, select objects in the results window and then click Create Submodel.
The following describes options that are not self-explanatory.
Search Results tab

Whole Word: Searches for whole words in the search string. For example, if your search string is the word “data,”
check the Whole Word check box if you do not want results such as the word “database.”

Object Scope tab
Lets you narrow your search to specific objects, and to specific string usages within the selected objects.
Model Scope tab

Lets you restrict the search to specific models within the diagram.

Notes
¢ Changes are not implemented until you click Apply.

* RTF-formatted reports are ideal for print distribution, while HTML-formatted reports are better-suited for browser
viewing.

< For information on using the Submodel Editor, see Creating and Editing Submodels.

Creating and Editing Data Base Views

A data base view, also known as a materialized view, is a dynamic virtual table that reflects changes made to the
entity or table data. In SQL, a view is the set of columns or attributes resulting from a SELECT statement. It is not part
of the physical schema of a relational database and does not incur any extra storage overhead.

Some of the uses for views include:
* Presenting a subset of the data included in a table.
« Joining and simplifying tables into a single virtual table.
¢ Hiding the complexity of data.

« Depending on the database platform, providing an additional layer of security by restricting user access to
specific columns and/or rows.

¢ Acting as aggregated tables, where aggregated data such as sum and average, are calculated and presented as
part of the view.

« Limiting the amount of exposure of sensitive data in the tables.

¢ Creating a layer of abstraction to simplify complex data, transparently partitioning the actual underlying table.
« Facilitating database normalization beyond second normal form.

* Making it easier to decompose the underlying table and then join the parts without losing any information.

NOTE: Some database platforms offer more properties than others that can be applied to physical view
definitions.



USING ER/STUDIO > COMMON TASKS

titleview [Column Info]

title : fithes, title

au_ord :titleauthar.au_ord
au_lname ; authors.au_lname
price : titles. price

yid_sales; titles, yid_sales
pub_id :titles.pub_id

In the View Editor you can select specific attributes from entities on the Entities tab or specific columns from tables on
the Tables tab to include in the view. In the View Editor, you can reorganize the column order in the view and add
notes and descriptions to your view. You can also add Pre and/or Post SQL that generate immediately prior to or after
the CREATE OBJECT statement.

1 Inthe Diagram Explorer, expand the node of the model to which you want to create a view.
2 Right-click the Views node and then click New View.

TIP:  You can also create a view by selecting the tables in the Diagram Window that you want to include
in the view and then selecting Insert > View. Clicking anywhere in the Diagram Window will create
anew view that is comprised of the tables you selected. Double-click the view to edit its properties.

3 Complete the areas of the View Editor and then click OK to implement the changes to the view.

TIP: Once you've created the view, you can edit it by right-clicking the view and then clicking Edit View.

TIP: The status bar at the bottom of the screen shows the total number of views in the selected model
or submodel.

The following describes options in the View Editor that are not self-explanatory.
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Entity/Table tab

« Logical Only: In a logical model, if selected, the view will not be implemented when generating a physical
model and will be ignored when comparing the logical model with a physical model.

« Physical Only: In a physical model, if selected, the view will be ignored when comparing the physical model
with a logical model.

Attribute/Column tab

¢ View Columns/Attributes > Column Expression: This is standard SQL expression that creates a computed
column, combining existing data in order to produce data that you don’t need to store but want to have
available. For example, in the Northwind model, the Product Sales for 1997 view uses the following column
expression to calculate the value of sales using the unity price, quantity sold and the applicable discount.
Sum(CONVERT(money, (*'Order Details"_UnitPrice*Quantity*(1-Discount)/100))*100
A column expression can only be added when no column is specified and requires an alias.

* Select distinct: If selected, adds a SELECT DISTINCT statement to the View DDL, which selects and shows
only unique rows.

Column Alias dialog

This dialog appears if you try to add columns with duplicate names to a view. To use the columns in the view,
you must assign an alias to each duplicate column name. If an alias is not assigned to the duplicate column
name, a SQL syntax error will result when generating the view. Note that a column expression can only be added
when no column is specified. So you may have a column with an alias, or an expression with an alias. The
expression requires an alias.

Where tab

Define a WHERE clause of the view, such as WHERE [city] = “Monteray”, which selects rows matching
the stated criteria.

Group By tab

Select columns and tables to include in a GROUP BY clause for the view, such as
SELECT Product, SUM (Sales) GROUP BY Product
which allows you to easily find the sum for each individual group of column values.

Having tab

Enter a HAVING clause for the view, such as
SELECT Product, SUM (Sales) GROUP BY Product HAVING SUM (Sales) > 10000
which allows you to test for result conditions.

DDL tab

Displays and allows you to edit the CREATE VIEW statement needed to build the view. In physical models,
ER/Studio uses the platform-specific parser of the model’s selected database platform to generate the view. If
you're adding a view to a logical data model, the default parser AINSI SQL is used unless you change the View
Parser in the Logical Model Options to another parser. For more information, see Defining Model Options for the
Selected Model.

SQL Validation dialog

If any errors are detected, they are displayed in the Validation Results area. You can then exit the SQL Validating
dialog, correct the errors on the DDL tab and then rerun the validation check.

Options tab

When selected, the With Check Option and With Read Only options add a WITH CHECK OPTION and WITH
READY ONLY clause, respectively to the DDL statement.



Definition tab

Enter or edit a definition for the view. If the target database supports it, ER/Studio adds this definition as a view
comment when generating SQL code.

Notes tab

Add notes about the view that you can format using HTML tags that are processed when creating an HTML
Report of the model.

Where Used tab
Shows where the view is used according to definitions you set.
Dependencies tab

Create, edit or delete any scripted procedures (see Create an SQL Procedure) or functions (see Add a Stored
SQL Function)_that are bound to the view.

NOTE: If any procedures or functions are bound the view, the folder is expandable. Double-click or right-click
either folder to access the either editor.

PreSQL & PostSQL tab

Enter SQL to be applied before or after the CREATE OBJECT statement. The PreSQL and PostSQL scripts
entered here are included in the script when you generate the physical database.

Permissions tab

Sets access roles and user permissions for the view. Keep in mind that the more specific permissions are, the
more time you may have to spend maintaining and updating them. The Roles and Users must be previously
assigned to appear in the View Editor. For more information, see Creating and Editing Database Roles and
Creating and Editing Database Users.

Security Information tab

Displays the current security information as defined in the Data Dictionary. You can add or edit security reporting
information in by double-clicking the field you want to change. To set the model-wide default value for a property,
go to the Data Dictionary tab and expand the Data Security Information Node. For more information, see
Enforcing Security Using Data Security Types and Properties.

Attachment Bindings tab

Binds an external piece of information, or attachment to the database view. You can also remove an attachment
from an object, override an attachment binding’s default value, or change a bound attachment'’s position. To
override the value of the attachment you have moved to the Selected Attachments grid, double-click the Value
field of the target attachment. ER/Studio opens the Value Override Editor or a list depending on the attachment
datatype. Attachments are created in the Attachments folder of the Data Dictionary and must be applied to the
view before they will display on this tab. For more information, see Attaching External Documents to the Data
Model.

Defining the Default View Settings for New Models
1 Click Tools > Options and then click the Display tab.

2 Complete your setting selections in the View Display Settings area.

3 Click the View tab.



4 Complete your setting selections and then click OK.

You can override the settings here for a specific model or submodel using the options in View >
Diagram and Object Display Options > View.

The following describes options that are not self-explanatory:

View Reverse-Engineer/Import > Import Invalid Views: Lets you import invalid views when importing a data
model or reverse-engineering a database.

Duplicate View Column Name Resolution

* Prompt: Prompts for column aliases to differentiate between columns whenever duplicate column names
exist.

« Don’t propagate: Eliminates duplicate column names from the SELECT clause of the SQL statement
generated to create the view.

« Attach prefix and/or suffix: Append a prefix or suffix to the column names to differentiate between duplicate
column names. The prefix is comprised of the entity name and an underscore character. The designated suffix
is comprised of sequential numbering.

View Column Propagation > Don’t propagate any columns: Does not automatically propagate of any
columns to a view. You can select the columns to include in the View Editor.

Column Sorting: Sets column sorting hierarchy.

NOTE: The Column Sorting setting determines the column order in the DDL SELECT statement.

Customize the View Settings for a Specific Model
Use the View tab of the Diagram and Object Display Options to control which components of the views in a specific
model are displayed.

NOTE: The settings here override display settings configured in Tools > Options > Display.

1 Click View > Diagram and Object Display Options and then click the Views tab.
2 Complete your settings selections and then click the Apply To tab.

3 Select the models and submodels to apply the new settings to and then click OK.

Creating and Editing Submodels

ER/Studio lets you create independent views of all or part of your logical or physical models called submodels.
Submodels can focus attention on specific characteristics of a model and can facilitate faster data access. Any
changes to submodel objects, except object deletions, automatically propagate to the main model. When deleting a
submodel object, you have the option to apply the change to the main model or delete the object only from the
submodel. You can create any number of submodels within your data model and can nest any humber of submodels
within a submodel.

In addition to creating submodels of models, ER/Studio also lets you derive a submodel from a submodel, and then
display the submodel relationships by nesting submodel folders in the Diagram Explorer.



ER/Studio automatically includes relationships between objects if related objects are part of the submodel. You can
edit the submodel to include or exclude specific relationships. When you add a relationship, ER/Studio automatically
includes the corresponding parent table in the submodel definition.

1 On the Diagram Window or Diagram Explorer, select one or more objects to include in the submodel.

Ctrl-Click to select multiple objects.

N

Click Model > Create Submodel.
3 In the Create Submodel dialog, enter a name for the submodel.

4  From the list of objects, Ctrl-click to select the objects to add to the submodel and then press the right arrow to
add the selected objects to the submodel.

5 Click OK to create the submodel.

Once you are finished creating a submodel, ER/Studio adds the submodel to the Diagram Explorer and displays
the model in the Diagram Window.

The following describe options that are not self-explanatory:
Edit Submodel tab
¢ Click Select Related Objects to add parent and child entities and dependent views or procedural logic.

« If you select Inherit Objects Added to Nested Submodels, any objects you later add to submodels nested within
the model or submodel will automatically also be added to the model.

Attributes tab

Lets you choose which attributes of the entities selected on the Edit Submodel tab to include in the submodel.
Definition tab

Enter or edit a definition for the submodel.
Attachment Bindings tab

Lets you bind an external piece of information, or attachment to the submodel. You can also remove an
attachment from an object, override an attachment binding’s default value, or change a bound attachment'’s
position. To override the value of the attachment you have moved to the Selected Attachments grid, double-click
the Value field of the target attachment. ER/Studio opens the Value Override Editor or a list depending on the
attachment datatype. Attachments are created in the Attachments folder of the Data Dictionary. For more
information, see Attaching External Documents to the Data Model.

Security Information tab

Displays the current security information as defined in the Data Dictionary. You can add or edit security reporting
information in by double-clicking the field you want to change. To set the model-wide default value for a property,
go to the Data Dictionary tab and expand the Data Security Information node. For more information, see
Enforcing Security Using Data Security Types and Properties.

Definition tab

Enter or edit a definition for the submodel. If the target database supports it, ER/Studio adds this definition as a
comment when generating SQL code.

Notes

« If you select a submodel to add to the new submodel, then all objects belonging to the source submodel will be
added to the new submodel.



« Deleting an object from a submodel does not delete the object from the Main model unless you select the Delete
from Model option in the Delete dialog.

« Once you have created a submodel, you can add objects to it by right-clicking an object in the main model or in
another submodel and then selecting Apply to Submodel(s) from the shortcut menu. In the dialog that appears
you can select which submodels you want to add the object to.

Synchronizing Submodels

Use the Submodel Synchronization Utility to synchronize object positioning, color and font settings, display level,
members and hierarchies of submodels within the same file or across disparate files. You can synchronize submodels
between logical and physical models by adding, removing, and updating submodel items or synchronize submodels of
the local model with a local ER/Studio file or a file in the ER/Studio Repository. Submodels in source and target
models are matched by Submodel name.

NOTE: You can synchronize submodels between logical and physical models by adding, removing and
updating submodel items.

The following are examples of when synchronizing submodels may be useful.

Example 1: You have existing logical and physical models in a *.dm1 file, each with 20 to 30 submodels. The
physical model represents the current development environment. You use the Add New Physical Model function to
add a physical model of the test environment. The physical model of the test environment is close but doesn’t exactly
match the existing physical model that is the development benchmark environment. To match the test and
development physical models, you can use the submodel synchronization utility to add or transfer submodels from the
development model to the test model within the same or across disparate *.dm1 files.

Example 2: You have a logical and physical model within the same *_dm1. For reporting purposes, the same
submodels are used in the logical and the physical models. You make substantial changes to the logical model,
adding and removing objects or adding new submodels for new projects. You can use the Submodel Synchronization
Utility to synchronize or promote these changes to the physical model.

Example 3: Many people manage their submodels in the logical model and want to be able to move the structure to
a physical or project model that was spun off from the Enterprise logical model. Members and display settings change
often; this utility automates the process of synchronizing the submodels.

1 Inthe Diagram Explorer, select the source submodel.
2 Click Model > Submodel Synch Utility.

3 Complete the pages of the Submodel Synchronization Utility and then click Finish to implement the changes
to the view.

The following describes options that are not self-explanatory.
Page 1

For information on using the Quicklaunch utility, see Saving and Using Quick Launch Settings.

Page 2

Your changes to the source model can be merged into one target model. Select the target from the list or go
back to the first page and use the file browser controls to load the *.dm1 for the target file. The submodels to be
merged will be selected on page 4.

Page 3

« Synchronize members: If selected, the settings specified for the submodel on the Diagram and Object Display
Options dialog will be inherited by the target submodel.



* Synchronize submodel hierarchies: If selected, synchronizes nested submodels.
Page 4

For each operation, select the submodels you want to synchronize with the target model. The available
operations (update, delete) depend on the submodel chosen. If this is a frequently updated submodel, you may
want to save all the wizard settings in a Quick Launch file. The file will load your selections when you next use
the utility if you select it upon launching the utility. You can load the file and make changes to it.

Notes
« To make changes to both the source and target models, run the utility twice, reversing the source and target the
second time you run the utility.

« The available operations (update, delete) will depend on the submodel chosen and the differences that exist
between the source and target submodels. For example, if the source contains updates not reflected in the
target, then the update operation will be available.

Copying a Database Object to a Submodel (Apply to Submodel)

You can replicate database objects by copying the object and then pasting it to each submodel individually or you can
use the Apply to Submodel function to paste an object into multiple submodels within the same model simultaneously.

1 In either the Diagram Explorer or the Diagram Window, right-click the object you want to copy to one or more
submodels in the active model and then click Apply to Submodel.

2 Inthe Apply to Submodel dialog, individually select the submodels you want to apply the object to, or select the
model to copy the object to the main model and all submodels of the active model.

NOTE: Inthe Apply to Submodel dialog, clicking Place New Object Near Existing Objects prevents the
new object from being placed randomly in the Diagram Window. This may be important when
working with large models and submodels.

Establishing Database Security

Define and establish database security to, for example, inform data model reviewers and database administrators of
the security required for data model objects when these objects are implemented on a DBMS.

This section includes the following topics:

¢ Creating and Editing Database Users

¢ Creating and Editing Database Roles

* Associating Database Users with New Database Roles

* Associating Database Roles with New Database Users

« Changing Database Roles Associated with Existing Database Users
¢ Changing Database Users Associated with Existing Database Roles

¢ Granting and Revoking Permissions to Modify Database Objects

Creating and Editing Database Users

Granting database access, authorities, and privileges to users and groups is one of the most important ways to ensure
data security.



In conjunction with database roles, users and the permissions you grant them enable you to manage the permissions
logical model users have to insert, select, update, delete, alter, or reference entities, tables, and views in the logical
database. In addition to being supported by tables and views in the physical data model, depending on the database
platform, users also can be applied to specific physical models to manage system privileges such as those required to
backup databases and logs, or to create databases, defaults, procedures, rules. tables, and views. The system
privileges available are database dependent and display on page 2 of the User Wizard and User Editor.

Database users supported by the logical data model and physical data models for the following platforms:

IBM DB2 for LUW 5.x, 6.%, 7.X, 8.X, 9.X

IBM DB2 for OS/390 5.x, 6.x and DB2 for z/OS 7.x, 8.x, 9.x

Microsoft SQL Server 4.x, 6.x, 7.x, 2000, 2005

Oracle 7.x, 8.x, 9i, 10g, 11g

Sybase ASE 11.0, 11.5, 11.9, 12.0, 12.5, 15

NOTE: The User Wizard and User Editor share the same options, except for Attachment Bindings options
which are present only in the editor.

In the Diagram Window, expand the Main Model of the Logical model, or of a physical model for which

database users are supported, right-click the Users node, and then click New Database User.

In the User Wizard, assign the permissions desired, and then click Finish.

The following describes options that are not self-explanatory.

NOTE: The options and permissions available are platform-dependant.

General page/tab

User Name: The restrictions for the number of character permitted when defining user and group names is
dependant on the database platform.

Is Group: Members of a user group automatically inherit the group's privileges. Privileges granted to a user
override the privileges associated with any groups the user is a member of, and are retained if the user is later
removed from the groups. Explicit privileges granted to a user must be explicitly revoked.

Password: When selected, specifies that the user is a local user who must specify the password when accessing
the database.

Externally: When selected, specifies that the user is an external user who must be authorized by an external
service (such as an operating system or third-party service) to access the database.

Globally: When selected, specifies that the user a global user who must be authorized to use the database by
the enterprise directory service or at login.

Add: When clicked, the Select Roles dialog appears where you can select the roles to assign to the user. Hold
Ctrl-Shift to select multiple roles. If you have not previously defined a role the list will be empty.

Tablespace Quota: On some physical models, you can define tablespace usage parameters (in units of 10KB).
This will limit a user’s ability to grow tablespace, but should not be used instead of designed range limits.

System Privileges page/tab

Clicking the column name selects the entire column. Control-click to select multiple objects individually. The
permissions available are dependant on the physical platform selected.



Object Privileges page/tab

Set access privileges for users for objects such as tables and views. Some database platforms also allow
detailed access to database objects such as procedures, packages, materialized views, sequences, and
functions. Clicking the column name selects the entire column. Control-click to select multiple objects
individually.

Dependencies page/tab

If the object associated with the permissions assigned have dependencies, these will be displayed here.
Dependencies are SQL code such as functions, triggers, and procedures. For more information, see Creating

and Editing Functions, Creating and Editing Triggers, and Creating and Editing Procedures.
Definition page/tab

Usually used to describe why you’re defining the limitations of the user. Enter or edit a definition for the user. If
the target database supports it, ER/Studio adds this definition as a comment when generating SQL code.

DDL tab

Lets you view the CREATE USER statement needed to build the user, or the GRANT ... ON CONNECT
statement required to establish user privileges when connecting to the database. In physical models, ER/Studio
uses the platform-specific parser of the model’s selected database platform to generate the view. If you're adding
a view to a logical data model, the default parser AINSI SQL is used unless you change the View Parser in the
Logical Model Options to another parser. For more information, see Defining Model Options for the Selected
Model.

Attachment Bindings tab

Lets you bind an external piece of information, or attachment to the user. You can also remove an attachment
from an object, override an attachment binding’s default value, or change a bound attachment'’s position. To
override the value of the attachment you have moved to the Selected Attachments grid, double-click the Value
field of the target attachment. ER/Studio opens the Value Override Editor or a list depending on the attachment
datatype. Attachments are created in the Attachments folder of the Data Dictionary and must be applied to the
database user before they will display on this tab. For more information, see Attaching External Documents to
the Data Model.

Notes

« In order to view the users in the Diagram Window, ensure that Display All Security Objects is selected in View >
Diagram and Object Display Options > Security Objects. Reverse-engineered diagrams do not display security
objects by default; however, models created from scratch do.

* Once you've created a user, you can assign that user a particular role in the Role Editor or Role Wizard. For more

information, see Associating Database Users with New Database Roles and Associating Database Roles with
New Database Users.

« You can change the permissions assigned to a user in the User Editor or on the Permissions tab of the Entity
Editor or Table Editor. For more information, see Creating and Editing Entities and Tables.

« Database users created in the logical model are propagated to the physical model when you generate a physical
model that supports database users.

« Depending on the database platform, database users can provide security for entities, tables, functions,
materialized views, packages, procedures, and sequences.

Creating and Editing Database Roles

A role is a named collection of privileges. In a business setting, roles are defined according to job competency,
authority and responsibility. The ultimate intent of creating database roles is to achieve optimal security administration
based on the role each individual plays within the organization.



Advantages of effective role creation and application include:
« Optimal assignment of roles to user privileges.
« Identification of users who operate outside the normal pattern.
« Detecting and eliminating redundant or superfluous roles or user privileges.
« Keeping role definitions and user privileges up-to-date.
« Eliminating potential security loopholes and minimizing consequent risks.

By implementing database roles for specific user groups, you can save time by assigning roles to users instead of
assigning permissions to each object for each individual user. Database roles enable you to manage the permissions
logical model users have to insert, select, update, delete, alter, or reference entities, tables, and views in the logical
database. In addition to being supported by tables and views in the physical data model, depending on the database
platform, roles also can be applied to select physical models to manage system privileges such as those required to
backup databases and logs, or to create databases, defaults, procedures, rules. tables, and views. The system
privileges available are database dependent and are listed on page 2 of the Role Wizard and Role Editor.

Database roles are supported in the logical model and by the following physical database platforms:
« Microsoft SQL Server 4.x, 6.x, 7.x, 2000, and 2005
¢ Oracle 7.x, 8.x, 9i, 10g, and 11g

1 Inthe Diagram Window, expand the Logical Main Model or the Main Model of a physical model for which
database roles are supported, right-click the Roles node, and then click New Database Role.

2 Inthe Role Wizard, assign the permissions desired and then click Finish.
The following describes options that are not self-explanatory.

NOTE: The options and permissions available are platform-dependant.

General page/tab

* Role Name: The restrictions for the number of character permitted when defining role names is dependant on the
database platform.

The following options specify the specific method used to authorize a user before the role can be enables with
the SET ROLE statement.

« Password: When selected, specifies that the user is a local user who must specify the password when enabling
the role.

« Externally: When selected, specifies that the user is an external user who must be authorized by an external
service (such as an operating system or third-party service) to enable the role.

« Globally: When selected, specifies that the user a global user who must be authorized to use the role by the
enterprise directory service before the role is enabled or at login.

« Not Identified: When selected, indicates that this role is authorized by the database and no password is required
to enable the role.

« Add: When clicked, the Select User dialog appears where you can select the users to assign to the role. Ctrl-click
to select multiple users. If you have not previously defined a user the list will be empty.

System Privileges page/tab

Clicking the column name selects the entire column. Ctrl-click to select multiple objects individually. The
permissions available are dependant on the physical platform selected.



Object Privileges page/tab

Set access privileges for users for objects such as tables and views. Some database platforms also allow
detailed access to database objects such as procedures, packages, materialized views, sequences, and
functions. Clicking the column name selects the entire column. Control-click to select multiple objects
individually.

Dependencies page/tab

If the object associated with the permissions assigned have dependencies, these will be displayed here.
Dependencies are SQL code such as functions, triggers, and procedures. For more information, see Creating

and Editing Functions, Creating and Editing Triggers, and Creating and Editing Procedures.
Definition page/tab

Enter or edit a definition for the user. Usually used to describe why you're defining the limitations of the user. If
the target database supports it, ER/Studio adds this definition as a comment when generating SQL code.

DDL tab

Lets you view the CREATE ROLE statement needed to build the user, or the GRANT ... ON CONNECT
statement required to establish user privileges when connecting to the database. In physical models, ER/Studio
uses the platform-specific parser of the model’s selected database platform to generate the view. If you're adding
a view to a logical data model, the default parser AINSI SQL is used unless you change the View Parser in the
Logical Model Options to another parser. For more information, see Defining Model Options for the Selected
Model.

Attachment Bindings tab

Lets you bind an external piece of information, or attachment to the role. You can also remove an attachment
from an object, override an attachment binding’s default value, or change a bound attachment'’s position. To
override the value of the attachment you have moved to the Selected Attachments grid, double-click the Value
field of the target attachment. ER/Studio opens the Value Override Editor or a list depending on the attachment
datatype. Attachments are created in the Attachments folder of the Data Dictionary and must be applied to the
role before they will display on this tab. For more information, see Attaching External Documents to the Data
Model.

Notes

« In order to view the roles you create in the Diagram Window, ensure that Display All Security Objects is selected
in View > Diagram and Object Display Options > Security Objects. Reverse-engineered diagrams do not display
security objects by default; however, models that you create from scratch do.

* Once you've created a role, you can assign that role to a particular user in the User Editor or User Wizard.

¢ You can change the permissions assigned to a role in the Role Editor or on the Permissions tab of the Entity
Editor or Table Editor. For more information, see Creating and Editing Entities and Attributes and Creating and
Editing Tables.

« Database roles created in the logical model are propagated to the physical model when you generate a physical
model that supports database roles.

« Depending on the database platform, database roles can provide security for entities, tables, functions,
materialized views, packages, procedures, and sequences.



Associating Database Users with New Database Roles

Once you have a database user defined, you can assign that user a database role. Once defined, the permissions
granted to a particular user directly and by applying roles can be edited on the Permissions tab of the Entity/Table

Editor.
1 Inthe Diagram Window, expand the logical or physical Main Model, right-click the Roles node, and then click
New Database Role.
2 On the first page of the wizard, click Add in the Roles area and choose the roles you want to apply.
3 Click Finish.

Now, when you edit the database user, if you have selected Show inherited permissions on the Object Privileges
tab of the User Editor, you will see blue check marks denoting the granted permissions afforded to the user by
the applied roles.

NOTE: Permissions granted or revoked through the application of a role are overridden by permissions
afforded the user in the User Editor, or on the Permissions tab of the Entity/Table Editor.

Changing Database Users Associated with Existing Database Roles

Once you have a database user defined, you can assign a role to that user. Once defined, the permissions granted to
users directly and through applying roles can be edited on the Permissions tab of the Entity Editor.

1

In the Diagram Explorer, expand the logical or physical Main Model, expand the Roles node, right-click the role
you want to change, and then click Edit Database Roles.

Click the General tab.

To associate the role with a user, on the General tab, click Add in the Users area and choose the users you want
to associate with the role.

To disassociate a role from a user, on the General tab, click Drop in the Users area and choose the users you
want to disassociate from the role.

Click Finish.

Now, when you edit the database user, if you have selected Show inherited permissions on the Object Privileges
tab of the User Editor, you will see blue check marks denoting the granted permissions afforded to the user by
the applied roles. Permissions revoked by rules don't display with crosses.

NOTE: Permissions granted by applying roles are overridden by permissions granted to the user in the
User Editor, or on the Permissions tab of the Entity/Table Editor.

Associating Database Roles with New Database Users

Once you have a database role defined, you can assign that role to any new users created. Once defined, the
permissions granted to users directly and through applying roles can be edited on the Permissions tab of the Entity
Editor.

1

In the Diagram Window, expand the logical or physical Main Model, right-click the Users node, and then click
New Database User.

2 On the first page of the wizard, click Add in the Roles area and choose the roles you want to apply.



Click Finish.

Now, when you edit the database user, if you have selected Show inherited permissions on the Object Privileges
tab of the User Editor, you will see blue check marks denoting the granted permissions afforded to the user by
the applied roles.

NOTE: Generally, permissions granted or revoked through the application of a role are overridden by
permissions afforded the user in the User Editor, or on the Permissions tab of the Entity/Table
Editor. Check your DBMS documentation for verification.

Changing Database Roles Associated with Existing Database Users

Once you have a database role defined, you can assign that role to any users created. Once defined, the permissions
associated with a role can be edited on the Permissions tab of the Entity/Table Editor.

1

In the Diagram Window, expand the logical or physical Main Model, expand the Users node, right-click the user
you want to edit, and then click Edit Database User.

To add a new role to the user, on the General tab, click Add in the Roles area and choose the roles you want to
apply.

To drop a role from the user, on the General tab, click Drop in the Roles area and choose the roles you want to
remove.

Click Finish.

Now, when you edit the database user, if you have selected Show inherited permissions on the Object Privileges
tab of the User Editor, you will see blue check marks denoting the granted permissions afforded to the user by
the applied roles. Permissions revoked by rules don’t display with crosses.

NOTE: Generally, permissions granted or revoked through the application of a role are overridden by
permissions afforded the user in the User Editor, or on the Permissions tab of the Entity/Table
Editor. Check your DBMS documentation for verification.

Granting and Revoking Permissions to Modify Database Objects

Once you have created users and roles you can grant or revoke their permissions to insert, select, update, delete,
reference, and alter entities, tables, attributes, columns, and views.

1

2

In the Diagram Explorer, double-click an object to invoke the editor.

Click the Permissions tab.

Select a particular role or user.

Select an individual operation, or click the column header to select the entire column.

You can select multiple operations by holding Ctrl+Alt down while selecting the operations.

Select Grant or Revoke.
Click OK to exit the editor

NOTE: Keep in mind that the more specific permissions are, the more time you may have to spend
maintaining and updating them.



Comparing Models
For information on comparing data models, see Updating a Model Using the Compare and Merge Utility.

Customizing the Data Model
This section describes customizations you can make to the Data Model. It is comprised of the following topics:

¢ Setting Diagram Properties
e Setting Diagram Properties
« Set Data Model Properties

¢ Setting the Model Notation

« Setting the Relationship Notation

* Manipulating Relationship Lines

¢ Changing the Model Background
« Creating and Editing Shapes

« Adding and Editing Lines
* Adding and Editing Title Blocks

¢ Adding Text Blocks

« Overriding Color and Font Settings for a Specific Object

¢ Change Data Model Display Preferences
« Changqing Entity Display Preferences
¢ Changing Data Model Layout

Setting Diagram Properties

In the Diagram Properties dialog you can document basic information about your data model. Data entered on this
dialog is used when generating reports about the model and is also used to populate the Title Block.

1 Click File > Diagram Properties
2 Make your changes to the Information, Description, and Attachment Bindings tabs, and then click OK.
The following describes options that are not self-explanatory:
Attachment Bindings tab

Lets you bind an external piece of information, or attachment to the domain. You can also remove an attachment
from an object, override an attachment binding’s default value, or change a bound attachment'’s position. To
override the value of the attachment you have moved to the Selected Attachments grid, double-click the Value
field of the target attachment. ER/Studio opens the Value Override Editor or a list depending on the attachment
datatype. Attachments are created in the Attachments folder of the Data Dictionary and must be applied to the
diagram before they will display on this tab. For more information, see Attaching External Documents to the Data
Model.



Set Data Model Properties

The Model Properties Editor lets you modify the Security, Attachment, PreSQL and PostSQL properties for the model.
It also displays the name handling options that were applied when the physical model was generated. The editor
varies slightly between the logical and physical models.

1 Right-click the model and then click Model Properties.

2 For Logical Models, make your changes on the Security Information and Attachment Bindings tabs and then
click OK.

For Physical Models, make your changes on the Security Information, Attachment Bindings, PreSQL &
PostSQL, and Name Handling tabs, and then click OK.

The following describes options that are not self-explanatory:

Security Information tab

Displays the current security information as defined in the Data Dictionary. You can add or edit security reporting
information in by double-clicking the field you want to change. To set the model-wide default value for a property,
go to the Data Dictionary tab and expand the Data Security Information Node. For more information, see

Enforcing Security Using Data Security Types and Properties.
Attachment Bindings tab

Lets you bind an external piece of information, or attachment to the model. You can also remove an attachment
from an object, override an attachment binding’s default value, or change a bound attachment’s position. To
override the value of the attachment you have moved to the Selected Attachments grid, double-click the Value
field of the target attachment. ER/Studio opens the Value Override Editor or a list depending on the attachment
datatype. Attachments are created in the Attachments folder of the Data Dictionary and must be applied to the
data model before they will display on this tab. For more information, see Attaching External Documents to the
Data Model.

PreSQL & PostSQL tab

Lets you enter SQL to be applied before or after the CREATE OBJECT statement. If you select Generate, the
PreSQL and PostSQL scripts entered here are included in the script when you generate the physical database.

Name Handling tab

The Name Handling tab is read-only and displays the name handling options applied when the physical data
model was generated. The tab displays the space, case shift, and invalid SQL character handling options.

Setting the Model Notation

You can generate a DM diagram by starting with a logical model, by reverse-engineering, by importing an SQL or ERX
file, or by adding a new physical model.The Model Notation controls whether the data model design technique used is
Entity Relational (ER) or Dimensional (DM). You can use either technique depending on your requirements.

Dimensional modeling is often used for data warehouses, providing for high-performance end-user access to data.
Where a single ER diagram for an enterprise represents every possible business process, a DM diagram represents a
single business process in a fact table. ER/Studio can identify individual business process components and create the
DM diagram for you.



Dimensional Table Types

In a dimensional model, each table is assigned a Table Model type, which is distinguished by an icon displayed in the
upper left of the entity or table box. You can further define a table in the Table Editor by assigning it a Table Type that
displays at the bottom of the table. The Table Type doesn’t change how the data is handled but provides information to
the reader about the data in the table:

ER/Studio supports the following Dimensional table types:

Fact: Tables with one or more foreign keys and no children.

Fact tables contain individual records, the data for which the database is being designed. Fact tables are
the central tables in a star schema.

ER/Studio allows you to further define fact tables as one of the following types:

« Aggregate: Contains information that is more coarsely granulated than the detail data contained in other tables.
For example in a retail, transactional database, you may have a Sales_Receipts fact table that contains
information about individual sales, and a Sales_Monthly aggregate table that aggregates information from the
Sales_Receipts table to present information such as monthly sales totals for software, hardware, and services.
Aggregates provide quick access to data during reporting; like indexes they improve performance.

« Atomic: Contains detail information, such as the Sales_Receipts table in the discussion above.

« Cumulative: Contains cumulative information such as how long it took to complete the sale by accumulating the
time it took between the date of sale and the shipping date for each line item of the sales receipt.

* Snapshot: Contains time-related information, that detail specific steps in the life on the entity. For example,
snapshot information for a sale could contain information such as when the order was created, committed,
shipped, delivered, and paid for.

0 — Dimension: Parents of fact tables.

@ : Dimension tables contain groups of related data, such as dates, hours, minutes, and seconds, represented
G by one key such as “time” in a fact table.

ER/Studio allows you to further define dimension tables as one of the following types:
« Fixed Dimension: The values in the table are not expected to change.

« Degenerate: A degenerate dimension is derived from the fact table. Degenerate dimensions are useful when a
fact table's grain represents transactional level data and you want to maintain system-specific identifiers such as
order numbers and invoice numbers without forcing them to be included in their own dimensions. Degenerate
dimensions can provide a direct reference to a transactional system without the overhead of maintaining a
separate dimension table. For example, in the sample model, Orders.dml you could create a degenerate
dimension that references the Commission Credit ID, Payment Detail ID, and Sales Order ID from the
Commission Credit, Payment Detail, and Sales Order Line ID fact tables respectively,



Multi-Valued: A multi-valued dimension can help you model a situatio
attribute or column. For example, a health care bill has a line item of D

don’t double count the Billed Amount in the fact table.
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Ragged: In a ragged dimension, the logical parent of at least one member is missing from the level immediately
above the member. Ragged dimensions allow for hierarchies of indeterminate depth, such as organizational
charts and parts explosions. For example, in an organization some employees may be part of a team which is
managed by a team leader, and other employees report directly to the department manager. Another example of
a ragged dimension is illustrated in the model below; cities such as: Washington, D.C., Vatican City, and Monte
Carlo don't belong to states.
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Shrunken: A shrunken table is a version of the fact table it is attached to but with fewer attributes in order to draw
attention to those specific attributes.

Slowly Changing Type 0, 1, 2, 3, 6: Slowly changing dimensions capture information such as the customer’s
income level or income-to-debt ratio which may change overtime. The most commonly used methods to maintain
these changes are:

Type 0: No effort has been made to deal with the changes.
Type 1: Overwrite the existing dimension member values. Does not track the change history.
Type 2: Create a new row with the current dimension member. Tag the original row as expired.

Type 3: Used for dimensions that change with a predictable rhythm, such as every year. Every dimension row
has a current category attribute that can be overwritten as well as attributes for each annual designation, such
as 2008 category and 2009 category.

Type 6: Combines the approaches of types 1, 2, and 3. For changes to this type of table, the row is overwritten
but the table may contain an additional pair of date columns to indicate the date range at which a particular row
in the dimension applies, or the table may contain a revision number.



Snowflake: Parents of dimension tables.
S

Snowflake tables present a more-normalized format where elements of dimension tables are listed. The
following example shows two snowflake tables which are parents of a dimensional table. There are many
other good examples or snowflake tables in the sample model, Orders.dm1.
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Bridge: Implements a many-to-many relationship.

X

Bridge tables support multi-valued dimensions or complex hierarchies. The Bridge is also known as a
helper table or an associative table. It's the only way to implement two (or more) one-to-many
relationships, or many-to many relationships.

Hierarchy Navigation

Used to support complex hierarchies, such as organization charts

Undefined: All other tables

Assign this type to flag tables for which you have not yet determined the appropriate type, such as a table
with a many-to-many relationship, or a table that is a parent to both a fact table and a dimension table.

Changing the Model Notation
1 Click the target model and then click Model > Model Notation.

2 From the list, select Relational or Dimensional.

The model is redrawn to conform with the model notation selected.

Notes
* When generating a Physical Model, and reverse-engineering or importing from an external data source to create
a model, you can choose the model notation.

« You can change the notation of a physical model in the Physical Model Options dialog. Access this dialog by
right-clicking the target physical model, and selecting Model Options.

« You can change the table type of an object in the dimensional model using the Dimensional tab of the Entity/Table
Editor. Access this editor by double-clicking the entity or table.



See Also
Reverse Engineering an Existing Database

Importing a Model
Generating a Physical Data Model

Setting the Relationship Notation

ER/Studio can present the relationships in your data models in IDEF1X notation or in one of three varieties of IE
notation.

This section is comprised of the following topics:
« IDEF1X versus |IE Relationship Notation
« Changing the Relationship Notation for all Diagram Models

¢ Changing the Relationship Notation for a Selected Model

IDEF1X versus IE Relationship Notation

IDEF1X is based on the relational data model designed by E. F. Codd, and on the entity-relationship model designed
by Peter Chen, but IDEF1X models differ from the models on which IDEF1X is based. A model created using Peter
Chen’s or E.F.Codd’s designs will appear different compared to a model created using ER/Studio and the IDEF1X
notation, and vice versa.

IDEF1X makes it easier to visualize primary and foreign keys. IDEF1X also offers the power (and danger) of using
identifying relationships to cascade primary keys through a chain of entities.



The following illustrates how relationships are presented in ER/Studio using the IDEF1X notation:

IDEF1X Notation

Identifying Hon-Specific Relationships
CUSTOMER_1 Non-Identifyi CUSTOMER 3
# cuUSTOMER ID on-fde ng,
Mandatory Relationship FCUSTOMER ID I
CUSTOMER_Z

& cuUSTOMER ID

CUSTOMER ADDRESS_1

F CUSTOMER ADDRESS ID
BCUSTOMER 1D (FK)

|

CUSTOMER ADDRESS_2

CUSTOMER ADDRESS_3
# CUSTOMER ADDRESS ID

Hun-l_dentllfjnng, Optional 'Eﬁ CUSTOMER ID (Fk) One-to-One Relationship
Relationship “# CUSTOMER ADDRESS ID
|
CUSTOMER_4 CUSTOMER_S
H CUSTOMER 1D F CUSTOMER ID
| |
| |
. ’
CUSTOMER ADDRESS 4 CUSTOMER ADDRESS_ S
$# CUSTOMER ADDRESS ID 4 CUSTOMER ADDRESS ID I
% CUSTOMER 1D (FK) % CUSTOMER (D (FK) I

IE is considered to be semantically stronger than IDEF1X, supporting more abstract approaches to data modeling. IE
is more flexible in supporting subtypes, permitting roll up (generalization) and roll down (specialization)
transformations. In addition, primary keys are less prominent in the IE notation; therefore, its practitioners are less
likely to think about logical key choice prematurely.



The following illustrates how relationships are presented in ER/Studio using the IE (Martin/Finkelstein) notation:

IE (James Martin) Notation

Identifying
CUSTOMER_1
F CUSTOMER 1D

CUSTOMER ADDRESS_1

[-{-F’ CUSTOMER ADDRESS ID

Non-ldentifying,
Optional Relationship

CUSTOMER_4
& CUSTOMER ID

CUSTOMER ADDRESS_4

& CUSTOMER ADDRESS ID

Non-ldentifying,
Mandatory Relationship

CUSTOMER_2
& CUSTOMER 1D

CUSTOMER ADDRESS_2

@ CUSTOMER ADDRESS ID

Non-Specific Relationships

CUSTOMER_3
# CUSTOMER ID

CUSTOMER ADDRESS_3
# CUSTOMER ADDRESS ID

One-to-One Relationship

CUSTOMER_5
F CUSTOMER 1D

CUSTOMER. ADDRESS_5
# CUSTOMER ADDRESS ID




The following illustrates how relationships are presented in ER/Studio using the IE (Crow’s Feet) notation.

IE (Crow's Feet) Notation

ldentifying Non-Specific Relationships
T Non-ldentifying CUSTOMER 3
# CUSTOMER 1D - : -
Mandatory Relationship & CUSTOMER ID
CUSTOMER_2

T CUSTOMER 1D

CUSTOMER ADDRESS_1

CUSTOMER ADDRESS_3
# CUSTOMER ADDRESS ID

# CUSTOMER ADDRESS ID
B|CUSTOMER ID (FK)

CUSTOMER ADDRESS _2

Non-ldentifying, % CUSTOMER 1D (FK) One-to-One Relationship
Optional Relationship “# CUSTOMER ADDRESS 1D
CUSTOMER._4 CUSTOMER_5
# CUSTOMER 1D # CUSTOMER ID
CUSTOMER ADDRESS_4 CUSTOMER ADDRESS_5
# CUSTOMER ADDRESS ID # CUSTOMER ADDRESS ID

% CUSTOMER 1D (Fk) % CUSTOMER 1D (FK)




The following illustrates how relationships are presented in ER/Studio using the IE (Martin/Finkelstein) notation.

Filtered IE (Hide Foreign Keys) Notation

Identifying Non-Specific Relationships
CL-ISTDMERJ Non-ldentifyin CUSTOMER_3
& CUSTOMER IO - 9 F CUSTOMER ID

Mandatory Relationship

CUSTOMER_2
# CUSTOMER ID

CUSTOMER ADDRESS_1

CUSTOMER ADDRESS _3
& CUSTOMER ADDRESS ID

[{p CUSTOMER ADDREESS ID

CUSTOMER ADDRESS_2

Non-dentifying, ¥ CUSTOMER ADDRESS ID

One-to-One Relationshi
Optional Relationship ne-to-Lne Relationsiip

CUSTOMER_4 CUSTOMER_5
# CUSTOMER ID # CUSTOMER ID
CUSTOMER ADDRESS 4 CUSTOMER ADDRESS 5

# CUSTOMER ADDRESE ID #F CUSTOMER ADDRESS ID

Changing the Relationship Notation for all Diagram Models
1 Click View > Diagram and Object Display Options.

2 Click the Relationship tab.

3 In Display Preferences, choose the desired notation and then click OK.



Changing the Relationship Notation for a Selected Model
1 Right-click the target model and select Model Options.

2 Inthe Notation area, choose the desired notation and then click OK.

Manipulating Relationship Lines

Relationship lines represent relationships between entities and/or attributes. You can customize the appearance of
any relationship line in any model, even when using an auto layout. For example, if you use an Orthogonal layout,
where all relationships bend at a 90 degree angle, you can change any individual bend to an N bend, or straighten the
relationship line.

You can also set the bend attributes of any relationship in a model. There are two kinds of bends in ER/Studio: N
bends and Orthogonal bends. N Bends are relationship lines that bend at any angle while Orthogonal bends only bend
at a 90 degree angle. Both Hierarchical and Orthogonal auto layouts use only Orthogonal relationship lines. All other
auto layouts use straight relationship lines. You can also create straight relationship lines that are vertical or
horizontal.

When you use the auto layouts, ER/Studio organizes the data model objects according to the specifications of that
particular layout. Each layout has different specifications for the way relationships bend and how relationships dock or
intersect with entities and attributes. You can move the docking positions on parent or child entities.

You can also change the color of all or individual relationships in the data model. You can specify a default
relationship color on the Options Editor - Application tab. You can use the Colors and Fonts Editor to change all or an
individual relationship in your model.

NOTE: You can overwrite relationship defaults after applying an automatic layout by changing
relationship lines in a diagram or by changing the line disposition in a diagram.

You can use the Options Editor, Diagram and Object Display Options Editor, and the Format
Menu to change relationship disposition and colors. Use the Options Editor - Application tab to
make global changes to all your data models. Use the View Menu to make changes to the current
data model and the Format Menu to make changes to the selected objects. Changes made in the
Format Menu will override changes made first in the Options Editor.

This section is comprised of the following topics:

¢ Change the Style of Relationship Lines

e Create an N Bend

¢ Straightening an N Bend

« Change the Disposition of Relationship Lines

Change the Style of Relationship Lines

To make your diagram easier to read, you may want to change the style of relationship lines from elbowed to straight
or vice-versa.

NOTE: When changing from elbowed to straight relationship lines, ER/Studio repositions the docking
points to as close as possible.

« To change the style of relationship lines in all new data models, click Tools > Options > Display and in the
Model Display area, select the Line Drawing Mode you want, Elbowed Lines or Straight Lines.

Relationships in all new data models you create will default to the Line Drawing Mode selected.



« To change the style of all relationship lines in the current data model, click View > Diagram and Object Display
Options > Relationship and in the Display Preferences area, select the Relationship Style you want,
Elbowed or Straight.

The relationships in the current data model are redrawn to conform with the Relationship Style selected.

« To change the style of a selected relationship line, right-click the relationship line, click Layout Relationships,
and then select EIbowed or Straight. Alternatively, after selecting the relationship line, select Elbowed or
Straight from the Format > Layout Relationships list.

The selected relationship is redrawn to conform with the relationship style selected.
« To straighten a relationship line, right-click the relationship line and then click Straighten Relationship Line.

Alternatively, you can straighten a horizontal relationship by selecting the relationship and then
pressing Ctrl+H; pressing Ctrl+L straightens a vertical relationship.

NOTE: Changes are cascading meaning that changes made in the Format menu will override changes
made in the Options Editor.

Create an N Bend

To make your diagram easier to read, you may want to create N bends, which are like an elbows, on one or more
relationship lines.

NOTE: If you are using an automatic layout, ER/Studio lets you create N bends only in the following
layouts: Circular Layout, Symmetric Layout, and Tree Layout.

1 Select the relationship line that you want to bend.

2 Move the cursor over the line at the point where you want to create the bend.

NOTE: The pointer should change to ‘f%

3 Click and drag to position the bend.

4  To create more than one bend point on the relationship, repeat steps 2 and 3.

Straightening an N Bend
Once you have created an N Bend, you can use the following methods to straighten the line.

« To remove a bend, click the relationship line you want to straighten and then click Format > Layout
Relationship > Straight

« To reset the line to its default position, click the relationship line you want to straighten and then click Format >
Line Disposition > Reset to Default Docking Side(s).



« To straighten a line between two entities that have overlapping edges, as shown in the following illustration,
right-click the line and then click Straighten Relationship Line.
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Change the Disposition of Relationship Lines
To make your diagram easier to read, you may want to change the positioning or disposition of the relationship lines.

1 Click the relationship line and then click Format > Line Disposition.

You can select all the relationship lines in the data model by pressing CRTL+A.

2 From the list select Center, Vertical, Horizontal or Reset to Natural Docking Side(s).
You can reset the disposition of a relationship line to the natural docking side by right-clicking the
relationship line and then from the list, selecting Reset to Default Docking Position.

The selected relationship is redrawn to conform with the relationship line disposition selected.

Changing the Model Background

To make your model more visually appealing, you can change the background color displayed to better suit the colors
you choose for other object models in the Diagram Window.

Change the Background Color of New Data Models
1 Click Tools > Options.

2 To change the background of new logical models, select the Logical tab.

To change the background of new physical models, select the Physical tab.



3 Inthe Main Model Display area, click Background Color.
4 To choose one of the Basic colors or one of the existing Custom Colors, select a color box and then click OK.

To choose a color not already displayed in this dialog, click Define Custom Colors, define the new color, click
Add to Custom Colors. (This adds a new color option to the available Custom Colors.) Now you can select the
new color box and then click OK.

5 Click OK again to exit the Options editor.

You can export the model background by selecting Export model and object background color in
Model > Options > Display.

Change the Background and Outline Colors of Existing Models and Views
1 Inthe Diagram Explorer, click a data model or a view of a data model.

2 Click Format > Colors & Fonts > Colors.
3 To set the background color of a model, from the list select Model Background and then click Set Color.

To set the background color of all views in the model, from the list, select View Background and then click Set
Color.

To set the foreground color of all views in the model (the dotted line around the view box), from the list, select
View Foreground and then click Set Color.

4 To choose one of the Basic colors or one of the existing Custom Colors, select a color box and then click OK.

To choose a color not already displayed in this dialog, click Define Custom Colors, define the new color, click
Add to Custom Colors. (This adds a new color option to the available Custom Colors.) Then you can select
the new color box and click OK.

5 To apply your changes and exit the Colors & Fonts editor, click OK again.

Notes

* When exporting the model, you can also export the model background by selecting Export model and object
background color in Model > Options > Display.

* You can specify background and foreground colors for an individual view by right-clicking the view in the Diagram
Window and then clicking View Background/Outline Color.

¢ You can specify that all views in the data model share the same background and foreground (outline) colors by
clicking Tools > Options > View and then in the View are, selecting Same background color for all views.

See Also
Overriding Color and Font Settings for a Specific Object

Setting Default Diagram Colors and Fonts

You can create color schemes and change fonts to help manage your workspace. The Colors and Fonts Editor lets
you customize the data model display by customizing the background and foreground colors of the model, entities,
and database objects and by customizing the font for individual components of the data model or standardizing on a
specific font for all displayed text.

1 Click Format > Colors & Fonts.

2 Make the changes as required and then click OK to implement the changes.



Notes

« Override the default colors and fonts for specific objects or for instances of a specific object. For more
information, see Overriding Color and Font Settings for a Specific Object.

« Set the default background color of the model in the Main Model Display area of the Logical or Physical tabs of
the Options editor, click Tools > Options.

Overriding Color and Font Settings for a Specific Object

To make your model more attractive and easier to read, you can change the background, outline, and font colors
along with the font type entities/tables, attributes/columns, views, and relationships in your data model. Use specific
colors and/or fonts to help you organize your data model.

Set the default background color of the model in the Main Model Display area of the Logical or
Physical tabs of the Options editor, select Tools > Options.

This section is comprised of the following topics:

* Change Color and Font Settings for an Entity, Table, Attribute, Column or View

* Change Entity/Table Background and Outline Colors

« Change the Background and Outline Colors of Views in an Open Data Model

« Changing the Color of Relationships

Change Color and Font Settings for an Entity, Table, Attribute, Column or View
Use the Color and Fonts editor to do the following:

« Change the font, font style, size, and effects (strikeout and underline) for one or more selected components of an
entity or table, such as: entity name, entity attributes, primary keys, role names, alternate keys, and inversion
entries.

« Change the font, font style, size, and effects (strikeout and underline) for selected components of a view column.

« Apply font and color settings to attribute categories such as: non-inherited primary keys, inherited primary keys,
non-inherited non-keys, inherited non-keys, primary key index, unique indexes, non-unique indexes,
attachments, triggers, and data security.

« Change the background and outline color of entities, tables and views.

1 Inthe Diagram Window, right-click the object you want to change or the object containing the object you want to
change.

2 For entities, tables, columns, and attributes, click Entity Color and Font Settings > Entity/Attributes Colors
and Fonts.

For views and view columns, click View Color and Font Settings > View/View Columns Colors and Fonts.
3 Inthe Colors and Fonts editor make the changes desired.
NOTE: You can apply the same changes to multiple attributes or columns by pressing and holding Citrl
while clicking the objects.
4 To apply color and font setting changes to all occurrences of the selected object in the model, select Apply to all

submodels; otherwise, the changes will affect only the occurrence of the entity selected.

5 Use the preview area to preview your changes and then click OK to implement the changes.



Change Entity/Table Background and Outline Colors

1
2
3
4

In the Diagram Window, right-click the entity/table you want to change.
Click Entity Color and Font Settings > Entity Background/Outline Color.
In the Entity Color editor make the changes desired.

To apply color changes to all occurrences of the selected entity in the model, select Apply to all submodels;
otherwise, the changes will affect only the occurrence of the entity selected.

Change the Background and Outline Colors of Views in an Open Data Model

1

In the Diagram Explorer, expand the Views node of a logical or physical mode, and then right-click the view you
want to change.

Click View Color and Font Settings > Colors & Fonts > Colors.

To set the background color of all views in the model, from the list, select View Background and then click Set
Color.

To set the foreground color of all views in the model (the dotted line around the view box), from the list, select
View Foreground and then click Set Color.

To choose one of the Basic colors or one of the existing Custom Colors, select a color box and then click OK.

To choose a color not already displayed in this dialog, click Define Custom Colors, define the new color, click
Add to Custom Colors. (This adds a new color option to the available Custom Colors.) Then you can select
the new color box and click OK.

5 To apply your changes and exit the Colors & Fonts editor, click OK again.

Notes

« When exporting the model, you can also export the view background by selecting Export model and object

background color in Model > Options > Display.

You can specify background and foreground colors for an individual view by right-clicking the view in the Diagram
Window and then selecting View Background/Outline Color. This setting can be overridden by selecting Same
background color for all views in Tools > Options > View. If Same background color for all views is enabled, the
View Background/Outline Color option will be unavailable in the View Color and Font Settings short-cut menu.

You can specify that all views in the data model share the same background and foreground (outline) colors by
selecting Tools > Options > View and then in the View area, selecting Same background color for all views. This
setting will override any setting made for individual views in Tools > Options > View.

Changing the Color of Relationships

1

In the Diagram Window, right-click the relationship for which you want to change the color.

2 Click Relationship Color > Edit Settings.

You can change the color of all or individual relationships in your diagram. You can specify a
default relationship color on the Options Editor - Application tab. Even if you set a default color for
your relationships, you can still use the Colors and Fonts Editor to change all or individual
relationships in your diagram.



Change Data Model Display Preferences

The Display tab of the Options Editor lets you specify the default Model display settings for any new models you
create.

1 Click Tools > Options > Display.

2 Inthe Model Display area, select the options desired.

Notes

¢ You can change the display settings of the current model or submodel by clicking View > Diagram and Object
Display Options and then making your changes within the editor that appears.

¢ Selecting Rolename Notation displays the full IDEF1X rolename notation.

Changing Entity Display Preferences

The Display tab of the Options Editor lets you specify the default Entity display settings for any new models you
create.

1 Click Tools > Options > Display.

2 Inthe Entity Display Settings area, from the list select the Display Mode, and then select the Display Options
desired.

3 Click OK to implement the changes.

You can change the display settings of the current model or submodel by clicking View > Diagram
and Object Display Options and then making your changes within the editor that appears.

Customizing the Layout

Using the Layout Properties Editor, customize layout properties common to all layouts and customize the appearance
of a specific layout method.

NOTE: Any changes made in the Layout Properties Editor apply only to the model currently selected.

1 Inthe Diagram Explorer, click the model you want to layout using a customized layout.

2 Click Layout > Layout Properties Editor.

3 Click a layout tab.

4 Complete the changes as desired.
For help on a specific option, click the option and then press F1. Contextual help for this option
appears.

5 Click OK to apply the changes and exit the editor.

The following describes options that are not self-explanatory:
All tabs
« Apply: Applies your changes to all selected diagrams without closing the dialog box.

« Defaults: Resets all values of the selected property sheet to ER/Studio default values.



Layout: Applies your changes to all selected diagrams without closing the dialog box, and immediately displays
any changes to the active model in the Diagram Window.

Reset: Resets all values of the selected property sheet to the values displayed when you opened the Layout
Editor.

Disconnected tab

Tiling: Offers three ways of tiling disconnected entities: to grid, to rows, and to columns.

e Tile to Grid: All disconnected entities are spaced evenly apart in a grid.

« Tile to Rows: Maximizes space efficiency by placing connected entities in rows running left to right, leaving
just enough vertical space for the tallest entity in the row.

« Tileto Columns: Maximizes space efficiency by placing connected entities in columns running top to bottom,
leaving just enough horizontal space for the widest entity in the column.

Circular tab

Biconnectivity: A graph is considered biconnected if within that graph, when any entity is deleted the graph
remains completely connected.

Cluster By: The final clustering phase must be either Biconnectivity or Degree.

Degree: Specifies the minimum number of relationship lines that must branch off a diagram symbol before
necessitating the creation of a new cluster. For example, if the data model Auto Layout Degree value is five (the
default), any entity in that diagram with five or more relationship lines seeds a new cluster.

Hierarchical tab

Edge Routing: Specifies the nature and look of the relationship lines in the selected data model.

Incremental Layout: Specifies the retention of familiar component shapes in the Diagram Window. For example,
if you produce a data model in one layout style, paste into the window of a data model laid out in a different style,
and then join them to make a connected diagram, selecting the Incremental Layout check box preserves the
different layout styles as you continue to make modifications to the data modelEdge RoutingV.

Layout Quality: Specifies the speed of the algorithm used to produce the layout.

« Draft: Provides the lowest quality, but fastest level of layout.
* Proof: Provides the highest quality, slowest level.

Orientation: Lets you specify one of four ways to orient the data model. Changing data model orientation does
not automatically change port specifications, connectors, entity shapes, or constraints, some or all of which can
rely on specific sides of entities, making for some complicated side effects of changing the orientation of complex
data models. Selecting Rotation Specifications includes port specifications, connectors, entity shapes, or
constraints when re-orienting the data model.

Undirected Layout: When a diagram is undirected, the source and target entities of any relationship are treated
the same. In a directed diagram, the direction of the relationship is significant. Networks are often represented in
undirected layouts, while processes are often represented in directed layouts.

Orthogonal tab

Compaction Quality: Specifies the quality of the process that removes unused white space in the target
diagram. The primary difference between Draft, Default, and Proof quality is the number of times ER/Studio runs
a compaction algorithm on the diagram. The more often the algorithm runs, the more efficient the use of white
space, and the more resource-intensive the process.

Edge Spacing: Specifies the horizontal and vertical distance between parallel relationship lines.



« Incremental Layout: Specifies the retention of familiar component shapes in the Diagram Window. For example,
if you produce a data model in one layout style, paste into the window of a data model laid out in a different style,
and then join them to make a connected diagram, selecting the Incremental Layout check box preserves the
different layout styles as you continue to make modifications to the data modelEdge RoutingV.

« Node Spacing: Specifies the horizontal and vertical distance between entities.
Symmetric tab
« Layout Quality: Specifies the speed of the algorithm used to produce the layout.

« Draft: Provides the lowest quality, but fastest level of layout.
« Proof: Provides the highest quality, slowest level.

Tree tab

« Undirected Layout: When a diagram is undirected, the source and target entities of any relationship are treated
the same. In a directed diagram, the direction of the relationship is significant. Networks are often represented in
undirected layouts, while processes are often represented in directed layouts.

Creating and Editing Shapes

Drawing shapes are supported in the logical model and in all database platforms supported by ER/Studio.

Drawing shapes have no fixed meaning in your diagrams, so you can determine how they are used and interpreted.
There are three, primary uses for drawing shapes:

* Unique Representation: Drawing shapes can represent schema objects in your model that are not commonly
represented by regular ER notation. For example, using ER/Studio’s drawing shapes, you can add objects in a
physical model to represent Java classes. Such objects can ultimately have crucial meaning to your database
design.

« Notation: The note drawing shape enables you to document special circumstances that exist in your diagrams.
Because the contents of the note drawing shape are displayed in the Diagram Window, they are more easily
seen than entity notes or table notes, which are buried in the entities and tables themselves.

« Containment: Enabling containment embeds entities and tables within the drawing shapes, essentially locking
the tables and entities to the drawing shapes. When you move the drawing shape, the entities and tables follow,
maintaining their positions within the drawing shape. Containment is particularly useful when you want to isolate
entities and tables, making those entities and tables more obvious. Similarly, you can use containment to keep
objects together that share a certain importance so can you move these shared objects in unison when you move
the drawing shape.

1 Onthe Drawing Shapes toolbar, click the icon for the shape you want to insert.

Drawing Shapes Toolbar
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2 Onthe Diagram Window, click the mouse where you want to add the shape.

3 Double-click the shape to launch the Shape Editor, where for example, you can add text and change the color of
the shape.

The following describes options that are not self-explanatory.



Shape Text tab

You can adjust the text positioning choices either with the Horizontal Justification and Vertical Justification
drop-down menus or by clicking one of the nine squares in the adjacent grid.

With Fit Shape selected, the shape is automatically resized to fit the shape text. With this option selected, Wrap
Text is disabled, and the object cannot be resized by dragging its outline handles.

Colors and Fonts tab

Here you can change the shape type (e.g. oval to rectangle).

Attachment Bindings tab

Lets you bind an external piece of information, or attachment to the shape. You can also remove an attachment
from an object, override an attachment binding’s default value, or change a bound attachment’s position. To
override the value of the attachment you have moved to the Selected Attachments grid, double-click the Value
field of the target attachment. ER/Studio opens the Value Override Editor or a list depending on the attachment
datatype. Attachments are created in the Attachments folder of the Data Dictionary. For more information, see

Attaching External Documents to the Data Model.

See Also
Locking Data Model Objects to a Drawing Shape

Adding and Editing Lines

Locking Data Model Objects to a Drawing Shape

1

2

In the Diagram Window, place a shape close to the data model object you want to contain.

Click the shape and then use the sizing handles to resize the shape so that it encompass the objects you want to
move with the shape.

Right-click the shape and select Containment > Enable.

NOTE: You can remove the containment restriction by right-clicking the object and then clicking
Containment > Disable.

Adding and Editing Lines
You can use lines to establish a visual connection between two entities without propagating foreign keys as would
occur when creating a relationship.

1
2
3

On the Main toolbar, click the Line tool.
Click the object where the line is to start and then click the object where the line is to end.
Double-click the line to launch the Line Editor and then click OK to exit the editor.

The following describes the options that are not self-explanatory.

Properties tab

Here you can change the color or weight of the line and end-point styles

Define the relationship between the source and target objects of the line using the Verb Phrase and Inverse Verb
Phrase definitions in the Line Editor.



Attachment Bindings tab

Lets you bind an external piece of information, or attachment to the line. You can also remove an attachment
from a line, override an attachment binding’s default value, or change a bound attachment’s position. To override
the value of the attachment you have moved to the Selected Attachments grid, double-click the Value field of the
target attachment. ER/Studio opens the Value Override Editor or a list depending on the attachment datatype.
Attachments are created in the Attachments folder of the Data Dictionary. For more information, see Attaching
External Documents to the Data Model.

Notes

Edit the line by right-clicking the line and then clicking Layout Line, Straighten or Format.

Change the properties of a line in the Line Editor by right-click the line you want to change and then selecting
Format.

Turn on and off the display of verb phrases in the Display tab of the Options editor (Tools > Options).

Change the default line type from elbowed to straight lines in the Line Drawing Mode area of the Display tab in
Tools > Options.

Choose whether or not to display the verb phrase of the line in the Model Display area of the Display tab in Tools
> Options.

When you hover over a line, ER/Studio displays the name of the parent and child of the line if you've clicked View
> Cursor Help Popup Options > Display Relationship Help.

Adding and Editing Title Blocks

The Title Block provides important identification information about your model or submodel that by default includes the
file name and information from the Diagram Properties, such as project name, author name, company name, diagram
version number, copyright information, the diagram’s creation date and last modification date. You can change many
of the field values in the title block without affecting the values in the Diagram Properties editor.

1 Click the model or submodel to which you want to add a title block.

2 Click Insert >Title Block.

3 Inthe Diagram Window, click where you want to place the title block, and then right-click to deselect the Title
Block creator.

4 Use the selection tool to reposition the title block if desired.

5 Double-click the Title Block to launch the Title Block editor, make the changes desired, and then click OK to
affect the changes and exit the editor.

6 Repeat steps 1-4 for each model or submodel as desired.

Notes

The File Name and Submodel or Model name fields in the Title Block editor are read-only, as are the creation and
modification dates.

For information on Diagram Properties, see Setting Diagram Properties.



Adding Text Blocks

Use text blocks to insert useful information into the diagram. You can add multiple text blocks at specific points
throughout the diagram to add clarity and help with organization. When you no longer need to use a text block in your
diagram, you can delete the text block.

1 Click Insert > Text Block.
2 Inthe Diagram Window, click where you want to place the text block, enter the text you want to display, and then

right-click to deselect the Text Block creator.

Notes
« To resize the text box, select the text box, grab a sizing handle and drag to the desired position.

« Change the font attributes by right-clicking the Text Block and then clicking Colors & Fonts.

Changing Data Model Layout

ER/Studio offers two ways to change the layout of your data models:
« Auto Layout that redraws your data model according to preset styles.
« The Layout Properties Editor that allows you to further customize the preset styles by setting parameters such as

spacing, packing, tiling, and labeling conventions.

Redraw a Data Model Using Auto Layout
1 Open a data model.

2 From the Alignment toolbar, select an auto layout option.
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ER/Studio redraws the data model in the Diagram Window according to the rules of the preset style chosen.



Notes
The following describes the auto layout preset styles shown above, in order from left to right:

< Circular Layout: The circular layout reveals the dependencies and relationships between the data model
objects.Emphasizes group structure by rearranging the data model into one or more circular patterns. This layout
groups related entities into clusters and each cluster is grouped into circles according to the logical
interconnection of the clusters and in a manner that minimizes the number of lines that cross the middle of the
data model.

e Hierarchical Layout: Organizes entities in a hierarchical pattern based on the direction of the relationship
between the entities. Hierarchical diagrams can display circular relationships, where the relationship path starts
and ends on the same entity.

Note: The Hierarchical Layout is the only type that represents data flows in a consistent direction.

« Orthogonal Layout: Useful for data models where inherent hierarchical structures are unimportant but the
relationship orientation and ease of navigation is important. The orthogonal layout rearranges the data model into
square-line, rectangular patterns that use only horizontal and vertical line routing. Orthogonal Layouts have few
crossings and allow minimal stretching of entities that have a high number of incident relationships. Diagrams
with this layout never overlap between entities or between entities and non-incident relationships.

« Symmetric Layout: This layout provides a symmetrical pattern centered around a single entity where peripheral
entities move to the edge of the diagram. Symmetric Layouts naturally expose ring and star diagrams, producing
clear data model diagrams that highlight the natural symmetry of many data models. Symmetric Layouts produce
congruent data models of isomorphic graphs (graphs with the same structure), distribute entities uniformly, and
create diagrams with few relationship crossings.

« Tree Layout: Use a tree layout for data models that contain a unique predecessor relationship. The tree layout
rearranges your diagram into a tree pattern with parent and child entities, producing a data model that contains a
root entity and only one unique path from the root entity to any other entity. Tree layouts can have branches and
siblings where parent to child relationships are inherent.

« Global Layout: Rearranges your data model according to the style chosen for the target data model.

« Incremental Layout: Rearranges your data model according to the style chosen for the target data model
without disturbing styles previously applied to pre-existing objects.

See Also
Customizing the Layout

Associate Similar Objects Using User-Defined Mappings

Create user-defined mappings to relate logical entities to physical tables. The UDM can relate any objects of the same
type. Once the UDM is created, you can see a graphical tree/node representation of the mapping on the User Defined
Mappings tab in the Entity Editor or Table Editor.

One use of the UDM is to back-construct the relationships normally shown in the Where Used tab.

For example, frequently a legacy physical model must be imported and added to a mature logical model (Using the
Add New Physical model wizard: from the Main menu, Model > Add New Physical Model). You must relate the two
models and can use the user-defined mapping to create and document the relationship.

Denormalization information for the imported physical model likely is not available. Therefore, ER/Studio has no
denormalization mapping information to display on the Where Used tab. The UDM system allows you to build the
mappings with no restrictions. You can map attributes to columns and entities to tables by right-clicking any of the
models listed and selecting the related objects.



Create and Edit User-Defined Mappings

1 Inthe Diagram Explorer or Diagram Window, right-click the entity or table that you want to associate with other
entities or tables.

2 Click Edit User-Defined Mappings.
3 Select the items to be mapped to the selected entity or table.
The following describes options that are not self-explanatory:
Definition tab

Enter or edit a definition for the user-defined mapping. If the target database supports it, ER/Studio adds this
definition as a table comment when generating SQL code.

Attachment Bindings tab

Lets you bind an external piece of information, or attachment to the user-defined mapping. You can also remove
an attachment from an object, override an attachment binding’s default value, or change a bound attachment’s
position. To override the value of the attachment you have moved to the Selected Attachments grid, double-click
the Value field of the target attachment. ER/Studio opens the Value Override Editor or a list depending on the
attachment datatype. Attachments are created in the Attachments folder of the Data Dictionary. For more
information, see Attaching External Documents to the Data Model.

Notes
« You can map an entity to tables in disparate physical models.

« Once you've created a user-defined mapping, to view the mapping you can open a Table Editor or Entity Editor
and then select the User-Defined Mappings tab.

* You can also edit the mappings from the User-Defined Mappings tab in the Table Editor or Entity Editor by
right-clicking the model you want to editor and clicking the Edit option. When editing the user-defined mappings,
you can also edit the definition and the attachments bound to the user-defined mapping.

Enforcing Data Integrity Using Check Constraints

The Check constraint evaluates the data as it is entered and only if the check evaluates to true is the entry allowed.
The constraint entered for an entity is used when creating the physical model and can be seen in the table’s DDL.

1 Double-click the entity or table you want to create a check constraint for.

2 Onthe Rule/Constraints tab of the Entity or Table Editor, name the constraint and then enter the constraint in
the text box.

The constraint is added to the CREATE TABLE statement in the Table’s DDL in the format:
CONSTRAINT (constraint_name) CHECK (constraint_text)

where

constraint_name is the name of the constraint

constraint_text is the text entered in the text box

NOTE: Constraints are created in the Data Dictionary, in the Rules folder. For more information, see
Promoting Data Integrity Through Rules.




Developing the Logical Model

A logical model is developed before the physical model. It addresses the business and functional requirements of
systems development. The logical design allows you to determine the organization of the data that you need to store
in a database before you create the database; it serves as a blueprint.

To design the most effective data model possible, you should focus on the logical design before developing the
physical design. Both the logical and physical design processes are complex so it is best to separate rather than to
mix the two. A sound logical design should streamline the physical design process by clearly defining data structures
and the relationships between them.

A data model can be extremely useful for other things besides creating databases, though that is generally its primary
purpose. In systems development, the goal is to create an effective database application that can support some or all
of your enterprise. However, a data model of your business can help you define operational aspects of your business
that you might otherwise overlook. Also, a well-defined data model that accurately represents your business can be
helpful in orienting employees to goals and operations. The data model can also serve as an invaluable
communications tool for both internal and external constituents.

For more information, see the following topics:

¢ Logical Design Concepts

¢ Creating and Editing Entities and Attributes

¢ Creating and Editing Attributes and Columns

¢ Creating and Editing Keys
« Creating Relationships
« Validating the Model

* Creating and Editing Database Users

* Creating and Editing Database Roles

¢ Validating the Model
¢ Creating and Editing SQL Procedures
« Customizing Datatype Mappings

Logical Design Concepts

To avoid bugs, rewrites, and, in some instances, failed projects, ensure critical design issues have been fully identified
and addressed. In order to realize the benefits of data modeling, you must commit to certain practices that require a
more thorough design cycle in order to realize a more efficient development cycle. A sound design can streamline the
development process and improve the quality of your data models and ultimately improve the performance of your
database.

Because most people involved in data modeling are database administrators or developers, there is a tendency to
approach data modeling as a straightforward database design exercise. While you ultimately implement a data model
as a database design, you should not dismiss the opportunity to re-examine fundamental assumptions about your
business and the rules that govern it. At the design stage the focus should be on business problems, not the technical
details. In the process of developing the logical model, you might discover a simpler approach to implementing a
database design that better accommodates growth and change.

The following topics provide guidelines for the logical design process that should help you achieve better results:

* Object Name Rules describes how to hame the entities and attributes in the logical design.




» Logical Design Documentation describes the importance of providing definitions for entities, attributes, and
relationships.

« Normalization briefly describes the importance of normalizing your logical design before transforming it to a
physical design.

Object Name Rules

Naming entities and attributes deserves serious attention. Long after you implement a system, the nhames you give to
entities and attributes persist. You should not sacrifice clarity for brevity. Names should be descriptive yet general
enough to represent all members. Several naming rules should be followed in order to ensure that your design is as
clear as possible. Consider the following naming rules:

¢ Singular Form: Entity and attribute names should be singular (for example, Customer, not Customers), even
though they can have many members.

* Name Length: The IDEF1X methodology permits name lengths of up to 65 characters, which is more than
adequate for naming objects properly. However, most databases support maximum table and column name
lengths of only 18 or 30 characters. While you can enter longer names, the Validate Logical or Physical Models
function will check length violations before DDL generation.

« Case: When naming your objects, you have the choice of using upper, lower or mixed case. Perhaps the easiest
format for people to read and understand is mixed case, capitalizing the first letter of every word (for example,
CustomerAddress).

Logical Design Documentation

To ensure your ideas are understandable, document the meaning of your entities, relationships and attributes. A
well-documented data model is easier to maintain and will probably find greater use in your organization.

Provide a definition for each entity in the logical model, even when their meanings seem obvious. Sometimes, this can
reveal an incomplete design or logical inconsistencies. In addition to defining the entities, define all attributes in your
logical design. Detailed documentation is invaluable to database developers and administrators who need to
understand the design at its most basic level.

In addition to defining entities and attributes, you should also define the relationships in the logical model. Since
relationships are used to enforce business rules, it is especially important to document their meaning. Relationships
can be defined using verb phrases, names, and definitions. Verb phrases can clarify the business rules that govern
the interaction between a pair of entities, while a name and definition can provide additional details about the
relationship.

Normalization

Normalization helps eliminate redundancy and streamline your logical design. A normalized database design is
well-organized, even elegant. It is very important to complete the normalization process before transforming the
logical design to a physical design; doing so allows a more efficient implementation of the physical design on an actual
database.

Normalization is the process of separating data into multiple, related tables. A normalized database design is
characterized by multiple entities with relatively few attributes in each; an unnormalized design is characterized by few
entities with relatively many attributes in each. Normalizing the logical design helps eliminate certain types of
redundancy and incompleteness in the model.

Part of the normalization procedure entails moving certain sets of repeating data from one entity to its own entity, then
creating a relationship between the two. For example, consider the development of a data model for a university to
store information about alumni. One entity can hold information about alumni, like their names, degrees they've
earned, and the year they graduated. If some alumni have earned more than one degree from the university, then
degree information becomes a set of repeating data. In the normalization process, the degree information is removed
from the entity and placed in a separate entity. Next, a relationship is created between the first entity and the new
entity so that information in each entity is associated with information in the other.



While working with logical data models, a data modeler should understand the rules (or forms) of normalization to
produce a good data model.

The following defines the normalization forms:

« Eliminate Repeating Groups (1NF): A separate table exists for each set of related attributes and each table has
a primary key.

« Eliminate Redundant Data (2NF): Attributes depending on only part of a multi-valued key is removed it to a
separate table.

¢ Eliminate Columns Not Dependent On Key (3NF): Attributes not contributing to a description of the key, are
removed to a separate table.

¢ BCNF. Boyce-Codd Normal Form (BCNF): Non-trivial dependencies between candidate key attributes are
separated out into distinct tables.

« Isolate Independent Multiple Relationships (4NF): No table contains two or more 1:n or n:m relationships that
are not directly related.

« Isolate Semantically Related Multiple Relationships (5NF): There may be practical constraints on information
that justify separating logically related many-to-many relationships.

« Isolate Semantically Related Multiple Relationships (ONF): A model limited to only simple (elemental) facts,
as expressed in Object Role Model notation.

e Domain-Key Normal Form (DKNF): A model free from all modification anomalies.

NOTE: All normal forms are additive, so if a model is in 3rd normal form, it is also in 2nd and 1st normal
form.

Creating and Editing Entities and Tables

Entities are logical model objects and represent real objects, such as people, places or things, that are relevant to your
enterprise. Entities store data about particular objects that users can query or modify. In their physical implementation,
entities become tables, which are the focal point of any database.

The table is the basic unit of a physical data model. ER/Studio facilitates the smooth conversion of databases into
physical models for deployment on an SQL database platform. You can populate your data model with tables by
importing or reverse-engineering an existing database, generating a new physical model from a logical model, or by
adding individual tables as needed. You can make changes to a table at any time using the Table Editor. You can also
edit table Columns and Indexes using the Column Editor and Index Editor. respectively.

Because the entity and table are so closely related, the options available in their editors are often common to both
objects.

This section is comprised of the following topics:

¢ Creating and Editing Entities and Attributes

¢ Creating and Editing Attributes and Columns

Creating and Editing Entities and Attributes

Entities are the starting point for a data model. The relevant properties or characteristics of an entity are represented
by attributes. Entities are basically an aggregation of attributes, and therefore we recommend that you are clear on the
scope and purpose of each entity before worrying about its attributes. Once you have thought carefully about an
entity's purpose, then its attributes should become apparent.



Supertypes and subtypes are one of the more advanced topics in entity-relationship modeling. For more information,
see Creating Subtype Cluster Relationships.

ER/Studio represents entities in the Diagram Window as boxes. In the default display mode, entity names appear
above the entity boxes with the primary key and non-key attributes showing inside the entity box, separated by a line.

ER/Studio entity boxes have either square or rounded corners. Entity boxes with square corners are independent
entities and those with rounded corners are dependent entities. In IDEF1X, an entity becomes dependent when it
becomes the child entity in any identifying relationship. Based on this simple rule, ER/Studio automatically maintains
entity type. An entity is always created as an independent entity because it starts with no relationships attached to it.
An entity remains independent until it becomes a child in any identifying relationship.

Independent Entity
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1 To create a new entity, in the Diagram Explorer, expand the Logical Main Model, right-click the Entities node,
and then click New Entity.

To define or edit entity details, double-click the entity to launch the Entity Editor.
2 Define the entity as required and then click OK.
The following describes options that are not self-explanatory:
Attributes tab

Add, edit, or delete attributes. You can also change the list order of the attributes, which changes their
corresponding column placement in the entity's table. You can also add an attribute to the primary key for the
entity. The tabs at the bottom of the Attributes tab apply only to the attribute selected. For more information, see
Creating and Editing Attributes and Columns.

Keys tab

Add, edit, or delete alternate keys and inversion entries. Provides access to the Key Editor. For more
information, see Creating and Editing Keys.

Relationships tab

View any Relationships, if any, that exist between the entity and any other entities. Information included about
the relationships include the relationship type and the Foreign Keys. On this tab, you can double-click a related
table to open the table editor for that table. For more information, see Creating and Editing Relationships.

Definition tab

Enter or edit a definition for the entity. If the target database supports it, ER/Studio adds this definition as an
entity comment when generating SQL code.

Note tab

The notes added here are included as part of the HTML report when you generate a report for the model. You
can format the notes using standard HTML tags.



Where Used tab
Shows which logical and physical models and submodels implement the entity or table.
User-Defined Mappings tab

Shows any existing user-defined mappings (UDM) for this entity. UDMs tie data together that can be
conceptually related but not necessarily with concrete transactional relationships. UDMs are not used when
comparing data models or when generating SQL. Use the Note tab to describe the relationship between entities
that is created using user-defined mappings. For more information, see Associate Similar Objects Using

User-Defined Mappings.

Constraints tab

Add, modify, or delete a constraint. Check constraints are used to ensure the validity of data in a database and to
provide data integrity. For more information, see Enforcing Data Integrity Using Check Constraints.

Permissions tab

Sets access roles and user permissions for the entity. Keep in mind that the more specific permissions are, the
more time you may have to spend maintaining and updating them. The Roles and Users must be previously
assigned to appear in the Entity Editor. For more information, see Creating and Editing Database Roles and
Creating and Editing Database Users. For more information, see Granting and Revoking Permissions to Modify
Database Objects.

Naming Standards tab

Controls User and Object Permissions to modify the affected item. When a Naming Standards Template is
bound to an object, then that template is used instead of the Naming Standards Template selected in the
Naming Standards Utility or the Generate Physical Model utility. This allows you to apply different naming
standards to different objects when portions of a model require different versions of a standard. For example,
some objects already exist in the database and you do not want to apply a newer naming standard to them. For
more information, see Enforce Naming Standards Using Naming Standards Templates.

Data Lineage tab

Maps the flow of data from source to target entities and attributes in the model. The Data Lineage tab appears in
the entity and table editors. At the attribute level, you can add transformation logic for source/target attribute
mapping. For more information, see Data Lineage Workflow.

Security Information tab

Displays the current security information as defined in the Data Dictionary. You can add or edit security reporting
information in by double-clicking the field you want to change. To set the model-wide default value for a property,
go to the Data Dictionary tab and expand the Data Security Information Node. For more information, see
Enforcing Security Using Data Security Types and Properties.

Attachment Bindings tab

Lets you bind an external piece of information, or attachment to the entity. You can also remove an attachment
from an object, override an attachment binding’s default value, or change a bound attachment'’s position. To
override the value of the attachment you have moved to the Selected Attachments grid, double-click the Value
field of the target attachment. ER/Studio opens the Value Override Editor or a list depending on the attachment
datatype. Attachments are created in the Attachments folder of the Data Dictionary and must be applied to the
entity before they will display on this tab. For more information, see Attaching External Documents to the Data
Model.

Notes

« When you create an entity, it automatically appears as an independent entity with square corners. As
relationships are drawn associating the entity with others, ER/Studio automatically maintains its status as an
independent or dependent entity.



* You can name entities as you add them by using on-screen editing. Either type a name for an entity immediately
after adding it to the diagram, or press the SHIFT key, click the default entity name to enable the entity name
field, and then type a name. Click the diagram background to save the name and deactivate on-screen editing.
For information on entity naming rules and conventions, see Best Practices.

« The status bar at the bottom right of the application window displays the number of entities in the selected model.

* You can specify haming rules, such as maximum length, case, and synchronization level between entities and
tables on the Logical and Name Handling tabs of the Options Editor, which you can access by clicking Tools >
Options > Logical.

* You can specify the display order of the attributes and primary keys of any entity on the Display tab of the Options
Editor, which you can access by clicking Tools > Options > Logical.

* You can customize the information that pops up when you hover the mouse over an entity by selecting an option
from the list that appears when you select View > Cursor Popup Help Options > Entity Help.

« By default, ER/Studio automatically fits entities and views to display all content selected. However, you can
resize any entity to any size by selecting the entity and then dragging the size handles. You can make global
changes to how entities display by right-clicking the model, and selecting Diagram and Object Display Options.
Then you can choose the display options desired in the Entity and View tabs of the Diagram and Object Display
Options editor.

« For information on arranging entities in the Diagram Window, see Changing Data Model Layout.

« For information on changing the colors of entities, see Overriding Color and Font Settings for a Specific Object.

Creating and Editing Tables

The table is the basic unit of a physical data model. ER/Studio facilitates the smooth conversion of databases into
physical models for deployment on an SQL database platform. You can populate your data model with tables by
importing or reverse-engineering an existing database, generating a new physical model from a logical model, or by
adding individual tables as needed. You can make changes to a table at any time using the Table Editor. You can also
edit table Columns and Indexes using the Column Editor and Index Editor. respectively.

ER/Studio lets you add as many tables to your physical model as you need. When you add a table to the diagram, it
creates as an independent table with square corners in the Diagram Explorer. You can create relationships between
tables and create views as needed. As you draw relationships and foreign Keys, associating the table with others,
ER/Studio automatically maintains the table status as an independent or dependent (child).

Create a Table
1 Inthe Diagram Explorer, expand a Physical model or submodel.

2 From the Data Modeling toolbar, click the Table tool, position the cursor over the desired location in the
Diagram Window, and then left-click.

Right-click to revert to the Selection tool.

3 To define table details, double-click the table to launch the Table Editor.
4 Define the table as required and then click OK.
The following describes options that are not self-explanatory:
Columns tab

Add, edit, or delete columns. You can also change the order of the columns in the list which changes their
corresponding column placement in the entity's table. You can also add an column to the primary key for the
table. The tabs at the bottom of the Columns tab apply only to the column selected and are the same as those
available for the Attributes tab in the Entity Editor. For more information, see Creating and Editing Columns.




Dimensional tab

This tab is available for Dimensional Models only. Lets you set the dimensional type of the table and the data
type.

« Override Automatic Designhation—If selected, the table’s type will not be changed when the Automatic Table
Type Ildentification process is run on a related table.

* Run Automatic Table Type Identification—If selected, when you change the Dimensional Model Table Type
and then click OK to close the Table Editor, ER/Studio automatically changes the type of other tables to reflect
the change, using the same logic as it does when creating a new dimensional model from a logical model. For
example, if you change a table’s type from Dimension to Fact, its parent’s type can change from Snowflake to
Dimension.

DDL tab

Displays the DDL to create the table. The DDL shown here includes code to reproduce the table including all its
properties, as defined on the tabs of the Table Editor. You can edit the code if you like. You can customize the
DDL that appears to include only include the options you want. For more information, see Customizing Table
DDL.

Indexes tab
Add, edit, or delete indexes. Provides access to the Index Editor. For more information, see Creating Indexes.
Foreign Keys tab

View any relationships that exist between the selected table and other tables in the model. Information included
about the relationships include the relationship type and the Foreign Keys. For more information, see Creating

and Editing Keys.
Definition tab

Enter or edit a definition for the table. If the target database supports it, ER/Studio adds this definition as a table
comment when generating SQL code.

Note tab

The notes added here are included as part of the HTML report when you generate a report for the model. You
can format the notes using standard HTML tags.

Where Used tab
Shows which logical and physical models and submodels implement the table.
User-Defined Mappings tab

Shows any user-defined mappings (UDM) for this table. UDMs tie data together that can be conceptually related
but not necessarily with concrete transactional relationships. UDMs are not used when comparing data models
or when generating SQL. Use the Note tab to describe the relationship between entities that is created using

user-defined mappings. For more information, see Associate Similar Objects Using User-Defined Mappings.
Storage tab

Lets you select various storage options depending upon the selected database platform. For more information,
see Defining Table Storage.



Properties tab
Select the table type storage engine you want. This tab is available only for MySQL.
* HEAP: Also know as Memory. Provides in-memory tables. Handles non-transactional tables.
* INNODB: Provides transaction-safe tables.

« MYISAM: Manages non-transactional tables. Provides high-speed storage and retrieval, as well as full text
searching capabilities.

Storage tab

Lets you select various storage options dependant on the selected database. For more information, see Defining
Table Storage.

Partition Columns tab

Lets you select partitioning options dependant on the selected database. For more information, see Table
Partition Columns for IBM DB2 for OS/390 5.x, 6.x, 7.X, and 8.x.

Partitions tab

Lets you select the columns to include in a partition and reorder the selections. Provides access to the Partitions
Editor. For more information, see Partitioning a Table.

Overflow tab

Lets you specify how to store the overflow records when a row is updated and no longer fits on the page where it
was originally written. For more information, see Define Table Overflow Options.

Constraints tab

Add, modify, or delete a constraint. Check constraints can ensure the validity of data in a database and provide
data integrity. For more information, see Enforcing Data Integrity Using Check Constraints.

Dependencies tab

Add, modify, or delete dependencies that are bound to the table. These dependencies must be met before the
data can be loaded into the table. Dependencies are SQL code such as functions, triggers, and procedures. For
more information, see Creating and Editing Functions, Creating and Editing Triggers, and Creating and Editing
Procedures.

Capacity Panning tab

Assists in planning the space required to accommodate database growth. For more information, see Planning for
and Predicting Database Growth.

Permissions tab

Sets access roles and user permissions for the table. Keep in mind that the more specific permissions are, the
more time you may have to spend maintaining and updating them. The Roles and Users must be previously
assigned to appear in the View Editor. For more information, see Creating and Editing Database Roles and
Creating and Editing Database Users.

PreSQL & Post SQL tab

Lets you enter SQL to be applied before or after the CREATE OBJECT statement. The PreSQL and PostSQL
scripts entered here are included in the script when you generate the physical database.



Naming Standards tab

Controls User and Object Permissions to modify the affected item. When a Naming Standards Template is
bound to an object, then that template is used instead of the Naming Standards Template selected in the
Naming Standards Utility or the Generate Physical Model utility. This allows you to apply different naming
standards to different objects when portions of a model require different versions of a standard. For example,
some objects already exist in the database and you do not want to apply a newer naming standard to them. For
more information, see Enforce Naming Standards Using Naming Standards Templates.

Compare Options tab
Select the differences you want the Compare and Merge Utility to ignore.
Data Lineage tab

Maps the rules that describe data movement between source data and target entities and attributes in the model.
The Data Lineage tabs appear in the physical and logical models. At the attribute level, you can add
transformation logic for source/target attribute mapping. For more information, see Documenting Data
Extraction, Transformation. and Load.

Security Information tab

Displays the current security information as defined in the Data Dictionary. You can add or edit security reporting
information in by double-clicking the field you want to change. To set the model-wide default value for a property,
go to the Data Dictionary tab and expand the Data Security Information Node. For more information, see
Enforcing Security Using Data Security Types and Properties.

Attachment Bindings tab

Lets you bind an external piece of information, or attachment to the table. You can also remove an attachment
from an object, override an attachment binding’s default value, or change a bound attachment’s position. To
override the value of the attachment you have moved to the Selected Attachments grid, double-click the Value
field of the target attachment. ER/Studio opens the Value Override Editor or a list depending on the attachment
datatype. Attachments are created in the Attachments folder of the Data Dictionary and must be applied to the
table before they will display on this tab. For more information, see Attaching External Documents to the Data
Model.

Notes

* A new a table automatically appears as an independent table with square corners. As relationships are drawn
associating the table with others, ER/Studio automatically maintains its status as an independent or dependent
table.

¢ You can name tables as you add them by using on-screen editing. Either type a name for a table immediately
after adding it to the diagram, or press the SHIFT key, click the default table name and then type a name. Click
the diagram background to save the name and deactivate on-screen editing. For information on table naming
rules and conventions, see Best Practices.

¢ The status bar at the bottom right of the application window displays the number of entities in the selected model.

« Specify naming rules, such as maximum length, case, and synchronization level between entities and tables on
the Logical and Name Handling tabs of the Options Editor, which you can access by clicking Tools > Options >
Logical.

« Specify the display order of the attributes and primary keys of any entity on the Display tab of the Options Editor,
which you can access by clicking Tools > Options > Logical.

« You can customize the information that pops up when you hover the mouse over an entity by selecting an option
from the list that appears when you click View > Cursor Popup Help Options > Entity Help.



« By default, ER/Studio automatically fits entities and views to display all content selected. However, you can
resize any entity to any size by selecting the entity and then dragging the size handles. You can make global
changes to how entities display by right-clicking the model, and selecting Diagram and Object Display Options.
Then you can choose the display options desired in the Entity and View tabs of the Diagram and Object Display
Options editor.

« For information on arranging tables in the Diagram Window, see Changing Data Model Layout.
« For information on changing the colors of tables, see Overriding Color and Font Settings for a Specific Object.

Creating and Editing Attributes and Columns

Attributes represent the relevant properties or characteristics of an entity. In the physical model, attributes are
represented as table columns.

This section is comprised of the following topics:

« Creating and Editing Attributes
* Creating and Editing Columns

Creating and Editing Attributes
There are two types of attributes:

« Identifiers—Helps to identify an entity instance because it is all or part of the entity's primary key.

« Descriptor—A non-key attribute. Following the rules of normalization, if an attribute is not part of the primary key,
then its only purpose is to describe each entity instance.

Attribute definitions together with relationships can determine or enforce business rules. You can define a particular
set of valid values for any attribute of any entity. For example, you can define a valid range of salaries for a subset of
employees for an attribute called Salary. This set of values is known as a domain. For more information, see Ensuring
Consistent Domain Definitions Using User Datatypes.

If you define your entities carefully, then defining attributes should be relatively straightforward. When you first add
attributes to an entity, be sure to name your attributes appropriately. Attributes can be native to an entity or inherited
via an identifying or non-identifying relationship. To promote consistency, ER/Studio only lets you edit the properties of
an entity’s native attributes. To change the properties of a foreign key of a child entity, you must edit the attribute in the
parent entity. For information on attribute naming rules and conventions, see Best Practices.

1 Inthe Diagram Explorer, expand the Logical Main Model, right-click the Entities node, and then select the
entity to which you want to add attributes.

2 Onthe Attributes tab of the Entity Editor, click Add.
3 Define the attribute as required and then click OK.
The following describes options that are not self-explanatory:

« Domain Name: Lists all defined domains. You can bind any available domains to the attribute. To change the
domain name, you must first select Override Bound Data on the Datatype tab.

« Create Domain: Lets you create a new domain that is automatically added to the Data Dictionary. Enter a new
Domain Name and then select Create Domain. When you click OK to save the changes, the new domain is
created in the Data Dictionary.

¢ Default Column Name: The column name is by default the attribute name. If you want a different column name,
type a new one in the box. ER/Studio uses this name when generating the physical model.



« Logical Rolename: This option is only available when there is an overlapping foreign key in a logical model and
the Synchronize Column Rolename with Logical Rolename option is not selected. Use this when the name of the
child attribute differs from the parent attribute. In the logical model, ER/Studio distinguishes between the logical
rolename and the column rolename. ER/Studio uses the column rolename when generating the physical model.

« Hide Key Attribute: If selected, hides the key in the child entity. Commonly used to support partial migration of
PK columns when you don’t want to migrate primary key columns into child tables. ER/Studio will not generate a
foreign key because most database systems require that FKs have the same number of columns as the child. By
selecting this option, you will “remove” the column from the child table so that it won’t show up in any child tables
further down the FK chain, DDL generations or comparisons to the database. It will display as unavailable when
editing the child table, but you can make it available again later.

« Logical Only: If selected, the entity will not be implemented as a table when generating a physical model, and
will be ignored when comparing the logical model with a physical model.

* Synchronize Column Rolename with Logical Rolename Available when the attribute selected is a foreign key.
This option affects name modification in the entity or table editor, on-screen name editing, and name modification
in the Diagram Explorer. Lets you change the role names of foreign attributes or columns to the same names as
other attributes or columns in the same entity or table. Duplicates will be unified when the user ends the edit
session.

« Edit Foreign Key Datatype: When selected for a child object, you can edit the Datatype values of the foreign
key. When this option is selected, changes made to this relationship in the parent are not propagated to the child
until you deselect this option. This preserves the foreign key overrides.

Datatype tab

« Override Bound Data: Overrides datatypes on an attribute basis (for supported types: SQL Server, Sybase, IBM
DB2 for LUW, and IBM DB2 for 0S/390). Used to handle any exceptions while maintaining the binding to the
same domain. For example, there is a VARCHAR domain on two separate DBMS platforms. The character
domain’s primary use can be on Oracle. You specified it as VARCHAR (which will be VARCHAR2 in Oracle).
Using this option, you can have a DB2 model where it is implemented it as CHAR. You can customize the
domain’s implementation to accommodate the specific platform, without losing the bindings between DB2
columns and the domain.

« ldentity Properties: For numeric datatypes for which nulls are not allowed and for whose datatype supports
identity properties, you can specify identity properties by selecting the Identity Column option and then specifying
a seed and increment value. The seed and increment values are used to automatically generate sequential
numbers for each row in the table beginning with the Seed value and incrementing by the amount specified by
Increment. The default seed and increment values are one but may be changed.

Default tab

If a default value has not already been bound to the entity attribute (Data Dictionary > Defaults > Edit Default
Definition > Binding Information), you can type a Declarative Default or select Override Bound Data and then
choose another value from the Default Binding list. The declarative default will appear in the SQL produced
when you select Generate Database from the physical model. If a default value attribute has been previously
bound to the entity, you can override the default by selecting another default from the Default Binding list. For
more information, see Working with the Data Dictionary. If the attribute selected is a primary key of the entity,
you have the option to select the option to Propagate Default to Child Keys.

Rule/Constraint tab

Lets you select a rule binding from the Data Dictionary or manually type in a rule binding. The exact text in the
declarative box gets inserted into the physical model DDL. Add, modify, or delete a constraint. Check constraints
are used to ensure the validity of data in a database and to provide data integrity. For more information, see
Enforcing Data Integrity Using Check Constraints. If the information is grayed out (read-only) it is because a
domain is being used and the definition, datatype, rule, constraint or default is inherited from the domain.

Reference Values tab

For information, see Defining Valid Attribute Data Using Reference Values.




Definition tab

Enter or edit a definition for the attribute. If the target database supports it, ER/Studio adds this definition as an
attribute comment when generating SQL code.

Notes tab

The notes added here are included as part of the HTML report when you generate a report for the model. You
can format the notes using standard HTML tags.

Where Used tab
Shows which logical and physical models and submodels implement the attribute.
User-Defined Mappings tab

Shows any existing user-defined mappings (UDM) for this attribute. UDMs tie data together that can be
conceptually related but not necessarily with concrete transactional relationships. UDMs are not used when
comparing data models or when generating SQL. Use the Notes tab to describe the relationship between entities
that is created using user-defined mappings. For more information, see Associate Similar Objects Using
User-Defined Mappings.

Naming Standards tab

Controls User and Object Permissions to modify the attribute. When a Naming Standards Template is bound to
an object, then that template is used instead of the Naming Standards Template selected in the Naming
Standards Utility or the Generate Physical Model utility. This allows you to apply different naming standards to
different objects when portions of a model require different versions of a standard. For example, some objects
already exist in the database and you do not want to apply a newer naming standard to them. For more

information, see Enforce Naming Standards Using Naming Standards Templates.

Data Lineage tab

Maps the rules from source to target entities and attributes in the model. At the attribute level, you can add
transformation logic for source/target attribute mapping. You can map multiple source/targets to one attribute in
the physical model.

Security Information tab

Displays the current security information as defined in the Data Dictionary. You can add or edit security reporting
information in by double-clicking the field you want to change. To set the model-wide default value for a property,
go to the Data Dictionary tab and expand the Data Security Information Node. For more information, see

Enforcing Security Using Data Security Types and Properties.
Attachment Bindings tab

Lets you bind an external piece of information, or attachment to the attribute. You can also remove an
attachment from an object, override an attachment binding’s default value, or change a bound attachment’s
position. To override the value of the attachment you have moved to the Selected Attachments grid, double-click
the Value field of the target attachment. ER/Studio opens the Value Override Editor or a list depending on the
attachment datatype. Attachments are created in the Attachments folder of the Data Dictionary and must be
applied to the attribute before they will display on this tab. For more information, see Attaching External
Documents to the Data Model.

Notes

« Choosing the correct datatype is a critical data integrity and storage consideration. Select a datatype that is
efficient for its intended use but properly accommodates the data it stores. Your choice of database platform
dictates your choice of column datatypes because each has its own set of datatypes. For example, some
databases have binary datatypes; others do not. Some provide support for blobs and text, but many do not.
Finally, only a few databases support user-defined datatypes. ER/Studio can convert datatypes between different
databases; however, some conversions can only be approximations.



« Another important consideration in specifying datatypes is determining the appropriate width, precision and
scale, as applicable. You want to store data efficiently, but not at the expense of completeness, accuracy or
precision.

« For information on datatype mapping, see Customizing Datatype Mappings. If you want to enforce datatypes
across common columns, use Data Dictionary Domains. For more information, see Reusing Attribute Definitions

Using Domains.

* When determining attribute and column names, make sure you consider the naming rules of the target database.
Some key considerations are name length, avoiding the use of reserved words, and prohibited characters. Most
databases restrict name lengths to 30 or 18 characters. All have reserved key words that cannot be used in
names unless surrounded by quotes. Certain characters, such as a space, *, +, and % are also prohibited from
being used in names.

* You can specify nhaming rules, the default datatype and whether NULL values are permitted for the attributes
created with the default datatype on the Logical tab of the Options Editor by clicking Tools > Options > Logical.

* You can specify the order in which the attributes appear on the Display tab of the Options Editor by clicking Tools
> Options > Display.

* You can specify the level of synchronization between the attribute and column names, click Tools > Options >
Name Handling.

¢ The status bar at the bottom right of the application window displays the number of entities in the selected model.

Creating and Editing Columns

Attributes represent the relevant properties or characteristics of an entity. In the physical model, attributes are
represented as table columns. There are two types of attributes and tables:

« lIdentifiers—Helps to identify a entity/table instance because it is all or part of the entity's/table’s primary key.

« Descriptor—A non-key attribute/column. Following the rules of normalization, if an attribute/column is not part of
the primary key, then its only purpose is to describe each entity instance.

Attribute definitions together with relationships can determine or enforce business rules. You can define a particular
set of valid values for any attribute of any entity. For example, you can define a valid range of salaries for a subset of
employees for an attribute called Salary. This set of values is known as a domain. For more information, see Ensuring

Consistent Domain Definitions Using User Datatypes.

If you define your entities carefully, then defining attributes should be relatively straightforward. When you first add
attributes to an entity, be sure to name your attributes appropriately. Attributes can be native to an entity or inherited
via an identifying or non-identifying relationship. To promote consistency, ER/Studio only lets you edit the properties of
an entity’s native attributes. To change the properties of a foreign key of a child entity, you must edit the attribute in the
parent entity. For information on attribute naming rules and conventions, see Best Practices.

When determining column names, make sure you consider the naming rules of the target database. Some key
considerations are name length, avoiding the use of reserved words, and prohibited characters. Most databases
restrict name lengths to 30 or 18 characters. All have reserved key words that cannot be used in names unless
surrounded by quotes. Certain characters, such as a space, *, +, and % are also prohibited from being used in names.

Add a Column
1 Inthe Data Modeling Window, double-click the table to which you want to add column.

2 Onthe Column tab of the Table Editor, click Add.
3 Define the attribute as required and then click OK.
The following describes options that are not self-explanatory:

« Domain Name: Lists all defined domains. You can bind any available domains to the column.



Attribute Name: The attribute name is by default the column name. If you want a different column name, type a
new one in the box. ER/Studio uses this name when generating the physical model.

Default Column Name: The attribute name is by default the column name. If you want a different column name,
type a new one in the box. ER/Studio uses this name when generating the physical model.

Logical Rolename: This option is only available when there is an overlapping foreign key in a logical model and
the Synchronize Column Rolename with Logical Rolename option is not selected. Use this when the name of the
child attribute differs from the parent attribute. In the logical model, ER/Studio distinguishes between the logical

rolename and the column rolename. ER/Studio uses the column rolename when generating the physical model.

Hide Key Attribute: If selected, hides the key in the child entity. Commonly used to support partial migration of
PK columns when you don’t want to migrate primary key columns into child tables. ER/Studio will not generate a
foreign key because most database systems require that FKs have the same number of columns as the child. By
selecting this option, you will “remove” the column from the child table so that it won’t show up in any child tables
further down the FK chain, in DDL generations or in comparisons to the database. It will display as unavailable
when editing the child table, but you can make it available again later.

Logical Only: If selected, the entity will not be implemented as a table when generating a physical model, and
will be ignored when comparing the logical model with a physical model.

Synchronize Column Rolename with Logical Rolename Available when the attribute selected is a foreign key.
This option affects name modification in the entity or table editor, on-screen name editing, and name modification
in the Diagram Explorer. Lets you change the role names of foreign attributes or columns to the same names as
other attributes or columns in the same entity or table. Duplicates will be unified when the user ends the edit
session.

Datatype tab

Override Bound Data: Overrides datatypes on an attribute basis (for supported types: SQL Server, Sybase, IBM
DB2 for LUW, and IBM DB2 for OS/390). Used to handle any exceptions while maintaining the binding to the
same domain. For example, there is a VARCHAR domain on two separate DBMS platforms. The character
domain’s primary use can be on Oracle. You specified it as VARCHAR (which will be VARCHAR2 in Oracle). Using
this option, you can have a DB2 model where it is implemented it as CHAR. You can customize the domain’s
implementation to accommodate the specific platform, without losing the bindings between DB2 columns and the
domain.

Identity Properties: For numeric datatypes for which nulls are not allowed and for whose datatype supports
identity properties, you can specify identity properties by selecting the Identity Column option and then specifying
a seed and increment value. The seed and increment values are used to automatically generate sequential
numbers for each row in the table beginning with the Seed value and incrementing by the amount specified by
Increment. The default seed and increment values are one but may be changed.

Edit LOB Segment: If the specified datatype of the column is BLOB, CLOB, or NCLOB, you can click Edit LOB
Segment option to define LOB storage. For more information, see Oracle LOB Segment Storage Options.

RowGuidCol: Lets you return the row global unique identifier column. When using the ROWGU IDCOL property to
define a globally unique identifier column, consider that a table may have only one ROWGUIDCOL column, and
that column must be defined using the unique identifier data type.

Computed Column: If selected you can enter a formula to transform the column; for example, sale commission
= 10% total sales.

Sparse: Specify sparse if the column may have many NULLS. Specifying sparse for such columns can improve
retrieval response. A sparse column is stored nulls don'’t take up any space; however, a sparse column with data
in it requires a little more space than usual. This option will be available only if the datatype selected supports the
sparse property.

Collate: Lets you specify collations for each character string. ER/Studio will use the COLLATE clause with the
CREATE TABLE or ALTER TABLE statement.



« For Bit Data: Lets you use binary SQL to specify a binary character array for character SQL types. IBM database
platforms support columns with binary data types by defining CHAR, VARCHAR, LONG VARCHAR, columns with the
FOR BIT DATA attribute.

« LOB Unit: If the datatype is BLOB, CLOB, or DBCLOB, lets you select the LOB Unit measurement. Specify K - for
Kilobytes, M for Megabytes or G for Gigabytes.

Default tab

« Default Binding: If a default value has not already been bound to the entity attribute (Data Dictionary > Defaults
> Edit Default Definition > Binding Information), you can type a Declarative Default or select Override Bound Data
and then choose another value from the Default Binding list. The declarative default will appear in the SQL
produced when you select Generate Database from the physical model. If a default value attribute has been
previously bound to the entity, you can override the default by selecting another default from the Default Binding
list. For more information, see Working with the Data Dictionary. If the attribute selected is a primary key of the
entity, you have the option to select the option to Propagate Default to Child Keys.

« Default Name: Specifies a name for a declarative default when a declarative default is specified below, or when
the Override Bound Data is selected.If you are using a bound default from the Data Dictionary, you cannot
specify a name for an inline default

« Declarative Default: Specifies the default column value when a value is not explicitly specified during an insert.
DEFAULT definitions can be applied to any columns except those defined as timestamp, or those with the
IDENTITY property. Only a constant value, such as a character string; a system function, such as
SYSTEM_USER(); a NULL; or a constraint name can be assigned to a DEFAULT.

Rules/Constraints: Lets you select a rule binding from the Data Dictionary or manually type in a rule binding.
The exact text in the declarative box gets inserted into the physical model DDL. Add, modify, or delete a
constraint. Check constraints are used to ensure the validity of data in a database and to provide data integrity.
For more information, see Enforcing Data Integrity Using Check Constraints. If the information is grayed out
(read-only) it is because a domain is being used and the definition, datatype, rule, constraint or default is
inherited from the domain.

Definition tab

Enter or edit a definition for the column. If the target database supports it, ER/Studio adds this definition as a
column comment when generating SQL code.

Notes tab

The notes added here are included as part of the HTML report when you generate a report for the model. You
can format the notes using standard HTML tags.

Where Used tab
Shows which logical and physical models and submodels implement the column or attribute.
User-Defined Mappings tab

Shows any user-defined mappings (UDM) for this table. UDMs tie data together that can be conceptually related
but not necessarily with concrete transactional relationships. UDMs are not used when comparing data models
or when generating SQL. Use the Notes tab to describe the relationship between entities that is created using
user-defined mappings. For more information, see Associate Similar Objects Using User-Defined Mappings.

Reference Values tab

Reference Values are attributes that define allowed data. They represent look-up table columns or code-value
ranges or a rule or constraint applied to columns. For more information, see Defining Valid Attribute Data Using
Reference Values.




Naming Standards tab

Controls User and Object Permissions to modify the affected item.When a Naming Standards Template is bound
to an object, then that template is used instead of the Naming Standards Template selected in the Naming
Standards Utility or the Generate Physical Model utility. This allows you to apply different naming standards to
different objects when portions of a model require different versions of a standard. For example, some objects
already exist in the database and you do not want to apply a newer naming standard to them. For more
information, see Enforce Naming Standards Using Naming Standards Templates.

Compare Options tab
Select the differences you want the Compare and Merge Utility to ignore.
LOB Storage tab

For HiIRDB only. If the column datatype specified on the Datatype tab is BLOB, this tab becomes available where
you can specify a large object storage location.

Data Lineage tab

Maps the rules that describe data movement from source data to target entities and attributes in the model. At
the attribute level, you add transformation logic for source/target attribute mapping. You can map multiple
source/targets to one attribute in the physical model. For more information, see Documenting Data Extraction,
Transformation, and Load.

Security Information tab

Displays the current security information as defined in the Data Dictionary. You can add or edit security reporting
information in by double-clicking the field you want to change. To set the model-wide default value for a property,
go to the Data Dictionary tab and expand the Data Security Information Node. For more information, see

Enforcing Security Using Data Security Types and Properties.
Attachment Bindings tab

Lets you bind an external piece of information, or attachment to the column. You can also remove an attachment
from an object, override an attachment binding’s default value, or change a bound attachment’s position. To
override the value of the attachment you have moved to the Selected Attachments grid, double-click the Value
field of the target attachment. ER/Studio opens the Value Override Editor or a list depending on the attachment
datatype. Attachments are created in the Attachments folder of the Data Dictionary and must be applied to the
column before they will display on this tab. For more information, see Attaching External Documents to the Data

Model.

Notes

« Choosing the correct datatype is a critical data integrity and storage consideration. Select a datatype that is
efficient for its intended use but properly accommodates the data it stores. Your choice of database platform
dictates your choice of column datatypes because each has its own set of datatypes. For example, some
databases have binary datatypes; others do not. Some provide support for blobs and text, but many do not.
Finally, only a few databases support user-defined datatypes. ER/Studio can convert datatypes between different
databases; however, some conversions can only be approximations.

« Another important consideration in specifying datatypes is determining the appropriate width, precision and
scale, as applicable. You want to store data efficiently, but not at the expense of completeness, accuracy or
precision.

¢ Forinformation on datatype mapping, see Customizing Datatype Mappings. If you want to enforce datatypes
across common columns, use Data Dictionary Domains. For more information, see Reusing Attribute Definitions

Using Domains.



* When determining attribute and column names, make sure you consider the naming rules of the target database.
Some key considerations are name length, avoiding the use of reserved words, and prohibited characters. Most
databases restrict name lengths to 30 or 18 characters. All have reserved key words that cannot be used in
names unless surrounded by quotes. Certain characters, such as a space, *, +, and % are also prohibited from
being used in names.

« You can specify naming rules, the default datatype and whether NULL values are permitted for the attributes
created with the default datatype on the Logical tab of the Options Editor. Select Tools > Options > Logical.

« You can specify the order in which the attributes appear on the Display tab of the Options Editor. Select Tools >
Options > Display.

« You can specify the level of synchronization between the attribute and column names on the Name Handling tab
of the Options Editor. Select Tools > Options > Name Handling.

« The status bar at the bottom right of the application window displays the number of entities in the selected model.

Creating and Editing Keys
The purpose of keys in a database is to enforce unique values in an entity and provide a means of sorting the tables to
access entity data faster.

In a relational database, there are four types of keys:

« Primary Key: A primary key or unique key is a candidate key to uniquely identify each row in a table. A primary
key comprises a single column or set of columns where no two distinct rows in a table can have the same value
(or combination of values) in those columns. Depending on its design, a table may have many unique keys but at
most one primary key. A unique key must uniquely identify all possible rows that exist in a table and not only the
currently existing rows, such as social security numbers. A primary key is a special case of a unique key in that
for unique keys the implicit NOT NULL constraint is not automatically enforced, while for primary keys it is. The
values in a unique key column may or may not be NULL. Unique keys as well as primary keys can be referenced
by foreign keys.

« Alternate Key: Alternate keys are non-unique keys in a database, such as name and date of birth in an employee
database.

< Inversion Entry: An attribute or set of attributes that does not uniquely identify every instance of an entity, but
which are frequently used for access. The database implementation of an inversion entry is a non unique index.

« Foreign Key: A primary key or non-key attribute that is inherited from another entity.

ER/Studio can reverse-engineer key definitions that are not primary key or unique constraints, from a database. You
can create primary, inversion, or alternate keys using the Key Editor, which is accessible from the Entity Editor.

For more information, see the following:

e Create a Primary Key

* Create an Alternate Key or Inversion Entry

¢ Create a Foreign Key/Relationship

Create a Primary Key

1 Inthe Diagram Explorer, expand the Logical Main Model, expand the Entities node, and then double-click the
entity to which you want to add keys.

2 To change an existing attribute to a primary key, in the Entity Editor, click an attribute you want to make a key
and then click Edit.

To create a primary key based on a new attribute, the Entity Editor, click Add and define the entity properties as
required.
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On the Attributes tab, click Add to Primary and then click OK and exit the Entity Editor.

Create an Alternate Key or Inversion Entry

1

In the Diagram Explorer, expand the Logical Main Model, right-click the Entities node, and then double-click
the entity to which you want to add keys.

To change the properties of an existing attribute, In the Entity Editor, click an attribute you want to make a key
and then click Edit.

To create an alternate key or inversion entry based on a new attribute, in the Entity Editor, click Add and define
the entity properties as required.

On the Keys tab, click Add.
In the Key Editor, type a name for the key and select the type of key you want to create.

From the list of Available Keys, which are all the attributes of the entity, double-click the attributes you want to
add to the key.

You can reorder the attributes by selecting an attribute and then pressing Up or Down until the
attribute is in the desired position within the list of Selected Keys.

Click OK to accept the attribute selections and then click OK again to affect the changes to the entity.

Attachment Bindings tab: Lets you bind an external piece of information, or attachment to the key. You can
also remove an attachment from an object, override an attachment binding’s default value, or change a bound
attachment’s position. To override the value of the attachment you have moved to the Selected Attachments
grid, double-click the Value field of the target attachment. ER/Studio opens the Value Override Editor or a list
depending on the attachment datatype. Attachments are created in the Attachments folder of the Data
Dictionary. For more information, see Attaching External Documents to the Data Model.

Notes

¢ You can prevent a key from being implemented when generating a physical model or SQL, by selecting Logical

Only on the Keys tab.

« To modify the properties of a foreign key attribute, you must alter the corresponding primary key column in the

originating parent table.

« To preserve domain consistency, ER/Studio only lets you change the column name of foreign keys. To modify

other properties of a foreign key column, you must alter the corresponding primary key column in the originating
parent table.

Create a Foreign Key/Relationship

Foreign keys are created when you establish relationships between entities. The primary key of the parent object
becomes the foreign key of the child object. Foreign keys are not displayed in the entity boxes in the Diagram Window
when using Filtered IE (No FKs) but are displayed using all other notation types. For more information, see Creating
Relationships.

Specify FK Attribute Name and Datatype

By default, the foreign keys inherit their names from the primary key of the parent object; however, you can choose to
provide another name for the foreign key using the Logical Rolename.

1
2

Double-click the entity you want to change.

Click the foreign key in the attributes list and then click Edit.



Enter a Logical Rolename and then select Synchronize Column Rolename with Logical Rolename.
Click Save.

The child now displays the logical rolename of the foreign key.

Similarly, you can specify a different datatype for the foreign key.

Double-click the entity and from the Entity Editor, select the foreign key from the attributes list and then click
Edit.

Select Edit Foreign Key Datatype and then make the necessary changes to the datatype.

Click Save.

Creating Relationships

Relationships help to enforce business rules and assertions in a data model. Relationships determine how data are
related between two entities and/or views. Relationships are implemented as foreign keys in the physical model. The
properties of these foreign keys dictate how referential integrity is enforced between tables through constraints and
triggers.

In addition to standard relationships ER/Studio lets you create recursive relationships, those where an object is related
to itself; duplicate relationships, where multiple relationships relate to the same objects; view relationships that relate
entities or tables to views, and subtype clusters that associate multiple homogenous entities (subtypes) to a supertype
entity.

For more information on creating relationships, see the following topics:

Creating and Editing Relationships

Creating and Editing Recursive Relationships

Creating View Relationships

Creating Subtype Cluster Relationships

Resolving Name Duplication in Parent and Child Entities (Unification)

Creating and Editing Relationships

1
2

On the Diagram Explorer, click the Data Model tab.

Click Insert > Relationship and then click the type of relationship you want to insert



3 Onthe Diagram Window, click the parent object and then click the child object.

« The Duplicate Attribute Editor displays If both the parent and child objects have the same column or attribute
names. Here you can resolve these conflicts by assigning rolenames to foreign keys.

« The Recursive Relationship editor displays when you create a recursive relationship, which is a non-identifying
relationship where the parent and child object are the same. Using this editor you can assign rolenames to any
duplicate keys to differentiate the native and foreign key. For more information, see Creating and Editing
Recursive Relationships.

¢ The Duplicate Relationship editor displays when you draw a relationship that will result in multiple identifying
and/or non-identifying relationships between two entities. Using this editor you can assign rolenames to any
overlapping foreign keys; otherwise, ER/Studio unifies any overlapping Foreign Keys.

« The Edit Rolenames dialog displays if overlapping foreign keys are detected when you are drawing a
relationship. On the Edit RoleNames dialog you can specify rolenames for foreign keys that are inherited more
than once. When a primary key is propagated to a child table, the name of the attribute is also propagated to
the child table. A rolename lets you rename the attribute of the foreign key to avoid confusion and resolve the
relationship conflict.

Repeat step 2 and step 3 and until you have created all necessary relationships.
To revert to the Selection tool, right-click anywhere on the Diagram Window.

On the Diagram Window, double-click the relationship
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Complete the Relationship Editor and then click OK to exit the editor.

The following describes options that are not self-explanatory. For general information that applies to the
Relationship Editor, see Notes.

« Parent Key: Lets you select and propagate an Alternate Key (logical model) or a Unique Index (physical model)
to a child entity or table. Use this option if you do not want to propagate the primary key. If there are no alternate
keys or unique indexes in the parent table the primary key will be used.

¢ Logical Only: Logical model only. If selected, the relationship will not be implemented when generating a
physical model, and will be ignored when comparing the logical model with a physical model.

« Physical Only: Physical model only. If selected, the relationship will be ignored when comparing the physical
model with a logical model.

* Do Not Generate: Physical model only. If selected, the foreign key (FK) columns (if any) will be ignored when
generating DDL, as in the Compare and Merge Utility. The FK constraint is not generated but the FK column is
generated as a native column. To prevent the FK from being generated, edit the FK column in the Table Editor
and select the Hide Key Attribute option. Use this option when relational integrity is enforced in the application
rather than by an explicit foreign key in the RDBMS.

« Not For Replication: If selected, updates to the parent will not be replicated to the child entity. This prevents any
foreign key constraints from being applied when updating the child entity.

« Deferrable: Physical model only.If selected, the DEFERRABLE syntax will appear in the FK DDL for inline (in the
create table) or ALTER (out of the create table). The DEFERRABLE statement becomes part of the constraint
state logic after the referencing clause.

In general, the DEFERRABLE parameter indicates whether constraint checking in subsequent transactions can
be deferred until the end of the transaction using the SET CONSTRAINT(S) statement. If omitted, the default is
NOT DEFERRABLE. If a constraint is deferrable in the model but not deferrable in the database it will need to be
dropped and recreated with the deferrable constraints. See Oracle syntax documentation for a description of
deferrable constraints.

Properties tab



Relationship Type > Identifying Relationships: Identifying relationships are always mandatory. A foreign key
value must exist in the child entity and the foreign key value must be found in the primary key of the parent.
Identifying relationships propagate primary keys as primary keys to child entities, which can result in compound
keys.

The use of compound keys is often valid and appropriate; however, they limit the flexibility of your data model.
When you use a compound key, the data contained in the child entity can only be identified in the context of its
parent. If you ever need to use the data independently, then you will have a problem.

The cardinality of a mandatory relationship must be in the form of one-to-something.

When generating a physical model, foreign key columns propagated by a mandatory relationship default to NOT
NULL.

Independent Entity
Aftribute MName

Dependent Entity
[-Attrihute Narrie (FK)
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Relationship Type > Non-Identifying, Optional Relationships: Non-identifying relationships propagate the
parent's primary key to the non-key attributes of the child. Since the relationship is optional the foreign key value
is not always required in the child entity; however, if a value does exist, then the foreign key value must be found
in the primary key of the parent.

The cardinality of an optional relationship takes the form of zero or one to something.

When generating a physical model, foreign key columns propagated by a optional relationship default to NOT
NULL.

Independent Entity
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Relationship Type > Non-Ildentifying, Mandatory Relationships: Non-identifying relationships propagate the
parent's primary key to the non-key attributes of the child. A foreign key value must exist in the child entity and
the foreign key value must be found in the primary key of the parent.

The cardinality of a mandatory relationship must be in the form of one to something.

When generating a physical model, foreign key columns propagated by a mandatory relationship default to NOT
NULL.

Independent Entity
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« Relationship Type > Non-Specific Relationships: Non-specific relationships denote many-to-many
relationships. Because many-to-many relationships cannot be resolved, non-specific relationships do not
propagate any foreign keys. Many-to-many relationships are undesirable and should be removed as you
normalize your data model.

The following illustrates a non-specific relationship where the parent and the child are both optional. In the
Relationship Editor you can specify whether the parent and the child are optional or mandatory.

Independent Entity
Aftribute Mame

Dependent Entity
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e Cardinality: Cardinality displays the ratio of related parent and child instances. The cardinality ratio for the parent
depends on whether the relationship is mandatory or optional. Although cardinality is a powerful concept for
expressing business rules, you should know that no database can directly enforce cardinality. Enforcing
cardinality constraints can be accomplished through procedural database logic or somewhere other than in the
database.

The iconic cardinality representations for IE (Crows Feet) notation are illustrated below:

Non-Ildentifying Relationship

Identifying Optional Mandatory

Relationship

One to Zero or More  Zero or One to Zero or More One to Zero or More
— = —r — e — - o=

One to One or More  Zero or One to One or More (P) One to One or More (P)

—t o--fe —+--k=

Fh

One to Zero or One  Zero or One to Zero or One (Z) One to Zero or One (Z)

i — - _|_ _

Z £z Z

One to Exactly: N Zero or One to Exactly: N One to Exactly: N
_|_ —_—r———— _|_ _____
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Phrases tab

« Verb Phrase: Describes the relationship of the Parent table to the Child table.

« Inverse Verb Phrase: Describes the relationship of the Child table to the Parent table.
Name tab

« Business Name: Identifies the relationship for business documentation purposes.



« Constraint Name: Names the referential constraint the relationship enforces between parent and child tables, if
any. ER/Studio uses this name as the foreign key constraint name when generating DDL.

Trigger tab

Select a trigger to maintain referential integrity for INSERT, UPDATE, and DELETE operations on child and parent
objects. Select one of the following triggers for each operation.

« Restrict: Verifies the existence of foreign key values in the object’s primary key and prevents the insertion,
updating, or deleting of data if the values cannot be validated.

« Cascade: Propagates any modification of a primary key value to the corresponding foreign key values in the child
table.

« Set Null: Verifies the existence of the foreign key values in the parent table’s primary key. If the values cannot be
validated, the trigger sets the foreign key values to null in the child table and lets the data modification operation
proceed.

For more information, see Creating and Editing Database Schemas.

Definition tab

Enter or edit a definition for the relationship. If the target database supports it, ER/Studio adds this definition as a
comment when generating SQL code.

Compare Options tab

Allows you to choose which properties of the attribute will be ignored when using the Compare and Merge, thus
allowing you to have intentional discrepancies.

Note tab

The notes added here are included as part of the HTML report when you generate a report for the model. You
can format the notes using standard HTML tags.

Rolename tab

You can change the rolename of foreign keys to differentiate between child and parent attributes in the event
that overlapping foreign keys exist. To change a rolename, double-click any of the rows to invoke the Foreign
Key dialog. You can also change logical and default column rolenames through the Columns tab of the Table
Editor or by right-clicking the relationship and selecting Edit RoleName.

Attachment Bindings tab

Lets you bind an external piece of information, or attachment to the relationship. You can also remove an
attachment from an object, override an attachment binding’s default value, or change a bound attachment'’s
position. To override the value of the attachment you have moved to the Selected Attachments grid, double-click
the Value field of the target attachment. ER/Studio opens the Value Override Editor or a list depending on the
attachment datatype. Attachments are created in the Attachments folder of the Data Dictionary and must be
applied to the relationship before they will display on this tab. For more information, see Attaching External
Documents to the Data Model.

Notes

* You can view the incoming and outgoing relationships of a table by expanding the relevant table node and then
expanding Incoming Relationships or Outgoing Relationships. Expand the relationship node to see the name of
the related table.

* You can change the relationship type, specify cardinality, create verb phrases to describe the relationship, create
a logical business and constraint name, and define triggers by double-clicking the relationship, and then making
your changes in the Relationship Editor.

* You can delete a relationship by right-clicking it in the Diagram Window and then selecting Delete Relationship.



* You can edit a relationship by right-clicking the relationship in the Diagram Window and then selecting Edit
Relationship for a logical model or Edit Foreign Key for a physical model.

¢ Changing relationship types causes ER/Studio to re-propagate foreign keys using the following rules:

* When changing from identifying to non-identifying, foreign keys change from primary keys to non-key columns
in the child object.

* When changing from identifying to non-specific, or from non-identifying to non-specific, the foreign keys are
removed from the child object.

« When changing from non-identifying to identifying, the foreign keys change from non-key to primary key
columns or attributes in the child object.

« When changing from non-specific to identifying, the child object inherits the parent object’s primary keys as
primary key columns or attributes.

* When changing from non-specific to non-identifying, the child object inherits the parent table’s primary keys as
non-key columns or attributes.

« You can configure how ER/Studio displays relationships for the selected model by clicking View > Diagram and
Object Display Options Editor > Relationship and then making your changes.

« You cannot edit a View Relationship (see Creating View Relationships).

See Also
Moving Relationship Docking Points

Setting the Relationship Notation

Manipulating Relationship Lines

Overriding Color and Font Settings for a Specific Object

Creating and Editing Relationships

Creating and Editing Recursive Relationships

A recursive relationship associates an object with itself; the object is both the parent and child. For example, you can
have an employee who manages many employees and each employee is managed by one employee. The employee
entity has a recursive relationship to itself.

If you have a recursive relationship, you must assign rolenames to the relationship. Use the Recursive Relationship
dialog to specify rolenames for a foreign key that is inherited more than once within the same entity. For example, if a
recursive relationship is created where one entity is designated as both the parent and child entity, then the primary
key is propagated within the entity. ER/Studio automatically opens the Recursive Relationship dialog box when it
detects overlapping foreign keys in an entity.

The steps for adding recursive relationships are slightly different from adding regular relationships; however, you can
for edit and delete recursive relationships in the same manner as for regular relationships.

1 Click Insert > Insert Relationship, and then select a non-identifying relationship type.

2 Onthe Diagram Window, click the object to which you want to apply the recursive relationship, and then click it
again.

3 Complete the Recursive Relationship or Recursive Relationship for Multiple Keys dialog box, and then click
OK.

4 Right click anywhere on the Data Model to revert to the Selection tool.



Notes

« If you have a recursive relationship, the Recursive Relationship editor appears where you must assign a
rolename to the primary key or to at least one attribute of the primary key. The rolename cannot be the same as
the attribute or column name. In order for the foreign key to appear in the child, it must be assigned a rolename
so it can be differentiated it from the native key.

« If you have a recursive relationship where multiple foreign keys that are inherited more than once within the same
entity, the Recursive Relationship for Multiple Keys dialog display where you specify rolenames for each foreign
keys. For example, if a recursive relationship is created, where one entity is designated as both the parent and
child entity, then the primary keys are propagated within the entity.

« Edit the rolenames associated with the relationship by right-clicking the relationship in the Diagram Window, and
then selecting Edit Rolenames.

« Navigate between the parent and child object by right-clicking the object and then selecting Navigate to Parent or
Navigate to Child from the shortcut menu.

Creating View Relationships

The steps to adding and deleting view relationships are the same as those of regular relationships. However, view
relationships are a special type of relationship used to propagate attributes from an entity or a view to a view. When
adding a view relationship, the end point of the relationship must be a view. View relationships cannot be edited, but
they can be deleted. To determine which attributes of an entity can be propagated from the parent entity or view to the
child view, use the View Editor - Column Tab.

NOTE: In order for view relationships to display, you must enable the options to display views and view
relationships on the View tab of the Diagram and Object Display Options dialog. Click View >
Diagram and Object Display Options.

See Also
Creating and Editing Data Base Views

Creating Subtype Cluster Relationships

NOTE: Subtype cluster relationships can only be represented in the logical model. When the physical
model is generated from a logical model, the subtype relationship is converted to identifying
relationship.

A subtype cluster refers to a group of entities sharing similar characteristics that form a generalization hierarchy. In
each subtype cluster, there is one parent entity, known as a supertype, and one or more subtype entities. The
supertype generalizes a set of subtypes; the common characteristics of subtype entities are assigned to the supertype
while the subtype entities have more specific attributes. The subtypes, also known as category entities, represent
homogeneous subsets of the supertype. The attributes and relationships of the supertype entity are propagated to all
of its subtypes. Discriminators, an attribute of the subtype, distinguish the entities in the subtype from each other.

Other than recognizing a generalization hierarchy, an important issue with subtyping is to decide how to implement a
subtype cluster in the physical model. Sometimes it is best to project subtypes into the supertype, representing the
entire cluster as a single, generalized entity. Other times, you may need the granularity of separate subtype entities,
choosing to implement the subtypes and supertype one-for-one or rolling the supertype down into the subtypes.

During the logical model phase, you should search for hierarchies that can reveal a more general approach to
aggregating attributes into entities. By addressing the general case, you can design a more flexible and extensible
approach to storing data. The use of subtyping is a powerful tool in identifying and portraying such generalizations.



Example

To illustrate the use of subtyping, let's take the example of the group of entities - Person, Customer, and Employee.
Each entity stores information about employees. Accordingly, Person is the supertype in this example and the
remaining entities can be grouped in a subtype. Any person contained in a subtype entity is also represented in
Person. In each entity, the primary key is the Name. Because each entity instance for the entities in the subtype are
also represented in the supertype, the relationships between the supertype entities and all subtype entities must be an
identifying relationship, that is the customer, engineer and writer must all be employees. The relationship between
Person, Customer, Employee, and Supplier is complete, because the business is concerned only with these types of
persons. The relationship between the Employee, Engineer, and Writer is an incomplete subtype because there can
be other employee types, such as quality assurance analysts.
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In this example, the Person entity is the supertype. All Person's have a name, address and telephone number. A
person may be either an Employee or a Customer. In addition to sharing name, address and telephone number
attributes, each of these subtypes has its unique attributes; for example, an Employee has a Profession; and a
Customer has a Credit Limit. An entity may be both a supertype and a subtype, as is the case with Employee, which
can be further divided into Engineer and Writer.

1 Click the Logical model.
2 Click Insert > Subtype Cluster and then choose Complete or Incomplete.

3 Click an entity to designate it as the parent (supertype) and then click the entity (subtype) you want to add to the
subtype cluster.

You can add multiple entities to the subtype cluster by pressing Ctrl while clicking the desired
entities.
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Right-click to revert to the Selection tool and then double-click the newly created subtype relationship indicator.
Complete the Subtype Cluster Editor as required and then click OK.

The following describes options that are not self-explanatory:

Subtype tab

Type: Select the subtype cluster type, Complete or Incomplete.

« Complete: A subtype cluster is complete when all possible subtype entities are included in the subtype cluster.
An example of a complete subtype cluster is one in which Person is the supertype and Male and Female are
the subtypes.

« Incomplete: Select if all possible subtype entities will not included be in the cluster. For example, a subtype
cluster is made up of several entities, Employee, StoreManager, SalesPerson and StockPerson, each of which
stores information about employees. In this example, Employee is the supertype and the remaining entities
can be grouped in a subtype. This is probably an incomplete subtype cluster because other employee types
may not be represented in the cluster, such as security guards and cashiers.

Membership Type: Select Inclusive or Exclusive subtype.

« Inclusive: Select if each supertype that has subtypes can be more than one subtype at a time. For example,
an EMPLOYEE and be both an ENGINEER and a WRITER.

« Exclusive: Select if each supertype that has subtypes can be only one subtype at a time. For example, a
PERSON cannot be both an EMPLOYEE and a CUSTOMER.
In IE notation, an exclusive subtype is represented with an exclusive OR symbol. The diagram and reports will
show the type of supertype/subtype cluster in the TYPE field depending on what you selected, Complete,
Inclusive; Complete, Exclusive; Incomplete, Inclusive; Incomplete, Exclusive.

Discriminator: Select a discriminator from the list.A discriminator is an attribute that distinguishes each of the
subtype entities from one another. A subtype discriminator can be a primary key or non-key attribute of the
supertype. After you define a discriminator, ER/Studio displays it next to its subtype cluster symbol.

Attachment Bindings tab: Lets you bind an external piece of information, or attachment to the domain. You can
also remove an attachment from an object, override an attachment binding’s default value, or change a bound
attachment’s position. To override the value of the attachment you have moved to the Selected Attachments
grid, double-click the Value field of the target attachment. ER/Studio opens the Value Override Editor or a list
depending on the attachment datatype. Attachments are created in the Attachments folder of the Data
Dictionary. For more information, see Attaching External Documents to the Data Model.

Notes

You can add an entity to a subtype cluster by clicking Insert > Relationship > Identifying, clicking the subtype
cluster symbol next to the supertype you want to associate the entity with, and then clicking the entity you want to
add to the subtype cluster.

You can edit the subtype by right-clicking the subtype cluster symbol and then selecting Edit Subtype Cluster.

You can change the colors of the subtype cluster symbol, by right-clicking it and then selecting Subtype Cluster
Color.

You can remove an entity from a subtype by selecting the relationship between the subtype and the entity and
then clicking Edit > Remove Relationship.

You can delete a subtype if you no longer want to include it in your data model. You can also add or remove
entities from a subtype cluster in much the same way you add or delete relationships between entities. Delete a
subtype by selecting the subtype and then selecting Edit > Delete Subtype Cluster. Deleting a subtype cluster
deletes all relationships between the parent entity (supertype) and the child entities (subtypes).

You must redefine the relationships between the entities after you delete a subtype.



While subtypes can be specified as complete or incomplete, you'll get a visual indication of it only in IDEF1X. To
see the distinction in IE (Crow’s feet) you can view it in the Subtype Cluster Editor, or use a naming convention or
color as a mnemonic.

IE is more flexible in supporting subtypes, permitting roll up (generalization) and roll down (specialization)
transformations.

Resolving Name Duplication in Parent and Child Entities (Unification)

The Duplicate Attribute Editor displays when you create or rename primary key attributes, relationships, or foreign
keys and it duplicates existing attributes, columns, or foreign keys in child tables or entities. For example, if you have
two entities called Parent and Child where Parent has a primary key called Key and Child also has an attribute called
Key, when you create a relationship from Parent to Child, then the Duplicate Native Attribute Editor launches where
you must decide how to handle the propagated attributes.

NOTE: Ifthe child entity has a foreign key with the same name as the parent entity, the Duplicate Attribute
Editor launches only if you have selected Prompt to Resolve FK Columns on the Application tab
of the Options editor. Select Tools > Options.

The option, Allow Unification when Editing Names on the Options Editor - Name Handling tab
allows you to change the role names of foreign attribute or columns to the same names as other
attributes or columns in the same Entity or Table.

Attribute Name Editing Options

The following describes the options and functionality on the Duplicate Attribute Editor:

Propagating Attributes to Resolve: Displays a list of the Attributes/Columns that are duplicates. Select the
propagating attribute that you want to resolve then select the way you want to propagate.

Replace Native Attribute with propagating Attribute: If selected, ER/Studio replaces the attribute in the child
with the propagated foreign key attribute. If the relationship is deleted from the main model, ER/Studio removes
the propagated attribute and original native attribute from the child entity.

Rolename propagating Attribute: If selected, you can rename the foreign key so that the native attribute in the
child entity can still exist with its original name. After propagation, both attributes will exist in the child entity.

Change Native Attribute Name to allow propagating Attribute Name: If selected, you can rename the original
native attribute in the child entity so that the attribute name from the parent entity can be used for the foreign key.
After propagation, both attributes will exist in the child entity.

Unify Native Attribute with propagating Attribute: If selected, ER/Studio unifies the propagating foreign with
the native attribute in the child table. If the relationship is later deleted, ER/Studio leaves the native child attribute.

Examples of Duplicate Name Resolutions

The following examples illustrate how duplicate names are resolved depending on the options chosen in the Duplicate
Attribute Editor dialog.
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Replace Native Attribute with propagating Attribute

If selected, ER/Studio replaces the attribute in the child with the propagated foreign key attribute. If the relationship is deleted
from the main model, ER/Studio removes the propagated attribute and original native attribute from the child entity.

Entityt Entity2
id

id (FK)

Rolename propagating Attribute

If selected, you can rename the foreign key so that the native attribute in the child entity can still exist with its original
name. After propagation, both attributes will exist in the child entity.

NOTE: To resolve the naming conflict, the rolename idrolename for the foreign key specified in the
Duplication Attribute Editor..

Entity1
id

] id
id_rolename (FE)

Change Native Attribute Name to allow propagating Attribute Name

If selected, you can rename the original native attribute in the child entity so that the attribute hame from the parent
entity can be used for the foreign key.

Entity2

NOTE: To resolve the FKNew child name specified is idchangenative.

Emtity1
id

Entity?

id_change_native
id (FK)




Unify Native Attribute with propagating Attribute
If selected, ER/Studio unifies the propagating foreign with the native attribute in the child table.

NOTE: ER/Studio keeps id in the child entity if you delete the relationship.

Entity1
d

Entity2

id (FK)

Validating the Model

The Model Validation wizard helps enforce your selected standards for data model objects and data dictionary usage.
Validating the model also eases the process of model correction and review. More than 50 checks validate either the
logical or physical model for problems such as missing object definitions, unused domains, identical unique indexes,
and circular relationships. You can choose which validation options to use and sort the report results found by the
wizard so that colleagues know exactly where to begin when correcting a model. You can also build validation
templates by using the Quicklaunch feature.

Validate the Model
1 Inthe Diagram Explorer, navigate to and then right-click the top-level of the model node.

2 Click Validate Logical Model (or Physical model) from the shortcut menu.

3 Inthe Model Validation Wizard, choose your validation rules and options as follows:
Validation Options tab: Select the validation rules you want enforced for modeling and for the Data Dictionary.
Object Selection tab: Select the objects to which the rules should be applied.

4 Click Run Validation.

5 Click the Output tab to view and sort the results, and then to export the results if desired.

Notes
¢ For information on using the Quick Launch feature, see Saving and Using Quick Launch Settings.

« If you have selected the SQL Validation option on the View tab of the Options Editor then whenever you update
the sql for a view, the validation dialog will appear to notify you of any syntax errors. Select Tools > Options >
View.

« If you select View SQL Alerts on the Repository tab of the Options Editor then when you check your models into
the Repository you'll be notified of any SQL problems. Select Tools > Options > Repository.

Customizing Datatype Mappings

When you create an entity attribute you assign it a datatype, which defines how the data is stored in the database
along with the length and precision. When you want to generate a physical model from the logical model, the datatype
of the logical attribute is translated into a physical Datatype. The target datatype used in the logical to physical
translation depends on the target platform and the datatype mapping. Physical datatypes are platform specific and
can differ depending on your DBMS platform. You can view the specific mappings for each supported platform in the
Datatype Mapping Editor. You can either use the default system mappings or create customized mappings.



Using the designated mapping, when generating a physical model ER/Studio knows if, for example, the logical CHAR
datatype should be converted into a string, C, or remain unchanged, and also the length and precision of the physical
datatype. ER/Studio supports many different database platforms and provides standard datatype mappings for each
platform. You can customize these standard datatype mappings to create new mappings that better suit your
purposes.

Use the Datatype Mapping Editor to customize the datatype mapping as you move your logical models to physical
models.

1 Select Tools > Datatype Mapping Editor.
2 Display the mapping for the target platform, by choosing a mapping from the Select Mapping list.
3 Click New, enter a name for the mapping, and then click OK.

4 Make the changes as required, and then click OK.

Notes
¢ In the Datatype Mapping Editor, you can change the Physical Mapping values for every logical datatype.

< In the Datatype Mapping Editor, you can change the Is Default, Default Length, and Default Precision values only
if you haven't defined a length, precision, or default for the datatype in the logical model.

* Rename a datatype by clicking Rename in the Datatype Mapping Editor.

« Customized datatype mappings are saved as .xml files in the . . .\ERStudio_X.X\DatatypeMapping
directory.

< In the Generate Physical Model Wizard, the list of datatype mappings that you can choose from is limited to the
system mapping for the physical platform and any customized mappings that were based on this system

mapping.
e Mappings are stored in ..\Embarcadero\ERStudio_X.X\DatatypeMapping.

Developing the Physical Model

In order to create a database, ensure you have the client software installed and are using the correct connection
strings. For more information, see Connecting to Database Sources and Targets.

If you don’t have the client connection software for the platform for which you want to create a database, you can
generate a physical model from the logical model (See Generating a Physical Data Model), and then change the
database platform to the target database. You can then access the Database Wizard to create the DDL required to
create the database.

Generally, a logical data model represents business information and defines business rules, and a physical data
model represents the physical implementation of the model in a database. The physical design addresses the
technical implementation of a data model, and shows how the data is stored in the database. For example, you can
specify the datatype of each column in the table, and determine how tables will be stored in the database.

To design the most effective data model possible, focus on the logical design before developing the physical design. A
physical data modeler should have the technical-know-how to create data models from existing databases and to tune
the data models with referential integrity, alternate keys, indexes and how to match indexes to SQL code. In systems

development, the goal is to create an effective database application that can support some or all of your enterprise.

The physical design focuses on performance and tuning issues for a particular database platform. A highly normalized
database design often results in performance problems, particularly with large data volumes and many concurrent
users. These problems are often due to complex query patterns, the cost of multi-table joins, and the high I/O intensity
of querying or modifying large tables. When addressing performance problems, you should consider the following
physical design issues:



« Transforming Model Objects from Logical to Physical: How the elements of a physical model correspond to the

elements of the corresponding logical model.

* Optimizing Query Performance on the Physical Model: How to modify the logical design to increase the efficiency

of database operations.

« Creating Indexes: How to create indexes to increase the efficiency of read operations (queries) without sacrificing
the efficiency of write operations (insert, update, delete).

« Physical Storage Considerations: How to determine the physical storage of the tables and indexes in the
database to maximize efficiency and allow for growth.

For information on physical data model objects in ER/Studio, see the following topics:

¢ Creating and Editing Entities and Tables

¢ Creating and Editing Attributes and Columns

¢ Customizing Table DDL

« Creating Indexes

« Defining Table Storage

« Creating/Editing Database Dependent Objects

Transforming Model Objects from Logical to Physical

Before considering physical design issues, it is important to understand how a physical design maps to its
corresponding logical design. When ER/Studio derives a physical design from a logical one, it transforms logical
model objects into their physical model analogs. The table below details how different logical objects are transformed
into physical objects. Understanding the transformation lets you better assess the impact of altering the physical
design to differ from the logical design.

The table below describes logical model objects and their corresponding physical model objects:

Logical Physical Model | Notes

Model Object | Object

Entity Table An entity translates directly into a table. In a dimensional model, tables are
automatically assigned types (fact, dimension, snowflake, or undefined) based on an
analysis of the schema.

Attribute Column An attribute translates directly into a table column.

View View Views translate directly between logical and physical models. However, some
database platforms offer additional properties that can be applied to physical view
definitions.

Relationship Foreign Key A relationship becomes a foreign key in the physical design. You can enforce
referential integrity through foreign key constraints or through triggers.

Primary Key Unique Index or | You can enforce primary keys with unique indexes or primary key constraints,

Primary Key
Constraint

depending on the database platform.

Alternate Key

Unique Index or

You can enforce alternate keys with unique indexes or unique constraints, depending

Unique on the database platform.

Constraint
Inversion Entry | Non-unique You can convert inversion entries into non-unique indexes.
Key Index




Logical Physical Model | Notes
Model Object | Object
Default Default or Data Dictionary defaults are converted to default objects for Sybase and Microsoft
Declared Default | SQL Server. Otherwise, they are converted to declared defaults, if supported by the
selected database platform.
Rule Rule, Check Data Dictionary rules are converted to rule objects for Sybase and Microsoft SQL
Constraint, Server. Otherwise, they are converted to check constraints, if supported by the
Default Value selected database platform.
Relationship Foreign Key
Definition Comment
User Datatype | User Datatype or | Data Dictionary datatypes are converted to user datatypes for Sybase and Microsoft
Base Datatype SQL Server. Otherwise, they are converted into their underlying base datatype
definitions.
Domain Column Domains are translated into the base column definition for each column that refers to
Definition a domain.

Physical Storage Considerations

Planning the storage of tables and indexes is best done during the physical design stage in order to improve
performance and to streamline data administration tasks. When planning physical storage, carefully consider both the
placement and size of tables and indexes.

The performance of almost all database applications is 1/0O bound. To improve I/O throughput, you should physically
separate tables that are frequently joined together. You should also separate tables from their indexes. The objective
is to have the database read or write data in parallel as much as possible.

Two key concerns of every database administrator are free space management and data fragmentation. If you do not
properly plan for the volume and growth of your tables and indexes, these two administrative issues could severely
impact system availability and performance. Therefore, when designing your physical model, you should consider the
initial extent size and logical partition size.

As a starting point, you should estimate the size of each table and its indexes based on a projected row count. For
databases that let you specify initial extent sizes, such as Oracle, you should set the initial extent size to the estimated
size in order to avoid data fragmentation as the table grows. By keeping tables within a single extent, you can
decrease data access times and avoid reorganizing tables.

Once you have determined the placement and sizes of the tables and indexes in your database, you can estimate the
total size requirements of the database. This should help you avoid running out of free space for your database.

The following sections describe how you can optimally store and partition tables and indexes through the options
available in the table and index editors for the specific database platforms that support these options.

¢ Defining Table Storage

« Partitioning a Table

« Defining Index Storage

« Partitioning a Table Index

See Also
Creating and Editing StoGroups

Creating and Editing Tablespaces




Defining Table Storage

Storage parameters affect both how long it takes to access data stored in the database and how efficiently space in
the database is used. For heavily accessed tables, place these tables in one location and place the table's indexes in
a different location on different physical disk arrays. This will improve performance, because separate threads will be
created to access the tables and indexes.

You can define how your tables are stored using the options in the Storage tab of the Table Editor.

Also to be considered, is how to store the overflow records when a row is updated and no longer fits on the page
where it was originally written. The Overflow tab of the Table Editor is available for index-organized tables on the
Oracle 8.x and 9.x platforms. For more information, see Define Table Overflow Options:

1 Inthe Diagram Window, double-click the table for which you want to specify storage options.
2 From the Table Editor, select the Storage tab.
3 Complete the Storage tab options as required and then click OK to exit the editor.

NOTE: The table storage options available in the Table Editor depend on the database platform.

Click a link below for information on the storage options for your database platform:
« HiRDB Table Storage Options

« |IBM DB2 Common Server and IBM DB2 for LUW Table Storage Options

« |BM DB2 OS/390 Table Storage Options

« Informix Table Storage Options
« Interbase Table Storage Options

« Microsoft SQL Server Table Storage Options
* NCR Teradata Table Storage Options

¢ QOracle 7 Table Storage Options

¢ Oracle 8.x, 9i, 109, and 119 Table Storage Options

* PostgreSQL Table Storage Options

* Sybase Table Storage Options
HIiRDB Table Storage Options

* FIXX: Specifies a fixed length table, without null data. Select this option to reduce table access time and thus
improve performance.

« Table Storage: Select to enable the IN and PARTITIONED BY options. Select IN to define the RD area of the
table, the space where the table and index information is stored. Select PARTITIONED BY to define the partition
setting, such as (RDINDX19) 10, (RDDATA10).

« PCTFREE: (PCTFREE) Specifies the maximum percentage of space in each data block to reserve for future
updates. This reserved space helps to avoid row migration and chaining caused by an update operation that
extends a data row's length. Tables that won't be updated should have this value set to 0. Specify PCTFREE in
one of the following formats:

UNUSED-SPACE-PERCENTAGE
(UNUSED-SPACE-PERCENTAGE, FREE-PAGES-PERCENTAGE-PER-SEGMENT)
(, FREE-PAGES-PERCENTAGE-PER-SEGMENT)

* Lock Mode: Select the locking mode. Select Page to lock all rows on a page when one row is locked for
update. Select Row to lock only the row being updated.



HIRDB LOB Column Storage

If the column datatype specified on the Datatype tab is BLOB, this tab becomes available where you can specify
a large object storage location.

IBM DB2 Common Server and IBM DB2 for LUW Table Storage Options

Tablespace: Displays the tablespace on which the table is stored. Choose another tablespace from the list if you
like.

Index Tablespace: Displays the tablespace on which the table index is stored. Choose another tablespace from
the list if you like.

LONG Tablespace: Displays the name of the tablespace on which the long objects (LOB,CLOB) stored on the
table reside. Choose another tablespace from the list if you like.

Log for Replication: Select to keep a record of all changes in the table. Replication enables the data to be
copied from a source table to one or more target tables and synchronize the changes in the source to the target.

Not Logged Initially: Select to prevent logging on operations that are performed in the same unit of work in
which the table is created; however, other operations against the table in subsequent units of work are logged.

IBM DB2 OS/390 Table Storage Options

The options available depend on the version of the database platform.

Database: Displays the database on which the table data is stored. Choose another database from the list if you
like.

Tablespace: Displays the tablespace on which the table data is stored. Choose another tablespace from the list
if you like.

Log Data Changes: Select to log any changes to the table data.

Audit Option: Choose the audit option desired. Record activity related to changes only or record all access
activities.

Edit Proc: Enter the name of an edit routine that edits or encodes a row whenever a row is inserted or updated.
Typically used to compress the storage of rows to save space, and to encrypt the data.

Valid Proc: Enter the name of the validation routine that validates the data whenever a row is inserted or
updated. Typically used to impose limits on the information that can be entered in a table; for example, allowable
salary ranges for job categories in the employee table.

Encoding: Select to enable encoding and then choose the encoding format desired.

Restrict On Drop: Select to prevent users from accidently dropping the table (removing the table from the
database) until the RESTRICT ON DROP attribute is removed.

Volatile: Select to define the table as volatile so that when querying the table, the DB2 optimizer uses the
indexes defined on the table even though statistics may indicate that using the index would result in slower
performance. This prevents the optimizer from using table statistics that are out of date that would result in poor
performance.

Informix Table Storage Options

The options available depend on the version of the database.

.

DB Space: Specifies the name of the database in which the table data is stored.

Lock Mode: Specifies the locking mode. Select Page to lock all rows on a page when one row is locked for
update. Select Row to lock only the row being updated.

Initial Extent: (INITEXTENT) Specifies the table’s initial number of data blocks. Informix will reserve the data
blocks that correspond to the initial extent for that table’s rows.



Next Extent: (NEXT) Specifies the size of the next extent, in kilobytes. Monitor this value in comparison with the
largest available chunk of free space in the tablespace if the free space is less than the next extent size then the
table extent cannot be allocated; the table will no longer be able to extend and, therefore, cannot accept
additional data.

Path Name: Specifies the full path name of the database in which the table data is stored.

Interbase Table Storage Options

External File: Specifies the file where the table data is stored.

Microsoft SQL Server Table Storage Options

NOTE: The options available depend on the version of the database platform.

Segment: Specifies where the table data is stored.
File Group: Specifies the name of the file group where the table data is stored.

Partition Scheme: Specifies the name of the partition scheme created that associates the partitions with their
physical location in a file group.

Text Image File Group: Specifies the name of the file group where text or image data for the table is stored. This
option becomes available when any of the columns in the table have an image datatype.

Partition Keys: Specifies the partition key. This column guides how data is divided along the partition
boundaries. Typically, a partition key is data-based or a numerically ordered data grouping.

NCR Teradata Table Storage Options

Journal Table: Specifies the name of the journal table in the format database_name.table_name. If the database
name is not specified, the default database for the current session is assumed. If a default journal table was
defined for the database, then this option can override the default. The journal table stores an image of the table
before initiating a transaction. If the transaction completes successfully, the journal is deleted,; if the transaction
fails, the journal data is used to perform a rollback.

Before Journal: Specifies the number of before change images to be maintained. If the JOURNAL keyword is
specified without NO or DUAL, then a single copy of the image is maintained unless FALLBACK is in effect or is
also specified. If journaling is requested for a table that uses fallback protection, DUAL images are maintained
automatically.

After Journal: Specifies the number of after-image to be maintained for the table; any existing images are not
affected until the table is updated.

Freespace: Specifies percent free space (between 0 and 75) that remains on each cylinder during bulk data load
operations on this table. This reserved space helps to avoid row migration and chaining caused by an update
operation that extends a data row's length. Tables that won'’t be updated should have this value set to 0.

Datablock Size: Specifies the maximum data block size for blocks contain multiple rows. Larger block sizes
enhance full-table scans by selecting more rows in a single 1/0; smaller block sizes are best for
transaction-oriented tables to minimize overhead by retrieving only what is needed. The maximum data block
size is 127.5 Kilobytes.

Duplicate Row Control: Specifies whether or not duplicate rows are permitted. Specify Set to disallow duplicate
rows and Multiset to allow duplicate rows.

Fallback Protection: Select this option to implement software fault tolerance which copies the primary table to
create a duplicate copy.

Oracle 7 Table Storage Options

Tablespace: Specifies the name of the tablespace where the table data is stored.



¢ Initial Transactions: (INITTRANS) Specifies the number of DML transactions for which space is initially
reserved in the data block header. Oracle stores control information in the data block to indicate which rows in the
block contain committed and uncommitted changes. The amount of history that is retained is controlled by this
parameter. If too many transactions concurrently modify the same data block in a very short period, Oracle may
not have sufficient history information to determine whether a row has been updated by a “too recent”
transaction. Specify a higher value for tables that may experience many transactions updating the same blocks.

« Max Transactions: (MAXTRANS) Once the space reserved by INITRANS is depleted, space for additional
transaction entries is allocated out of any available free space. Once allocated, this space effectively becomes a
permanent part of the block header. This parameter limits the number of transaction entries that can concurrently
use data in a data block and therefore limits the amount of free space that can be allocated for transaction entries
in a data block.

« Percent Free: (PCTFREE) Specifies the maximum percentage of space in each data block to reserve for future
updates. This reserved space helps to avoid row migration and chaining caused by an update operation that
extends a data row's length. Tables that won't be updated should have this value set to 0.

* Percent Used: (PCTUSED) Specifies the maximum percentage of available space in each data block before
re-adding it to the list of available blocks. When deletes take place and the room available in a block falls below
this value, the block is made available for new inserts to take place. Tables that won't be updated should have
this value set to 99. The default value is 40% means that blocks are available for insertion when they are less
than 40% full.

e |Initial Extent: (INITEXTENT) Specifies the initial number of data blocks that Oracle should reserve. Oracle will
reserve the number of data blocks that correspond to the initial extent for that table’s rows.

* Next Extent: (NEXT) Specifies the size in kilobytes of the next extent. Monitor this figure against the largest
available chunk of free space in the tablespace. If a table cannot allocate its next extent, it will no longer be able
to extend and, therefore, cannot accept additional data.

¢ Percent Increase: (PCTINCREASE) Specifies the percentage by which the next extent should grow over the
previous extent's size. Be careful when setting Percent Increase because it magnifies how an object grows and,
therefore, can materially affect available free space in a tablespace.

* Min Extents: (MINEXTENTS) Specifies the number of extents to allocate when the segment is created. Controls
free space fragmentation by making sure that every used or free extent is at least as large as the value you

specify.

¢ Max Extents: (MAXEXTENTS) Specifies the maximum number of extents that Oracle can allocate to the
materialized view. Once this limit is reached, Oracle prevents further growth of the cluster and cannot accept
additional data. As a result, you should carefully monitor the number extents already allocated to the table with
this limit.

Oracle 8.x, 9i, 10g, and 11g Table Storage Options
The options available depend on the version of Oracle used.

* Heap: Organizes the table with physical rowids. Oracle Corporation does not recommend that you specify a
column of datatype UROWID for a heap-organized table.

« Cache: (CACHE) Select for data that is accessed frequently to specify that blocks retrieved for this table be placed
at the most recently used end of the least recently used (LRU) list in the buffer cache when a full table scan is
performed. This attribute is useful for small lookup tables.

¢ Index Organized: (ORGANIZATION INDEX) Groups data rows according to the primary key. It the table is Index
Organized you can specify how overflow is handled. For more information, see Define Table Overflow Options.




Temporary Table: (GLOBAL TEMPORARY TABLE) Creates a global temporary table whose definition is visible to
all sessions but the data is visible only to the session that created it until the session or transaction is committed.
The data persists in the temporary table at either the session or transaction level based on how ON COMMIT is
specified. You cannot use this option for tables with relationships.

< DELETE ROWS: Deletes the temporary table with the user ends the transaction by issuing a commit
statement.

< PRESERVE ROWS: Retains the table changes until the session is ended.

Enable Compression: (COMPRESS) Select to enable compression, which can reduce disk and buffer cache
requirements, while improving query performance in addition to using fewer data blocks thereby reducing disk
space requirements. This is most useful for fact tables in a data warehouse environment.

Tablespace: Specifies the name of the tablespace on which the table is stored.

* No Logging: Select if you do not want the DLL operations to be logged in the redo file. This can reduce index
creation and updates by up to 30%.

Parallel: (PARALLEL) Selects Oracle's parallel query option, allowing for parallel processes to scan the table.You
can achieve substantial performance gains by using Oracle's parallel query option.

« Degrees: Specifies the number of query server processes that should be used in the operation. Usually this
would be the number of CPUs on the Oracle server -1.

Instances: Specifies how you want the parallel query partitioned between the parallel servers.

Pct Free: (PCTFREE) Specifies the maximum percentage of space in each data block to reserve for future
updates. This reserved space helps to avoid row migration and chaining caused by an update operation that
extends a data row's length. Tables that won't be updated should have this value set to 0.

Pct Used: (PCTUSED) Specifies the maximum percentage of available space in each data block before re-adding
it to the list of available blocks. When deletes take place and the room available in a block falls below this value,
the block is made available for new inserts to take place. Tables that won't be updated should have this value set
to 99. The default value is 40% means that blocks are available for insertion when they are less than 40% full.

Initial Trans: (INITTRANS) Specifies the number of DML transactions for which space is initially reserved in the
data block header. Oracle stores control information in the data block to indicate which rows in the block contain
committed and uncommitted changes. The amount of history that is retained is controlled by this parameter. If too
many transactions concurrently modify the same data block in a very short period, Oracle may not have sufficient
history information to determine whether a row has been updated by a too recent transaction. Initial Transactions
limit the minimum number of concurrent transactions that can update a data block to avoid the overhead of
allocating a transaction entry dynamically. Specify a higher value for tables that may experience many
transactions updating the same blocks.

Max Trans: (MAXTRANS) Specifies the maximum number of concurrent transactions that can update a data block
to avoid performance problems. Once the space reserved by INITRANS is depleted, space for additional
transaction entries is allocated out of any available free space. Once allocated, this space effectively becomes a
permanent part of the block header. This parameter limits the number of transaction entries that can concurrently
use data in a data block and therefore limits the amount of free space that can be allocated for transaction entries
in a data block.

Initial Extent: (INITEXTENT) Specifies the initial number of data blocks that Oracle should reserve. Oracle will
reserve the number of data blocks that correspond to the initial extent for that table’s rows.

Next Extent: (NEXT) Specifies the size in kilobytes of the next extent. Monitor this figure against the largest
available chunk of free space in the tablespace. If a table cannot allocate its next extent, it will no longer be able
to extend and, therefore, cannot accept additional data.

Pct Increase: (PCTINCREASE) Specifies the percentage by which the next extent should grow over the previous
extent's size. Be careful when setting Percent Increase because it magnifies how an object grows and, therefore,
can materially affect available free space in a tablespace.



Min Extents: (MINEXTENT) Specifies the number of extents to allocate when the segment is created. Controls
free space fragmentation by making sure that every used or free extent is at least as large as the value you

specify.

Max Extents: (MAXEXTENT) Species the maximum number of extents that Oracle can allocate to the materialized
view. Once this limit is reached, Oracle prevents further growth of the cluster and cannot accept additional data.
Carefully monitor the number extents already allocated to the table with this limit.

Free Lists: (FREELISTS) Specifies the number of free lists to apply to the table. The default and minimum value
is 1. Free lists can help manage the allocation of data blocks when concurrent processes are issued against the
index. Oracle uses the free list to determine which data block to use when an INSERT operation occurs. Oracle
allows table and indexes to be defined with multiple free lists. All tables and index free lists should be set to the
high-water mark of concurrent INSERT or UPDATE activity. For example, if the table has up to 20 end users
performing INSERTSs at any time, then the index should have FREEL1STS=20.Too low a value for free lists will
cause poor Oracle performance. An increase in FREELISTS or FREELIST GROUPS can alleviate segment
header contention.

Free List Groups: (FREELIST GROUPS) Applicable only if you are using Oracle with the Parallel Server option in
parallel mode. Specifies the number of free list groups which allow the table to have several segment headers.
This enables multiple tasks to insert into the index; thereby alleviating segment header contention. Free list
groups should be set to the number of Oracle Parallel Server instances that access the index. For partitioned
objects and cases of segment header contention, free list groups my be set for non-RAC systems.

Buffer Pool: (BUFFER_POOL) Specifies the memory structure that is used for caching data blocks in memory,
providing faster data access.

« DEFAULT caches data blocks in the default buffer pool.
« KEEP retains the object in memory to avoid 1/O conflicts.

« RECYCLE removes data blocks from memory as soon as they are no longer in use, thereby saving cache
space.



Oracle LOB Segment Storage Options

If a datatype is defined as LOB, CLOB or NLOB on the Dataype tab of the Table Editor, the Edit LOG Segment
option is available, which when clicked opens the LOG Segment editor. The following describes the options
available on the LOG Segment editor:

Segment Name: Specifies the name of the segment on which the LOB data is stored.
Tablespace: Specifies the name of the tablespace on which the LOB data is stored.
Blocks Accessed at one time: (CHUNK) Determines the granularity of allocation for out of row LOBSs.

Percent Space Used for New Version: (PCTVERSI0N) Controls the mechanism that stores the previous
image within the data block. The default value for PCTVersion is 10, reserving 10% of the LOB storage space
for UNDO operations.

Enable LOB Storage In Row: An LOB can be stored either along the row to which it belongs (in row storage)
or in the lob segment (out of row storage). The maximum size for in row LOBs is 3964 bytes.

LOB Cache: (CACHE) Select for data that is accessed frequently to specify that blocks retrieved for this
column be placed at the most recently used end of the least recently used (LRU) list in the buffer cache when a
full table scan is performed.

Logging: (LOGGING) Select if you want the DLL operations to be logged in the redo file. This can increase
index creation and updates by up to 30%.

Initial Extent: (INITEXTENT) Specifies the initial number of data blocks that Oracle should reserve. Oracle
will reserve the number of data blocks that correspond to the initial extent for that table’s rows.

Next Extent: (NEXT) Specifies the size in kilobytes of the next extent. Monitor this figure against the largest
available chunk of free space in the tablespace. If a table cannot allocate its next extent, it will no longer be
able to extend and, therefore, cannot accept additional data.

Pct Increase: (PCTINCREASE) Specifies the percentage by which the next extent should grow over the
previous extent's size. Be careful when setting Percent Increase because it magnifies how an object grows
and, therefore, can materially affect available free space in a tablespace.

Min Extents: (MINEXTENT) Specifies the number of extents to allocate when the segment is created. Controls
free space fragmentation by making sure that every used or free extent is at least as large as the value you

specify.

Max Extents: (MAXEXTENT) Species the maximum number of extents that Oracle can allocate to the
materialized view. Once this limit is reached, Oracle prevents further growth of the cluster and cannot accept
additional data. Carefully monitor the number extents already allocated to the table with this limit.

Free Lists: (FREELISTS) Specifies the number of free lists to apply to the table. The default and minimum
value is 1. Free lists can help manage the allocation of data blocks when concurrent processes are issued
against the index. Oracle uses the free list to determine which data block to use when an INSERT operation
occurs. Oracle allows table and indexes to be defined with multiple free lists. All tables and index free lists
should be set to the high-water mark of concurrent INSERT or UPDATE activity. For example, if the table has
up to 20 end users performing INSERTSs at any time, then the index should have FREEL1STS=20.Too low a
value for free lists will cause poor Oracle performance. An increase in FREELISTS or FREELIST GROUPS
can alleviate segment header contention.

Free List Groups: (FREELIST GROUPS) Applicable only if you are using Oracle with the Parallel Server
option in parallel mode. Specifies the number of free list groups which allow the table to have several segment
headers. This enables multiple tasks to insert into the index; thereby alleviating segment header contention.
Free list groups should be set to the number of Oracle Parallel Server instances that access the index. For
partitioned objects and cases of segment header contention, free list groups my be set for non-RAC systems.

PostgreSQL Table Storage Options

« Table Space: Specifies the name of the tablespace on which the table data is stored.



Sybase Table Storage Options

The options available depend on the database platform.

DB Space: Specifies the name of the database where the table data is stored.
Segment: Specifies the name of the segment where the table is stored.

Locking Scheme: Specifies the locking scheme to implement for DDL transactions.

* ALLPAGES: Locks the data pages and index pages affected by the query.

< DATAPAGES: Locks the data pages but not the index pages, and the lock is held until the end of the
transaction.

« DATAROWS: Locks the individual rows on data pages; rows and pages are not locked. This scheme requires
more overhead but is beneficial for small tables with much contention.

Max Rows per Page: Specifies the maximum number of rows per page.
Reserve Page Gap: Specify the reserve gap parameters.

Identity Gap: Controls the allocation of ID numbers and potential gaps resulting from restarting the server.
Creates ID number blocks of a specific size which improves performance by reducing contention for the table.
Overrides the server-wide identity burning set factor. If the identity gap is set to 1000m the server allocates the
first 1000 numbers and stores the highest number of the block to disk. When all the numbers are used, the server
takes the next 1000 numbers. If after inserting row 2050 the power fails, then when the server restarts it’ll start
with ID 3000, leaving an ID gap of 950 numbers. Each time the server must write the highest number of a block to
disk, performance is affected so you must find the best setting to achieve the optimal performance with the lower
gap value acceptable for your situation.

Replacement Strategy: Select to use the fetch-and-discard (or MRU) replacement strategy that reads pages
into cache at the most recently-used (MRU) end of the buffer, so it does not flush other pages. But these pages
remain in cache a much shorter time, so subsequent queries are less likely to find the page in cache.

Prefetch Strategies: Enables or disables large 1/O for a session.

Define Table Overflow Options

The Table Editor Overflow tab specifies how to store the overflow records when a row is updated and no longer fits on
the page where it was originally written. The Overflow tab of the Table Editor is available for index-organized tables on
the Oracle 8.x, 9i, 10g and 11g platforms.
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In the Diagram Window, double-click the table for which you want to specify storage options.
From the Table Editor, select the Overflow tab.
Complete the Overflow tab options as required and then click OK to exit the editor.

The Overflow tab creates an ORGANIZATION INDEX clause in the CREATE TABLE statement. Any options you
specify on this tab will follow this clause.

The following describes options on the Overflow tab that are not self-explanatory.
Tablespace: Specifies the name of the tablespace on which the overflow is stored.

No Logging: Select if you do not want the DLL operations to be logged in the redo file. This can reduce index
creation and updates by up to 30%.

Pct Threshold: (PCTTHRESHOLD): Specifies the percentage of space reserved in the index block for the
index-organized table. Any portion of a row that exceeds this threshold is stored in the overflow segment.

Including: (INCLUDING) Select the column to include in the overflow.



Pct Free: (PCTFREE) Specifies the maximum percentage of space in each data block to reserve for future
updates. This reserved space helps to avoid row migration and chaining caused by an update operation that
extends a data row's length. Tables that won't be updated should have this value set to 0.

Pct Used: (PCTUSED) Specifies the maximum percentage of available space in each data block before re-adding
it to the list of available blocks. When deletes take place and the room available in a block falls below this value,
the block is made available for new inserts to take place. Tables that won't be updated should have this value set
to 99. The default value is 40% means that blocks are available for insertion when they are less than 40% full.

Initial Trans: (INITTRANS) Specifies the number of DML transactions for which space is initially reserved in the
data block header. Oracle stores control information in the data block to indicate which rows in the block contain
committed and uncommitted changes. The amount of history that is retained is controlled by this parameter. If too
many transactions concurrently modify the same data block in a very short period, Oracle may not have sufficient
history information to determine whether a row has been updated by a “too recent” transaction. Specify a higher
value for indexes that may experience many transactions updating the same blocks.

Max Trans: (MAXTRANS) Once the space reserved by INITRANS is depleted, space for additional transaction
entries is allocated out of any available free space. Once allocated, this space effectively becomes a permanent
part of the block header. This parameter limits the number of transaction entries that can concurrently use data in
a data block and therefore limits the amount of free space that can be allocated for transaction entries in a data
block.

Initial Extent: (INITEXTENT) Specifies the initial number of data blocks that Oracle should reserve. Oracle will
reserve the number of data blocks that correspond to the initial extent for that table’s rows.

Next Extent: (NEXT) Specifies the size in kilobytes of the next extent. You should monitor this figure against the
largest available chunk of free space in the tablespace. If a table cannot allocate its next extent, it will no longer
be able to extend and, therefore, cannot accept additional data.

Pct Increase: (PCTINCREASE) Specifies the percentage by which the next extent should grow over the previous
extent's size. Be careful when setting Percent Increase because it magnifies how an object grows and, therefore,
can materially affect available free space in a tablespace.

Min Extents: (MINEXTENTS) Specifies the number of extents to allocate when the segment is created. Controls
free space fragmentation by making sure that every used or free extent is at least as large as the value you

specify.

Max Extents: (MAXEXTENTS) Specifies the maximum number of extents that Oracle can allocate to the index.
Once this limit is reached, Oracle prevents further growth of the cluster and cannot accept additional data.
Carefully monitor the number extents already allocated to the index with this limit.

Free Lists: (FREELISTS) Specifies the number of free lists to apply to the index. The default and minimum value
is 1. Free lists can help manage the allocation of data blocks when concurrent processes are issued against the
index. Oracle uses the free list to determine which data block to use when an INSERT operation occurs. Oracle
allows table and indexes to be defined with multiple free lists. All tables and index free lists should be set to the
high-water mark of concurrent INSERT or UPDATE activity. For example, if the index has up to 20 end users
performing INSERTSs at any time, then the index should have FREELI1STS=20.Too low a value for free lists will
cause poor Oracle performance. An increase in FREELISTS or FREELIST_GROUPS can alleviate segment
header contention.

Free List Groups: (FREELIST GROUPS) Applicable only if you are using Oracle with the Parallel Server option in
parallel mode. Specifies the number of free list groups which allow the index to have several segment headers.
This enables multiple tasks to insert into the index; thereby alleviating segment header contention. Free list
groups should be set to the number of Oracle Parallel Server instances that access the index. For partitioned
objects and cases of segment header contention, freelist_groups may be set for non-RAC systems.



Buffer Pool: (BUFFER_POOL) Specifies the memory structure that is used for caching data blocks in memory,
providing faster data access.

« DEFAULT: Caches data blocks in the default buffer pool.
« KEEP: Retains the object in memory to avoid I/O conflicts.

« RECYCLE: Removes data blocks from memory as soon as they are no longer in use, thereby saving cache
space.

Partitioning a Table

The performance of almost all database applications is /0 bound. To improve 1/O throughput, you should physically
separate tables that are frequently joined together. You should also separate tables from their indexes. The objective
is to have the database read or write data in parallel as much as possible.
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In the Diagram Window, double-click the table that you want to partition.

From the Table Editor, click the Partitions tab and the select the index for which you want to specify storage
options.

Complete the Partitions options as required, click Add to launch the Table Partition Editor.

Complete the Table Partition Editor options as required, click OK to exit the editor and then click OK again to
exit the Table Editor.

NOTE: The index storage options available on the Partitions tab and the Table Partition Editor depend on
the database platform and version.

The following describes options that are not self-explanatory. For information on the storage options available for
your database platform, click a link below:

Table Partition Options for Sybase

Table Partition Options for Oracle 8.x and 9i
Table Partition Options for IBM DB2 for OS/390 8.x and 9.x

Table Partition Options for IBM DB2 for LUW 9.x

Table Partition Columns for IBM DB2 for 0S/390 5.x, 6.x, 7.X, and 8.x

Table Partition Options for Sybase

Partition Table: (PARTITION num) Select if you want to partition the table and then enter the number of
partitions desired.



Table Partition Options for Oracle 8.x and 9i
* Type: Select the partition type.

« Composite: Select to hash partition range partitions on a different key. When selected, specify the
subpartitions by clicking Subpartition Type. More partitions increase the possibilities for parallelism and
reduce contention. For example the following range partitions a table on invoiceDate and subpartitions
these partitions by invoiceNo, creating 16 subpartitions.

CREATE TABLE invoices

(invoice_no NUMBER NOT NULL,

invoice_date DATE NOT NULL)

PARTITION BY RANGE (invoiceDate)

SUBPARTITION BY HASH (invoiceNo)

SUBPARTITIONS 4

(PARTITION invoices_Q1 VALUES LESS THAN (TO_DATE("01/04/2007", “DD/MM/ZYYYY®)),
PARTITION invoices_Q2 VALUES LESS THAN (TO_DATE("01/07/2007%, “DD/MM/YYYY®)),
PARTITION invoices_Q3 VALUES LESS THAN (TO_DATE("01/09/2007", “DD/MM/YYYY")),
PARTITION invoices_Q4 VALUES LESS THAN (TO_DATE("01/01/2008%, “DD/MM/YYYY®));

¢ Range: (PARTITION BY RANGE (column_name)) Select to store distinct ranges of data together, such as
dates. Searches can then be limited to partitions with data that is the correct age. Also, once historical data is
no longer useful, the whole partition can be removed.

e Hash: (PARTITION BY HASH (column_name) PARTITIONS count STORE IN tablespace)) Select
if there is no obvious range key or if range partitioning might cause uneven data distribution.

e List: (PARTITION BY LIST) Select to control how rows map to partitions. Specify a list of discrete values for
the partitoning key in the description of each partition.

« Subpartition Type button: Launches the Subpartition Type Editor where you can specify the columns to use in
the subpartition. For a HASH subpartition, you can specify the number of subpartitions and where they’re stored.
For a LIST subpartition, you can specify the subpartitions to include.

« Available Columns: Displays the columns available to add to a partition.

« Selected Columns: Displays the columns that make up the partition key. This guides how data is divided along
the partition boundaries. Typically, a partition key is date-based or based on a numerically ordered data grouping.
Use the left and right arrows to move columns to and from this grid. Columns that are in this grid make up the
partition.

« Up/Down buttons: Let you reorder the columns on the partition. The partition order can affect the access speed.
The most frequently accessed columns should be at the top of the partition list.

« Add: Click to add table partitions. When clicked, launches the Table Partition Editor for Oracle 8.x and 9i.

« Edit: Select a partition and click to modify it. When clicked, launches the Table Partition Editor for Oracle 8.x and
9i.



Table Partition Editor for Oracle 8.x and 9i

Max Value: (VALUES LESS THAN (MAXVALUE)) Select to create a catch-all partition for values that exceed
all specified ranges. Otherwise, specify a High Value for the partition range.

High Value: (VALUES LESS THAN (high value)) Specifies the ending value for the partition range.

Tablespace: Specifies the name of the tablespace on which the table is stored.
* No Logging: Select if you do not want the DLL operations to be logged in the redo file. This can reduce index
creation and updates by up to 30%.

Pct Free: (PCTFREE) Specifies the maximum percentage of space in each data block to reserve for future
updates. This reserved space helps to avoid row migration and chaining caused by an update operation that
extends a data row's length. Tables that won’t be updated should have this value set to 0.

Pct Used: (PCTUSED) Specifies the maximum percentage of available space in each data block before
re-adding it to the list of available blocks. When deletes take place and the room available in a block falls
below this value, the block is made available for new inserts to take place. Tables that won't be updated
should have this value set to 99. The default value is 40% means that blocks are available for insertion when
they are less than 40% full.

Initial Trans: (INITTRANS) Specifies the number of DML transactions for which space is initially reserved in
the data block header. Oracle stores control information in the data block to indicate which rows in the block
contain committed and uncommitted changes. The amount of history that is retained is controlled by this
parameter. If too many transactions concurrently modify the same data block in a very short period, Oracle
may not have sufficient history information to determine whether a row has been updated by a “too recent”
transaction. Specify a higher value for indexes that may experience many transactions updating the same
blocks.

Max Trans: (MAXTRANS) Once the space reserved by INITRANS is depleted, space for additional transaction
entries is allocated out of any available free space. Once allocated, this space effectively becomes a
permanent part of the block header. This parameter limits the number of transaction entries that can
concurrently use data in a data block and therefore limits the amount of free space that can be allocated for
transaction entries in a data block.

Edit Subpartition button: Launches the Subpartition Editor where you can specify how to subpartition the
partition and where the subpartitions should be stored.

Initial Extent: (INITEXTENT) Specifies the initial number of data blocks that Oracle should reserve. Oracle
will reserve the number of data blocks that correspond to the initial extent for that table’s rows.

Next Extent: (NEXT) Specifies the size in kilobytes of the next extent. You should monitor this figure against
the largest available chunk of free space in the tablespace. If a table cannot allocate its next extent, it will no
longer be able to extend and, therefore, cannot accept additional data.

Pct Increase: (PCTINCREASE) Specifies the percentage by which the next extent should grow over the
previous extent's size. Be careful when setting Percent Increase because it magnifies how an object grows
and, therefore, can materially affect available free space in a tablespace.

Min Extents: (MINEXTENTS) Specifies the number of extents to allocate when the segment is created.
Controls free space fragmentation by making sure that every used or free extent is at least as large as the
value you specify.

Max Extents: (MAXEXTENTS) Specifies the maximum number of extents that Oracle can allocate to the index.
Once this limit is reached, Oracle prevents further growth of the cluster and cannot accept additional data.
Carefully monitor the number extents already allocated to the index with this limit.

Free Lists: (FREEL1STS) Specifies the number of free lists to apply to the index. The default and minimum
value is 1. Free lists can help manage the allocation of data blocks when concurrent processes are issued
against the index. Oracle uses the free list to determine which data block to use when an INSERT operation
occurs. Oracle allows table and indexes to be defined with multiple free lists. All tables and index free lists
should be set to the high-water mark of concurrent INSERT or UPDATE activity. For example, if the index has
up to 20 end users performing INSERTs at any time, then the index should have FREEL1STS=20.Too low a
value for free lists will cause poor Oracle performance. An increase in FREELISTS or FREEL1ST_GROUPS can
alleviate segment header contention.



e Free List Groups: (FREELIST GROUPS) Applicable only if you are using Oracle with the Parallel Server
option in parallel mode. Specifies the number of free list groups which allow the index to have several segment
headers. This enables multiple tasks to insert into the index; thereby alleviating segment header contention.
Free list groups should be set to the number of Oracle Parallel Server instances that access the index. For
partitioned objects and cases of segment header contention, freelist_groups my be set for non-RAC systems.

« Buffer Pool: (BUFFER_POOL) Specifies the memory structure that is used for caching data blocks in memory,
providing faster data access.
DEFAULT: Caches data blocks in the default buffer pool.
KEEP: Retains the object in memory to avoid I/O conflicts.
RECYCLE: Removes data blocks from memory as soon as they are no longer in use, thereby saving cache
space.

Table Partition Options for IBM DB2 for OS/390 8.x and 9.x

Available Columns: Displays the columns available to add to a partition.

Selected Columns: Displays the columns that make up the partition key. This guides how data is divided along
the partition boundaries. Typically, a partition key is date-based or based on a numerically ordered data grouping.
Use the left and right arrows to move columns to and from this grid. Columns that are in this grid make up the
partition.

Up/Down buttons: Let you reorder the columns on the partition. The partition order can affect the access speed.
The most frequently accessed columns should be at the top of the partition list.

Add: Click to add table partitions. When clicked, launches the Table Partition Editor for IBM DB2 for OS/390 8.x
and 9.x.

Edit: Select a partition and click to modify Edit to modify it. When clicked, launches the Table Patrtition Editor for

IBM DB2 for OS/390 8.x and 9.x.

Table Partition Editor for IBM DB2 for OS/390 8.x and 9.x

Partitions: Displays existing partitions. If more than one column is used to create the partition, the ending values
of the partition keys (columns) are listed in the Ending At column in the same order as the columns in the partition
definition. You can change the partition definition by selecting the partition and then changing the High Values in
the Partition Definition area.

Partition Definition: Defines the high values of each partition key. You must enter a high value for each partition
key listed.

Inclusive: If selected, includes the high value in the partition; otherwise the partition will end just before the high
value is reached.

Table Partition Options for IBM DB2 for LUW 9.x

Available Columns: Displays the columns available to add to a partition.

Selected Columns: Displays the columns that make up the partition key. This guides how data is divided along
the partition boundaries. Typically, a partition key is date-based or based on a numerically ordered data grouping.
Use the left and right arrows to move columns to and from this grid. Columns that are in this grid make up the
partition.

Up/Down buttons: Let you reorder the columns on the partition. The partition order can affect the access speed.
The most frequently accessed columns should be at the top of the partition list.

Add: Click to add table partitions. When clicked, launches the Table Partition Editor for IBM DB2 for OS/390 8.x
and 9.x.

Edit: Select a partition and click to modify Edit to modify it. When clicked, launches the Table Partition Editor for

IBM DB2 for LUW 9.x.




Table Partition Editor for IBM DB2 for LUW 9.x
Lets you create a PARTITION BY RANGE statement similar to the following:

CREATE TABLE orders (id INT, shipdate DATE, ...)
PARTITION BY RANGE(shipdate)

(

STARTING "1/1/2006" ENDING "12/31/2006"

EVERY 3 MONTHS

)

« Partitions: Displays existing partitions. If more than one column is used to create the partition, the ending values
of the partition keys (columns) are listed in the End Value column in the same order as the columns in the
partition definition. You can change the partition definition by selecting the partition and then changing the Start
Value in the Partition Definition area.

« Partition Name: Lets you define the name of the partition. This field is not used when creating several partitions
automatically, using the Range Width and Duration Label fields to create a range partitioning statement such as
EVERY 3 MONTHS.

¢ Column Name: Displays the column names selected to be part of the partition on the Partitions tab.

e Start Value: Lets you specify the earliest possible date or time, or the lowest integer to include in the partition. In
the partitioning statement, the start value is the STARTING FROM value.
A date string can be specified using one of the following formats:
¢ yyyy-mm-dd
« mm/dd/yyyy
e dd.mm.yyyy
A timestamp string can specified as:
e yyyy-mm-dd hh.mm.ss.nnnnnn
¢ yyyy-mm-dd-hh.mm.ss.nnnnnn
You can also choose MINVALUE or MAXVALUE from the list, the values of which depend upon the datatype.After
specifying the Start Value, specify the End Value.

e Start Value Inclusion: Select to include the specified start value in the partition. Keywords inserted are
INCLUSIVE IN. If not selected, the partition will start at the value just greater than the specified start value, and
the keywords inserted will be EXCLUSIVE IN.

« End Value: Lets you specify the latest possible date/time or the largest integer to include in the partition. When
working with a date-partitioned table, this would be the ENDING value. See Start Value above for acceptable
formats for date and time stamp strings.

« End Value Inclusion: Select to include the specified end value in the partition. Keywords inserted are
INCLUSIVE IN. If not selected, the partition will end at the date/time or integer just greater than the specified
end value, and the keywords inserted will be EXCLUSIVE IN.

* Range Width: Use Range Width and Duration Label to automatically create multiple partitions. The Range Width
is the date, time or integer interval used to partition the table. For example, in the EVERY 3 MONTHS clause, the
Range Width is 3.

« Duration Label: From the list, select the unit of measure to use to partition the table. In the EVERY 3 MONTHS
clause, the Duration Label is MONTHS. For an integer-partitioned table, select (none) as the duration label.

« Tablespace: Specifies the tablespace where the partition is stored.

« LONG IN: Lets you specify a large tablespace where long data is to be stored. Large objects are by default
stored in the same tablespace as the corresponding data objects, whether the partitioned table uses only one
tablespace or multiple tablespaces. The LONG IN clause overrides this default behavior, causing long data to be
stored in the tablespace specified, which may improve database performance.



Table Partition Columns for IBM DB2 for OS/390 5.x, 6.x, 7.x, and 8.x

Available Columns: Displays all the columns available to add to the partition. Select the column you want to add
to the partition and move it to the Selected Columns box.

Selected Columns: Displays the columns that make up the partition key. This guides how data is divided along
the partition boundaries. Typically, a partition key is date-based or based on a numerically ordered data grouping.
Use the left and right arrows to move columns to and from this grid. Columns that are in this grid make up the
partition.

Up/Down buttons: Let you reorder the columns on the partition. The partition order can affect the access speed.
The most frequently accessed columns should be at the top of the partition list.

Use Hashing: If selected, ER/Studio partitions the table according to a hash function, which can speed up table
lookup or data comparison tasks.

Defining Index Storage

Storage parameters affect both how long it takes to access data stored in the database and how efficiently space in
the database is used. For heavily accessed tables, place these tables in one location and place the table's indexes in
a different location on different physical disk arrays. This will improve performance, because separate threads will be
created to access the tables and indexes.

You can define how your tables are stored using the options in the Index Editor, which is accessible through the Index
tab of the Table Editor.
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In the Diagram Window, double-click the table for which you want to specify index storage options.

From the Table Editor, click the Indexes tab, select the index for which you want to specify storage options, and
then click Edit.

The Index Editor appears with options that are specific to the database platform and version.

Complete the Index Editor options as required, click OK to exit the Index Editor, and then click OK again to exit
the Table Editor.

For information on the storage options available for your database platform, click a link below:

Hitachi HIRDB Index Storage Options
IBM DB2 for OS/390 Index Storage Options

Informix Index Storage Options

Interbase Index Storage Options

Microsoft SQL Server Index Storage Options

Oracle 7.x Index Storage Options

Oracle 8.x, 9i, 10g, and 11g Index Storage Options, see Properties tab
Postgre SQL Index Storage Options

Sybase SQL Anywhere Index Storage Options

Sybase System 10, ASE 10, 11 Index Storage Options

Hitachi HIRDB Index Storage Options

Index Storage: (ON) Specifies where to store the index.



« PCTFREE: (PCTFREE) Specifies the maximum percentage of space in each data block to reserve for future
updates. This reserved space helps to avoid row migration and chaining caused by an update operation that
extends a data row's length. Tables that won't be updated should have this value set to 0.

* Unbalanced Split: (UNBALANCED SPLIT) Specifies that in order to maintain the balance of the index tree and
improve performance the index pages can be split.

IBM DB2 for OS/390 Index Storage Options

The storage options for an IBM DB2 for OS/390 appear on the Options tab of the Index Editor for that platform.
For more information, see IBM DB2 for OS/390 Index Options.

Informix Index Storage Options

« Fill Factor: (FILLFACTOR) Specifies the percent or degree of index-page fullness. A low value provides room for
index growth. A high value compacts the index. If an index is full (100 percent), any new inserts result in splitting
nodes.

Interbase Index Storage Options
« External File: Specifies where to store the index.
Microsoft SQL Server Index Storage Options

NOTE: The options available depend on the version of the database.

* Segment: (ON) Specifies where the index will be stored.
« File Group: (ON) Specifies where the index will be stored.

* Fill Factor: (FILLFACTOR) Specifies the percent or degree of index-page fullness. A low value provides room for
index growth. A high value compacts the index. If an index is full (100 percent), any new inserts result in splitting
nodes.

« Pad Index: (PAD_INDEX) Specifies how much space to leave available on each page in the intermediate levels
of the index. If PAD__INDEX is not used, by default each intermediate index page is given only enough empty
space to hold at least one row of the maximum size the index can have. For tables with heavy index updates, this
can cause the intermediate index pages to split often, causing unnecessary overhead. To prevent intermediate
index page splitting, assign both the FILLFACTOR and the PAD_ INDEX options. The PAD_ INDEX option uses the
FILLFACTOR, and applies it to the intermediate index pages. For example, if a FILLFACTOR of 80 is specified,
then the PAD_INDEX will use this value, and only fill 80% of the intermediate index page space, instead of leaving
enough space for just one new row.

¢ Sort In Tempdb: (SORT_IN_TEMPDB) Specifies to use tempdb to store intermediate sort results that are used to
build the index. Although this increases the amount of temporary disk space that is used to create an index, it
could reduce the time required to create or rebuild an index when tempdb is on a disparate set of disks from that
of the user database.

« Partition Keys: Select the key to use when partitioning the index. Partitioning the index can substantially reduce
query time, improving the load time and maintainability of the index.

Oracle 7.x Index Storage Options
« Tablespace: (TABLESPACE) Specifies the name of the tablespace where the index is stored.

< Initial Transactions: (INITTRANS) Specifies the number of DML transactions for which space is initially
reserved in the data block header. Oracle stores control information in the data block to indicate which rows in the
block contain committed and uncommitted changes. The amount of history that is retained is controlled by this
parameter. If too many transactions concurrently modify the same data block in a very short period, Oracle may
not have sufficient history information to determine whether a row has been updated by a “too recent”
transaction. Specify a higher value for indexes that may experience many transactions updating the same blocks.



Max Transactions: (MAXTRANS) Once the space reserved by INITRANS is depleted, space for additional
transaction entries is allocated out of any available free space. Once allocated, this space effectively becomes a
permanent part of the block header. This parameter limits the number of transaction entries that can concurrently
use data in a data block and therefore limits the amount of free space that can be allocated for transaction entries
in a data block.

Percent Free: (PCTFREE) Specifies the maximum percentage of space in each data block to reserve for future
updates. This reserved space helps to avoid row migration and chaining caused by an update operation that
extends a data row's length. Tables that won't be updated should have this value set to 0.

Initial Extent: (INITEXTENT) Specifies the initial number of data blocks that Oracle should reserve. Oracle will
reserve the number of data blocks that correspond to the initial extent for that table’s rows.

Next Extent: (NEXT) Specifies the size in kilobytes of the next extent. You should monitor this figure against the
largest available chunk of free space in the tablespace. If a table cannot allocate its next extent, it will no longer
be able to extend and, therefore, cannot accept additional data.

Percent Increase: (PCTINCREASE) Specifies the percentage by which the next extent should grow over the
previous extent's size. Be careful when setting Percent Increase because it magnifies how an object grows and,
therefore, can materially affect available free space in a tablespace.

Min Extents: (MINEXTENTS) Specifies the number of extents to allocate when the segment is created. Controls
free space fragmentation by making sure that every used or free extent is at least as large as the value you

specify.

Max Extents: (STORAGE (MAXEXTENTS)) Species the maximum number of extents that Oracle can allocate to
the index. Once this limit is reached, Oracle prevents further growth of the cluster and cannot accept additional
data. Carefully monitor the number extents already allocated to the index with this limit.

Postgre SQL Index Storage Options

Tablespace: (TABLESPACE) Specifies the name of the tablespace where the index is stored.

Sybase SQL Anywhere Index Storage Options

DB Space: (IN) Specifies where the index is stored.

Sybase System 10, ASE 10, 11 Index Storage Options

.

Segment: (ON) Specifies where the index will be stored.

Max Rows per Page: (MAX_ROWS_PER_PAGE) Specifies the maximum number of rows per page. This restricts
the number of rows allowed on a page, reducing lock contention and improving concurrency for frequently
accessed tables.The default value is 0, which creates clustered indexes with full data pages, non clustered
indexes with full leaf pages, and leaves a comfortable amount of space within the index B-tree in both the
clustered and nonclusteredindexes.

For heap tables and clustered indexes, the range for MAX_ROWS_PER_PAGE is 0-256. For non clustered indexes,
the maximum value for MAX_ROWS_PER_PAGE is the number of index rows that fit on the leaf page, without
exceeding 256. To determine the maximum value, subtract 32 (the size of the page header) from the page size
and divide the difference by the index key size.

Fill Factor: (FILLFACTOR) Specifies the percent or degree of index-page fullness. A low value provides room for
index growth. A high value compacts the index. If an index is full (100 percent), any new inserts result in splitting
nodes.

Partitioning a Table Index

For database platforms that support this feature, partitioning the index can substantially reduce query time, limiting
access to relevant partitions only. A partitioned index may be efficiently maintained. Partition independence enables a
partition to be maintained without affecting the availability of other partitions.



You can access the Index Partition Editor through the Table Editor > Index tab, where you can choose to partition the
index and add new partitions as required. The options available in the Index Partition Editor depend upon the selected
database platform. For information on the options for your database, click one of the following links:

« |BM DB2 for OS/390 Index Patrtitions Options

¢ Oracle 8.x, 9i, 109, and 11g Index Partitions Options

IBM DB2 for OS/390 Index Partitions Options

NOTE: ForlIBM DB2 for 0S/390, the Cluster option on the Options tab must be selected in order to enable
the partitioning options on the Partitions tab. Click Add on the Partitions tab to launch the Index
Partition Editor.

e High Value: Lets you specify the maximum value of the column for this partition, entries that exceed this amount
will not be included in the partition.

e Vcat: (VCAT) If selected, allocates space for the index on a data set managed using the virtual catalog (VCAT)
whose name is specified next to this option, and the user manages the data sets required for the index. The VCAT
method is usually used for defining system catalogs. It requires that the VSAM dataset be pre-defined before the
index space is created.

« StoGRoup: (STOGROUP) If selected, stores the index on a data set managed by DB2 in the named storage
group. Stogroup defined index spaces let DB2 do all the VSAM allocation work for you. If you have created a
Stogroup for the data model, using the Stogroup Editor (see Creating and Editing StoGroups), you can select that
Stogroup from the list. If you select Stogroup, you can also define values for PRIQTY and SECQTY. To prevent
wasted space for non-partitioned indexes, you should not define PRIQTY and SECQTY; instead let DB2 manage
the amount of primary and secondary space allocated for the index.

« PriQty: (PRIQTY) Specifies the minimum number of disk space in kilobytes to initially allocate for the index. The
primary allocation should be large enough to handle the storage needs that you anticipate.

* SecQty: (SECQTY) Specifies the amount of disk space in kilobytes to allocate to the index when it reaches the
size of the primary allocation. If the secondary allocation space is too small, the data set might have to be
extended more times to satisfy those activities that need a large space. The default value of -1 indicates that DB2
should determine the size of the secondary allocation, which is usually 10% of the primary allocation.

« Percent Free: (PCTFREE) Specifies the maximum percentage of space in each data block to reserve for future
updates. This reserved space helps to avoid row migration and chaining caused by an update operation that
extends a data row's length. Tables that won’t be updated should have this value set to 0.

* Free Page: (FREEPAGE) Specifies how often to leave a page of free space when index entries are created. One
free page is left for every number of pages specified here in the range of 0 to 255.

* GBP Cache: (GPBCACHE) In a data sharing environment, specifies what index pages are written to the group
buffer pool. This option is ignored in a non-data-sharing environment unless the index is on a declared temporary
table.

« Changed: Writes updated pages to the group buffer pool.
« All: Caches all pages to the group buffer pool as they are read in from DASD.
¢ None: Uses the buffer pool only for cross-invalidation.

Oracle 8.x, 9i, 10g, and 11g Index Partitions Options

Options available on the Partitions tab of the Index Editor depend on the version of the database platform.



Type: Select the partition type.

¢ Range: (PARTITION BY RANGE (column_name)) Select to store distinct ranges of data together, such as
dates. Searches can then be limited to partitions with data that is the correct age. Also, once historical data is
no longer useful, the whole partition can be removed.

¢ Hash: (PARTITION BY HASH (column_name) PARTITIONS count STORE IN tablespace)) Select
if there is no obvious range key or if range partitioning might cause uneven data distribution. If selected, the
Partition Count option is available.

« Partition Count: Click to launch the Hash Partition Editor where you can specify the number of subpartitions
and where to store them.

Available Columns: Displays the columns available to add to a partition.

Selected Columns: Displays the columns that make up the partition key. Guides how data is divided along the
partition boundaries. Typically, a partition key is date-based or based on a numerically ordered data grouping.
Use the left and right arrows to move columns to and from this grid.

Up/Down buttons: Let you reorder the columns on the partition. The partition order can affect the access speed.
The most frequently accessed columns should be at the top of the partition list.

Index Scope: Lets you specify the type of index partition to create.

¢ Local: (LOCAL) All index entries in the partition correspond to a one table partition (equi-partitioned). Supports
partition independence, allowing for more efficient queries.

¢ Global: (GLOBAL) The index in the partition can correspond to many table partitions. Does not support partition
independence and must be partitioned by range. If specified, you must specify the partition range values.

Add: Click to launch the Index Partition Editor where you can add table partitions. For more information, see
Index Partition Editor for Oracle 8.x, 9i, 109, and 11g Options.

Edit: Click to launch the Index Partition Editor where you can add table partitions. For more information, see
Index Partition Editor for Oracle 8.x, 9i, 109, and 11g Options.

Index Partition Editor for Oracle 8.x, 9i, 10g, and 11g Options

Max Value: (VALUES LESS THAN (MAXVALUE)) Select to create a catch-all partition for values that exceed all
specified ranges. Otherwise, specify a High Value for the partition range.

High Value: (VALUES LESS THAN (high value)) Specifies the ending value for the partition range.

Pct Free: (PCTFREE) Specifies the maximum percentage of space in each data block to reserve for future
updates. This reserved space helps to avoid row migration and chaining caused by an update operation that
extends a data row's length. Tables that won't be updated should have this value set to 0.

Initial: (INITTRANS) Specifies the number of DML transactions for which space is initially reserved in the data
block header. Oracle stores control information in the data block to indicate which rows in the block contain
committed and uncommitted changes. The amount of history that is retained is controlled by this parameter. If too
many transactions concurrently modify the same data block in a very short period, Oracle may not have sufficient
history information to determine whether a row has been updated by a “too recent” transaction. Specify a higher
value for indexes that may experience many transactions updating the same blocks.

Max Trans: (MAXTRANS) Once the space reserved by INITRANS is depleted, space for additional transaction
entries is allocated out of any available free space. Once allocated, this space effectively becomes a permanent
part of the block header. This parameter limits the number of transaction entries that can concurrently use data in
a data block and therefore limits the amount of free space that can be allocated for transaction entries in a data
block.

Initial Extent: (INITEXTENT) Specifies the initial number of data blocks that Oracle should reserve. Oracle will
reserve the number of data blocks that correspond to the initial extent for that table’s rows.



« Next Extent: (NEXT) Specifies the size in kilobytes of the next extent. You should monitor this figure against the
largest available chunk of free space in the tablespace. If a table cannot allocate its next extent, it will no longer
be able to extend and, therefore, cannot accept additional data.

« Pct Increase: (PCTINCREASE) Specifies the percentage by which the next extent should grow over the previous
extent's size. Be careful when setting Percent Increase because it magnifies how an object grows and, therefore,
can materially affect available free space in a tablespace.

* Min Extents: (MINEXTENTS) Specifies the number of extents to allocate when the segment is created. Controls
free space fragmentation by making sure that every used or free extent is at least as large as the value you

specify.

* Max Extents: (MAXEXTENTS) Specifies the maximum number of extents that Oracle can allocate to the index.
Once this limit is reached, Oracle prevents further growth of the cluster and cannot accept additional data.
Carefully monitor the number extents already allocated to the index with this limit.

e Free Lists: (FREELISTS) Specifies the number of free lists to apply to the index. The default and minimum value
is 1. Free lists can help manage the allocation of data blocks when concurrent processes are issued against the
index. Oracle uses the free list to determine which data block to use when an INSERT operation occurs. Oracle
allows table and indexes to be defined with multiple free lists. All tables and index free lists should be set to the
high-water mark of concurrent INSERT or UPDATE activity. For example, if the index has up to 20 end users
performing INSERTSs at any time, then the index should have FREELISTS=20.Too low a value for free lists will
cause poor Oracle performance. An increase in FREELISTS or FREELIST_GROUPS can alleviate segment
header contention.

e Free List Groups: (FREELIST GROUPS) Applicable only if you are using Oracle with the Parallel Server option in
parallel mode. Specifies the number of free list groups which allow the index to have several segment headers.
This enables multiple tasks to insert into the index; thereby alleviating segment header contention. Free list
groups should be set to the number of Oracle Parallel Server instances that access the index. For partitioned
objects and cases of segment header contention, freelist_groups my be set for non-RAC systems.

« Buffer Pool: (BUFFER_POOL) Specifies the memory structure that is used for caching data blocks in memory,
providing faster data access.

« DEFAULT caches data blocks in the default buffer pool.
« KEEP retains the object in memory to avoid 1/O conflicts.

« RECYCLE removes data blocks from memory as soon as they are no longer in use, thereby saving cache
space.

Customizing Table DDL
The options selected in the Table Editor determine the clauses used in the CREATE TABLE and CREATE INDEX
statements. Options on the DDL tab can give you more control over the DDL created.

1 Double-click a table to open the Table Editor.

2 Click the DDL tab and then click Customize.

NOTE: Ifthe DDL is not displaying the options you expect to see, it may be because the relevant options
on the DDL Tab Options dialog have not been selected.

The following describes options that are not self-explanatory:

« Enclose names in quotes/brackets: To avoid object name conflicts, you can enclose in brackets or quotations
all names or enclose only names that conflict with SQL keywords. If the database platform supports object names
enclosed in brackets or quotes, these options are available in the General Options section of the DDL tab
Options and the DDL Generation Wizard. If you select Enclose Names That Conflict with Keywords, then any
column names that contain SQL keywords will be automatically enclosed in brackets.



Creating Indexes

An index is an ordered set of pointers to rows in a base table. Each index is based on the values of data in one or
more table columns. An index is an object that is separate from the data in the table. When an index is created, the
database builds and maintains it automatically. Indexes are used to improve performance; in most cases, access to
data is faster with an index. Although an index cannot be created for a view, an index created for the table on which a
view is based can improve the performance of operations on that view. Indexes are also used to ensure unigueness; a
table with a unique index cannot have rows with identical keys. If Unique is checked or UNIQUE is selected, each row
must have a unique index value. If Unique is unchecked, or NONUNIQUE is selected, rows may have duplicate index
values. Oracle offers a third option, BITMAP, type of index commonly used in data warehousing and other
environments with large amounts of data and ad hoc queries, but a low level of concurrent DML transactions. DB2:
Allow Reverse

Indexes improve performance by providing an efficient mechanism for locating data. Indexes work like a card catalog
in a library: instead of searching every shelf for a book, you can find a reference to the book in the card catalog, which
directs you to the book’s specific location. Logical indexes store pointers to data so that a search of all of the
underlying data is not necessary.

Indexes are one of the most important mechanisms for improving query performance. However, injudiciously using
indexes can negatively affect performance. You must determine the optimal number of indexes to place on a table, the
index type and their placement in order to maximize query efficiency.

Consider the following rules to optimize your indexes:

¢ Index Number—While indexes can improve read (query) performance, they degrade write (insert, update, and
delete) performance. This is because the indexes themselves are modified whenever the data is modified. As a
result, you must be judicious in the use of indexes. If you know that a table is subject to a high level of insert,
update, and delete activity, you should limit the number of indexes placed on the table. Conversely, if a table is
basically static, like most lookup tables, then a high number of indexes should not impair overall performance.

* Index Type—Generally, there are two types of queries: point queries, which return a narrow data set, and range
queries, which return a larger data set. For those databases that support them, clustered indexes are better
suited to satisfying range queries, or a set of index columns that have a relatively low cardinality. Non-clustered
indexes are well suited to satisfying point queries.

¢ Index Placement—AIlmost every SQL database provides some physical storage mechanism for placing tables
and indexes. At a minimum, you should take advantage of this database feature by separating the placement of
tables from their indexes. In this manner, the database can read both the index and the table data in parallel,
leading to faster performance.

In addition to indexing tables, you can also define indexes for auxiliary tables. For more information, see Creating and
Editing Auxiliary Tables.

1 Inthe Diagram Explorer, select a physical data model.

2 Inthe Diagram Window, double-click the table you want to add an index to.
3 Inthe Table Editor, select the Indexes tab.

4 Complete the Index Editor as required and then click OK.

If you change the index options and can see no reflection of the change in the DDL, click

Customize on the DDL tab and ensure the options required to display your changes are selected.

For example, If you create a non-unique index for a MySQL table and turn on full text, you must

customize the DDL by selecting Generate Defined Nonunique Indexes for the index to show up.
The following describes options that are not self-explanatory.

NOTE: The options and tabs available depend on the database platform.

« Set as PK Index: Read-only. If selected, indicates that the index selected is the primary key.



« Unique Constraint: Select to specify that every value in the named column must be unique. Unique constraints
are similar to Primary keys. They require unique values throughout the named column or columns in the table.

« Physical Only: Select to specify that the index be ignored when comparing the physical model to a logical
model.

For information on the various tabs available, click a link below:
¢ Columns tab
e Properties tab

* Options tab

« Storage tab of the Index Editor
« Partitions tab of the Index Editor

« Attachment Bindings tab of the Index Editor

Columns tab

Select the columns or keys, the index should be based on. The efficiency of the index depends upon the keys
chosen and their search order.

Properties tab
This tab is available for Oracle 8.x, 9i, 10g, and 11g.
* Index Type: Select the appropriate index type; it can have a big impact on performance.

« Bitmap: Select for an index that will not be frequently updated by concurrent applications, although be aware
that when applied to the index of a unique column (primary key candidate) you need to consider the space
required, which depends on the cardinality of the column and the data distribution. A bitmap for each key value
is used instead of a list of row IDs.

« B-tree: Select when indexing a primary key, because Oracle does not support primary key indexes, or select
B-tree when space is a consideration. B-tree indexes are balanced to equalize access times to any row.

« Unique: (UNIQUE) If selected, specifies that the index key contains no duplicate values and therefore every row
in the table is in some way unique. If not selected, a non-unique index is created that lets table rows have
duplicate values in the columns that define the index. For a unique index, there is one rowid per data value. If
selected, Oracle will generate a separate unique index before creating the PK constraint.

« No Sort: (NOSORT) If selected, specifies to not sort the data when the index is rebuilt.

* Reverse Byte Order: If selected, reverses the bytes of each column indexed (except the rowid) while keeping
the column order. By reversing the keys of the index, the insertions will be distributed across all leaf keys in the
index.

« Enable Compression: (COMPRESS) Select to enable index compression. Compression can repress duplication
of keys in non-unique indexes. For concatenated indexes (indexes with multiple columns), the compress option
can reduce the size of the index by more than half. For concatenated indexes (indexes with multiple columns),
compression can reduce the size of the index by more than half. The compress option allows you to specify the
prefix length for multiple column indexes.

« Prefix Length: This is the prefix length for multiple column indexes.

« Tablespace: Displays the tablespace on which the table index is stored.

* No Logging: Select, if you do not want the DLL operations to be logged in the redo file. This can reduce index
creation and updates by up to 30%.

* Pct Free: (PCTFREE) Specifies the maximum percentage of space in each data block to reserve for future
updates. This reserved space helps to avoid row migration and chaining caused by an update operation that
extends a data row's length. Tables that won't be updated should have this value set to 0.



Initial Trans: (INITTRANS) Specifies the number of DML transactions for which space is initially reserved in the
data block header. Oracle stores control information in the data block to indicate which rows in the block contain
committed and uncommitted changes. The amount of history that is retained is controlled by this parameter. If too
many transactions concurrently modify the same data block in a very short period, Oracle may not have sufficient
history information to determine whether a row has been updated by a too recent transaction. Initial Transactions
limit the minimum number of concurrent transactions that can update a data block to avoid the overhead of
allocating a transaction entry dynamically. Specify a higher value for indexes that may experience many
transactions updating the same blocks.

Max Trans: (MAXTRANS) Specifies the maximum number of concurrent transactions that can update a data block
to avoid performance problems. Once the space reserved by INITRANS is depleted, space for additional
transaction entries is allocated out of any available free space. Once allocated, this space effectively becomes a
permanent part of the block header. This parameter limits the number of transaction entries that can concurrently
use data in a data block and therefore limits the amount of free space that can be allocated for transaction entries
in a data block.

Parallel: Selects Oracle's parallel query option. You can achieve substantial performance gains by using
Oracle's parallel query option.

« Degrees: Specifies the number of query server processes that should be used in the operation.
¢ Instances: Specifies how you want the parallel query partitioned between the parallel servers.

Initial Extent: (INITEXTENT) Specifies the initial number of data blocks that Oracle should reserve. Oracle will
reserve the number of data blocks that correspond to the initial extent for that table’s rows.

Next Extent: (NEXT) Specifies the size in kilobytes of the next extent. You should monitor this figure against the
largest available chunk of free space in the tablespace. If a table cannot allocate its next extent, it will no longer
be able to extend and, therefore, cannot accept additional data.

Pct Increase: (PCTINCREASE) Specifies the percentage by which the next extent should grow over the previous
extent's size. Be careful when setting Percent Increase because it magnifies how an object grows and, therefore,
can materially affect available free space in a tablespace.

Min Extents: (MINEXTENTS) Specifies the number of extents to allocate when the segment is created. Controls
free space fragmentation by making sure that every used or free extent is at least as large as the value you

specify.

Max Extents: (MAXEXTENTS) Specifies the maximum number of extents that Oracle can allocate to the index.
Once this limit is reached, Oracle prevents further growth of the cluster and cannot accept additional data.
Carefully monitor the number extents already allocated to the index with this limit.

Free Lists: (FREELISTS) Specifies the number of free lists to apply to the table. The default and minimum value
is 1. Free lists can help manage the allocation of data blocks when concurrent processes are issued against the
index. Oracle uses the free list to determine which data block to use when an INSERT operation occurs. Oracle
allows table and indexes to be defined with multiple free lists. All tables and index free lists should be set to the
high-water mark of concurrent INSERT or UPDATE activity. For example, if the index has up to 20 end users
performing INSERTs at any time, then the index should have FREEL 1STS=20.Too low a value for free lists will
cause poor Oracle performance. An increase in FREELISTS or FREELIST GROUPS can alleviate segment
header contention.

Free List Groups: (FREELIST GROUPS) Applicable only if you are using Oracle with the Parallel Server option in
parallel mode. Specifies the number of free list groups which allow the table to have several segment headers.
This enables multiple tasks to insert into the index; thereby alleviating segment header contention. Free list
groups should be set to the number of Oracle Parallel Server instances that access the index. For partitioned
objects and cases of segment header contention, free list groups my be set for non-RAC systems.



Buffer Pools: (BUFFER_POOL) Specifies the memory structure or buffer pool that is used for caching data blocks
in memory, providing faster data access.

« DEFAULT: Caches data blocks in the default buffer pool.
« KEEP: Retains the object in memory to avoid I/O conflicts.

« RECYCLE: Moves data blocks from memory as soon as they are no longer in use, thereby saving cache
space.

Options tab

Options available depend on the database platform selected. For information on the index options available for your
database platform, click a link below:

Hitachi HIRDB Index Options

IBM DB2 for AS/400, Common Server, and UDB Versions 5 through 9 Index Options
IBM DB2 for OS/390 Index Options

Informix Index Options

Interbase Index Options

Microsoft Access and SQL Server Index Options

MySQL Index Options
NCR Teradata Index Options

Oracle 7 Index Options
Postgre SQL Index Options

Sybase Index Options

Hitachi HIRDB Index Options

Unique: (UNIQUE) If selected, specifies that the index key contains no duplicate values and therefore every row
in the table is in some way unique. If not selected, a non-unique index is created that lets table rows have
duplicate values in the columns that define the index.

IBM DB2 for AS/400, Common Server, and UDB Versions 5 through 9 Index Options

Unique: (UNIQUE) If selected, specifies that the index key contains no duplicate values and therefore every row
in the table is in some way unique. If not selected, a non-unique index is created that lets table rows have
duplicate values in the columns that define the index.

Where Not Null: (WHERE_NOT_NULL) If selected, specifies that multiple nulls can exist in a unique index. Useful
when an index contains at least one nillable column, but all non-null entries must be unique.

Cluster: If selected, specifies to create a clustered index. A clustered index specifies that the rows of the table
should be inserted sequentially on data pages, which generally requires less disk 1/O to retrieve the data.
Generally, the clustered index should be on a column that monotonically increases, such as an identity column,
or some other column where the value is increasing, and is unique. This is especially true if the table is subject to
many INSERTS, UPDATES, and DELETES. Clustered indexes can greatly increase access speed, but usually only
where the data is accessed sequentially in the same or reverse order of the clustered index, or when a range of
items are selected.

Percent Free: (PCTFREE) Specifies the maximum percentage of space in each data block to reserve for future
updates. This reserved space helps to avoid row migration and chaining caused by an update operation that
extends a data row's length. Tables that won't be updated should have this value set to 0.

Min Percent Used: (MINPCTUSED) Specifies the minimum amount of used space on an index leaf page. If used,
online index defragmentation is enabled for this index.



Allow Reverse Scans: Specifies that the index be created in a way so that scans can also be performed in the
direction opposite to that with which they were defined.

Include: Specifies additional columns to be appended to the set of index key columns. The included columns
may improve the performance of some queries through index-only access.

IBM DB2 for OS/390 Index Options

Unique: (UNIQUE) If selected, specifies that the index key contains no duplicate values and therefore every row
in the table is in some way unique. If not selected, a non-unique index is created that lets table rows have
duplicate values in the columns that define the index.

Cluster: (CLUSTER) Select to create a clustered index. A clustered index specifies that the rows of the table
should be inserted sequentially on data pages, which generally requires less disk 1/O to retrieve the data.
Generally, the clustered index should be on a column that monotonically increases--such as an identity column,
or some other column where the value is increasing--and is unique. This is especially true if the table is subject to
many INSERTS, UPDATES, and DELETES. Clustered indexes can greatly increase access speed, but usually only
where the data is accessed sequentially in the same or reverse order of the clustered index, or when a range of
items are selected.

NOTE: ForIBM DB2 for 0OS/390 5.x, the Cluster option must be selected to enable the index partitioning
options on the Partitions tab of the Index Editor. For more information, see Patrtitioning a Table
Index.

Where Not Null: (WHERE NOT NULL) Specifies that multiple nulls can exist in a unique index. Useful when an
index contains at least one nillable column, but all non-null entries must be unique.

Concurrent Copy: (COPY) If selected, concurrent copies of the index are allowed, which can increase index
availability by supporting index recovery.

Do Not Close Dataset: (CLOSE) If selected, the index will not be closed when not in use. If not selected, the
dataset can be closed if it's not in use and the maximum number of open datasets is reached or exceeded.

Defer Index Creation: (DEFER) Specifies that index modifications are to be deferred during INSERT, UPDATE,
and DELETE operations. This allows the data updates to complete quicker, but queries may not return the most
up-to-date information until the index is synchronized. This option is not supported for an index on a declared
temporary or auxiliary table.

Padded: (PADDED) If selected, the index entry is padded to the full length of its datatype which makes scanning
the index efficient if most of the index entries are close to or at the maximum length. If not selected, the index
supports true variable length key which allows for shorter indexes and more index entries on each page. It also
allows index-only access. If the index is not padded, data can be retrieved directly from the index without having
to look up the data length in the data page. Not padding the index can be more efficient if you'll save a lot of disk
space by not padding them.

Partitioned: Select if you want to partition the index. Then the options in the Index Partitions Editor accessible
from the Partitions tab become available. For more information, see Patrtitioning a Table Index.

Using Claus: (USING) Specifies what kind of index space is created for the index and who manages the index. If
you don't specify a USING claus, DB2 manages the index space on volumes listed in the default storage group of
the table’s database, which must exist. DB2 uses the defaults values PRIQTY, SECQTY, and Erase Data.

VCAT: (VCAT) If selected, allocates space for the index on a data set managed using the virtual catalog (VCAT)
whose name is specified next to this option, and the user manages the data sets required for the index. The
VCAT method is usually used for defining system catalogs. It requires that the VSAM dataset be pre-defined
before the index space is created.



« STOGROUP: (STOGROUP) If selected, stores the index on a data set managed by DB2 in the named storage
group. Stogroup defined index spaces let DB2 do all the VSAM allocation work for you. If you have created a
Stogroup for the data model, using the Stogroup Editor (see Creating and Editing StoGroups), you can select that
Stogroup from the list. If you select Stogroup, you can also define values for PRIQTY and SECQTY. To prevent
wasted space for non-partitioned indexes, you should not define PRIQTY and SECQTY; instead let DB2 manage
the amount of primary and secondary space allocated for the index.

¢ PRIQTY:(PRIQTY) Specifies the minimum number of disk space in kilobytes to initially allocate for the index.
The primary allocation should be large enough to handle the storage needs that you anticipate.

*« SECQTY: (SECQTY) Specifies the amount of disk space in kilobytes to allocate to the index when it reaches
the size of the primary allocation. If the secondary allocation space is too small, the data set might have to be
extended more times to satisfy those activities that need a large space. The default value of -1 indicates that
DB2 should determine the size of the secondary allocation, which is usually 10% of the primary allocation.

« Erase Data: (ERASE) If selected, specifies to erase the index data set when the index is deleted.
* None: If selected, no USING claus is included in the CREATE INDEX statement.

« Buffer Pool: (BUFFERPOOL) Identifies the buffer pool to be used for the index. The buffer pool used determines
how the data blocks are cached in memory, in order to facilitate faster data access. BPO is the default buffer pool
for sorting.

« Percent Free: (PCTFREE) Specifies the maximum percentage of space in each data block to reserve for future
updates. This reserved space helps to avoid row migration and chaining caused by an update operation that
extends a data row's length. Tables that won't be updated should have this value set to 0.

* Free Page: (FREEPAGE) Specifies how often to leave a page of free space when index entries are created. One
free page is left for every number of pages specified here in the range of 0 to 255.

* Piece Size: (PIECESIZE) Specifies the maximum addressable space of each data set for a secondary index.
Specify the size followed by K (kilobyte), M (Megabyte), of G (Gigabyte). If you don’t specify the unit of measure,
kilobytes is assumed. Sizes specified in gigabytes are converted to megabytes in the DDL.

« GBP Cache: (GPBCACHE) In a data sharing environment, specifies what index pages are written to the group
buffer pool. This option is ignored in a non-data-sharing environment unless the index is on a declared temporary
table. Specify Changed to write updated pages to the group buffer pool, All to cache all pages to the group buffer
pool as they are read in from DASD or None to indicate that the buffer pool is only to be used for
cross-invalidation.

Informix Index Options

* Unique: (UNIQUE) If selected, specifies that the index key contains no duplicate values and therefore every row
in the table is in some way unique. If not selected, a non-unique index is created that lets table rows have
duplicate values in the columns that define the index.

¢ Cluster: (CLUSTER) Select to create a clustered index. A clustered index specifies that the rows of the table
should be inserted sequentially on data pages, which generally requires less disk 1/0O to retrieve the data.
Generally, the clustered index should be on a column that monotonically increases--such as an identity column,
or some other column where the value is increasing--and is unique. This is especially true if the table is subject to
many INSERTS, UPDATES, and DELETES. Clustered indexes can greatly increase access speed, but usually only
where the data is accessed sequentially in the same or reverse order of the clustered index, or when a range of
items are selected.

Interbase Index Options

« Unique: (UNIQUE) If selected, specifies that the index key contains no duplicate values and therefore every row
in the table is in some way unique. If not selected, a non-unique index is created that lets table rows have
duplicate values in the columns that define the index.

« Sort Order: Specify the sort order of the index, Ascending (ASC) or Descending (DESC) .



Microsoft Access and SQL Server Index Options

The options available depend on the database platform and version.

Unique: (UNIQUE) If selected, specifies that the index key contains no duplicate values and therefore every row
in the table is in some way unique. If not selected, a non-unique index is created that lets table rows have
duplicate values in the columns that define the index.

Clustered: (CLUSTERED or NONCLUSTERED) Select to create a clustered index. A clustered index specifies that
the rows of the table should be inserted sequentially on data pages, which generally requires less disk 1/O to
retrieve the data. Generally, the clustered index should be on a column that monotonically increases, such as an
identity column, or some other column where the value is increasing, and is unique. This is especially true if the
table is subject to many INSERTS, UPDATES, and DELETES. Clustered indexes can greatly increase access
speed, but usually only where the data is accessed sequentially in the same or reverse order of the clustered
index, or when a range of items are selected. If the index is not unique and the Clustered option is selected, the
Non-Unigue Clustered Options become available.

Ignore Dup Keys: (IGNORE_DUP_KEY) Specifies that if you attempt to create duplicate keys by adding or
updating data that affects multiple rows (with the INSERT or UPDATE statement), the row that causes the
duplicates is not added or, in the case of an update, is discarded.

Sorted Data: (SORTED_DATA) Specifies to sort the data when the index is rebuilt.

Non-Unique Clustered Options: Specifies the action to take when a duplicate row is added.

MySQL Index Options

Unique: (UNIQUE) If selected, specifies that the index key contains no duplicate values and therefore every row
in the table is in some way unique. If not selected, a hon-unique index is created that lets table rows have
duplicate values in the columns that define the index.

Fulltext: Lets you set the index as a full-text index. Full-text indexes in MySQL are an index of type FULLTEXT.
FULLTEXT indexes are used with MyISAM tables only and can be created from CHAR, VARCHAR, or TEXT
columns at CREATE TABLE time or added later with ALTER TABLE or CREATE INDEX.

NCR Teradata Index Options

Unique: (UNIQUE) If selected, specifies that the index key contains no duplicate values and therefore every row
in the table is in some way unique. If not selected, a non-unique index is created that lets table rows have
duplicate values in the columns that define the index.

Primary: (PRIMARY) If selected, specifies that this index is the primary index. If you do not define a primary
index, by default the first column in the table becomes the primary index in the table.

Partitioning Expression: (PARTITION BY expression) Available if you selected Primary. Enter an expression to
partition the data by a particular attribute, such as date by week, for some time. Partitioning the data enables you
to more efficiently retrieve summarized data for a particular week because you only have to read the data for that
week. Good candidates for a Partitioned Primary Index are tables where there is a high volume of daily inserts,
so there is a bias toward partitioning on the data date. Partitioning an index by product_code or agent_id can also
improve some queries. If you need more space than available in the text box to enter your expression, click More
to launch the Partition Expression Editor where you can input a multi-line expression. The following is an example
of a partitioning expression:

PARTITION BY RANGE_N(CAPTURE_DATE BETWEEN DATE "2007-11-30" AND DATE "2008-2-30"
EACH INTERVAL "1° MONTH)

Oracle 7 Index Options

Unique: (UNIQUE) If selected, specifies that the index key contains no duplicate values and therefore every row
in the table is in some way unique. If not selected, a non-unique index is created that lets table rows have
duplicate values in the columns that define the index.

No Sort: (NOSORT) If selected, specifies to not sort the data when the index is rebuilt.



Postgre SQL Index Options

Unique: (UNIQUE) If selected, specifies that the index key contains no duplicate values and therefore every row
in the table is in some way unique. If not selected, a non-unique index is created that lets table rows have
duplicate values in the columns that define the index.

Clustered: (CLUSTER) Select to create a clustered index. A clustered index specifies that the rows of the table
should be inserted sequentially on data pages, which generally requires less disk 1/O to retrieve the data.
Generally, the clustered index should be on a column that monotonically increases, such as an identity column,
or some other column where the value is increasing, and is unique. This is especially true if the table is subject to
many INSERTS, UPDATES, and DELETES. Clustered indexes can greatly increase access speed, but usually only
where the data is accessed sequentially in the same or reverse order of the clustered index, or when a range of
items are selected.

Sybase Index Options

The options available depend upon the database platform version.

Unique: (UNIQUE) If selected, specifies that the index key contains no duplicate values and therefore every row
in the table is in some way unique. If not selected, a non-unique index is created where table rows can have
duplicate values in the columns that define the index.

Type: Sybase 1Q uses HG or LF indexes to generate better or faster query plans to execute the query. The HG or
LF index may also be appropriate for a DATE, TIME, DATET IME, or TIMESTAMP column, if you are evaluating
equality predicates against the column. An LF index is also recommended, if you frequently use the column in the
GROUP BY clause and there are less than 1000 distinct values, for example, less than three years of dates.

¢ HG: Use an HG (High Group) index when the column will be used in a join predicate or the column has more
than 1,000 unique values. The High_Group index is commonly used for join columns with integer data types
because it handles GROUP BY efficiently. Each foreign key columns requires its own HG index; however, if a
join index exists, the same column cannot have both an explicitly created HG index and a foreign key
constraint.

e LF: LFis the fastest index in Sybase 1Q. Use an LF (Low Fast) index when a column has less than 1,000
unique values or a column has less than 1,000 unique values and is used in a join predicate. This index is
ideal for columns that have a few unique values (under 1,000) such as sex, Yes/No, True/False, number of
dependents, and wage class.Never use an LF index for a column with 10,000 or more unique values. If the
table has less than 25,000 rows, use an HG index, which requires fewer disk 1/O operations for the same
operation.

Clustered: (CLUSTER) Select to create a clustered index. A clustered index specifies that the rows of the table
should be inserted sequentially on data pages, which generally requires less disk I/O to retrieve the data.
Generally, the clustered index should be on a column that monotonically increases, such as an identity column,
or some other column where the value is increasing, and is unique. This is especially true if the table is subject to
many INSERTS, UPDATES, and DELETES. Clustered indexes can greatly increase access speed, but usually only
where the data is accessed sequentially in the same or reverse order of the clustered index, or when a range of
items are selected.

Ignore Dup Keys: (IGNORE_DUP_KEY) Specifies that if you attempt to create duplicate keys by adding or
updating data that affects multiple rows (with the INSERT or UPDATE statement), the row that causes the
duplicates is not added or, in the case of an update, is discarded.

Sorted or Sorted Data: (SORTED_DATA) Specifies to sort the data when the index is rebuilt.



¢ Non-Unique Clustered Options: Choose how you want to handle duplicate rows.

e Ignore Dup Rows: (IGNORE_DUP_ROW) Eliminates duplicate rows from a batch of data and cancels any insert
or update that would create a duplicate row, but does not roll back the entire transaction.

¢ Allow Dup Rows: (ALLOW_DUP_ROW) Allows you to create a new, non-unique clustered index on a table that
includes duplicate rows. If a table has a non-unique clustered index that was created without the
allow_dup_row option, you cannot create new duplicate rows using the insert or update command.

« None: If neither Ignore Dup Rows or Allow Dup Rows has been selected, when you attempt to create an index
on a table that has duplicate rows the creation fails, and the insertion fails If you try to insert a duplicate row to
an indexed table.

Storage tab of the Index Editor

Lets you select various storage options depending upon the selected database platform. For more information,
see Defining Index Storage.

Partitions tab of the Index Editor

Lets you select various storage options depending upon the selected database platform. For more information,
see Partitioning a Table Index.

Compare Options tab
Select the differences you want the Compare and Merge Utility to ignore.
Attachment Bindings tab of the Index Editor

Lets you bind an external piece of information, or attachment to the index. You can also remove an attachment
from an object, override an attachment binding’s default value, or change a bound attachment’s position. To
override the value of the attachment you have moved to the Selected Attachments grid, double-click the Value
field of the target attachment. ER/Studio opens the Value Override Editor or a list depending on the attachment
datatype. Attachments are created in the Attachments folder of the Data Dictionary. For more information, see

Attaching External Documents to the Data Model.

Creating Relationships
For information on creating relationships between tables, see Creating Relationships.

Creating/Editing Database Dependent Objects

The availability of many physical data model objects depends on the database platform selected. For more
information, see the following topics:

Creating and Editing Aliases Creating and Editing Rollback Segments
Creating and Editing Auxiliary Tables Creating and Editing Node Groups
Creating and Editing Buffer Pools Creating and Editing Rollback Segments
Creating and Editing DataBases Creating and Editing Sequences

Creating and Editing SQL Procedures Creating and Editing StoGroups

Creating and Editing Materialized Views  Creating and Editing Synonyms

Creating and Editing Node Groups Creating and Editing Tablespaces
Creating and Editing Object Types Creating and Editing Database Schemas

Creating and Editing Packages Creating and Editing Database Schemas



Creating and Editing Aliases

An alias is an alternate name for an alias, synonym, table, view or for another undetermined object type. (You can only
create an Alias for a synonym on the IBM DB2 for OS/390 or z/OS platforms.) An alias can provide a more meaningful
object name for the target audience. An alias can also act as a low-overhead view. Table aliases may refer to each
other in a process called chaining. Aliases let you assign the permissions of a database user to an object without
creating a separate user entity or masking a user’s identity.

The following database platforms support Aliases:
e IBM DB2 for LUW 5.%, 6., 7.X, 8.X, 9.X
* |BM DB2 for OS/390 5.x and 6.x
* |BM DB2 for z/OS 7.x, 8., and 9.x

NOTE: The DB2 Alias Wizard and DB2 Alias Editor share the same options, except for Attachment
Bindings options which are present only in the editor.

Create an Alias

1 Inthe Diagram Explorer, expand the Physical Main Model, right-click the Aliases node, and then select New
Alias.

2 Complete the DB2 Alias Wizard and then click Finish to create the alias.
Once you've created the alias, you can edit it by right-clicking the alias you want to change, and
then selecting Edit Alias.
The following describes options that are not self-explanatory.
Name page/tab
Enter the name of alias and its owner.

« The alias name is the fully-qualified name of the alias and must not be the same as any table, view, alias, or
synonym on the current server.

e The owner name is the user ID for the owner of the alias. This name is the authorization ID that qualifies the
alias.

Reference page/tab

Select the type of object you want to reference. If there are any objects in the model that match your selection,
you can click the identifier list to choose the appropriate identifier.

Definition page/tab

Enter or edit a definition for the alias. If the target database supports it, ER/Studio adds this definition as a
comment when generating SQL code. The maximum length of comments in the DDL is 254 characters.

DDL page/tab

Displays the CREATE ALIAS statement needed to build the alias. ER/Studio uses the platform-specific parser of
the model’s selected database platform to generate the alias.



Attachment Bindings tab

Lets you bind an external piece of information, or attachment to the alias. You can also remove an attachment
from an object, override an attachment binding’s default value, or change a bound attachment'’s position. To
override the value of the attachment you have moved to the Selected Attachments grid, double-click the Value
field of the target attachment. ER/Studio opens the Value Override Editor or a list depending on the attachment
datatype. Attachments are created in the Attachments folder of the Data Dictionary and must be applied to the
alias before they will display on this tab. For more information, see Attaching External Documents to the Data
Model.

Creating and Editing Auxiliary Tables

Auxiliary Tables are created to store the data of large object (LOB) Columns. LOB Columns are columns in a regular
table, called the Base Table, whose data type is BLOB or CLOB and whose data is large objects. Since the data is
very large, it is not stored with the other data in the table. Even though the base table holds the LOB Column logically,
as a VARCHAR(4), the LOB Column'’s data is physically stored in the auxiliary table. Each LOB Column has at least
one auxiliary table associated with it. Either one auxiliary table for each LOB Column of a non-partitioned table, or one
auxiliary table for each LOB Column for each partition, if the LOB Column is defined in a partitioned base table. For
example, if you have two LOB Columns in a Base Table with four partitions, you must also have a total of eight
auxiliary tables.

NOTE: You must store Auxiliary tables each in their own auxiliary tablespaces, and you must create a
unigue index on them.
The following database platforms support auxiliary tables:
e IBM DB2 for OS/390 5.x and 6.x
* |BM DB2 for z/OS 7., 8.x, and 9.x

NOTE: The Auxiliary Table Wizard and Auxiliary Table Editor share the same options, except for
Attachment Bindings options which are present only in the editor.

Add an Auxiliary Table

1 Inthe Diagram Explorer, expand the Physical Main Model, right-click the Auxiliary Tables node, and then
select New Auxiliary Table.

2 Complete the Auxiliary Tables Wizard and then click Finish to create the auxiliary table.
Once you've created the auxiliary table, you can edit it by right-clicking the auxiliary table you want
to change, and then selecting Edit Auxiliary Table.
The following describes options that are not self-explanatory.
Name page/tab
Enter the name of auxiliary table and its owner.

« The table name is the fully-qualified name of the auxiliary table and must not be the same as any table, view,
alias, or synonym on the current server.

« The owner name is the name of the owner of the base table whose column you want to store in the auxiliary
table. This name is the authorization ID that qualifies the table name. If not specified, the DBS subsystem user
identifier for the connection used to create the database is used.



Base Table page/tab

The base table identifier is the name of the base table whose column you want to store in the auxiliary table. The
auxiliary table is created to hold the data of a LOB column. The LOB column logically belongs to a regular table,
called the base table. However, because its data is too large to physically stored in the base table, the LOB
column data is physically stored in the auxiliary table. The base table identifier is also made up of owner name,
dot, table name. The drop-down list displays the name of all tables in the model that have tables defined with
BLOB or CLOB columns. The base table identifier is optional ER/Studio, but required for a valid CREATE AUX
TABLE SQL statement.

You must have one auxiliary table per LOB column for a non-partitioned base table. However, if a LOB Column is
defined in a partitioned base table, then each LOB column must have a separate auxiliary table for each partition
in the base table. The drop-down list displays the name of all columns in the selected base table that are defined
as BLOB or CLOB datatypes. The LOB column name is optional ER/Studio, but required for a valid CREATE AUX
TABLE SQL statement.

When creating an auxiliary table for a partitioned table, you can specify the number of the partition whose data
you want to store. This is only valid for LOB Columns defined in base tables stored in partitioned tablespaces.

Storage page/tab

If you have any defined databases in the model, you can click the list and select the database where the auxiliary
table will be created. For more information, see Creating and Editing DataBases.

Each auxiliary table must be defined in its own tablespace; i.e. you must have exactly one tablespace per
auxiliary table. The tablespace name can be qualified with the database name in which the tablespace resides.
Together the database.tablespace make up the tablespace identifier. The tablespace name is optional
ER/Studio, but required for a valid CREATE AUX TABLE SQL statement. For more information, see Creating and
Editing Tablespaces.

Each auxiliary table requires a Unique Index.

Index Options page/tab

Concurrent Copy: (COPY) If selected, concurrent copies of the index are allowed, which can increase index
availability by supporting index recovery.

Do Not Close Dataset: (CLOSE) If selected, the index will not be closed when not in use. If not selected, the
dataset can be closed if it's not in use and the maximum number of open datasets is reached or exceeded.

None: If selected, no USING clause is included in the CREATE INDEX statement.

VCAT: (VCAT) If selected, allocates space for the index on a data set managed using the virtual catalog (VCAT)
whose name is specified next to this option, and the user manages the data sets required for the index. The VCAT
method is usually used for defining system catalogs. It requires that the VSAM dataset be pre-defined before the
index space is created.

STOGROUP: (STOGROUP) If selected, stores the index on a data set managed by DB2 in the named storage
group. Stogroup defined index spaces let DB2 do all the VSAM allocation work for you. If you have created a
Stogroup for the data model, using the Stogroup Editor (see Creating and Editing StoGroups), you can select that
Stogroup from the list. If you select STOGROUP, you can also define values for PRIQTY and SECQTY. To prevent
wasted space for non-partitioned indexes, you should not define PRIQTY and SECQTY; instead let DB2 manage
the amount of primary and secondary space allocated for the index.

« PRIQTY:(PRIQTY) Specifies the minimum number of disk space in kilobytes to initially allocate for the index.
The primary allocation should be large enough to handle the storage needs that you anticipate.

*« SECQTY: (SECQTY) Specifies the amount of disk space in kilobytes to allocate to the index when it reaches
the size of the primary allocation. If the secondary allocation space is too small, the data set might have to be
extended more times to satisfy those activities that need a large space. The default value of -1 indicates that
DB2 should determine the size of the secondary allocation, which is usually 10% of the primary allocation.

Erase Data: (ERASE) If selected, specifies to erase the index data set when the index is deleted.



« Buffer Pool: (BUFFERPOOL) Identifies the buffer pool to be used for the index. The buffer pool used determines
how the data blocks are cached in memory, in order to facilitate faster data access. BPO is the default buffer pool
for sorting.

« Percent Free: (PCTFREE) Specifies the maximum percentage of space in each data block to reserve for future
updates. This reserved space helps to avoid row migration and chaining caused by an update operation that
extends a data row's length. Tables that won't be updated should have this value set to 0.

* Free Page: (FREEPAGE) Specifies how often to leave a page of free space when index entries are created. One
free page is left for every number of pages specified here in the range of 0 to 255.

* Piece Size: (PIECESIZE) Specifies the maximum addressable space of each data set for a secondary index.
Specify the size followed by K (kilobyte), M (Megabyte), of G (Gigabyte). If you don’t specify the unit of measure,
kilobytes is assumed. Sizes specified in gigabytes are converted to megabytes in the DDL.

« GBP Cache: (GPBCACHE) In a data sharing environment, specifies what index pages are written to the group
buffer pool. This option is ignored in a non-data-sharing environment unless the index is on a declared temporary
table.

¢ Changed: Writes updated pages to the group buffer pool.
« All: Caches all pages to the group buffer pool as they are read in from DASD.
« None Uses the buffer pool only for cross-invalidation.

Definition page/tab

Enter or edit a definition for the auxiliary table. If the target database supports it, ER/Studio adds this definition as
a comment when generating SQL code.

DDL page/tab

Displays the CREATE AUXILIARY TABLE.statement needed to build the auxiliary table. ER/Studio uses the
platform-specific parser of the model's selected database platform to generate the auxiliary table.

Attachment Bindings tab:

Lets you bind an external piece of information, or attachment to the auxiliary table. You can also remove an
attachment from an object, override an attachment binding’s default value, or change a bound attachment'’s
position. To override the value of the attachment you have moved to the Selected Attachments grid, double-click
the Value field of the target attachment. ER/Studio opens the Value Override Editor or a list depending on the
attachment datatype. Attachments are created in the Attachments folder of the Data Dictionary. For more

information, see Attaching External Documents to the Data Model.

See Also
Creating and Editing Tablespaces

Creating and Editing Buffer Pools

The buffer pool is a memory structure that can cache data blocks in memory, providing faster data access by retaining
the object in memory to avoid I/O conflicts or remove data blocks from memory as soon as they are no longer in use,
thereby saving cache space. You can choose to use the buffer pool to store indexes and tables for many different
database platforms.

The default page size of a buffer pool is the size specified when the database was created unless you explicitly specify
another page size. Pages can be ready into a buffer pool only if the table space page size is the same as the buffer
pool page size, so ensure the buffer pool page size matches that of the table space.



The following database platforms support buffer pool creation.
« |BM DB2 for LUW 5.x, 6.X, 7.X, 8.X, 9.X

NOTE: The Bufferpool Wizard and Bufferpool Editor share the same options, except for Attachment
Bindings options which are present only in the editor.

Create a Buffer Pool

1 Inthe Diagram Explorer, expand the Logical Main Model, right-click the Buffer Pools node, and then click New
Bufferpool.

2 Complete the Bufferpool Wizard and then click Finish to create the buffer pool.
Once you've created the auxiliary table, you can edit it by right-clicking the auxiliary table you want
to change, and then selecting Edit Auxiliary Table.
The following describes options that are not self-explanatory.
Name page/tab
« Specify the size of the buffer pool in the number of pages. If you don'’t specify the size, the default size is -1.
« Click the list to specify the size of the pages for the buffer pool in Kilobytes.

« Extended Storage: Select to use extended storage on unix systems, then if the pages requested are not in the
buffer pool, they can be accessed from extended storage, which can be faster than reading the pages from disk.
This option is ignored in IBM DB2 for LUW version 9 and later.

NOTE: Ensure your system has enough real memory for all the buffer pools, in addition to the memory
required for the database manager and application.
Nodes page/tab
In version 9, IBM started using DBPARITITOINNUM instead of NODE.
Definition page/tab

Enter or edit a definition for the buffer pool. If the target database supports it, ER/Studio adds this definition as a
comment when generating SQL code.

DDL page/tab

Displays the CREATE BUFFERPOOL statement needed to build the buffer pool. ER/Studio uses the
platform-specific parser of the model’s selected database platform to generate the buffer pool.

Attachment Bindings tab

Lets you bind an external piece of information, or attachment to the buffer pool. You can also remove an
attachment from an object, override an attachment binding’s default value, or change a bound attachment'’s
position. To override the value of the attachment you have moved to the Selected Attachments grid, double-click
the Value field of the target attachment. ER/Studio opens the Value Override Editor or a list depending on the
attachment datatype. Attachments are created in the Attachments folder of the Data Dictionary. For more
information, see Attaching External Documents to the Data Model.

Creating and Editing DataBases

Databases are DB2 structures such as collections of tables with associated indexes, as well as the tablespaces and
index spaces that contain them. Using databases for administration, you can limit access to the data in the database
in one operation, or give authorization to access the data as a single unit.



When you create a database the following tasks are performed:

« System catalog tables required by the database are setup.

« The database recovery log is allocated.

« The database configuration file is created and the default values are set.

* The database utilities are bound to the database.
Before creating the database, ensure you have considered the contents, layout, potential growth and usage.
The following database platforms support database creation:

* |BM DB2 for OS/390 5.x and 6.x

« IBM DB2 for z/OS 7.x, 8.x, and 9

NOTE: The Database Wizard and Database Editor share the same options, except for Attachment
Bindings options which are present only in the editor.

Add a Database

1 Inthe Diagram Explorer, expand a physical model, right-click the Databases node, and then click New
Database.

2 Complete the Database Wizard and then click Finish to create the database.

Once you've created the auxiliary table, you can edit it by right-clicking the auxiliary table you want
to change, and then clicking Edit Auxiliary Table.

The following describes options that are not self-explanatory:
Name & Type page/tab

Name the database and specify the type. The database cannot already exist on the current server. The name
must not start with DSNDB, unless it's a workfile database and must not start with DSN followed by five digits.
Select WorkFile Database (AS WORKFILE) if the database operates in a data sharing environment and you are
creating a database that will be used for purposes such as managing the data of temporary tables, storing
intermediate SQL results, created global and temporary tables. If you choose to create a WorkFile Database,
you must also specify the member or DB2 subsystem that can use the workfile. Only one member of the data
sharing group can use this workfile.

Option page/tab
To make the database easier to manager, keep work files in a separate buffer pool.

« Tablespace and index buffer pools: (BUFFERPOOL and INDEXBP) Identifies the buffer pools to be used. The
buffer pool used determines how the datablocks are cached in memory, in order to facilitate faster data access.
BPO is the default buffer pool for sorting.

« Storage Group: (STOGROUP) If selected, stores the index on a data set managed by DB2 in the named storage
group. Stogroup defined index spaces let DB2 do all the VSAM allocation work for you. If you have created a
Stogroup for the data model, using the Stogroup Editor (see Creating and Editing StoGroups), you can select that
Stogroup from the list. If you select Stogroup, you can also define values for PRIQTY and SECQTY. To prevent
wasted space for non-partitioned indexes, you should not define PRIQTY and SECQTY; instead let DB2 manage
the amount of primary and secondary space allocated for the index.

« Encoding Scheme: (CCSID) Specifies the encoding scheme: ASCI1 1, EBCDIC, UNICODE or the system installed
default. This is not valid if this database is to be used as a work file in a data sharing environment. If you do not
want to use the default encoding scheme that was selected when you installed DB2 for OS/390 and z/OS, you
can override your installation selection here. You cannot specify an encoding scheme for a workfile database.



Definition page/tab

Enter or edit a definition for the database. If the target database supports it, ER/Studio adds this definition as a
comment when generating SQL code.

DDL page/tab

Displays the CREATE DATABASE statement needed to build the database. ER/Studio uses the platform-specific
parser of the model's selected database platform to generate the database.

Attachment Bindings tab

Lets you bhind an external piece of information, or attachment to the data base. You can also remove an
attachment from an object, override an attachment binding’s default value, or change a bound attachment'’s
position. To override the value of the attachment you have moved to the Selected Attachments grid, double-click
the Value field of the target attachment. ER/Studio opens the Value Override Editor or a list depending on the
attachment datatype. Attachments are created in the Attachments folder of the Data Dictionary. For more

information, see Attaching External Documents to the Data Model.

Creating and Editing SQL Procedures

SQL procedures are reusable blocks of PL/SQL that you create, which are stored in the database. Applications can
call procedures to streamline code development, debugging, and maintenance. Procedures can also enhance
database security by letting you write procedures granting users execution privileges to tables rather than letting them
access tables directly.

Stored procedures can contain program flow, logic, and database queries. They can accept and generate parameters,
return single or multiple result sets, and return values.

In addition to doing anything that can be accomplished with SQL statements, stored procedures can also:

Execute a series of SQL statements in a single stored procedure.
Reference other stored procedures, which can simplify a series of complex statements.

Execute faster than individual SQL statements because the stored procedure is compiled on the server when it is
created.

Be cached in memory, for faster execution.

There are several ways that you can implement SQL procedures:

SQL that runs before or after creating an object. For more information, see Creating and Editing PreSQL and

PostSQL for the CREATE TABLE Statement

Scripted and templated procedures that can store application code into the database for all applications to used
via the CALL statement. For more information, see Creating and Editing Procedures.

Scripted and templated triggers that enforce referential integrity rules; enforce business rules on table data;
synchronize information in another table when a table is updated; initiate an action external to the DBMS when an
update occurs; and prevent some types of operations, such as UPDATESs. For more information, see Creating

and Editing Triggers.

Functions that can execute multiple SQL statements from within an SQL statement. For more information, see
Creating and Editing Functions.

Packages that can store together all the code necessary to process SQL statements from a single source file.
You can use packages to process and call batches of SQL. For more information, see Creating and Editing

Packages.



Creating and Editing PreSQL and PostSQL for the CREATE TABLE Statement
In the PreSQL & PostSQL tab of the Table Editor you can enter SQL procedures to be applied before and after the
CREATE TABLE statement.

NOTE: The SQL in the procedure will be validated in context of the table selected and the database
platform.

1 Inthe Diagram Window or Diagram Explorer, double-click a table to launch the Table Editor.
2 Click the PreSQL & PostSQL tab.
3 Enter or edit an SQL procedure to run before the CREATE TABLE statement.

4 Click the PostSQL tab and then enter or edit an SQL procedures to run before the CREATE TABLE statement.

5 Click OK to implement the changes and exit the editor.

Creating and Editing Procedures

Procedures are reusable blocks of PL/SQL, stored in the database, that applications can call. Procedures streamline
code development, debugging and maintenance by being reusable. Procedures can enhance database security by
letting you write procedures granting users execution privileges to tables rather than letting them access tables
directly. Also, procedures can increase the efficiency of your database. They can consolidate and centralize logic that
might otherwise have existed in multiple applications that access the same database, making the code easier to
maintain. Since only the procedure executable is stored on the server, decreasing its storage requirements, and the
procedure is executed on the server, reducing network traffic.

Procedures are similar to functions except that functions can be used within SQL statements, whereas procedures
must be invoked using the CALL statement.

ER/Studio supports the following procedure types:

* Regular or scripted procedures: Specific to the table on which they are created. You can write scripted
procedures in SQL You can create a scripted procedure through the Table Editor - Dependencies Tab or though
the Procedure SQL Editor, which you can access by double-clicking the procedure name in the Procedures node
of the Data Model Explorer.

« Templated Procedures: Specific to the table on which they are created or modified. You can write templated
procedures in BASIC. Once created, they do not appear in the list of procedures on the Procedures node of the
Diagram Explorer.

* Reusable procedures: Created in the data dictionary, reusable procedures can become templated if they are
modified through the Table Editor. You can write templated procedures in BASIC. Reusable procedures are
templated procedures written in BASIC code. These procedures can be applied to any table, since they use the
table’s context in the code. The Reusable Procedure node in the Data Dictionary includes DBMS platform nodes.
ER/Studio organizes reusable procedures by platform. When you want to create, edit, or delete a reusable
procedure, right-click the target DBMS node and then click the appropriate short cut menu.

The following database platforms support Procedures:
« IBM DB2 for LUW 5.%, 6., 7.X, 8.x, and 9.x
* Microsoft Access 6.x and 7.x
« Microsoft SQL Server 6.x, 7.x, 2000, 2005, and 2008
« Oracle 7.x, 8.x, 9i, 10g, and 11g
* Sybase ASA 6.0, 7.0, 8.0, 9.0, Adaptive Server 1Q 12.

* Sybase Adaptive Server 1Q 12.



e Sybase ASE 11.0, 11.5, 11.9, 12.0, 12.5, and 15

The Northwind.dml sample model illustrates how procedures can be used to gather
information and perform computations on them to provide summary information.

Notes
« You can view the templated procedures associated with a table on the Dependencies tab of the Table Editor.

« You can view the scripted procedures you create under the Procedures tab of the node.

Create a Scripted Procedure

1 Inthe Diagram Explorer, expand the physical Main Model, right-click the Procedures node, and then click New
Procedure.

2 Complete the Procedure SQL Editor and then click Validate to ensure the SQL is valid.
3 Click OK to create the procedure and exit the editor.
Once you've created the auxiliary table, you can edit it by right-clicking the auxiliary table you want
to change, and then selecting Procedure.
The following describes options that are not self-explanatory.
SQL page/tab
Enter the SQL for the procedure.
Description page/tab

Enter or edit a definition for the procedure. If the target database supports it, ER/Studio adds this definition as a
comment when generating SQL code.

Permissions page/tab

Sets access roles and user permissions for the procedure. Keep in mind that the more specific permissions are,
the more time you may have to spend maintaining and updating them. The roles and users must be previously
assigned to appear in the Procedure Editor. For more information, see Granting and Revoking Permissions to
Modify Database Objects, Creating and Editing Database Roles, and Creating and Editing Database Users.

Attachment Bindings tab

Lets you bind an external piece of information, or attachment to the procedure. You can also remove an
attachment from an object, override an attachment binding’s default value, or change a bound attachment'’s
position. To override the value of the attachment you have moved to the Selected Attachments grid, double-click
the Value field of the target attachment. ER/Studio opens the Value Override Editor or a list depending on the
attachment datatype. Attachments are created in the Attachments folder of the Data Dictionary. For more

information, see Attaching External Documents to the Data Model.

Apply a scripted procedure to a submodel or model

You can copy a scripted procedure to from a submodel to the physical model or to one or more submodels using
the Apply to Submodel(s) command. For more information, see Copying a Database Object to a Submodel
(Apply to Submodel).



Create Reusable Procedure

Reusable procedures are maintained in the database and can save you time because they don't have to be
recreated for every database application in which you want to use the procedure.

Reusable user-defined procedures are created in the Data Dictionary. For more information, see Reusing
Procedural Logic

Create a Scripted User-Defined Procedure
NOTE: The SQL in the procedure will be validated in context of the table selected.

1 Inthe Diagram Window or Diagram Explorer, double-click a table to launch the Table Editor.

2 Click the PreSQL & PostSQL tab.

3 Enter or edit an SQL procedure to run before the CREATE TABLE statement.

4  Click the PostSQL tab and then enter or edit an SQL procedures to run before the CREATE TABLE statement.

5 Click OK to implement the changes and exit the editor.

Create a Templated User-Defined Procedure

The Templated Procedure Editor lets you create or edit a reusable procedure. Templated procedures are
specific to the specific table on which they are created or modified. Reusable procedures created in the data
dictionary can become templated if they are modified through the Table Editor. You can write templated
procedures in BASIC.

Notes
¢ The Templated Procedure Editor includes find and replace functionality for working with SQL text strings.

« Templated procedures are different from scripted procedures in that they are reusable.
* You can only access the Templated Procedure Editor from the Dependencies tab of the Table Editor.

* Procedures are considered to be data model schema, along with packages, functions, materialized views,
auxiliary tables, synonyms, and triggers.

The schema objects tab of the options editor allows you to set default trigger actions for Parent and Child actions. It
also enables you to apply default triggers to tables when relationships are created.

Bind a Reusable Procedure to a Table

Once you have defined the reusable procedure in the Data Dictionary, you can drag the procedure from the Reusable
Procedural Logic node in the Data Dictionary onto a table in the Data Model Window. This binds the procedure to the
table. You can see any bound procedures on the Dependencies tab of the Table Editor.

Create an SQL Procedure

1 Inthe Diagram Explorer, expand the Physical Main Model, right-click the Procedures node, and then click New
Procedure.

2 Complete the Procedure SQL Editor and then click OK to create the procedure.

Once you've created the SQL procedure, you can edit it by right-clicking the procedure you want
to change, and then selecting Edit SQL Procedure.

The following describes options that are not self-explanatory.



Description tab

Enter or edit a definition for the procedure. If the target database supports it, ER/Studio adds this definition as a
table comment when generating SQL code.

Attachment Bindings tab

Lets you bind an external piece of information, or attachment to the procedure. You can also remove an
attachment from an object, override an attachment binding’s default value, or change a bound attachment'’s
position. To override the value of the attachment you have moved to the Selected Attachments grid, double-click
the Value field of the target attachment. ER/Studio opens the Value Override Editor or a list depending on the
attachment datatype. Attachments are created in the Attachments folder of the Data Dictionary. For more

information, see Attaching External Documents to the Data Model.

Permissions tab

Sets access roles and user permissions for the procedure. Keep in mind that the more specific permissions are,
the more time you may have to spend maintaining and updating them. The roles and users must be previously
assigned to appear in the Procedure SQL Editor. For more information, see Creating and Editing Database
Roles and Creating and Editing Database Users.

Notes

You can choose to launch your preferred SQL editor when editing functions and procedures. Using the Tools tab
of the Options Editor, you can enter the name and location of the SQL editor that will launch and manage the SQL
ER/Studio outputs. Click Tools > Options > Tools > ISQL Path.

For all new models you can choose:

« To display the schema object description or its associated symbol; click Tools > Options > Display and then
select the desired display mode.

< To hide invalid schema objects; click Tools > Options > Schema Objects and then select Hide Invalid Schema
Object Bitmap.

For the current data model, you can choose:

« To display the schema objects or objects relationships, and object definition or object symbol; click View >
Diagram And Object Display Options > Schema Object and then select the desired display options.

* What to display when you mouse over a schema object; click Tools > Options > Diagram > Schema Object
Display and choose to display the object description or its associated DDL.

For physical models, you can enter SQL to be applied before and after the CREATE OBJECT clause in the
CREATE TABLE statement. Click Model > Model Properties > PreSQL & Post SQL.

The sample physical model for SQL Server 200 in Northwindl .dm1l provides some good examples of how SQL
procedures can be used.

Import an SQL Procedure

1

In the Diagram Explorer, expand the Physical Main Model, right-click the Procedures node, and then click New
Procedure.

On the Description tab, click Import and then type, or browse to and then select the name of SQL procedure file
you want to import.

Complete the Procedure SQL Editor and then click OK to create the procedure.



Export an SQL Procedure

1 Inthe Diagram Explorer, expand the Physical Main Model, right-click the Procedures node, and then click New
Procedure.

2 Onthe Description tab, click Export and then type, or browse to and then select the name of the SQL procedure
file name where you want to save the SQL procedure.

3 Complete the Procedure SQL Editor and then click OK to create the procedure.

Creating and Editing Triggers

Triggers are code objects associated with a table that automatically execute when the table is modified by an SQL
INSERT, UPDATE, or DELETE statement. Triggers can contain complex SQL statements, such as those required to
guery other tables, but cannot accept parameters or arguments, and cannot perform commit or rollback operations.
They are also subject to coding errors like every other script or application.

Because triggers are customizable and execute automatically, they are often used to:

« Enforce referential integrity rules. For example, when a new customer in the eastern territory is added to the
customer table, the new customer information is also added to the table for the sales representative handling
that region.

« Enforce business rules on table data. For example, restricting an order insertion based on the customer’s
account status. If the customer’s payment is overdue or the order exceeds the customer’s credit limit, the
order is rejected.

« Synchronize information in another table when a table is updated. For example, you can create a delete trigger
on the product table that the trigger uses to locate and delete matching rows in the sales table and pending
orders table.

< Initiate an action external to the SQL Server when an update occurs. For example, when a new employee is
hired and added into the employees table, an e-mail is sent to the human resources department that prompts
them to perform certain actions like arranging desk space and computer equipment, and ensuring all that all
required paperwork is sent to the new employee and is returned completed to the human resources
department.

« Prevent some types of operations, such as UPDATESs. For example, a trigger can roll back updates that
attempt to apply a bonus (stored in the renumeration table) to employees (stored in the persons table)
who work less than 16 hours a week.

You can view the triggers associated with your models from the Triggers node in the Diagram Explorer, but to create
or edit triggers, you must use the Triggers tab of the table with which you want to associate the trigger.

The generated trigger code is customized for each target database platform. ER/Studio uses templates to implement
trigger code generation. SQL Procedures can be triggers that are a special type of procedure.

ER/Studio supports the following trigger types:

« Referential Integrity Triggers ensure implied relationships in the database are enforced, by preventing users from
creating discrepancies in the database. They inform the database how to manage or process the procedural SQL
commands, which enforce the business rules of an organization. ER/Studio defines Referential Integrity Triggers
by establishing insert, update and delete options between parent and child tables.

On the Trigger tab of the Relationship Editor, you can define the level of referential integrity and SQL insert,
update, and delete behaviors. For more information, see Create a Referential Integrity Trigger.



« User-Defined Triggers are usually customized for special situations to override the default capabilities of
database generated code. User-defined triggers are closely tied to DBMS-specific code, and therefore, are
implemented only in physical models. There are three types of user-defined triggers:

« Scripted Triggers that are written in the raw procedural code of the database such as Oracle's PL/SQL or
Microsoft's Transact-SQL. You can reverse-engineer these objects if they exist on the database. You can also
display them in the Diagram Window. Reverse-engineered triggers have table names and other object
references hard-coded into their underlying code. For more information, see Create a Scripted User-Defined

Trigger.

« Templated Triggers that do not have names of specific objects the trigger references, such as table names
and specific columns hard-coded into their underlying code. This enables these triggers to be reused across
various objects of an application, and the body of the trigger code to be reused across models. For more
information, see Create a Templated User-Defined Trigger.

* Reusable Triggers that can perform actions against any number of tables. For more information, see Create a
Reusable User-Defined Trigger.

Notes

« To view triggers on the Diagram Window, you must enable them. To display triggers, click Tools > Options >
Schema Objects.

« Specify default trigger actions for new triggers on the Schema Objects tab of the Options editor. On this tab you
can also choose to apply the default triggers. For more information, see

¢ You can only access the Trigger Editors from the Dependencies tab of the Table Editor.

« You can choose to display only specific attributes of a relationship, including trigger actions on the Relationship
tab of the Diagram And Object Display Options. For more information, see Changing Diagram and Object Display

Options.



Trigger Example
Sub Main

Dim trigName As String
Dim trigBody As String
Dim attrib As AttributeObj
Dim crlf As String

crif = Chr(13) + Chr(10)

trigName = Left(CurrEntity.TableName, 24) + "UpdTrg"

trigBody = ""CREATE OR REPLACE TRIGGER " + trigName + " AFTER UPDATE ON " +
CurrEntity.TableName + crif

trigBody = trigBody + "REFERENCING OLD AS OLD NEW AS NEW" + crlf

trigBody = trigBody + "FOR EACH ROW" + crlf

trigBody = trigBody + "BEGIN" + crlf

trigBody = trigBody + "UPDATE " + CurrEntity.TableName + " SET UPDATEDATE = SYSDATE

WHERE **

For Each attrib In CurrEntity._Attributes
IT attrib.PrimaryKey = True Then
IT Right(trigBody,6) <> "WHERE " Then
trigBody = trigBody + " AND "
End If

trigBody = trigBody + attrib.ColumnName + " = :OLD." + attrib.ColumnName

End If
Next attrib

trigBody = trigBody + ;" + crlf + "END;"

"Resultstring outputs the trigger to the DDL script when the Generate Database
“"wizard is used. The string variable used to generate the trigger DDL needs to be

set to it.
resultstring = trigBody

"This message box is used to view the SQL when debugging the VB code. A table has

to be selected.
MsgBox (trigBody)

End Sub
The following database platforms support Triggers:
* |BM DB2 for LUW 5., 6.x, 7., 8.x, and 9.x
* |BM DB2 for OS/390 6.x and for z/OS 7.x, 8.x, and 9.x
« Microsoft SQL Server 4.x, 6.x, 7.x, 2000, 2005, and 2008
« Oracle 7.x, 8., 9i, 10g, and11g
» Sybase ASA 6.0, 7.0, 8.0, 9.0
« Sybase Adaptive Server 1Q 12.
* Sybase SQL Server System ASE 11.0, 11.5, 11.9, 12.0, 12.5, 15

Notes

* When generating a database using the DDL Generation Wizard, you can choose which triggers to include and
whether they should be generated using either CREATE or DROP statements. On the General Options tab, you
can choose to create system triggers such as referential integrity triggers.

« Triggers will display in physical model of the Diagram Explorer in this format: triggerName.assocatedTableName.



¢ You can display the trigger actions by selecting Trigger Actions on the Relationship tab of the Diagram and
Display Options dialog. For example, when trigger actions are displayed U:R displays next to an Employee table
with an Update Restrict trigger.

* There are certain commands, statements, and operations that cannot be used in trigger programs. To avoid
generating exceptions with your triggers, consult your DBMS documentation.

Create a Referential Integrity Trigger

Referential integrity triggers, or system triggers, ensure implied relationships in the database are enforced, by
preventing users from creating discrepancies in the database. They inform the database how to manage or process
the templated procedures, which enforce the business rules of an organization. On the Trigger tab of the Relationship
Editor, you can define referential integrity triggers by establishing insert, update and delete behaviors for the parent
and child tables.

NOTE: You cannot create a referential integrity trigger for a non-specific relationship.

1 Onthe Diagram Window, create a relationship between two tables you want to ensure get updated when an
SQL INSERT, UPDATE or DELETE operation is performed on one of the tables.

2 On the Diagram Window, double-click the relationship.
3 Onthe Relationship Editor, click the Trigger tab.
The following describes the options that are not self-explanatory.

NOTE: ER/Studio uses templates to implement referential integrity trigger code generation. The
generated trigger code is customized for each target database platform. For each INSERT,
UPDATE or DELETE action, you can apply the following trigger templates based type, selections,
and level of data modification required:

« Parent Actions: Defines what the child does when the parent is updated.
¢ Insert: None: This cannot be changed.

* None (No Action): The trigger verifies the existence of the foreign key values in the parent table’s primary key. If
the values cannot be validated, the update or delete fails the referential integrity checks.

< Set Null: The trigger verifies the existence of the foreign key values in the parent table's primary key. If the values
cannot be validated, then the trigger sets the foreign key value to null in the child table and then updates or
deletes the parent. For example, you have a parent table persons and a child table tasks, which through a
mandatory relationship share an id. By using a Set Null trigger you can allow the user to insert data into the
tasks table that contains an id for which their is no corresponding value in the persons table. The database will
not throw a referential integrity error in this case.

« Set Default: Sets the foreign key to its DEFAULT value, then updates or deletes the parent.

« Restrict: The trigger verifies the existence of foreign key values in the parent table's primary key. If the values
cannot be validated, then the trigger prevents the insertion, update or deletion of data. For example, you have a
parent table persons and a child table tasks, which through a mandatory relationship share an id. By using a
Restrict trigger you can prevent the user from inserting data into the tasks table that contains an id for which
their is no corresponding value in the persons table. The database will throw a referential integrity error in this
case.

e Cascade: If a primary key is updated or deleted, the trigger cascades that modification to corresponding foreign
key values in dependent tables.



Create a Scripted User-Defined Trigger
1 Onthe Diagram Window or the Diagram Explorer, select the table on which you want to create a Trigger.

2 Select Edit > Edit Database Table.
Alternatively, on the Diagram Window, open the Table Editor by double-clicking the table or
right-clicking the object and then selecting Edit Table.

3 Onthe Table Editor, click the Dependencies tab.

4 Click the Add button and then select Triggers > Scripted.

5 Complete the Trigger Editor and then click Finish to create the trigger.

NOTE: The Trigger Editor includes find and replace functionality for working with SQL text strings.

The following describes options that are not self-explanatory:
« Name: Lets you enter a trigger name or edit the existing one.

SQL tab

Lets you enter a CREATE TRIGGER statement for the trigger, or edit the existing script. If you do not want to
enter a SQL script, you can use the Import button to import it.

« Export: Lets you export the SQL script to a *.sql file. This is useful for when you want to create additional triggers
based on the one you are currently creating. You can export the code, and later import it into another procedure.
When you click Export, the Save As dialog box opens. Enter the file name. ER/Studio saves the files in the Model
folder, if you want to save your files in a different folder, browse and locate it.

« Import: Lets you import *_sql files. When you click Import, the Open dialog box opens. You can enter the
name of the *_sql file, or browse and locate it.

« Validate: Lets you validate the SQL script. If ER/Studio detects any errors, it returns them in a message box.
Errors include the error type, line, and column information.

Description tab

Includes a text box where you can enter a Trigger description.

Attachment Bindings tab

Lets you bind an external piece of information, or attachment to the trigger. You can also remove an attachment
from an object, override an attachment binding’s default value, or change a bound attachment'’s position. To
override the value of the attachment you have moved to the Selected Attachments grid, double-click the Value
field of the target attachment. ER/Studio opens the Value Override Editor or a list depending on the attachment
datatype. Attachments are created in the Attachments folder of the Data Dictionary. For more information, see

Attaching External Documents to the Data Model.

Create a Templated User-Defined Trigger
1 Inthe Diagram Explorer, expand the Physical Main Model, right-click the Triggers node, and then click New
Trigger.

2 Complete the Trigger Wizard and then click Finish to create the trigger.
Once you've created the auxiliary table, you can edit it by right-clicking the auxiliary table you want

to change, and then selecting Edit Auxiliary Table.

The following describes options that are not self-explanatory:



Description page/tab

Enter or edit a definition for the description. If the target database supports it, ER/Studio adds this definition as a
comment when generating SQL code.

Attachment Bindings tab

Lets you bind an external piece of information, or attachment to the trigger. You can also remove an attachment
from an object, override an attachment binding’s default value, or change a bound attachment'’s position. To
override the value of the attachment you have moved to the Selected Attachments grid, double-click the Value
field of the target attachment. ER/Studio opens the Value Override Editor or a list depending on the attachment
datatype. Attachments are created in the Attachments folder of the Data Dictionary. For more information, see

Attaching External Documents to the Data Model.

Create a Reusable User-Defined Trigger
Reusable user-defined triggers are created in the Data Dictionary. For more information, see Create and Edit
Reusable Triggers

Creating and Editing Functions

Functions are subroutines that you define. Functions can be written in a programming language such as C, COBOL,
or Java that returns a scalar value or a complete table, or they can call another function, or they can be written in SQL
and return a scalar value. Functions are useful for reusable application logic. You can use functions to determine the
best methods for controlling access and manipulation of the underlying data contained in an object. Functions accept
a number of parameters and pass a single value back to the calling program. Functions can be used in the database
to check the validity of the data being entered. For example, functions can be used to validate zip codes. By invoking a
routine with the zip code, the function can return a true or false value based on if the zip code is valid.

You can create a reusable function Function SQL Editor where you can create a function and bind attachments to it.
You can also add a Function through the Table Editor - Dependencies tab. They are not associated with a particular
table; they are stored in the database.

The following database platforms support SQL functions:

* IBM DB2 for LUW 5.x, 6.%, 7.X, 8.X, 9.X

Microsoft SQL Server 2000, 2005

* Oracle 7.x, 8.x, 9i, 10g

Sybase ASA 6.0, 7.0, 8.0, 9.0, Adaptive Server IQ 12

Add a Stored SQL Function

1 Inthe Diagram Explorer, expand the Logical Main Model, right-click the Functions node, and then click New
Function.

2 Complete the Function SQL Editor and then click OK to create the function.
Once you've created the function, you can edit it by right-clicking the function you want to change,
and then selecting Edit Function.
The following describes options that are not self-explanatory.
Description tab

Enter or edit a definition for the function. If the target database supports it, ER/Studio adds this definition as a
table comment when generating SQL code.



Permissions tab

Sets access roles and user permissions for the function. Keep in mind that the more specific permissions are,
the more time you may have to spend maintaining and updating them. The Roles and Users must be previously
assigned to appear in the Function Editor. For more information, see Creating and Editing Database Roles and
Creating and Editing Database Users.

Attachment Bindings tab

Lets you bind an external piece of information or attachment to the function. You can also remove an attachment
from an object, override an attachment binding’s default value, or change a bound attachment’s position. To
override the value of the attachment you have moved to the Selected Attachments grid, double-click the Value
field of the target attachment. ER/Studio opens the Value Override Editor or a list depending on the attachment
datatype. Attachments are created in the Attachments folder of the Data Dictionary. For more information, see
Attaching External Documents to the Data Model.

Notes

You can choose to launch your preferred SQL editor when editing functions and procedures. Using the Tools tab
of the Options Editor, you can enter the name and location of the SQL editor that will launch and manage the SQL
ER/Studio outputs. Click Tools > Options > Tools > ISQL Path.

For all new models you can choose:

« To display the schema object description or its associated symbol, click Tools > Options > Display and then
select the desired display mode.

« To hide invalid schema objects, click Tools > Options > Schema Objects and then select Hide Invalid Schema
Object Bitmap.

For the current data model, you can choose:

« To display the schema objects or objects relationships, and object definition or object symbol; click View >
Diagram And Object Display Options > Schema Object and then select the desired display options.

* What to display when you mouse over a schema object; click Tools > Options > Diagram > Schema Object
Display and choose to display the object description or its associated DDL.

Creating and Editing Packages

A package is a group of procedures, functions, variables, and SLQ statements, used to store together related objects.
Packages contain all the information needed to process SQL statements from a single source file. You can use
packages to process and call batches of SQL. They are not associated with a particular table; they are stored in the
database.

The following database platforms support packages:

* Oracle 7.x, 8.x, 9i, 10g, and11g



Create a Package
1 Inthe Diagram Explorer, expand the Logical Main Model, right-click the Packages node, and then click New
Package.
2 Complete the Package Editor and then click OK to create the package.

Once you've created the auxiliary table, you can edit it by right-clicking the package you want to
change, and then clicking Edit Package.

The Package Editor includes find and replace functionality for working with SQL text strings.

The following describes options that are not self-explanatory.
Header tab

The header contains the package specification. Here you can declare types, variables, constants, exceptions,
cursors and subprograms. The header does not contain any code. You can specify a package that contains only
global variables that will be used by subprograms or cursors. This type of package declares only types,
constants, variables, exceptions, and call specifications and does not require a package body.

Body tab

The package body provides the implementation for the subprograms and the queries for the cursors declared in
the header.

Definition tab

Enter or edit a definition for the package. If the target database supports it, ER/Studio adds this definition as a
comment when generating SQL code.

Attachment Bindings tab

Lets you hind an external piece of information, or attachment to the package. You can also remove an
attachment from an object, override an attachment binding’s default value, or change a bound attachment'’s
position. To override the value of the attachment you have moved to the Selected Attachments grid, double-click
the Value field of the target attachment. ER/Studio opens the Value Override Editor or a list depending on the
attachment datatype. Attachments are created in the Attachments folder of the Data Dictionary. For more

information, see Attaching External Documents to the Data Model.

Permissions tab

Sets access roles and user permissions for the package. Keep in mind that the more specific permissions are,
the more time you may have to spend maintaining and updating them. The Roles and Users must be previously
assigned to appear in the Package Editor. For more information, see Creating and Editing Database Roles and
Creating and Editing Database Users.

Creating and Editing Materialized Query Tables

A materialized query table is a table that, like a materialized view, is defined based upon the result of a query
addressing one or more tables. While the query on which a view is based is run whenever the view is referenced, a
materialized query table stores the query results as data that you can work with instead of the data that is in the
underlying tables.

Materialized query tables can significantly improve query performance, especially for complex queries.
The following database platforms support Materialized Query Tables:
* |BM DB2 for LUW 5., 6.x, 7., 8.x, and 9.x

NOTE: The DB2 Materialized Query Table Wizard and DB2 Materialized Query Table Editor share the
same options, except for Attachment Bindings options which are present only in the editor.



Add a Materialized Query Table

1 Inthe Diagram Explorer, expand the Physical Main Model, right-click the Materialized Query Table node, and
then click New Materialized Query Table.

2 Complete the DB2 Materialized Query Table Wizard and then click Finish to create the materialized query
table.

Once you've created the materialized query table, you can edit it by right-clicking the materialized
query table you want to change, and then clicking Edit Materialized Query Table.

The following describes options that are not self-explanatory.

Name page/tab

The name of the materialized query table is derived from the information entered here, in the format of
owner.name where:

« owner is the owner of the materialized query table.
* name is the name of the materialized query table.

Location page/tab

« What is the table tablespace: To avoid the performance overhead created by logging changes to the data,
create materialized query tables in a table space that is defined as NOT LOGGED.

* Refresh Preferences: Determines when the materialized query table is update when its base tables are
updated.

¢ Query Optimization: If enabled, DB2 can consider the materialized query table in automatic query rewrite. When
query optimization is enabled, DB2 is more restrictive of what can be selected in the full select for a materialized
query table.

SQL pagel/tab
Enter the entire select statement for the materialized view, starting with the keyword SELECT.
Definition page/tab

Enter or edit a definition or description for the materialized view. If the target database supports it, ER/Studio
adds this definition as a comment when generating SQL code.

DDL page/tab

Displays the CREATE SUMMARY TABLE AS ... (SELECT ...) statement needed to build the node group.
ER/Studio uses the platform-specific parser of the model’s selected database platform to generate the
materialized query table.

Attachment Bindings tab

Lets you bind an external piece of information, or attachment to the materialized query table. You can also
remove an attachment from an object, override an attachment binding’s default value, or change a bound
attachment’s position. To override the value of the attachment you have moved to the Selected Attachments
grid, double-click the Value field of the target attachment. ER/Studio opens the Value Override Editor or a list
depending on the attachment datatype. Attachments are created in the Attachments folder of the Data
Dictionary. For more information, see Attaching External Documents to the Data Model.

Notes

« The materialized query table is not populated when first created. You must explicitly populate the materialized
query table using the REFRESH TABLE statement for system-maintained materialized query tables or by using
the LOAD utility, INSERT statement or the REFRESH TABLE statement for user-maintained materialized query
tables.



Creating and Editing Materialized Views

The performance of data warehousing and decision support system tools can be significantly increased when
materialized views are used. Materialized views increase the speed of queries that access many records, allowing you
to query terabytes of data in seconds. A materialized view is a pre-computed table comprising aggregated or joined
data from fact and possibly dimension tables which is also known as a summary or aggregate table. An example of
such a pre-defined query would be the sum of sales by region for a specific period of time. The storage requirements
of the pre-computed summarizations and data joins of a materialized view are small compared to the original source
data. A materialized view creates a real table that can be indexed and analyzed.

The following database platforms support materialized views:
¢ Oracle 8.x, 9i, 10g, and 11g

NOTE: The Oracle Materialized View Wizard and Oracle Materialized View Editor share the same
options, except for PreSQL & PostSQL, Permissions, and Attachment Bindings options which are
available only in the editor.

Create a Materialized View

1 Inthe Diagram Explorer, expand the Physical Main Model, right-click the Materialized Views node, and then
click New Materialized View.

2 Complete the Oracle Materialized View Wizard and then click Finish to create the materialized view.
Once you've created the materialized view, you can edit it by right-clicking the materialized view
you want to change, and then clicking Edit Materialized View.

The following describes options that are not self-explanatory.
Name page/tab

Users already defined in the logical or physical model can be selected from the list or owners for the materialized
view.

Refresh page/tab

¢ How should the materialized view be refreshed? Choose how the materialized view is synchronized with
respect to the base tables it was created from. The query defining the materialized view determines which refresh
method can be used; the materialized view can always be rebuilt from scratch but it may not always be possible
to perform a fast refresh on it. For more information, see Requirements for the Fast Refresh Method.

¢ Complete: Build from scratch.

e Fast: Apply only the changes.

* Force: Perform a fast refresh if possible, if not possible perform a complete refresh.
« Never: Do not refresh the view automatically.

¢« Choose arefresh mechanism: Choose when the materialized view is refreshed.

< ON DEMAND: If selected, you can run a build-in Oracle procedure to refresh the materialized view such as
DBMS_MVIEW_REFRESH (refreshes specific materialized view), DBMS_MVIEW.REFRESH_DEPENDENT
(refreshes materialized views associated with specific base tables) or DBMS_MVIEW._.REFRESH_ALL_MVIEWS
(refreshes all materialized views).

« ON COMMIT: If selected, the materialized view is refreshed when a transaction is committed that updates
tables referenced in the materialized view.

« Automatically: If selected, Oracle refreshes the materialized view at the specified date and time or the
specified frequency.



Select a refresh method: If this materialized view is based on the Primary Key, it allows the master tables of the
view to be reorganized without affecting the eligibility of the view for fast refresh. In this case the master table
must contain a primary key constraint. Select Rowid if the materialized view is organized based on the Rowid,
which is useful if the view doesn’t include all primary key columns of the master tables.

Primary key: If selected, the materialized view master tables can be reorganized without affecting its ability to be
refreshed using the Fast refresh method. Select this method only if the master table contains an enabled primary
key constraint

Query page/tab

Select a pre-defined tablespace from the list or specify the name of another tablespace where you want the
materialized view placed.

Specify Default for the rollback segment if you want Oracle to select the rollback segment to use. Default is most
useful when modifying a materialized view.

One Master Rollback Segment is stored for each materialized view and is validated when the materialized view
is created and refreshed. The master rollback segment is ignored if the materialized view is complex.

What is the materialized view query? Enter the SQL query to be used to populate and to refresh the
materialized view. The SQL must be valid to create the materialized view.

Transaction page/tab

Initial transactions: (INITTRANS) Specifies the number of DML transactions for which space is initially reserved
in the data block header. Oracle stores control information in the data block to indicate which rows in the block
contain committed and uncommitted changes. The amount of history that is retained is controlled by this
parameter. If too many transactions concurrently modify the same data block in a very short period, Oracle may
not have sufficient history information to determine whether a row has been updated by a “too recent”
transaction. Specify a higher value for materialized views based on tables that may experience many
transactions updating the same blocks.

Max transactions: (MAXTRANS) Once the space reserved by INITRANS is depleted, space for additional
transaction entries is allocated out of any available free space. Once allocated, this space effectively becomes a
permanent part of the block header. This parameter limits the number of transaction entries that can concurrently
use data in a data block and therefore limits the amount of free space that can be allocated for transaction entries
in a data block.

Percent Free: (PCTFREE) Specifies the maximum percentage of space in each data block to reserve for future
updates. This reserved space helps to avoid row migration and chaining caused by an update operation that
extends a data row's length. Tables that won't be updated should have this value set to 0.

Percent Used: (PCTUSED) Specifies the maximum percentage of available space in each data block before
re-adding it to the list of available blocks. When deletes take place and the room available in a block falls below
this value, the block is made available for new inserts to take place. Materialized views that won’t be updated
should have this value set to 99. The default value is 40% means that blocks are available for insertion when they
are less than 40% full.

Extent page/tab

Initial Extent: (INITEXTENT) Specifies the initial number of data blocks that Oracle should reserve. Oracle will
reserve the number of data blocks that correspond to the initial extent for that table’s rows.

Next Extent: (NEXT) Specifies the size in kilobytes of the next extent. Monitor this figure against the largest
available chunk of free space in the tablespace. If a table cannot allocate its next extent, it will no longer be able
to extend and, therefore, cannot accept additional data.

Percent Increase: (PCTINCREASE) Specifies the percentage by which the next extent should grow over the
previous extent's size. Be careful when setting Percent Increase because it magnifies how an object grows and,
therefore, can materially affect available free space in a tablespace.



« Min Extents: (MINEXTENTS) Specifies the number of extents to allocate when the segment is created. Controls
free space fragmentation by making sure that every used or free extent is at least as large as the value you

specify.

¢ Max Extents: (MAXEXTENTS) Specifies the maximum number of extents that Oracle can allocate to the
materialized view. Once this limit is reached, Oracle prevents further growth of the cluster and cannot accept
additional data. As a result, you should carefully monitor the number extents already allocated to the table with
this limit.

Options page/tab
« Do you want to register a prebuilt table to the view? If selected, registers and existing table as a pre-initialized

materialized view, which is particularly useful when registering large materialized views in a data warehousing
environment.

« Should the materialized view be immediately filled? If not selected, the materialized view is populated during
the next refresh operation.

« Should data for the materialized view be cached? If selected, Oracle puts data accessed frequently at the
most recently used end of the list in the buffer cache when a full table scan is performed. This option is useful for
small lookup tables.

e Is the materialized view eligible for query rewrite? Only enable query rewrite if expressions in the statement
are repeatable.

< How many threads should be in a parallel operation? Enter an integer to set the default degree of parallelism
for queries and DML on the materialized view after creation.

« Isthe materialized view compressed? If selected, compresses data segments to reduce disk and memory use.
Definition page/tab

Enter or edit a definition for the materialized view. If the target database supports it, ER/Studio adds this
definition as a materialized view comment when generating SQL code.

DDL page/tab

Displays the CREATE MATERIALIZED VIEW statement needed to build the materialized view. ER/Studio uses
the platform-specific parser of the model’'s selected database platform to generate the materialized view.

PreSQL & PostSQL tab

Lets you enter SQL to be applied before or after the CREATE MATERIALIZED VIEW statement. The PreSQL
and PostSQL scripts entered here are included in the script when you generate the physical database.

Permissions tab

Sets access roles and user permissions for the materialized view. Keep in mind that the more specific
permissions are, the more time you may have to spend maintaining and updating them. The Roles and Users
must be previously assigned to appear in the Materialized View Editor. For more information, see Creating and

Editing Database Roles and Creating and Editing Database Users.
Attachment Bindings tab

Lets you bind an external piece of information, or attachment to the materialized view. You can also remove an
attachment from an object, override an attachment binding’s default value, or change a bound attachment’s
position. To override the value of the attachment you have moved to the Selected Attachments grid, double-click
the Value field of the target attachment. ER/Studio opens the Value Override Editor or a list depending on the
attachment datatype. Attachments are created in the Attachments folder of the Data Dictionary. For more
information, see Attaching External Documents to the Data Model.




Requirements for the Fast Refresh Method

Materialized View Characteristics

Fast Refresh Method is Supported When
the Materialized View has:

Only Joins

Joins and
Aggregates

Am Aggregate
on a Single
Table

Detail tables only

X

X

Single table only

Table appears only once in the FROM list

No non-repeating expressions like SYSDATE and ROWNUM

No references to RAW or LONG RAW

X[ X| X| X

No GROUP BY

Rowids of all detail tables appear in the SELECT list of the query

X | X| X| X| X

Expressions are allowed in the GROUP BY and SELECT clauses
provided they are the same

Aggregates allowed but cannot be nested

AVG with COUNT

SUM with COUNT

VARIANCE with COUNT and SUM

STDDEYV with COUNT and SUM

X | X| X| X[ X

WHERE clause contains join predicates which can be ANDed bit not
ORed.

No WHERE clause

No HAVING or CONNECT BY

No subqueries, inline views, or set functions like UNTON or MINUS

COUNT(*) must be present

No MIN and MAX allowed

X | X| X| X[ X

If outer joins, then unique constraints must exist on the join columns of
the inner join table

Materialized view logs must exist and contain all columns referenced
in the materialized view and have been created with the LOG NEW
VALUES clause

Materialized view logs must exist with rowids of all the detail tables

Non-aggregate expression in SELECT and GROUP BY must be
straight columns

DML to detail table

Direct path data load

ON COMMIT

ON DEMAND

X | X[ X| X

X | X[ X| X




Creating and Editing Node Groups

A node group is a named set of one or more database partitions. A node group can have 2 to 32 nodes defined for it.
The number of nodes that is defined for the node group determines the number of systems across which the database
file is created.

You may need to create a node group when you want the database files to be visible across a set of System i™
models in a load sharing and balancing environment. Nodgroups enable workload to be processed in parallel across a
partitioned database for large tables, while smaller tables can be stored on one partition or on a small number of
partitions if desired.

The following database platforms support node groups:
« IBM DB2 for LUW 5., 6.x, 7.X, 8.X, 9.x

NOTE: The DB2 Nodegroup Wizard and DB2 Nodegroup Editor share the same options, except for
Attachment Bindings options which are defined in the editor only.

Create a Node Group

1 Inthe Diagram Explorer, expand the physical Main Model, right-click the Node Groups node, and then click
New Nodegroup.

2 Complete the Node Groups Wizard and then click Finish to create the node group.
Once you've created the auxiliary table, you can edit it by right-clicking the node group you want
to change, and then clicking Edit Node Group.
The following describes options that are not self-explanatory.
Name page/tab
« What is the name of the NodeGroup? The name must not begin with SYS or IBM.

« Enter the nodes (partitions) to include: Specify the partition number(s). This must be a valid partition number
between 0 - 999

Definition page/tab

Enter or edit a definition for the node group. If the target database supports it, ER/Studio adds this definition as a
comment when generating SQL code.

DDL page/tab

Displays the CREATE NODEGROUP statement needed to build the node group. ER/Studio uses the
platform-specific parser of the model’s selected database platform to generate the node group.

Attachment Bindings tab

Lets you bind an external piece of information, or attachment to the node group. You can also remove an
attachment from an object, override an attachment binding’s default value, or change a bound attachment’s
position. To override the value of the attachment you have moved to the Selected Attachments grid, double-click
the Value field of the target attachment. ER/Studio opens the Value Override Editor or a list depending on the
attachment datatype. Attachments are created in the Attachments folder of the Data Dictionary. For more
information, see Attaching External Documents to the Data Model.




Creating and Editing Object Types

Types define an abstract data type or object composed of a collection of similar types of data. For example, you can
create an object type that defines a full address rather than the pieces of an address, such as city, state and postal
code in this case the object type stores the pieces of an address as a single type, in the same location and the full
address can be accessed and manipulated as single unit rather than multiple units. You could also use an object type
to create a purchase order object that includes a method to sum the cost of all purchased items.

Object types are useful for ensuring uniformity and consistency as they are defined as single encapsulated entity that
can be reused in other object types and objects. They also offer flexibility by allowing for the creation of objects that
represent real-world situations which is limited in relational objects.

Once created, you can use an object type as a datatype in a table.

You can create the following object types:

Incomplete: Specifies no attributes or methods and can be used for circular references such as person - female.
It lets the type be referenced before it is complete. Incomplete types can also be used to create types that contain
REF attributes to a subtype that has not yet been created. To create such a supertype, first create an incomplete
type of the subtype to be referenced and then create the complete subtype after you create the supertype.

A subtype is a specialized version of its direct supertype with an explicit dependency on it. To ensure that
subtypes are abandoned after a supertype is dropped, drop all subtypes first; a supertype cannot be dropped
until all its subtypes are dropped.

Complete: An incomplete type can be completed by executing a CREATE TYPE statement that specifies the
attributes and methods.

VARRAY: Used to store small sets of related data. For example, if you have ten offices (each one with a different
description) at a particular division in your company, you could create a VARRAY of 10 to hold the details of these
offices. The values for a VARRAY type must be fixed and known and be small values because they are stored in
RAW format.

Nested Table: Used when data is repeated for the same entity an unknown number of times and storage is a
concern.

A combination of complete, varray, and nested table types.

The following database platforms support object types:

Oracle 8.x, 9i, 10g, and 11g

Create an Object Type

1

2

In the Diagram Explorer, expand the physical Main Model, right-click the Object Types node, and then click
New Object Type.

Complete the tabs of the Object Type Editor and then click OK to create the object type.

Once you've created the object type, you can edit it by right-clicking the object type you want to
change, and then clicking Edit Object Type.

The Object Type Editor includes find and replace functionality for working with SQL text strings.

The following describes options that are not self-explanatory.

Header and Body tab

Enter the SQL to create the object type. The SQL generated from each these tabs will appear in their own SQL
blocks.



Description tab

Enter or edit a description for the object type.

Attachment Bindings tab

Lets you bind an external piece of information, or attachment to the object type. You can also remove an
attachment from an object, override an attachment binding’s default value, or change a bound attachment'’s
position. To override the value of the attachment you have moved to the Selected Attachments grid, double-click
the Value field of the target attachment. ER/Studio opens the Value Override Editor or a list depending on the
attachment datatype. Attachments are created in the Attachments folder of the Data Dictionary. For more

information, see Attaching External Documents to the Data Model.

Creating and Editing Rollback Segments

Rollback Segments allow you to undo, or rollback, DML transactions such as SQL deletes, inserts, and updates that
have been executed on a database. A rollback segment entry contains information about the database records before
they were modified by a transaction.

The following database platforms support rollback segments:

Oracle 7.x, 8.x, 9i, 10g, and 11g

Create or Edit a Rollback Segment

1 Inthe Diagram Explorer, expand the Physical Main Model, right-click the Rollback Segments node, and then
click New Rollback Segment.
2 Complete the Rollback Segments Wizard and then click Finish to create the Rollback Segment.
Once you've created the auxiliary table, you can edit it by right-clicking the rollback segment you
want to change, and then clicking Edit Rollback Segments.
The following describes options that are not self-explanatory.
Name tab

Should this rollback segment be made public? This option only applies to a database operating in a parallel
server environment. A public rollback segment can be brought online by any instance of the database in a
parallel server environment. A private rollback segment can only be brought online by the database instance that
has the rollback segment specified in its initialization file.

Storage tab

What extent sizes do you want to assign to this rollback segment?

The before-image details for multiple transactions can be recorded in one rollback segment but each transaction
must fit entirely into one segment and the blocks of a rollback segment are not overwritten until the transaction
that wrote to those blocks has been committed. You must therefore, ensure the rollback segment is big enough
to hold all the information for the longest running query without wrapping and is big enough to hold the undo
information for the largest transaction x number of concurrent transactions + number of rollback segments.

¢ The default extent size is the size of 5 data blocks. The default minimum extent size is the size of 2 data
blocks. The maximum extent size varies by operating system.

Optimal Size: The optimal extent size cannot be less that the space initially allocated for the rolback segment.

What are the minimum and maximum number of extents...? The default minimum number of extents is 2.The
default maximum number of extents varies by operating system.



Definition tab

Enter or edit a definition for the rollback segment. If the target database supports it, ER/Studio adds this
definition as a comment when generating SQL code.

DDL tab

Displays the CREATE ROLLBACK SEGMENT statement needed to build the rollback segment. ER/Studio uses the
platform-specific parser of the model’s selected database platform to generate the rollback segment.

Attachment Bindings tab

Lets you hind an external piece of information, or attachment to the rollback segment. You can also remove an
attachment from an object, override an attachment binding’s default value, or change a bound attachment'’s
position. To override the value of the attachment you have moved to the Selected Attachments grid, double-click
the Value field of the target attachment. ER/Studio opens the Value Override Editor or a list depending on the
attachment datatype. Attachments are created in the Attachments folder of the Data Dictionary. For more

information, see Attaching External Documents to the Data Model.

Creating and Editing Sequences

Sequences are used to generate a series of integer values according to rules defined in the sequence. Database
sequences are generally are used to create primary keys; they can also be used to generate random numbers.

The following database platforms support sequences:
¢ IBM DB2 for LUW 9.x
« Oracle 8.x, 9i, 9i, 10g, and 11g

NOTE: The Sequence Wizard and Sequence Editor share the same options, except for Attachment
Bindings options which are present only in the editor.

Create or edit a Sequence
1 Inthe Diagram Explorer, expand the Physical Main Model, right-click the Sequences node, and then select
New Sequence.

2 Complete the Sequences Wizard and then click Finish to create the sequence.
Once you've created the sequence, you can edit it by right-clicking the sequence you want to
change, and then clicking Edit Sequence.
The following describes options that are not self-explanatory.

NOTE: The options available depend on the database platform selected.

Name page/tab

« If you have already defined users for the selected database, you can click the list and choose a defined user for
the sequence owner.

Options page/tab
« Cycling: If you've specified a Maximum Value on the previous page/tab, you can choose to cycle the values.

« Ordering: Specify whether or not the sequence numbers must be generated in order of request.



« Cache: Consider the following performance and application requirements trade-offs when choosing to enable the
cache and the optimal cache size:

« Caching sequence numbers enables a range of sequence numbers to be kept in memory for fast access. If the
the next sequence number can be allocated from cache, number allocation can happen quickly; however, if
the next sequence number cannot be allocated from cache, the application may have to wait for /O operations
to complete.

« Not caching sequence values ensures that there is no loss of values in the event of a system failure, shutdown
or database deactivation. The values of the sequence are not stored in the cache and every sequence request
results in synchronous /O to the log.

Definition page/tab

Enter or edit a definition for the sequence. If the target database supports it, ER/Studio adds this definition as a
comment when generating SQL code.

DDL page/tab

Displays the CREATE SEQUENCE statement needed to build the sequence. ER/Studio uses the
platform-specific parser of the model’s selected database platform to generate the sequence.

PreSQL & PostSQL page/tab

Lets you enter SQL to be applied before or after the CREATE SEQUENCE statement. If you select Generate, the
PreSQL and PostSQL scripts entered here are included in the script when you generate the physical database.

Attachment Bindings page/ tab

Lets you bhind an external piece of information, or attachment to the sequence. You can also remove an
attachment from an object, override an attachment binding’s default value, or change a bound attachment'’s
position. To override the value of the attachment you have moved to the Selected Attachments grid, double-click
the Value field of the target attachment. ER/Studio opens the Value Override Editor or a list depending on the
attachment datatype. Attachments are created in the Attachments folder of the Data Dictionary. For more

information, see Attaching External Documents to the Data Model.

Permissions page/tab

Sets access roles and user permissions for the sequence. Keep in mind that the more specific permissions are,
the more time you may have to spend maintaining and updating them. The Roles and Users must be previously
assigned to appear in the Sequence Editor. For more information, see Granting and Revoking Permissions to
Modify Database Objects.

Creating and Editing StoGroups

A StoGroup is a set of volumes on direct access storage devices (DASD) that hold the data sets in which tables and
indexes are stored. The CREATE STOGROUP statement creates a storage group on the current server. You can then
allocate storage from the identified volumes for table and index spaces. Different parts of a single database can be
stored in different StoGroups.

If a dataset reaches its maximum number of extents, any transaction that writes data to tables or indexes associated
with that stogroup fails and the database can become inaccessible until more space is allocated to the stogroup. It is
important to allocate sufficient storage for the database and to monitor its growth carefully. For information on capacity
planning, see Planning for and Predicting Database Growth.

You can use stogroup you create to define storage for the index of an auxiliary table or a table, or storage for a
tablespace. For more information, see Creating and Editing Auxiliary Tables, Defining Index Storage, and Creating
and Editing Tablespaces.



The following database platforms support StoGroups:
« |BM DB2 for OS/390 5.x, 6.x, 7.X, 8.x, and 9.x

NOTE: The StoGroups Wizard and StoGroups Editor share the same options, except for Attachment
Bindings options which are present only in the editor.

Create a StoGroup
1 Inthe Diagram Explorer, expand the Physical Main Model, right-click the Entities node, and then click New
Stogroup.

2 Complete the StoGroup Wizard and then click Finish to create the stogroup.

Once you've created the stogroup, you can edit it by right-clicking the stogroup you want to
change, and then clicking Edit StoGroup.

The following describes options that are not self-explanatory.
Options page/tab

What is the name of the Stogroup? The stogroup name must identify a storage group that does not yet exist at
the current server.

* VCAT: Specify the integrated catalog facility catalog for the storage group. Specify an alias if the name of the
VCAT is longer than 8 characters.

« Enter the volumes to include in the Stogroup, separated by commas: Includes the specified volumes in
the StoGroup. To include all volumes in the stogroup, enter an asterisk (*).

Definition page/tab

Enter or edit a definition for the stogroup. If the target database supports it, ER/Studio adds this definition as a
comment when generating SQL code.

DDL page/tab

Displays the CREATE STOGROUP statement needed to build the stogroup.ER/Studio uses the platform-specific
parser of the model’s selected database platform to generate the stogroup.

Attachment Bindings tab

Lets you bind an external piece of information, or attachment to the stogroup. You can also remove an
attachment from an object, override an attachment binding’s default value, or change a bound attachment’s
position. To override the value of the attachment you have moved to the Selected Attachments grid, double-click
the Value field of the target attachment. ER/Studio opens the Value Override Editor or a list depending on the
attachment datatype. Attachments are created in the Attachments folder of the Data Dictionary. For more
information, see Attaching External Documents to the Data Model.

Creating and Editing Synonyms

A synonym is an alternate name for a database object that lets you:

« Reference an object without specifying its owner (The synonym definition references the owner, but to use the
synonym thereafter you don’t have to know the owner name.)

« Reference a remote object without specifying its database.

< Alias an object so its purpose becomes more obvious.



The following database platforms support Synonyms:
« |BM DB2 for OS/390 5.x and 6.x and for z/OS 7.x, 8.x, and 9.x
« Microsoft SQL Server 2005 and 2008
¢ Oracle 8., 9i, 10g, and 11g

NOTE: The Synonym Wizard and Synonym Editor share the same options, except for Attachment
Bindings options which are present only in the editor.

Create a Synonym

1 Inthe Diagram Explorer, expand the Physical Main Model, right-click the Synonyms node, and then click New
Synonym.

2 Complete the Synonyms Wizard and then click Finish to create the synonym.
Once you've created the synonym, you can edit it by right-clicking the synonym you want to
change, and then clicking Edit Synonym.
The following describes options that are not self-explanatory.

NOTE: The options available depend on the database platform selected.

Name page/tab

* Make this synonym accessible to all users? If selected, creates a public synonym that case be used by
everyone in the database, otherwise a private synonym is created that belongs to the synonym owner.

Reference page/tab

* What type of object does this synonym reference? The list of objects available depends on the selected
database platform.

« IBM DB2 for OS/390 5.x and 6.x and for z/OS 7.x, 8.x, and 9.x: Supports synonyms for aliases, synonyms,
tables, and views.

« Microsoft SQL Server 2005 and 2008: Supports synonyms for functions, procedures, and views.

e Oracle 8.x, 9i, 10g, and 11g: Supports synonyms for functions, materialized views, object types, packages,
procedures, sequences, synonyms, tables, and views.

NOTE: If you specify Unknown, the object type will change to correspond to the type of object named
below.

« What is the schema of the referenced object? What is the name of the referenced object? The list is
populated with the names of all the objects in the model matching the model type specified in the field above.

« Ifthe objectis on aremote database, please enter the DB link. Type the path of the remote database, or click
the list and select it.

Definition page/tab

Enter or edit a definition for the synonym. If the target database supports it, ER/Studio adds this definition as a
comment when generating SQL code.

DDL page/tab

Displays the CREATE SYNONYM statement needed to build the synonym. In physical models, ER/Studio uses the
platform-specific parser of the model’s selected database platform to generate the view. If you're adding a view
to a logical data model, the default parser AINSI SQL is used unless you change the View Parser in the Logical
Model Options to another parser. For more information, see Defining Model Options for the Selected Model.




Attachment Bindings tab

Lets you bind an external piece of information, or attachment to the synonym. You can also remove an
attachment from an object, override an attachment binding’s default value, or change a bound attachment'’s
position. To override the value of the attachment you have moved to the Selected Attachments grid, double-click
the Value field of the target attachment. ER/Studio opens the Value Override Editor or a list depending on the
attachment datatype. Attachments are created in the Attachments folder of the Data Dictionary. For more
information, see Attaching External Documents to the Data Model.

Creating and Editing Tablespaces

A tablespace is the physical location where the data in a database is stored. Using tablespaces, the administrator can
control disk layout to optimize database performance, by for example storing a frequently used index on a fast disk.
The manner in which space is allocated to database objects directly impacts their ability to grow, which can ultimately
affect database performance.

The following database platforms support tablespaces:
« |BM DB2 for LUW 5.x, 6.X, 7.X, 8.X, 9.X
« IBM DB2 for OS/390 5.x and 6.x and for z/OS 7.x, 8.x, and 9.x
e Oracle 7.x, 8.x, 9i, 10g, and 119

NOTE: The Tablespace Wizard and Tablespaces Editor share the same options, except for Attachment
Bindings options which are present only in the editor.

Create a TableSpace

1 Inthe Diagram Explorer, expand the Physical Main Model, right-click the Tablespaces node, and then click
New Tablespace.

2 Complete the Tablespaces Wizard and then click Finish to create the alias.
Once you've created the tablespace, you can edit it by right-clicking the tablespace you want to
change, and then selecting Edit Tablespace.
The following describes options that are not self-explanatory. The options available depend on the database
platform selected.

NOTE: Many of the table space parameters are also used when defining table storage. For information
on defining storage parameters not described here, see Defining Table Storage.

Name & Type page/tab
« Choose the type of data to store in the tablespace:

« Regular: Choose for all data types except for temporary tables.

« Long: Choose for long or LOB tables columns, or for structured type columns or index data. The table space
must be a DMS table space.

e Temporary: Choose if you want to store temporary data. A database must have at least one temporary table
space to store temporary tables and another that allows the declaration of temporary tables.

Name page/tab



Do you want space management to be performed through the dictionary or locally in the tablespace?
Specify how extents should be managed.

« Dictionary Managed: Relies on SQL dictionary tables to track space utilization. Adding an extent to a table
requires the database manager to find free space, mark it as non-free and potentially causes rollback
segments to extend. These operations may jeopardize database performance because they cannot be
performed simultaneously. However, dictionary managed tablespaces are very flexible, different objects
sharing the same tablespace can have different extent sizes.

* Locally Managed: Eliminates the problem of tablespace fragmentation, and potential bottlenecks associated
with the data dictionary. The database manager maintains a bitmap of free and used blocks, or sets of blocks.
Locally managed tablespaces can be used for temporary tablespaces and can often sustain high
extent-allocation and deallocation activities. If a table is created with the wrong extent size, causing tablespace
fragmentation, this type of tablespace management can enforce extent uniformity at the tablespace level.

Disable logging when schema/data is modified: If selected, disables logging when schema or data is
modified.

Place tablespace offline after creation: If selected, places tablespace offline after creation.

AutoAllocate Extents: If selected, Oracle automatically assigns and allocates appropriately sized extents
depending on the objects in the tablespace.

Uniform Extent Size: If selected, extent sizes are managed at the tablespace level, not at the object level. The
extent size is specified when the tablespace is created and all the extents for objects created in the tablespace
will be the same.The uniform extent size cannot be overridden when a schema object, such as a table or an
index, is created. This option may eliminate fragmentation.

Datafile page/tab

Defined Datafiles: Double-click the Size or Unit fields to edit them. Click Add only when you need to define
another datafile.

Reuse Existing File: If Use Oracle Managed Files to automatically generate Defaults is not enabled, this
option is available. If selected, lets you reuse an existing datafile, which the database manager overwrites the
first time the file is accessed.

Storage page/tab

If the table space of an Oracle table space is dictionary managed, as specified on the Name tab of the editor, then
define the parameters of the extents on this tab.

Specify the containers for the tablespace below: Specify an absolute or relative directory name. The relative
path is relative to the database directory. If the directory name does not exist, it will be created.

NOTE: Click Add only if you want to specify another container.

Select a NodeGroup to assign to the tablespace: Specify either a nodegroup or a database partition number.

Select a page size: The page size must be the same as the page size of the buffer pool that is associated with
the database.

Options page/tab

Extent Size: Specify the number of pages that will be written to a container before writing to the next container.
The database manager cycles through the containers as it stores data. The default extent size is specified by the
database configuration parameter DFT_EXTENT_SZ.

Prefetch Size: Specify the number of pages that will be read when prefetching tablespace data. The default
prefetch size is specified by the database configuration parameter DFT_PREFETCH_SZ.

Overhead: Specifies the overhead, disk seek, and latency time of the 1/O controller. This should be an average
for all containers belonging to the tablespace. This value is used during query optimization to determine the 1/O
cost.



« Transfer Rate: Specifies the time required to read one page into memory. This should be an average for all
containers belonging to the tablespace. This value is used during query optimization to determine the 1/O cost.

« Select the recovery status: If ON is selected, dropped tables in this tablespace may be recovered using the
ROLLFORWARD command with the RECOVER TABLE ON option.

Options 1 page/tab
« GBP Cache: Specifies a group buffer pool cache.
« Sizing: Specifies the settings for the different Sizing parameters:

< If you are creating a non-partitioned tablespace, enter a value between 1 and 255 in the Max rows per page
field.

« If you are creating a partitioned tablespace, enter the number of partitions you want to create for the
tablespace (between 1 and 254) in the Number of Partitions field, then select a size for the partitions from the
Partition Size (DSSIZE) list. Enter a value between 1 and 255 in the Max rows per page field.

« If you are creating a segmented tablespace, select a value from the Segment Size list, and enter a value
between 1 and 255 in the Max rows per page field.

< If you are creating an LOB tablespace, select a value from the Partition Size (DSS1ZE) list.

< TRACKMOD: When set to Yes, the database manager tracks database modifications to enable the backup utility
to detect which subsets of the database pages should be examined by an incremental backup and included in the
backup image if necessary.

Options 2 page/tab

« Locking: To control concurrent access and prevent uncontrolled data access, you can create locks which
associates a database manager resource with an application, called the lock owner, to control how other
applications access the same resource. The Lock Size determines the granularity of the locks.

¢ Maximum Locks: Set this to a low number to avoid contention. Setting LOCKMAX to zero increases tablespace
availability by preventing lock escalations which can lock the tablespace. Setting LOCKMAX to SYSTEM allows the
database manager to control the maximum number of locks by a setting in the database configuration file.

* Close Rule: Determines whether the data sets can be closed when the table space is not in use, and the limit on
the number of open data sets (DSMAX) is reached. If you select No, no data sets can be closed. However, if
DSMAX is reached and no CLOSE YES page sets exist, then even CLOSE NO page sets will be closed.

e Partitions: For information on partition parameters, see Patrtitioning a Table.
Definition page/tab

Enter or edit a definition for the tablespace. If the target database supports it, ER/Studio adds this definition as a
comment when generating SQL code.

DDL page/tab

Displays the CREATE TABLESPACE statement needed to build the tablespace. ER/Studio uses the
platform-specific parser of the model’s selected database platform to generate the tablespace.

Attachment Bindings page/ tab

Lets you bind an external piece of information, or attachment to the tablespace. You can also remove an
attachment from an object, override an attachment binding’s default value, or change a bound attachment'’s
position. To override the value of the attachment you have moved to the Selected Attachments grid, double-click
the Value field of the target attachment. ER/Studio opens the Value Override Editor or a list depending on the
attachment datatype. Attachments are created in the Attachments folder of the Data Dictionary. For more

information, see Attaching External Documents to the Data Model.



Creating and Editing Database Schemas

A database schema is a collection of unique objects in a namespace. Schemas allow you to group tables and other
related objects together, such as a table and an index. Once the schema has been defined you can

The following database platforms support Schemas:
« |BM DB2 for LUW 5.x, 6.x, 7., 8.x, and 9.x
¢ Microsoft SQL Server 2005 and 2008

NOTE: The Database Schema Wizard and Database Schema Editor share the same options, except for
Attachment Bindings options which are present only in the editor.

Create a Database Schema

1 Inthe Diagram Explorer, expand the Physical Main Model, right-click the Schema node and then click New
Database Schema.

2 Complete the Database Schema Wizard and then click Finish to create the database schema.
Once you've created the schema, you can edit it by right-clicking the schema you want to change,
and then selecting Edit Schema.
The following describes options that are not self-explanatory:
Object Privilege page/tab

Sets access roles and user permissions for the schema. Keep in mind that the more specific permissions are,
the more time you may have to spend maintaining and updating them. The Roles and Users must be previously
assigned to appear in the Sequence Editor. For more information, see Granting and Revoking Permissions to
Modify Database Objects.

Definition page/tab

Enter or edit a definition for the schema. If the target database supports it, ER/Studio adds this definition as a
comment when generating SQL code.

DDL page/tab

Displays the CREATE SCHEMA statement needed to build the schema. ER/Studio uses the platform-specific
parser of the model’s selected database platform to generate the tablespace.

Attachment Bindings tab

Lets you bind an external piece of information, or attachment to the schema. You can also remove an attachment
from an object, override an attachment binding’s default value, or change a bound attachment’s position. To
override the value of the attachment you have moved to the Selected Attachments grid, double-click the Value
field of the target attachment. ER/Studio opens the Value Override Editor or a list depending on the attachment
datatype. Attachments are created in the Attachments folder of the Data Dictionary. For more information, see
Attaching External Documents to the Data Model.

Optimizing Query Performance on the Physical Model

Denormalizing the Physical Model

0 matter how elegant a logical design is on paper, it often breaks down in practice because of the complex or
expensive queries required to make it work. Sometimes, the best remedy for the performance problems is to depart
from the logical design. Denormalization is perhaps the most important reason for separating logical and physical
designs, because then you don’t need to compromise your logical design to address real-world performance issues.



Here are some common scenarios you should consider when denormalizing a physical design.

e Duplicated Non-Key Columns: You may decide to duplicate non-key columns in other tables to eliminate the
need to access, or join to that table in a query, such as when you duplicate the description or name column of a
lookup table. When duplicating non-key columns in tables, ensure that the procedural logic synchronizes the
column data so that it does not differ from the values in the reference table.

* Horizontal Table Splits: When tables have many rows of data, you may want to partition the data by splitting the
table into multiple tables where each table uses the same schema but stores a different range of primary key
values. Splilting the table reduces the size and density of the indexes used to retrieve data, thereby improving
their efficiency. On the other hand, once the table is split you must access data in multiple tables instead of in a
single table which requires more complicated procedural logic to manage the tables.

¢ Vertical Table Splits: When tables with many columns have high read/write activity, you may want to split the
table into multiple tables with different column sets, where each column set uses the same primary key. This lets
you spread update activity across multiple tables, thus decreasing the impact of maintaining multiple indexes. As
with horizontal table splits, vertical table splits require more complex procedural logic to manage multiple tables.

After generating a physical model from a logical model, you can use denormalization mappings to improve
performance in the physical model implementation.

Unlike a manual edit of the physical model, a denormalization mapping provides a record of what has been changed
and retains the link back to the logical model (visible in the Table Editor Where Used tab). This makes the
denormalization self-documenting, and reduces the manual labor required when merging with an updated logical
model. Also, a mapping can be undone at any time (see Undo a Denormalization Mapping).

The following denormalization mappings are available:

* Roll Up Denormalization: Remove one or more unnecessary child tables, consolidating their columns into the
parent table. (All tables must share the same primary key.)

« Roll Down Denormalization: Remove an unnecessary parent table, copying all of its non-primary-key columns
into one or more of its child tables. (All tables must share the same primary key.) The child tables can be further
consolidated via a Table Merge Denormalization.

« Horizontal Split Denormalization: Partition a table into two or more tables with identical columns.

« Vertical Split Denormalization: Remove a table and distribute its columns among two or more new tables. The
new tables have the same primary keys as the original; each of the other columns can appear in one, several, or
all of the new tables, or can be dropped.

¢ Column Map Denormalization: Copy a column from one table to another to improve query performance by
eliminating the need for a join.

« Table Merge Denormalization: Remove unnecessary tables by combining two or more unrelated tables with the
same primary key into a single table containing both tables’ columns.

Removing and Consolidating Child Columns

Roll Up Denormalization

A roll-up denormalization mapping removes one or more unnecessary child tables from a physical model,
consolidating their columns into the parent table. All tables must share the same primary key. For a roll-up operation,
the PARENT primary key is preserved. Any native PK columns in the child are discarded.



In the following example, Sales Order Line has been rolled up into Sales Order, all of the columns of Sales Order Line
have been consumed by Sales order, and only the parent’s key remains.

SALES_ORDER

before

after
SALES_ORDER

F
SALES_ORDER_LIME

Create a New Roll-up Mapping
1 Display the physical model.

2 Click and drag or Ctrl-click to select the parent and child tables.
3 Right-click one of the selected tables and then select Denormalization Mapping > Rollups.

4 Complete the Roll Up Denormalization Wizard as required.

Notes

« The Convert Subtype Relationships to Recursive Relationships check box allows you to preserve relationships
between subtypes when rolling up subtypes into a supertype. The relationships will become recursive. The
rolenames in the subtypes will be used in the supertype. Otherwise this page is merely informative. If the correct
tables are listed, click Next; otherwise, click Cancel and redo your selection.

« If the Rollups menu choice is grayed, check to make sure you have not accidentally selected another table or
some other object.



* When appropriate, child columns can be repeated in the unified table. For example, if a parent-child relationship
normalizes month-specific data using a cardinality of 1:12, the wizard would by default repeat the child table’s
columns 12 times in the unified table. The repeating columns are named by appending numeric suffixes to the
original column name; you should rename them appropriately after creating the mapping.

Removing Unnecessary Parent Tables

Roll Down Denormalization

A roll-down denormalization mapping removes an unnecessary parent table, copying all of its non-primary-key
columns into one or more of its child tables. All tables must share the same primary key. In the following example, the
SLSORDR table has been rolled down into the SLSORDRLINE table. The child will keep the compound key from the
propagating SLSORDRID identifying relationship. For a Rolldown operation, the CHILD primary key is preserved. Any
native PK columns in the child are kept.

SL5_ORDR

before

after
SLS_ORDR_LINE

S5LS_ORDE_LIMNE

Create a New Roll-Down Mapping:
1 Display the physical model.

2 Click and drag or Ctrl-click to select the parent and child tables.
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3 Right-click one of the selected tables, then from the pop-up menu select Denormalization Mapping >
Rolldowns.

4 Complete the Roll Down Denormalization Wizard as required.

Notes

« If the Rolldowns menu choice is dimmed, check to make sure you have not accidentally selected another table or
some other object.

« The first panel of the wizard is merely informative. If the correct tables are listed, click Next; otherwise, click
Cancel and redo your selection.

« If appropriate, the denormalized child tables can be further consolidated via a Table Merge Denormalization.

Partitioning a Table and Duplicating Columns

Horizontal Split Denormalization

A horizontal split denormalization mapping partitions a table into two or more tables with identical columns. In the
following example, a single discounts table is split into three separate tables.

stor_id (PK)

stor_name

stor_address before
city

state

stor_id (FK)
stor_name
stor_address
discounttype city

stor_id (FK) state

lowaty zip
highaty

discount

discounttype
stor_id (FK)
lowaty

highagty
discount

discounttype
star_id (FK)
lowaty

highgty
discount

discounttype
stor_id (FK)
lowaty

highaty
discount
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Create a new horizontal split mapping:
1 Display the physical model.

2 Right-click the table to be partitioned and then click Denormalization Mapping > Horizontal Splits.

3 Complete the Horizontal Table Split Wizard as required.

Replacing a Table with New Tables That Share the Primary Key

Vertical Split Denormalization

A vertical split denormalization mapping removes a table and distributes its columns among two or more new tables.
The new tables have the same primary keys as the original; each of the other columns can appear in one, several, or
all of the new tables, or can be dropped. In the following example, a table with separate columns for each of five years’
revenues, is split into five tables, one for each year..

FRODUCT _REVENUE_00

before ¥ PRODUCT_REVENUE_ID

PRODUCT_REVENUE "/ TRADE_NAME_ID

# PRODUCT_REVENUE_ID ¥ PRODUCT

“# TRADE_NAME_ID + REV_2000

“# PRODUCT

S REV_2000 PRODUCT_REVENUE 01

“»REV_2001 # PRODUCT_REVENUE_ID

“#REV_2002 “# TRADE_NAME_ID

“#REV_2003 . PRODUCT

“# REV_2004 “#REV_2001

FRODUCT_REVENUE_02

# PRODUCT_REVENUE_ID
“# TRADE_NAME_ID
after | propuct
“#REV_2002

FRODUCT _REVENUE_03

# PRODUCT _REVENUE_ID
# TRADE_NAME_ID

2 PRODUCT
# REV_2003

FPRODUCT _REVENUE_04

# PRODUCT _REVENUE_ID
~#TRADE_NAME_ID

2 PRODUCT
“/ REV_2004
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Create a Vertical Split Mapping
1 Display the physical model.

2 Right-click the table to be split and then click Denormalization Mapping > Vertical Splits.
3 Complete the Vertical Table Split Wizard as required.

NOTE: When apportioning columns, you can select multiple columns using Shift-Click or Ctrl-Click, then
drag them all at once to one of the new tables. The columns remain selected, so if appropriate
you can drag the same set to another new table.

Eliminating Joins by Copying Columns

Column Map Denormalization

A column map denormalization mapping copies a column from one table to another to improve query performance by
eliminating the need for a join. In the following example, the pubname column is copied into the titles table, eliminating
the need for a join when querying for the name of a book’s publisher.

pub_id (PK)
pub_name

city
state

pub_id (PK})
pub_name

city
state

country country

Create a New Column Map Mapping

1 Inthe Data Model tab of the Diagram Explorer, right-click the column you want to map and then click
Denormalization Mapping > Column Mappings.

2 Complete the Column Mapping Wizard as required.

NOTE: The first panel of the wizard is merely informative. If the correct column is listed, click Next;
otherwise, click Cancel and redo your selection.
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Removing Unnecessary Tables

Table Merge Denormalization

A table merge denormalization removes unnecessary tables by combining two or more unrelated tables with the same
primary key into a single table containing all tables’ columns.In the following example, all the fields from the jobs table
are merged into the dbo.newjobs table.

before after

To create a new table merge mapping:
1 Display the physical model.

2 Click and drag or Ctrl-click to select the tables to be merged.
3 Right-click one of the selected tables and then click Denormalization Mapping > Table Merges.

4 Complete the Table Merge Denormalization Wizard as required.

Notes

« If the Table Merges menu choice is dimmed, check to make sure you have not accidentally selected another
table or some other object.

¢ The first panel of the wizard is merely informative. If the correct tables are listed, click Next; otherwise, click
Cancel and redo your selection.

Undo a Denormalization Mapping

1 Inthe Data Model tab of the Diagram Explorer, right-click the mapping (under the Denormalization Mapping
section of the physical model).

2 Select Undo Denormalization Mapping.

NOTE: If the Reflect changes to original tables option was selected for the mapping, any changes made
to the denormalized tables have been propagated to the original tables. Otherwise, undoing the
mapping will restore the original tables in their pre-mapping state.

Synchronizing Physical and Logical Models

After normalizing or denormalizing the model you may want to synchronize it with the real-world database. Using the
Submodel Synchronization Utility, you can see the differences found and decide which changes you want to change.
For more information, see Synchronizing Submodels.



Working with the Data Dictionary

Using the Data Dictionary you can enforce standards, promote reuse, and build a common framework across all
models.

A well-defined Data Dictionary prevents the constant reinventing of the wheel and gives you everything that is needed
right at your fingertips. Domains used in conjunction with Reference Values, Defaults, and Rules let you build a
common list of data elements that you can use in any logical or physical model. You can use the attachment system to
add additional metadata to any object in a logical or physical model. Every object editor includes an Attachment
Bindings tab where you can add attachments.

Once you define objects in the Data Dictionary, you can use them in either the logical or physical models. You can
define domains to create “template” or reusable attributes and columns. For example a domain, Timestamp, can be
created for attributes or columns tracking a modify date. Now any LastModifyDate attribute or column can be bound to
the Timestamp domain so that they can all be managed through that single domain. Reference values, defaults and
rules can be implemented directly on attributes and columns, or used to further define the definition of a domain.
Using the previous example, a common default for LastModifyDate is the current system date. So a default can be
created in the Data Dictionary called CurrentSystemDate with a different definition depending on the target DBMS. If
this default is then bound to the Timestamp domain under the default tab, every attribute or column that is bound to
the domain will now get a default of the current system date.

You can use Data Dictionaries across many *.dml1 files. If the Repository is in use, the Enterprise Data Dictionary
system can be used to implement one dictionary across disparate models. Changes to an object in an Enterprise Data
Dictionary will be reflected in any model where that object is used. If the Repository is not in use, use the Import Data
Dictionary command (see Importing a Data Dictionary) to import dictionary objects from another * _dm1 file. An
important note to remember when using the latter implementation is that changes to one dictionary will not affect the
source dictionary.

Macros can also be used to import and export domain definitions and reference values from Excel if they need to be
imported from other sources such as an external metadata repository. For more information on Macros, go to the
Macro tab of the Diagram Explorer to view documentation and sample macros.

You can find a good example of a well structured Data Dictionary in the Northwind data model that
ships with ER/Studio.

NOTE: If you are using the ER/Studio Repository, you can create an Enterprise Data Dictionary, which
you can use in multiple diagrams. For more information see, Working with Data Dictionaries in the
Repository.

The following reusable dictionary objects are stored in object-specific nodes on the Diagram Explorer Data Dictionary
tab:

« Attachments: Associate database objects with datatypes such as a text note or a pointer to an external file. For
more information, see Attaching External Documents to the Data Model.

« Data Security Information: Enforce Enterprise Data Security standards and custom levels. For more
information, see Enforcing Security Using Data Security Types and Properties.

« Defaults: Make database population more efficient by using default values. For more information, see Enhancing
Data Integrity Using Defaults.

* Rules: Enforce data integrity by disallowing transactions that violate the rules. For more information, see
Promoting Data Integrity Through Rules.

* Reference Values: Lets you create and manage reference values. For more information, see Defining Valid
Attribute Data Using Reference Values.

« Naming Standards Templates: Enforces naming standards. For more information, see Enforce Naming
Standards Using Naming Standards Templates.



« User Datatypes: Customized datatypes allow for greater flexibility. For more information, see Ensuring

Consistent Domain Definitions Using User Datatypes.

« Domains: Reusable attributes and columns that make model creation more efficient. Quickly create a model by
populating entities and tables with attributes and columns defined in domains. For more information, see Reusing

Attribute Definitions Using Domains.

* Reusable Procedural Logic: Reusable triggers, reusable procedures, and libraries. For more information, see
Reusing Procedural Logic.

This section also addresses the following topics

* Importing a Data Dictionary

¢ Copying and Pasting Data Dictionary Objects

Importing a Data Dictionary

You can import the Data Dictionary of another data model diagram (DML file), making it building a new model easier
and more efficient. You can also use macros to perform task such as importing items like domains and object
definitions, setting storage parameters on physical tables, and add naming conventions to constraints.

Using a common data dictionary in your models facilitates the re-use and enforcement of established data definitions
across multiple data models. When you important a Data Dictionary, the new objects are added to the existing Data
Dictionary. ER/Studio maintains all existing dictionary objects as well as organization structures.

Import a Data Dictionary
1 Click File > Import Data Dictionary.

2 Inthe File Name box, type the name of the data model where the target data Data Dlctionary is stored, or browse
and locate it.

3 Choose how you want to handle name duplications by selecting one of the option listed in the Resolve Imported
Objects with Duplicate Names pane.

4  Click Open.

Copying and Pasting Data Dictionary Objects

You can select any standard Data Dictionary object and copy and paste it either within the current diagram on in
another diagram. When you copy or paste a Data Dictionary object, ER/Studio copies and pastes all of its dependent
objects too. You can also select multiple standard Data Dictionary objects, such as Defaults and Rules, or multiple
Procedural Logic Data Dictionary objects, such as Reusable Triggers or Reusable Procedures.

1 Onthe Diagram Explorer, click the Data Dictionary tab.
2 Onthe Data Dictionary tab, right-click one or more target objects and then select Copy Dictionary Objects.

3 Locate the target Data Dictionary (either the current diagram or to another diagram), right-click any node and
then select Paste Data Dictionary Objects.

Notes
* You can also copy and paste objects from a local dictionary to an Enterprise Data Dictionary.



* When pasting domains, you can use the Switch Domain Bindings macro to map local properties to enterprise
properties. You can find the macro in the sample macros on the Macro tab of the Diagram Explorer (Modeling
Productivity Macros) This macro scans all the columns and attributes in the active model or all models and
switches the domain bindings from the source domain to the target domain. The information for each bound
column will be updated with the target domain. Any domain overrides will be preserved.

« When making multiple selections, Procedural Logic Data Dictionary objects, they must be the same type (i.e.
reusable triggers or reusable procedures, but not both), all other objects can be different types.

« To enable to the Copy Data Dictionary menu item, you must click within a Data Dictionary object node.

* The Paste Data Dictionary menu item is available both at the root Data Dictionary object node as well as with in
the node.

Attaching External Documents to the Data Model

Attachments and attachment types offer a structured method for you to associate an external piece of information to
your data model. You can extend your metadata this way and include supporting documentation, such as meeting
notes, risk analysis and spreadsheets. You can bind attachments to virtually any file or application on your system.

Attachments are organized into two key components:

« Attachment Types - An organizational system where you can group together similar attachments and specify
which objects can have this type of attachment bound to them.
Attachment Types define the scope of the attachments created underneath them. Use attachment types to
organize attachments by either the object types to which they are applied or the scope of the business data they
are supposed to capture for a model. Once you create an attachment, you can bind it to any data model objects
associated with the attachment type.

e Attachments - Information that you can associate with the diagram objects types selected for the Attachment
Type. Attachments can take many different forms such as an external file, a date, or a test list.

You can find a good example of a well-structured attachments folder in the Northwind sample
model.

Create and Edit Attachment Types
1 Inthe Data Dictionary, right-click the Attachments folder and then click New Attachment Type.

2 Define the attachment type as required and then click OK to complete the editor.
The following describes options that are not self-explanatory:
Name page/tab

Define the name of the attachment type and provide a description of the attachment type, such as when and why
attachments of this type are used.

Attachment Type Usage page/tab

Lists all supported object classes to which you can bind attachments of this type. Any object classes you select
here will be bound to this attachment type and will be displayed subsequently on the Binding Information tab of
the Attachment Editor.

Notes

* When you want to only allow specific attachments to be bound to specific objects, you can create an Attachment
Type for this purpose and on this tab, indicate the specific objects by selecting the corresponding boxes.

« If you are editing an existing attachment type, and you remove object types from the object list on the Attachment
Type Usage tab, bound attachments associated with this attachment type will be affected.



« To only allow specific attachments to be bound to specific objects, create an Attachment Type for this purpose
and on the Attachment Type Usage tab, indicate the specific objects by selecting the corresponding boxes.

Create and Edit Attachments
1 Inthe Data Dictionary, right-click the appropriate attachment type folder and then click New Attachment.

2 Define the attachment as required and then click OK to complete the editor.
Once you've created the attachment, you can edit it by right-clicking the attachment you want to
change, and then selecting Edit Attachment.
The following describes the options that are not self-explanatory:
Name page/tab

Define the name of the attachment and provide a description of the attachment, such as when and why this
attachment is used.

Value page/tab

Select what kind of data this attachment contains. For Text List datatypes, you can list possible data values and
then set the default value.

Binding Information tab

Select the object classes and/or specific objects to which you want to bind this attachment. You can override this
setting using the Attachment Bindings tab of data model object editors.

Override an Attachment Value

The Value Override Editor lets you override an Attachment’s default value with a new value. This lets you add
additional information to a bound attachments. To override an attachment value, click the value field. The Value field
varies depending on your datatype selection. For example, if the attachment is a text datatype, the Value Override
Editor lets you edit the text. The following describes the different available datatypes and their associated values and
how you would change their values:

* Boolean: Lets you select None, True, or False.
« Date: Displays the current date. To change the date, click the list, and use the calendar to select the target date.

« External File Path: Lets you change an external file path. Enter a file path or browse and locate it. If you want to
view the attached file, click the View File button.

« Numeric: Lets you change the numeric value. Enter a numeric value in the box.
e Text: Lets you change the character value. Enter text in the box.

« Text List: Double-click the blank line in the text box, enter a value and then use the TAB key to go to the next
line. Repeat these steps until you finished adding values. Use the Up or Down buttons to reorder the values. Use
the Delete button to remove a value. The first entry is the default value. To change this, click the target value and
then click the Set as Default button.

« Time: Lets you change the time value. Select one of the time parameters (hours, minutes, seconds, AM/PM) in
the box, and enter a value or scroll to the appropriate value. Continue selecting time parameters and changing
the value until the appropriate time is entered.



Enforcing Security Using Data Security Types and Properties

The Data Security management function of the Data Dictionary extension helps enforce security standards within the
data model. It allows the data architect to classify objects in the model such as an entity, attribute, submodel or model
and associate the database object with various security impact levels or compliance mappings. You can document the
security of your data as you would document other properties such as the data steward would for functional business
areas or external documentation. Use reporting features to communicate security information to other stakeholders.

« Data Security Type: A top-level description of a security aspect to be observed. Default descriptions are
Compliance and Classification. You can add or edit your own types and then add properties to the types. For
example, you may want to describe how security is enforced, so you might add an “Enforcement Mechanism”
type and then give it properties such as “Project and Model passwords required,” “Read-Only Granted By
Default,” and so on.

« Data Security Property: A specific security attribute to be observed. A default example is “Compliance Mapping”
which describes which of several industry compliance and reporting standards should be maintained. You can
add or edit your own types and then add properties to the types. For example, you may want to describe how
security is enforced, so you might add an “Enforcement Mechanism” type and then give it properties such as
“Project and Model passwords required,” “Read-Only Granted By Default,” and so on.

The topics in this section include:

¢ Generate Default Security Information

« Create and Edit a Data Security Type
« Create and Edit a Data Security Property

Generate Default Security Information

1 On the Data Dictionary tab, right-click the Data Security Information folder and then click Generate Default
Security Information.

2 if you have already generated the default security information, choose how to resolve duplicate properties.

This generates Compliance Mapping, Privacy Level, and Security Information security properties that you can
customize for your environment.

Notes

« View and edit the default security properties, right-click a security property object and then select Edit Security
Property.

« If, after editing the default security properties, you want to reset the properties to their default values, generate
the properties again and, when prompted, overwrite the existing security objects.

Create and Edit a Data Security Type
1 Onthe Data Dictionary tab, right-click the Data Security Information folder and then click New Security Type.

2 Enter a name for the security property type, provide a description of it, such as when and why this security
property is used, and then click OK.

Once you've created the Data Security Type, you can edit it by right-clicking the type you want to
change, and then selecting Edit Data Security Type.



Create and Edit a Data Security Property

1 On the Data Dictionary tab, right-click the appropriate security type folder and then select New Security
Property.

2 Define the security property as required and then click OK to complete the editor.
Once you've created the Data Security Property, you can edit it by right-clicking the property
object you want to change, and then selecting Edit Data Security Property.
The following describes options that are not self-explanatory:
Name tab

Define the name of the security object and provide a description of it, such as when and why this data security
property is used.

Value page/tab

Select what kind of data this security object contains. For Text List datatypes, you can list possible data values
and then set the default value.

Binding Information tab

Select the object classes and/or specific objects to which you want to bind this security property. You can
override this setting using the Security Information tab of object class editors.

Enhancing Data Integrity Using Defaults

Defaults enhance data integrity in your model by supplying a value to an attribute or column when you do not specify
one. Defaults ensure that attributes and columns always adopt a value, even when the user or transaction does not.
provide one.

You can bind defaults to columns, attributes, and domains, along with user-defined datatype created in the Data
Dictionary. Defaults are created in the Data Dictionary, which lets you manage and reuse commonly used defaults.

Create and Edit Defaults
1 Inthe Data Dictionary, right-click the Defaults folder and then click New Default.

2 Define the default as required and then click OK to complete the editor.
Once you've created the Default, you can edit it by right-clicking the default you want to change,
and then selecting Edit Default.
The following describes options that are not self-explanatory:
Default Value tab
You must add the value in the same syntax as the database platform in which you intend to use the default.
Attachment Bindings tab

Lets you bind an external piece of information, or attachment to the domain. You can also remove an attachment
from an object, override an attachment binding’s default value, or change a bound attachment’s position. To
override the value of the attachment you have moved to the Selected Attachments grid, double-click the Value
field of the target attachment. ER/Studio opens the Value Override Editor or a list depending on the attachment
datatype. Attachments are created in the Attachments folder of the Data Dictionary and must be applied to the
default before they will display on this tab. For more information, see Attaching External Documents to the Data
Model.




Binding Information tab

Select the object classes and/or specific objects to which you want to bind this default. You can override this
setting using the Default tab of the data model object editor.

See Also
Determining Which Objects are Bound by Data Dictionary Objects

Changing Data Dictionary Object Bindings and Values

Promoting Data Integrity Through Rules

Rules promote data integrity by validating the data supplied to an attribute or table column. For example, you could
define a rule, NotLessThanZero, which specifies that data values for an attribute or column be zero or greater. Once
bound to a table column, the rule would reject any transactions that supply a negative value to the table column. Rules
are independent database objects that behave like check constraints, but can be re-used throughout your data model.

Rules, like Defaults in the Data Dictionary let you manage and reuse commonly used rules. Rules can be bound to
other dictionary objects such as datatype or UDTs as well as attributes/columns. Rules can be created directly in the
domain or under the Rules node.

Example

If you have a generic constraint that will apply to many fields, you can create a domain that will allow you to specify the
constraint in that domain. You can use a place-holder for the column in the table. Use @var to substitute the column
name. The column name replaces @var when a rule in the data dictionary is bound to a column.

For example, a rule was created in the Northwind.dm1 sample model, with the following syntax:

UPPER(@var) in (°Y*, “N*)



When that rule is bound to column au_id as follows:
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the rules translates to:

UPPER(CURRENT_CUSTOMER) in (°Y”, “N?)
as shown in the Check Constraint Value area in the following screenshot:
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Create and Edit Data Dictionary Rules
1 Onthe Diagram Explorer, click the Data Dictionary tab.

2 On the Data Dictionary tab, right-click the Rules node and then select New Rule.



3 Complete the Add/Edit Dictionary Rule Editor and required and then click OK to implement the changes.

Once created, you can edit the rule by double-clicking it to launch the editor.

The following describes options that are not self-explanatory:
Rule Value tab

Specifies the rule. You must specify the rule the value in the same syntax as the database platform in which you
intend to use the rule.

Attachment Bindings tab

Lets you bind an external piece of information, or attachment to the rule. You can also remove an attachment
from an object, override an attachment binding’s default value, or change a bound attachment’s position. To
override the value of the attachment you have moved to the Selected Attachments grid, double-click the Value
field of the target attachment. ER/Studio opens the Value Override Editor or a list depending on the attachment
datatype. Attachments are created in the Attachments folder of the Data Dictionary and must be applied to the
default before they will display on this tab. For more information, see Attaching External Documents to the Data
Model.

Binding Information tab

Select the object classes and/or specific objects to which you want to bind this rule. You can override this setting
using the Rule/Constraint tab of the object class editor.

See Also
Determining Which Objects are Bound by Data Dictionary Objects

Changing Data Dictionary Object Bindings and Values

Defining Valid Attribute Data Using Reference Values

Reference Values are attributes that define allowed data. They represent look-up table columns, code-value ranges,
or a rule or constraint applied to a column. Reference values can be defined as a range of values or as an itemized
list.

NOTE: You can import or export multiple Reference Values from Excel using a macro. On the Macro Tab
of the Diagram Explorer, click SampleMacros > Import Reference Values from Excel for
information on different macros.

1 Inthe Data Dictionary, right-click the Reference Values node and then click New Reference Value.

2 Define the reference value as required and then click OK to complete the editor.

Once created, you can edit the reference value by double-clicking it to launch the editor.

The following describes options that are not self-explanatory:
Reference Value tab

* Values ‘NOT’ Between: If selected, lets you define a range of values for the bound domain, attribute, or column
that are not considered valid.



* Reference Value Type:

* By Range: If selected, lets you define a range of values for the bound attribute, domain, or column. enter
values in the Minimum and Maximum fields in the Reference Value Range section.

« By List: If selected, lets you define a list of values for the bound attribute, domain, or column. If you select By
List, the Editor changes to display a Value and Value Description box. Double-click in the Value field in the first
line of the table and enter a value. To enter a description, double-click the Value Description field for the first
line to enter a corresponding description. Continue entering values in this manner until you have entered all
desired values. The blank line at the end of the list is disregarded when saving the Reference Value.
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Definition tab

Enter or edit a definition for the reference value. If the target database supports it, ER/Studio adds this definition
as a reference value comment when generating SQL code.

Attachment Bindings tab

Lets you bhind an external piece of information, or attachment to the reference value. You can also remove an
attachment from an object, override an attachment binding’s default value, or change a bound attachment'’s
position. To override the value of the attachment you have moved to the Selected Attachments grid, double-click
the Value field of the target attachment. ER/Studio opens the Value Override Editor or a list depending on the
attachment datatype. Attachments are created in the Attachments folder of the Data Dictionary and must be
applied to the reference value before they will display on this tab. For more information, see Attaching External
Documents to the Data Model.

Binding Information tab
Select which object classes and/or specific objects can use this reference value. You can override this setting

using the Reference Values tab of the data model object editor.

See Also
Determining Which Objects are Bound by Data Dictionary Objects

Changing Data Dictionary Object Bindings and Values




Enforce Naming Standards Using Naming Standards Templates

n a Naming Standards Template you can define standards for character case, or add prefixes/suffixes to make the
object types more easily recognizable. The Naming Standards Templates is comprised of an abbreviation list used to
automatically convert logical to physical names and vice versa, and options for a given model that define case
standards by object type, name length standards, and prefix/suffix standards. The Naming Standards Utility is used to
apply the naming standards templates to a model or objects within a model. For more information, see Enforce
Naming Standards Using Naming Standards Templates

A naming standards template can be created and stored either as either as part of a Naming Standards Template
object in the Data Dictionary of a dm1 file or as XML data in an external file. Naming standard templates are supported
in Enterprise Data Dictionaries as well as in local data dictionaries.

Once created and saved, the naming standards can be used when using other wizards within ER/Studio, such as XML
Schema Generation, Generate Physical Model, Compare and Merge, Model Validation, and Add New Physical Model.
The naming standards templates can also be applied to domains, attributes, and entities through a Naming Standards
tab in the object editors.

Reference the following topics to create a new naming standards template, import an existing template, define, view or
customize the naming standard template, export the naming standards template, and apply a naming standards
template to a model using the Naming Standards Utility.

1 Create a Naming Standards Template
2 Track Versions of Naming Standards Templates

Create a Naming Standards Template

There are two implementations of the Naming Standards Template Editor; one for creating an external template that
can be imported for use with any diagram, and another for creating a template that is bound to the active diagram. The
Naming Standards Editor, used to bind objects in the diagram to a naming standards template includes two tabs not
present in the external template editor, Attachment Bindings and Binding Information.

1 To create an external naming standards template and that is saved as an XML file, click Tools > Naming
Standards Editor.

To create a naming standards template that is saved as an object in the Data Dictionary of the active diagram,
from the Diagram Explorer, Data Dictionary tab, right-click Naming Standards Templates node and then click
New Naming Standards Template.

Using either of the methods above launches the Naming Standard Template Editor.
2 To save the new file and exit the utility, click OK.

If this template is a Data Dictionary object, the new naming standards template appears within the Diagram
Explorer, Data Dictionary, Naming Standards Templates node.

If this template is an external file, a new naming standards template file is created in the Model directory. Naming
standards templates have an extension of .nst.

Once created, you can edit the naming standards template by double-clicking its object on the
Data Dictionary tab to launch the editor.
The following describes options that are not self-explanatory:
Name tab

« Import from External Naming Standards Template: Enables you to important an XML-formatted naming
standards template file into the diagram. This could be an external naming standards template that was created
using the Naming Standards Template Editor accessible from the Tools menu.



« Export to External Naming Standards Template: The haming standards template is saved with a file name
extension of .nst. Other ER/Studio users can then use the import function to open the naming standards template
in their diagram.

Logical and Physical tabs

« Case column: Select a conversion option to apply to each logical data model object type:

The results achieved by applying the case conversion options are described in the table that follows:

Case conversion option Data model name Converted name (spaces removed)
[none] CUSTOMER ADDRESS CODE CUSTOMERADDRESSCODE
UPPER Customer CUSTOMER
lower CUSTOMER customer
UpperCamel CUSTOMER ADDRESS CODE CustomerAddressCode
lowerCamel CUSTOMER ADDRESS CODE customerAddressCode
Mapping tab

« Import/Export: Click to import or export an abbreviation list in a comma-delimited formatted file (.csv)

« Abbreviations tab: Map logical names to physical names and then further qualify the name type. On this tab,
you can also define illegal names, import an abbreviation list from a comma delimited file (.csv), or export the
abbreviation list that displays to a .csv file.

Prime: Indicates that the word entered in the Logical or Physical column makes the name unique such as,
Customer, Employee, and Account.

Qualifier: Qualifies the class word to further define the meaning of the attribute. A name could have multiple
modifiers. For example, a logical column name is Customer First Name ID, Customer is the Prime and ID is
the Class. If there are abbreviations in the Naming Standards Template for the logical texts First and Name,
and you check the qualifier box, ER/Studio sorts First and Name as qualifiers when it reorders the text during
translation.

Class: The type of data in an attribute. Class data is typically used in attribute and column names, not entity or
table names. Most new naming standards have the class word at the end of the attribute name such as, name,
date, code, id, and document.

lllegal: Words that are not allowed in names. These will mainly be used during the validation process.

Priority: Used to resolve duplicate physical abbreviations as names are transformed from physical to logical.
The default value of the Priority field is Primary. The priority changes to Secondary when you define a mapping
for a physical name that is already mapped to a logical name. You can change the priority by selecting the
priority field, clicking the down arrow and selecting another priority. When you change the priority of an
abbreviation from Secondary to Primary, the abbreviation that was previously Primary is changed to
Secondary. A physical name can only have one primary abbreviation, but can have many secondary
abbreviations.

Order tab

Specify the order of each part of the name for both logical and physical names. If the order is not specified, the
order of the parts in the original name is maintained.

For each object type, select the corresponding cell in the Part 1 column, click the arrow, and then select which
part of the name should come first when translating between logical and physical names. Then define the
second and third part of the name if required.

NOTE: To specify that an object part is unordered, select the appropriate cell in the part column, click the

arrow and then select the ellipsis (...).



General tab

« Delimiter Options area: Defines how to break up words in both the logical and physical model. For example,
should Customer Number be translated to CustNum or Cust_Num. On this tab,
To separate a word when a specific character is encountered, in the Delimiter Options section, click By
Character and then type the character.
To separate a word when a cases change is encountered, in the Delimiter Options section. select By Case.

¢ Special Characters area: Specifies which characters are to be treated as special characters and how they are
processed.

Attachment Bindings tab

Lets you bind an external piece of information, or attachment to the naming standards template. You can also
remove an attachment from an object, override an attachment binding’s default value, or change a bound
attachment’s position. To override the value of the attachment you have moved to the Selected Attachments grid,
double-click the Value field of the target attachment. ER/Studio opens the Value Override Editor or a list
depending on the attachment datatype. Attachments are created in the Attachments folder of the Data Dictionary
and must be applied to the reference value before they will display on this tab. For more information, see
Attaching External Documents to the Data Model.

Binding Information tab

Select which object classes and/or specific objects can use this naming standards template. You can override
this setting using the Naming Standards tab of the data model object editor.

Track Versions of Naming Standards Templates

You can track versions of a naming standards template (NST) by importing the NST into an NST object of an
Enterprise Data Dictionary; a data dictionary that has been or will be added to the Repository. Whenever you check in
the Data Dictionary, you can add notes describing the changes applied. You can view the version history of any
object. in the Repository.

See Also
Working with Data Dictionaries in the Repository

Viewing the Checkin History of a Repository Object

Ensuring Consistent Domain Definitions Using User Datatypes

User-defined datatypes are a powerful mechanism for ensuring the consistent definition of domain properties
throughout a data model. You can build a user-defined datatype from base datatypes, specifying width, precision and
scale, as applicable. In addition, you can bind rules and defaults to the user-defined datatype to enforce domain
integrity. After creating a user-defined datatype, you can use it in attributes, table columns, and domains without
needing to define its underlying definition each time. User-defined datatypes are particularly useful with
commonly-referenced table columns in a database, such as PhoneNo, ZipCode or PartNo.

The central maintenance of user datatypes eliminates the tedium and potential for errors users can encounter when
manually editing each referenced table column. For example, you can define a surrogate key in the Part table, PartNo,
as an integer for efficiency. You have defined a user datatype, partnumber, to represent every use of PartNo
throughout the database design. Subsequently, you learn that the data to be converted from a legacy system contains
some part numbers in character format. To accommodate the change, you only need to edit the definition of
partnumber from an integer to a character-based user datatype. ER/Studio automatically converts all table columns
using partnumber to the new definition.



Although only a few database platforms currently support user-defined datatypes, ER/Studio extends their utility to all
database platforms in the physical model. ER/Studio automatically converts user-defined datatypes to their base
definitions when generating SQL code for any database platforms that do not provide native support.

NOTE: For SQL Server, Sybase, and IBM DB2 only, the CREATE statements of the user datatype can be
included in the DDL when generating the database.

Create and Edit User Datatypes
1 On the Data Dictionary tab, right-click the User Datatypes node and then select New UserDatatype.

2 Define the user-defined datatype as required and then click OK to complete the editor.
Once created, you can edit the naming standards template by double-clicking its object on the
Data Dictionary tab to launch the editor.
The following describes options that are not self-explanatory:
UDT tab

« Apply nullability to all bound columns: If you indicate Yes Allow Nulls, this check box is available. When you
are editing the user datatype and you change this selection from what it was previously, selecting this check box
broadcasts the change to all objects bound to this user datatype.

« Default Binding: Optional If you want to bind the user datatype to a Default, select it from the list.
* Rule Binding: Optional If you want to bind the user datatype to a Rule, select it from the list.
Attachment Bindings tab

Lets you bind an external piece of information, or attachment to the user dataype. You can also remove an
attachment from an object, override an attachment binding’s default value, or change a bound attachment’s
position. To override the value of the attachment you have moved to the Selected Attachments grid, double-click
the Value field of the target attachment. ER/Studio opens the Value Override Editor or a list depending on the
attachment datatype. Attachments are created in the Attachments folder of the Data Dictionary and must be
applied to the user datatype before they will display on this tab. For more information, see Attaching External
Documents to the Data Model.

Binding Information tab

Select which object classes and/or specific objects can use this user-defined datatype. You can override this
setting using the Attributes or Columns tab of the entity or table editor, respectively, or on the Datatype tab of the
domain editor.

NOTE: auser datatype and change its definition, ER/Studio automatically updates your entire model so
that all affected objects use the new definition.

Reusing Attribute Definitions Using Domains

Domains are very useful for creating entity attributes or table columns commonly used in your models. Creating a
domain allows you to define the object once and then use it repeatedly by applying the domain to the entity attributes
and table columns.

Domains are reusable attribute templates that promote consistent domain definitions. You construct domains as you
would attributes, specifying a name, datatype properties, null status, default values and validation rules. After creating
domains, you can re-use them in your data model by applying them to attributes and table columns. By defining a
domain, you also gain the power of propagating changes to the underlying domain definition to all attributes and table
columns that reference it.



One important method for enforcing business rules is to define and to apply domain restrictions. Domain integrity
refers to the rules governing what values an attribute can take. By restricting and validating an attribute’s values, you
can implement important business rules such as ensuring that a checking account maintains a positive balance, or
preventing the entry of invalid phone numbers.

ER/Studio lets you organize your domains using domain folders. Domain folders let you create and manage your Data
Dictionary Domains. You can classify domains in unique groups by creating different domain folders. You can create
nodes within nodes. You can move existing domains into a domain folder, or create new domains within the folder.

Domains can be dragged and dropped into a table or entity to create a column or attribute. Domains can also be
dragged onto another domain to create a subdomain, by moving the selected domain beneath the target domain.
Domains can also be copied and pasted onto another domain to create a copy of the selected domain as a subdomain
or the target domain. Note, changes to the copied domain will not be inherited by the pasted subdomain.

Domains can have nested subdomains or child domains that initially duplicate most of the attributes of the parent
domain, but can have divergent behaviors once created. A Domain Override option in the Add Domain or Edit Domain
functions creates inheritance and overrides the domain system without losing the valuable relationship with the
attributes/columns (binding information).

NOTE: When you delete a domain folder, all domains and folders within that folder are also deleted. All
bindings to any columns and attributes are unbound.

Create a Domain Folder
1 On the Data Dictionary tab, right-click the Domains node and then click New Domain Folder.

2 Enter a name for the domain and then click OK.

Create and Edit a Domain or Subdomain

1 To create a domain at the root of the Domains node, on the Data Dictionary tab, right-click the Domains node
and then click New Domain.

To create a domain within a domain folder, on the Data Dictionary tab, expand the Domains node, right-click
the node of a domain folder, and then click New Domain.

To create a subdomain (a domain within a domain folder), on the Data Dictionary tab, navigate to the domain
folder where you want to create the subdomain, right-click the domain folder, and then click New Domain.

2 Define the domain as required and then click OK to complete the editor.

Once created, you can edit the domain by double-clicking its object on the Data Dictionary tab to
launch the editor.

The following describes options that are not self-explanatory
Datatype tab

* Receive Parent Modifications: For subdomains, lets you synchronize changes made to the attributes of a
parent domain with a those of the child domain. Selecting this option automatically synchronizes parent and child
attributes, except those specified on the Reference Values, Naming Standards, Attachment Binding, and Binding
Information tabs. Not selecting this option creates a child domain that is initially identical to the parent domain,
except that the child domain is created without any attachment bindings. Subsequent changes to the parent
domain will not be inherited by the subdomain. Any changes you make to the subdomain will override the values
inherited from the parent domain. Henceforth, the child can only inherit attributes from the parent if these
attributes were not previously specified for the child.

« Synchronize Domain and Attribute/Column Names: Select this option to synchronize the Domain, Attribute,
and Column Names. If you entered names in the Attribute and/or Column Name fields that are different than the
Domain name, selecting this option overrides your entries.



« Apply nullability to all bound columns? This option becomes available when you select a datatype that can
have nulls but you choose to disallow nulls by clicking No in the Allow Nulls area. Selecting this check box does
not impact if there are no bound columns.

« Identity Property area: This area becomes available if the Identity Property is supported by the database
platform of a model in the diagram, and the datatype selected, such as TINYINIT, supports this property.

Default tab

« Default Binding: If a default value has not already been bound to the domain (Data Dictionary > Defaults > Edit
Default Definition > Binding Information), you can enter a Declarative Default value or choose another Default
from the Default Binding list. The declarative default will appear in the SQL produced when you select Generate
Database from the physical model.

« Declarative Default: Specifies the default domain value when a value is not explicitly specified during an insert.
DEFAULT definitions can be applied to any columns except those defined as timestamp, or those with the
IDENTITY property. Only a constant value, such as a character string; a system function, such as
SYSTEM_USER(); a NULL; or a constraint name can be assigned to a DEFAULT.

Rule/Constraint tab

Add, modify, or delete a constraint. Check constraints are used to ensure the validity of data in a database and to
provide data integrity. For more information, see Enforcing Data Integrity Using Check Constraints.

Reference Values tab

Reference Values are attributes that define allowed data. They represent look-up table columns or code-value
ranges or a rule or constraint applied to columns. For more information, see Defining Valid Attribute Data Using
Reference Values.

Naming Standards tab

Controls user and object permissions to modify the affected item. When a Naming Standards Template is bound
to an object, then that template is used instead of the Naming Standards Template selected in the Naming
Standards Utility or the Generate Physical Model utility. This allows you to apply different naming standards to
different objects when portions of a model require different versions of a standard. For example, some objects
already exist in the database and you do not want to apply a newer naming standard to them. For more

information, see Enforce Naming Standards Using Naming Standards Templates.

Definition tab

Enter or edit a definition for the domain. If the target database supports it, ER/Studio adds this definition as a
domain comment when generating SQL code.

Note tab

The notes added here are included as part of the HTML report when you generate a report for the model. You
can format the notes using standard HTML tags.

Override Controls tab
Controls what can or cannot be overridden on columns bound to this domain.

* General Overrides area: The allow/disallow options disable the “override” indicator on the bound
attributes/columns if set to Disallow. When you modify the domain override controls and set one or more of the
general override options to Disallow, ER/Studio (and the RepoServer for Enterprise Data Dictionaries) removes
all existing overrides for that particular property.

« Name Synchronization: Completely detaches the domain name from the bound attributes/columns. This avoids
inadvertent changes when the attribute or column names are set to the same as a column, creating a partial
sync, but then further changed causing the attribute or column to change.



« Attachment Synchronization: Keeps attachments in the domain in sync with the bound column. Any
attachments added to a domain will propagate to the attributes/columns. Always Migrate always migrates new
attachments on the domain to the columns. You can still add other attachments directly to the columns.

Attachment Bindings tab

Lets you bind an external piece of information, or attachment to the domain. You can also remove an attachment
from an object, override an attachment binding’s default value, or change a bound attachment’s position. To
override the value of the attachment you have moved to the Selected Attachments grid, double-click the Value
field of the target attachment. ER/Studio opens the Value Override Editor or a list depending on the attachment
datatype. Attachments are created in the Attachments folder of the Data Dictionary and must be applied to the
domain before they will display on this tab. For more information, see Attaching External Documents to the Data

Model.
Binding Information tab

Select the object classes and/or specific objects to which you want to bind this attachment. You can override this
setting using the Attribute or Column tab of the entity or table editor, respectively.

Reusing Procedural Logic

The Data Dictionary supports the following types of procedural logic and enables you to organize them by database
platform:

* Reusable Triggers: A special type of stored procedure that automatically executes when data modification
operations such as INSERT, UPDATE, or DELETE occur. Because triggers are customizable and fire
automatically, they are often used to maintain referential integrity in a database.

« Reusable Procedures: Templated procedures written in BASIC code. These procedures can be applied to any
table, since they use the table’s context in the code.

« Libraries: Lets you compartmentalize blocks of code used to generate SQL for Reusable Triggers and Reusable
Procedures. This lets you reuse blocks of code. Reusable triggers or procedure code can call library functions.

The editor that launches when creating new procedural logic is the Sax Basic editor, which is compatible with
Microsoft Visual Basic.

Topics covered in this section are:
« Create and Edit Reusable Triggers
* Create and Edit Reusable Procedures

¢ Create and Edit Libraries

Create and Edit Reusable Triggers
1 Selectatable.

NOTE: The SQL in the procedure will be validated in context of the table selected and the database
platform. If no table is selected, the SQL cannot be properly validated.
2 Inthe Data Dictionary, expand the Reusable Procedural Logic node and then expand the Reusable Triggers

node.

3 Right-click the node for the appropriate database platform and then click New Trigger.



4 Define the trigger as required and then click OK to complete the editor.
Once created, you can edit the trigger by double-clicking its object on the Data Dictionary tab to
launch the editor.
The following describes options that are not self-explanatory:
BASIC tab

Includes a text editor as well as all the editing and formatting tools that are available on the ER/Studio Macro
Editor. You can enter trigger code or you can use the Import button to import it. You can use Visual BASIC
and/or Al to create the code for the reusable trigger.

« DBMS: If you change the DBMS from the one you clicked when you opened the editor, you can use the Copy
Dictionary Object functionality to move the Trigger to the correct DBMS node.

« Select Libraries: Click to select a previously defined library to add to the trigger code. When using library
functions, the library file needs to be selected by selecting this option.

Create and Edit Reusable Procedures
1 Selectatable.

NOTE: The SQL in the procedure will be validated in context of the table selected and the database
platform. If no table is selected, the SQL cannot be properly validated.
2 Inthe Data Dictionary, expand the Reusable Procedural Logic folder and then expand the Reusable
Procedures folder.
3 Right-click the folder for the appropriate database platform and then click New Procedure.
4 Define the reusable procedure as required and then click OK to complete the editor.
Once created, you can edit the procedure by double-clicking its object on the Data Dictionary tab
to launch the editor.
The following describes options that are not self-explanatory:
BASIC tab

Includes a text editor as well as all the editing and formatting tools that are available on the ER/Studio Macro
Editor. You can enter procedure code or you can use the Import button to import it. You can use Visual BASIC
and/or Al to create the code for the reusable procedure.

« DBMS: If you change the DBMS from the one you clicked when you opened the editor, you can use the Copy
Dictionary Object functionality to move the procedure to the correct DBMS node.

¢ Select Libraries: Click to select a previously defined library to add to the procedure code.

Create and Edit Libraries
1 Inthe Data Dictionary, right-click the Libraries folder and then click New Library.

2 Define the library as required and then click OK to complete the editor.
The following describes options that are not self-explanatory:
BASIC tab

Includes a text editor as well as all the editing and formatting tools that are available on the ER/Studio Macro
Editor. You can enter library code or you can use the Import button to import it. You can use Visual BASIC and/or
Al to create the code for the library.



Library Example

"This function generates the header for a templated insert
"procedure. Input is entity name that is used to generate
"procedure name. Platform is Oracle.
Function insertprocheader (ent As Entity) As String
Dim result As String
Dim attr As AttributeObj
"add create statement for the procedure with naming convention
result = "CREATE OR REPLACE PROCEDURE P & ent.TableName & "INSERT™ & vbCrLf
result = result & """ & vbCrLF
"add parameter list for insert statement
"loop in actual sequence order
For i = 1 To ent_Attributes.Count
For Each attr In ent_Attributes
IT attr.SequenceNumber = 1 Then
"make parameter line for column

result = result & "V" & attr.ColumnName & vbTab & vbTab & vbTab
result = result & "IN "
result = result & attr.Datatype & "," & vbCrLF
End If
Next attr

Next 1
“trim last comma of the parameter list
result = Left(result, Len(result) - 3)
"add last closed parantheses
result = result & )" & vbCrLF
result = result & "AS" & vbCrLf & "BEGIN" & VvbCrLf
"return header
insertprocheader = result
End Function

Call to Library Example
This sub main routine demonstrates how to call a library function.

NOTE: The library needs to be added to the reusable trigger or stored procedure

Sub Main
Dim procstring As String
procstring = insertprocheader(CurrEntity)
"call other library functions for body of procedure
"call other library functions for end of procedure
"check procedure text with a message box
"disable when generating DDL
MsgBox(procstring)
"output procedure string variable to DDL wizard
resultstring = procstring

End Sub

Determining Which Objects are Bound by Data Dictionary Objects

The View Bindings dialog box displays the names of the attributes or columns to which the selected Data Dictionary
object is bound. Selected objects show which domains are bound to which attributes and columns.

1 On the Data Dictionary tab, navigate to the dictionary object you want to investigate, such as a specific rule.
2 Right-click the data dictionary object and select View .... Bindings, where ... is the name of the data dictionary

object.

Notes
« The View Bindings dialog is read-only.

« To unbind an object, use the Binding Information tab of the data dictionary object editor or the relevant tab of the
editor of the database class or object you want to unbind.



See Also

Changing Data Dictionary Object Bindings and Values

Changing Data Dictionary Object Bindings and Values

The bindings of data dictionary objects can be overridden in the data model object editor. For example, you've created
a security property and applied it to an entity. Unbinding the security property from an attribute of that entity or
changing the value of the security property can be accomplished through the Security Information tab of the Attribute

Editor.

NOTE: Inorderto bind an data dictionary object to a database object, that specific object or class to which
the object belongs, must have been bound to the data dictionary object in the data dictionary

object editor.

1 Inthe Diagram Explorer, right-click the data model object, and then click Edit.

2 Inthe editor, click the relevant tab, as described in the table below.

To change bindings of this type

Use this tab in the database object editor

Attachments

Attachment Bindings

Data Security Information

Security Information

Defaults

Default

Rules

Rule/Constraint or Constraints

Reference Values

Reference Values

Naming Standards Templates

Naming standards

User Datatypes

Datatype

Domains

Attributes

NOTE: You can also bind Attachments to an entire diagram. You can change the diagram bindings on
the Diagram Properties dialog. Click File > Diagram Properties.

3 Make your changes and then click OK to exit the editor.

Notes

* You can override the value of an attachment by double-clicking the value of the attachment in the grid, which

brings up the Value Override Editor.

* When you create a report, you can choose to include details of bound attachments for the objects selected to
described in the report. For more information, see Generating RTF and HTML Model Reports.

Working with the Enterprise Data Dictionary

If your installation comprises ER/Studio Enterprise Edition and access to the ER/Studio Repository, you can promote a
local data dictionary to the Repository, thereby creating an Enterprise Data Dictionary which can be shared amongst

Repository users. For more information, see Working with Data Dictionaries in the Repository.




Documenting Data Extraction, Transformation, and Load

This section is comprised of the following topics:

¢ Introduction to Data Lineage

« Data Lineage Workflow

« Creating and Editing Data Lineage Data Flows
¢ Defining Source Systems

* Relating Source and Target Tables and Columns

¢ Documenting Table/Entity Data ETL

« Documenting Column/Attribute ETL

Introduction to Data Lineage

Data Lineage enables you to document the movement of data from point A to point B, and any intermediate steps in
between. This movement is sometimes referred to as Extraction, Transformation and Load (ETL). Points A and B can
be anything from flat files, high-end databases like Oracles and DB2, XML files, Access databases, and Excel
worksheets. This is sometimes referred to as source and target mapping. A model produced in ERStudio can
represent any point along the way. Data Architects need the ability to specify the “source” or “target” of data, down to
the column/attribute level. Along with the metadata that defines the source and target mapping are rules for how the
data is manipulated along the way.

The task of moving the data is often assigned to specialized developers who have little data modeling experience.
They need good documentation to guide them in deciding what data goes where. Documenting the movement or
mappings for the developers is usually the task of a data architect. Data Architects need to track data between very
complex systems. For example, an organization may have a data warehouse that consists of data sourced from a
number of different systems, such as CRM (Customer Relationship Management), payroll, general ledger, accounting,
product, and inventory systems. The data warehouse may in turn have on-line data marts that receive data from it to
produce reports for Sales Executives, HR Executives and marketing teams that are generating reports about the
performance of various aspects of the business.



The following illustrates a generalized data movement process:
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In this illustration, the data is sourced from various systems on the left and fed to a data warehouse that stores the
data in a format that is more conducive to reporting. This reduces the amount of overhead on the source systems so
resources are not used for reporting directly on them. The data also must be cleansed to ensure the quality of the data
used for reports. Reports can be generated directly from the Enterprise Data Warehouse (EDW), but many times are
fed to other specialized data marts targeted for specific audiences. Further cleansing or manipulation of the data is
performed in the process of moving it to the Online Data Manager (ODM). An organization using ERStudio would most
likely have a model of each part of this process, the Customer Releation Management (CRM), General
Ledger/Accounting, Orders, Inventory, EDW, and ODMs. It is the job of the data architect to “map” these systems
together. They manage the models and need to define the mappings which produce reports that assist the data
warehouse engineers. An ETL developer feeding data into one of the data marts needs to know what columns and
tables to get the data from in the EDW. For consistency sake, they may also need the mappings from the legacy or
Online Transaction Processing (OLTP) systems.

ER/Studio provides several ways for you to document how your data moves from system to system.
In Reports and generated SQL you can view the ETL information you've specified as follows:

< In the Table editor, you can document how often the data is extracted along with the rules that regulate data
movement

¢ In the Table Column editor, you can document how the data is transformed as it moves from source to target,
known as source-to-target mapping.

Using the Data Lineage tab you can create a visualization of the data movement and transformation, so you can see
the relationships between the source and target, how the data flows from one table to another, and how the data is
transformed.



Data Lineage Workflow
Data Lineage workflow generally goes as follows:

1 Defining Source Systems

2 Relating Source and Target Models
3 Relating Source and Target Tables and Columns

Creating and Editing Data Lineage Data Flows

Documenting Table/Entity Data ETL

o o b

Documenting Column/Attribute ETL

7 Share the data lineage with your colleagues through reports, SQL, XML, exported Metadata or through the
ER/Studio Enterprise Portal and ER/Studio Viewer.

Defining Source Systems

Data sources can originate from models in the active diagram (local models), from external sources imported into the
active diagram or from a data sources created on the Data Lineage tab. The source can be imported from * .dm1 files,
*_dtl files, database or a SQL files, flat files, and other common application files. Potential sources from the open
diagram are found on the Data Lineage tab, which can be seen by expanding Data Sources > Local Models.

NOTE: Source data imported through the Data Lineage tab only includes information such as table and
column name, datatype, nillability, primary key, and column definitions. To obtain more details,
reverse engineer the database or import it into ER/Studio using the Metadata Wizard.

This section is comprised of the following topics:

« Creating a new Source
« Importing External Source into Other Sources

Creating a new Source
1 From the Data Lineage tab, expand the Data Sources node.

2 Right-click Other Sources and choose New Source.
3 Complete the Data Source Properties dialog as required and then click OK to exit the editor.

The new source will appear under the Other Sources node with one empty object node, which may be Tables or
Entities depending on the data source type defined.. You can edit the new source model by expanding the Other
Sources node, and then the new source node. Then, right-click the source object and select Add Table/Entity to
launch the Table or Entity Editor.

The following describes options that are not self-explanatory:
General tab
¢ General Properties

« Name: The name you give it here will be displayed as a data source in the Other Sources node within the Data
Lineage tab.

« Type: Select the source type. This setting affects available options in the Connectivity group. For example,
select Relational for a DBMS such as MySQL.



Connectivity Properties

* Host, Server/Service, Port: For connecting to an external DBMS. For an existing ER/Studio physical model,
leave blank.

« DBMS Type, Version, Location/Path, File Type, Encoding: These settings depend on the Type selected
above.

Model Usage tab

This is a read-only display of the source defined on the General tab. Ensure that it matches your intentions.

Importing External Source into Other Sources

1

2

3

From the Data Lineage tab, expand the Data Sources node.

Right-click Other Sources and choose Import New Source.

Complete the Data Source Properties dialog as required and then click OK to exit the Import Source wizard.
The new source will appear under the Other Sources node.

The following describes options that are not self-explanatory:

Page 1 - Please select where you would like to import the source metadata from

From a Repository based DML1 file: Lets you obtain source from data models and Named Releases managed
within the ER/Studio Repository. When you select this option, ER/Studio opens the Repository Operation Status
dialog box and the Get From Repository dialog box. This process connects to the current Repository Server
defined in the Repository settings. The Import Source wizard automatically gets the diagram.

From an SQL file ER/Studio imports the SQL file.

Compare against a live database: If you select this option, a page appears where you can select the database
and connection type. The connection type can be either ODBC or Native/Direct Connection. For information
about connecting to databases, including troubleshooting information, see Connecting to Database Sources and

Targets.

Comparison Quick Launch: The Compare Quick Launch data is saved as an *.rvo file. For information on using

the Quick Launch option in the wizard, see Saving and Using Quick Launch Settings.

Page 5 - Results

¢ Current and Target Model Display Grid: Between the Source and Target models is a Resolution column.
The default merge decision is Merge the data into the new source file. You can click on any item in the
Resolution column to enable the decision list. If you want to change the decision, click the list and then click
the new resolution. When you change the default resolution of an object, the decisions of their dependent
properties and objects are automatically updated. You can also click the category folders, like the Tables
Resolution column to change all the decisions for all the underlying objects in that object category. And, you
can use the CTRL key to select multiple items, and then right click to enable the decision list.

* SQL Dlfference: To enable the SQL Difference utility, select any difference that is a long text field, such as a
Definition, Note, or DDL, and then click SQL Difference to view the differences between the SQL of the
models. This utility only allows you to view the differences; difference resolutions are performed on the Results
page of the Compare and Merge Utility.

< Filter Report on Results: Create a report of the source content and your chosen resolutions. You can choose
to create an HTML or an RTF report.

You can modify the default display using the options at the bottom of the page.



Relating Source and Target Models

Data movement properties describe how source and target models are related outside of the Data Lineage tab. You
can relate a source model to one or more models in the same diagram or to models imported from external systems.
The rules defined here are used at the table/entity level on the Data Lineage tab of the entity and table editors.

1 Onthe Data Model Explorer, right-click the top-level node for the particular model and select Data Movement
Properties.

2 Select the Source or Targets tab.
3 Select the level of mapping you intend to add or edit.
4 Click Add and select from among the models listed.

5 Select the Synch registered data... option if you want changes to the current model that extend to other models
in the .dm1 file to be automatically updated.

Once complete, you can double-click any table to edit table-level and column-level movement rules.

Relating Source and Target Tables and Columns

Data movement rules describe how source and target tables and entities are related. You can relate source data to
one or more tables and entities in the same model, the active diagram, or to tables imported from legacy systems. The
rules defined here are used at the table level on the Data Lineage tab of the entity and table editors.

Create and edit data movement rules
1 Onthe Data Lineage tab, right-click Data Movement Rules and choose New Data Movement Rule.
2 Complete the Data Movement Rule editor as required and then click OK to exit the editor.

Once created, you can edit the Data Movement rule by double-clicking it to launch the Data Movement Rule
editor.

The following describes options that are not self-explanatory:
Rule Information tab

« Rule Name: Enter a name that indicates the operation and objects acted on, depending on the specifics of your
binding definition.

* Rule Type: Select a generic movement rule type that best describes the data movement.
¢ Rule Text: Document your data movement plan here, perhaps adding instructions or contingency plans.
Binding Information tab

Select the object classes and/or specific objects to which you want to bind this rule. You can override this setting
using the Data Lineage tab of the entity or table editor.

See Also
Data Lineage Workflow



Assigning Model Data Movement Properties

Assigns data sources or targets and the level of mapping you intend to use, direct or secondary. You must first have
added a source/target in the Data Lineage tab using the Data Source/Targets Properties. To add a data source/target
to a physical model:

1

2

Right-click the top-level node for your particular physical model name and select Data Movement Properties.
Select the Source or Targets tab.

Select the level of mapping you intend to add or edit.

Click Add and select from among the models listed.

Select the Synch registered data... option if you want changes to the current model that extend to other models
in the .dm1 file to be automatically updated.

Once complete, you can double-click any table to edit table-level and column-level movement rules.



Creating and Editing Data Lineage Data Flows

The Data Lineage Data Flow organizes and encapsulates one data transformation and the source tables and columns
used in the transformation to produce the target data. Multi-tiered mappings are possible and there can be multiple
transformations involving different attributes/columns between two entities/tables as illustrated below.
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Displaying the transformation definition, inputs and outputs, and code is controlled by the

Transformation options in the Diagram and Object Display Options editor. For more information,
see Configuring and Customizing ER/Studio.

Create a Data Lineage Data Flow

1 From the data model explorer, click the Data Lineage tab at the bottom of the application window.

2 If this is the first time you click the Data Lineage tab after opening a diagram, you are prompted to create a Data

Lineage Data Flow. Click Yes.

If this is not the first time you click the Data Lineage tab after opening a diagram, from the Data Lineage explorer,
right-click the Data Flow node in the Data Lineage explorer and then click Create Data Flow.

3 Enter a data flow name and then click OK.

NOTE:

The name that appears in the diagram title tab at the top of the application window is appended

with : data flow name, when you click a data flow in the Data Lineage explorer, such as
GIMDB.DML1 - Data Flow Model View: Data Flow Name*.



4 If you have not already created your data movement rules and data sources and targets, proceed to Relating
Source and Target Tables and Columns or Defining Source Systems, and then return to step 5.

5 Navigate to and then drag and drop the source and target tables or entities onto the Data Lineage window.
You can have multiple source and target tables or entities. Drag and drop as many as you need.
You can choose to display the inputs and outputs of the transformation, by right-clicking an empty

space on the Data Lineage window and selecting Diagram and Object Display Options, then
clicking the Transformation tab and selecting Input and Output Columns.

NOTE: The Data Lineage Window will continue to display the data flow visualization if you click the

Repository, Data Dictionary or Macros explorer tabs, but if you click the Data Model tab, the Data
Lineage Window is replaced with the Data Model window. Clicking the Data Lineage tab brings
back the Data Lineage window.

6 Right-click an empty space of the Data Lineage window and then click Insert Transformation.

7 Double-click the new transformation to open the Transformation Editor.

8 Complete the Transformation Editor as required and then click OK to exit the editor.
Once the data flow is created, you can double-click it to change its name, or double click a
transformation or component to change its properties.

9 Right-click an empty space of the Data Lineage window and then click Insert Data Stream.

10 Click an input source and then click the transformation object. Repeat as many times as necessary to link all the
inputs to the transformation object.

11 Click the transformation object and then click an output. Repeat as many times as necessary to link all the
outputs to the transformation object.

The following describes options in the Transformation Editor that are not self-explanatory:
Columns tab (also used for Attributes)
< Inputs: Click the ellipsis (...) button to choose the source data to be transformed in this data flow.
« Outputs: Click the ellipsis (...) button to choose the source data to be transformed in this data flow.
Definition tab
* Business: Describe the transformation for your audience.

« Code: Enter the code that will perform the transformation, such as a SELECT statement, of a VB Basic or
JavaScript function or procedure.

Rules tab
These are the rules from the Data Movement Rules node of the Data Lineage explorer.

NOTE: You can delete or edit an input or output column by double-clicking the transformation in the Data
Lineage window, clicking the ellipsis in the Transformation Editor and then deselecting the column
you want to remove.



Attachments tab

Lets you bind an external piece of information, or attachment to the transformation. You can also remove an
attachment from an object, override an attachment binding’s default value, or change a bound attachment'’s
position. To override the value of the attachment you have moved to the Selected Attachments grid, double-click
the Value field of the target attachment. ER/Studio opens the Value Override Editor or a list depending on the
attachment datatype. Attachments are created in the Attachments folder of the Data Dictionary and must be
applied to the default before they will display on this tab.

See Also
Data Lineage Workflow

Documenting Table/Entity Data ETL

Use the Data Lineage tab of the entity or table editor to document how often the table/entity data is sourced and when
it was last sourced. Once you have created data movement rules in the Data Lineage Explorer, you can apply these
rules to the selected table/entity. You can associate as many data movement rules as you want to the table/entity. You
can report data movement rules when creating reports, generating SQL or XML Schema, or Metadata is exported.

Document table data movement

1 From the Data Model tab, navigate to and then double-click the table/entity whose data lineage you want to
document.

2 Inthe Table Editor, click the Data Lineage tab.

3 Complete the Data Lineage dialog as required and then click OK to exit the editor.

See Also
Data Lineage Workflow

Documenting Column/Attribute ETL

At the column/attribute level, you can document how data is transformed as it moves from one system to another, by
adding transformation logic for source/target attribute mapping. You can map multiple source/targets to one
column/attribute in the physical/logical model.

You can register the same source/target or physical model more than once for a given physical model. For example, in
the Adventure Works.dm1 model, you can register the Adventure Works physical model to the Adventure Works DW
physical model as a direct source AND direct target if the data warehouse is used for analytical reporting and to
perform some data cleansing. Additionally, you can also register the Adventure Works physical model to the
Adventure Works DW physical model as both a secondary source and direct source.

Document column/attribute data sources

1 From the Data Model tab, navigate to and then double-click the table/entity whose data lineage you want to
document.

2 In the table/entity editor, select the column or attribute to document and then click the Data Lineage tab.
3 Click the Direct Sources tab.

4 Click Edit.



In the Edit Source/Target Mappings dialog, select from the list of sources to map to your target and edit the
transformation logic accordingly.

A description is optional, but a very good engineering practice vital to maintainability.

Continue in the same manner as above, to map secondary sources, and direct and secondary targets.

Click OK to exit the editor.

Saving and Using Quick Launch Settings

To improve efficiency when performing repetitive tasks, Quick Launch lets you save settings and selections for select
ER/Studio wizards and utilities for later reuse. You can save settings in separate files for each of the following wizards
and utilities

Compare and Merge

DDL Generation

Model Validation

Naming Standards

Reports, Reverse Engineering
Reverse Engineering
Submodel Synchronization

XML Schema Generation

Save Quick Launch Settings to a File

1
2
3
4

On the last page of the wizard or utility, deselect Use file-based Quick Launch settings.
Click Save As.
Enter a name for the quick launch settings file.

Click OK.

Use Quick Launch Settings from a File
1 Select Use file-based Quick Launch settings.

2 Click Load File.



3 Navigate to and then double-click the desired Quick Launch settings file.
The Quick Launch file extensions are:
¢ CMO for Compare and Merge
* DDO for DDL Generation
e MVO for Model Validation
¢ NSO for Naming Standards
* RPO for ER/Studio Report
« RVO for Reverse Engineering
e SSO for Submodel Synchronization
¢ XQO for XML Schema Generation

By default, these files are stored in the XML subdirectory of the ER/Studio application data directory; the default
directory can be changed in Tools > Options > Directories > Quick Launch.

¢ Windows XP: C:\Documents and Settings\<user>\Application
Data\Embarcadero\ERStudio\XML

* Windows Vista: C:\Users\<user>\AppData\Roaming\Embarcadero\ERStudio\XML

4 Select Settings and Objects if you want to use the saved selection or Settings Only to use the default
selections.

5 Click Go!

Rename Quick Launch Settings File
1 On the last page of the wizard or utility, deselect Use file-based Quick Launch settings.

2 Select a quick launch setting file from the list.
3 Click Rename.
4  Enter a new name for the quick launch settings file.

5 Click OK.

Delete Quick Launch Settings
1 On the last page of the wizard or utility, deselect Use file-based Quick Launch settings.

2 Select a quick launch setting file from the list.

3 Click Delete.

Generating RTF and HTML Model Reports

NOTE: This feature is not supported by ER/Studio Developer Edition.

One of ER/Studio’s most powerful applications is that of a documentation generator to communicate complex
databases and associated metadata to the Enterprise. ER/Studio is equipped with extensive report generation
capabilities:



* HTML Report Generation: Instantaneous generation of an HTML-based Web site designed to provide simple
navigability through data models and model metadata using standard browsers such as Microsoft’s Internet
Explorer or Netscape Navigator.

* RTF Report Generation: Instantaneous documentation generation compatible with applications like Microsoft
Word.

In addition to providing model reviewers with reports, you can also make the model available so
reviewers using ER/Studio Viewer or ER/Studio Enterprise Portal can see the actual model, but
not make any changes to it.

The ER/Studio Report Wizard guides you through the process of creating rich text format (RTF) and HTML reports
based on your logical or physical models. The ER/Studio Report Wizard lets you generate RTF and HTML reports.
Due to the formatting differences between RTF reports and HTML reports, the information is presented in slightly
different ways, even though the data, with few exceptions, is the same for both formats. Differences in the type of
information reported is noted for each format type in the pages that have specific information about each object type’s
reports.

Why Use RTF Reports

RTF reports are suitable for hard copy distribution. You can view the RTF-formatted reports using almost any popular
word processing application.

You can select the object types to include in the report (such as entities, relationships, etc.) You can also select the
amount of information about each object type to include in the report such as the summary of all instances of each
object type, and/ or detailed information about each object instance.

RTF reports include a title page, followed by a table of contents, followed by the reports. In general, and subject to the
selections made for information that should be included in the report, each object type such as entity, relationship, etc.
is introduced in a summary report that gives general information about each instance of each object type, followed by
detailed reports for each instance of an object type. Much of the information in the report is presented in easy-to-read
tables.

Why Use HTML Reports?

HTML reports are suitable for sharing on the internet or local Intranet. The reports require a browser that supports
frames (and has them enabled). You can set the zoom level for each submodel individually.

Reports generated in HTML format have a similar feel to web pages. The title page is opened when the report is open.
At the top of the title page and at the top of all pages in the report is a list that lets you select an object type’s report
page. The list includes only those object types that have a report page. If there is no information reported about a
particular diagram object type, it is not included in the list. The report page for each object type has a list in a left-hand
pane that provides links to specific instances of an object type. Information is presented in easy-to-read tables.

Generate a Report
ER/Studio generates reports on all data model objects each with their own specific properties.

1 Onthe Diagram Explorer, locate the Logical or Physical model for which you want to create a report.
2 Right-click the model source for the report and then click Generate Reports.
3 Complete the pages of the ER/Studio Report Wizard as required.

ER/Studio generates reports on all data model objects each with their own specific properties.

The following describes options that are not self-explanatory:

NOTE: The options differ depending on whether the model selected is a Logical or a Physical model and
whether you selected to create an RTF or an HTML report.



Page 1

« Do you want to invoke an Editor to view the report after it is generated?: If Yes is selected, launches the
default application for viewing and editing .rtf or .html files, for example, Microsoft Word for .rtf files or Firefox for
.html files.

* Use enhanced version. Use this option if your model contains an attribute with more than 200 objects. If
selected, ER/Studio splits the HTML report into three areas or frames, ensuring quick navigation of all objects in
an attribute. In the report, viewable data is divided into Object Type, Object List, and Object detail.

Page 2
Select the database objects to report on.

< To view the full name of the database object in the tree on the left side of this page, pause the cursor over the
representative icon and the full name will appear.

¥ ER/Studio Report Wizard - Page 2 of 4

Please select the objects in your d:
like to generate a report For.

Diagram ]Data Diu:tiu:unar_l,ll F'n:n:eu:luresl Functions

& @ Emergency Ad... A

Logical
b air M. ..
"= Enfi...
I:; ERADMIM ADMISSION
1 E...

« Available database objects displaying in the area on the right of this page differ depending on the database
platform you are using.
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« If you right-click anywhere on the object tree, you can select all or deselect all objects using the short-cut menu.
You can also display or hide object owner names for those objects with owners.

« If you select diagram objects on the data model before opening the wizard, only those selected object are
selected in the object tree saving you from reselecting objects.

¢ You can expand or collapse portions of the tree by clicking the + and - nodes.

« Select All button: Selects all objects. If you do not click Select All and if you are using Quick Launch settings
saved from versions earlier than 6.6, object selections will be overwritten due to a more recent feature that
organizes objects by submodel.

Page 3 for RTF Reports

« Create Title Page: Lets you create a title page, which consists of the report title, Diagram Report, followed by
diagram details as specified on the Information tab of Diagram Properties.

« Page Break Options: Lets you specify where to insert page breaks in the report. By default, a page break occurs
after each section in the report. Note: Inserting page breaks after each section can significantly increase the
length of the report.



Page 3 for HTML Reports

« Submodel Image Options: If selected, a .jpg formatted image of the model or submodel, similar to a screenshot,
is included in the report.

NOTE: Generating a JPG is a resource intensive and may not be possible for large data models. If you
need to capture an entire large data model, you can try reducing quality or zoom size or, select
individual options and ER/Studio will capture individual objects for each selected object. For
example, don't select the Logical Model, which selects each model and submodel in that model;
rather, select the models and submodels individually.

Select HTHML generation options
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« Image File: Select an image, such as your company logo, to include on the to left-hand side of the page.

« New Link: Enter the URL of the content you want to display when the report reader clicks the image specified
above.

Exporting the Data Model

You can export the logical or physical data model to a variety of different formats and platforms, allowing you to
collaborate with other database users, communicate your database design, create SQL from your data model to
create a physical database, and create an XSD Schema you can share with application developers who can use this
schema.

Click a link below for information on exporting data models:

¢ Exporting Metadata for a Particular Model

« Exporting Metadata for all Models and Submodels
¢ Exporting a Data Model to XML
« Exporting a Data Model to Describe

Exporting Metadata for a Particular Model

NOTE: You need a separate license to access the MetaData Export bridges. See the About ERStudio
dialog for a list of the modules you are licensed to use.



Using the MetaData Export Wizard, you can export your diagrams in formats compatible with a wide-variety of
industry-standard tools. For a current list of supported platforms and bridges available, see:

¢ Windows XP: C:\Program Files\Embarcadero\ERStudioX.X\MIRModelBridges.xml
* Windows Vista: C:\ProgramData\Embarcadero\ERStudioX.X\MIRModelBridges.xml
or see the pdf version at http://www.embarcadero.com/products/erstudio/erdocs.html.

1 Onthe Diagram Explorer, right-click the model or submodel you want to export.

2 Click Export Model Metadata.

3 Complete the Export Model Metadata dialog as required.
Click the field beside the option name to either enter a value or select a value from the list. Help
text for each option appears in the area at the bottom of the page.

4 If you want to save or print the log, click Save to File or Print.

The following describes options that are not self-explanatory.
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Type: From the list, select the MIR Bridge you want to use to generates a file that can be imported into the
third-party application supported by the selected bridge type.

Page 3

This page displays informational and warning messages describing successful and unsuccessful exports
respectively.

Exporting Metadata for all Models and Submodels

NOTE: You need a separate license to access the MetaData Export bridges. See the About ERStudio
dialog for a list of the modules you are licensed to use.

Using the MetaData Export Wizard, you can export your diagrams in formats compatible with a wide-variety of
industry-standard tools. For a current list of supported platforms and bridges available, see:

¢ Windows XP: C:\Program Files\Embarcadero\ERStudioX.X\MIRModelBridges.xml

« Windows Vista: C:\ProgramData\Embarcadero\ERStudioX.X\MIRModelBridges.xml

or see the pdf version at http://www.embarcadero.com/products/erstudio/erdocs.html.

1 Click File > Export File > Export Model Metadata.
2 Complete the Export Model Metadata dialog as required.

Click the field beside the option name to either enter a value or select a value from the list. Help
text for each option appears in the area at the bottom of the page.

3 If you want to save or print the log, click Save to File or Print.
The following describes options that are not self-explanatory:
Page 1

Type: From the list, select the MIR Bridge you want to use to generates a file that can be imported into the
third-party application supported by the selected bridge type.


http://www.embarcadero.com/products/erstudio/erdocs.html
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Page 2

Model selection: Choose to export the logical model, physical model, or all models. If you choose to export the
physical model, because there can be numerous physical models in an ER/Studio file you must enter the name
of the model in the Physical model name field.

Page 3

This page displays informational and warning messages describing successful and unsuccessful exports
respectively.

Exporting a Data Model to XML

The eXtensible Markup Language (XML) is a document format that has recently emerged as a standard for data
representation and exchange on the Internet. XML is also now supported by many applications and platforms,
allowing the data modelers and application developers to collaborate on service-oriented architecture (SOA)
initiatives. For example, the data modeler models the data and the relationships that describe how applications
exchange data, and exports the model to XML, which the application developer can then use to ensure that the
applications interface correctly.

ER/Studio allows you to generate the following XML-type files:

¢ Schema Definition (XSD): The XSD formally describes the elements in an XML document. It is an abstract
representation of an object’s characteristics and how the object relates to other objects. The XSD is used to verify
that each element in an XML document conforms to the element rules described in the XSD. Schemas are most
often used in e-commerce, data control, and database-style applications where character data content must be
validated, strict data control is needed, or where strong data typing is required. For example, many applications
use an XSD to validate parameters in configuration files.

WIth one click, you can export the entire logical model to an xsd file. This function makes assumptions about
how the model elements map to the xsd element and gives you no control over the mappings. For more
information, see Generating a Schema Definition (XSD).

¢ Document Type Definition (DTD): The DTD is another XML schema language used in traditional text document
publishing applications.The DTD is a description in XML declaration syntax of a particular type or class of
documents. It defines what names are used for certain element types, where they may occur, how the elements
fit together, and ensures that all documents conforming to the DTD are constructed and named in a consistent
manner. Validators in applications such as editors, search engines, browsers, and databases can read the DTD
before reading the XML file in order to prepare to display or otherwise work with the XML document.

« XML Metadata Interchange (XMI): The XMl file format was designed primarily to allow the exchange of data
between data modeling applications. Based on the XML format, XMI allows data modelers using Unified
Modeling Language (UML) and programmers using different languages and development tools to exchange
information about the model metadata, what a set of data consists of and how it is organized.

Using the MetaData Export Wizard, you can export the entire .dm1 file or an individual model to an .xsd or an
xmi file. This function makes assumptions about how the model elements map to the xsd elements but gives
you some control over the export parameters. For more information, see Exporting Metadata for a Particular

Model and Exporting Metadata for all Models and Submodels.



¢« XML Schema Generation (XML): The XML Schema Generation Wizard creates schemas that can be based on
a logical or physical model, a submodel, or even specific components only of a model or submodel. The XML
Schema Generation Wizard allows you to customize the XML schema structure by clicking the desired options
and dragging the available objects from the database design into a tree representing the XML schema. This
wizard provides advanced options to transform relational entities and attributes into complex types, elements and
attributes, define naming standards and datatype mapping, and incorporates the Quicklaunch system used in
other wizards to save previous settings and streamline repetitive operations. For more information, see

Generating a Customized XML Schema.

You can use XML editing applications such as Microsoft XML Notepad, Eclipse, Visual Studio, and Altova XML
Spy to view and edit the schema.

This section contains the following topics:

* Generating a Schema Definition (XSD)

¢ Generating a Document Type Definition (DTD)

¢ Generating a Customized XML Schema

Generating a Schema Definition (XSD)

1 Open the model you want to base the XML Schema on.
2 Click File > Export File > XML File > Schema Definition (XSD).

3 Specify the output file and then click Save.

Generating a Document Type Definition (DTD)

Use the Schema Definition (XSD) command to create a schema definition of the logical model.
1 Open the model you want to base the Schema Definition on.
2 Click File > Export File > XML File > Document Type Definition (DTD).

3 Specify the output file and then clic